Layer 2 VPN Ethernet over MPLS

Sebelumnya saya sudah membahas MPLS L3VPN, pada saat ini saya akan membahas lagi salah satu teknologi pada MPLS yaitu L2VPN. Teknologi ini hampir sama dengan L3VPN yaitu menghubungkan antar Customer Edge yang berada di Provider Edge yang berbeda, jika pada L3VPN antar CE berbeda segmen Network pada L2VPN antar CE berada di segmen Network yang sama.

L2VPN ini membuat sebuah jalur Bridge yang melewati MPLS Backbone, jalur ini bisa kita sebut dengan Psuedowire yaitu sebuah jalur logika yang berada di dalam jalur fisik, jadi Psuedowire ini yang akan menjadi jalur penghubung antar Segmen Network yang terpecah, Psuedowire memiliki alamat identifikasi VCID (Virtual Circuit ID), untuk membuat sebuah jalur Psuedowire kita harus melakukan peering atau menghubungkan antara satu PE dengan PE yang lainnya yang terdapat CE yang ingin dihubungkan.

Setelah sedikit teori yang saya ketahui saya bahas, sekarang kita lanjut pada praktek Lab MPLS L2VPN , kali ini protokol Layer2 yang ingin dibridge adalah Ethernet, Inshaa Allah selanjutnya akan saya bahas yang lainnya seperti PPP, Frame-Relay, dll. Kita lihat topologinya :

Dua CE R4 dan R5 berada di segmen Network yang sama (45.45.45.0/24) dan terhubung dengan PE yang berbeda, R4 dengan R1 dan R5 dengan R3, kemudian pada Lab ini kita ingin menghubungkan antara R4 dengan R5 dengan L2VPN Psuedowire yang melewati MPLS Backbone, perintah yang akan digunakan adalah xconnect untuk melakukan bridge.

IP Addressing

Kita konfigurasi IP Address pada tiap Interface Router yang ada di topologi ini terlebih dahulu

    R1

    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi

    R2

    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi

    R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi

    R4

    R4(config)#int e0/0
    R4(config-if)#ip add 45.45.45.4 255.255.255.0
    R4(config-if)#no sh
    R4(config-if)#exi
    R4(config)#int lo0
    R4(config-if)#ip add 4.4.4.4 255.255.255.255
    R4(config-if)#exi

    R5

    R5(config)#int e0/0
    R5(config-if)#ip add 45.45.45.5 255.255.255.0
    R5(config-if)#no sh
    R5(config-if)#exi
    R5(config)#int lo0
    R5(config-if)#ip add 5.5.5.5 255.255.255.255
    R5(config-if)#exi

Routing EIGRP

Konfigurasi EIGRP pada masing-masing Router yang ada di MPLS Backbone

    R1

    R1(config)#router eigrp 10
    R1(config-router)#no auto-summ
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#ex

    R2

    R2(config)#router eigrp 10
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#exi

    R3

    R3(config)#router eigrp 10
    R3(config-router)#no auto-summ
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#exi

MPLS LDP

Tiap interface pada Router MPLS Backbone, kita aktifkan LDP untuk mendistribusikan label kecuali Interface yang terhubung dengan Router CE.

    R1

    R1(config)#int e0/0
    R1(config-if)#mpls ip
    R1(config-if)#exi

    R2

    R2(config)#int ra e0/0-1
    R2(config-if-range)#mpls ip
    R2(config-if-range)#exi

    R3

    R3(config)#int e0/0
    R3(config-if)#mpls ip
    R3(config-if)#exi

Psuedowire

Kita buat psuedowire antara R1 dan R3, caranya dengan melakukan peering Interface loopback kedua Router dengan perintah xconnect pada interface yang terhubung dengan CE, jalur psuedowire ini yang akan menjadi penghubung antara R4 dan R5.

    R1

    R1(config)#int e0/1                   
    R1(config-if)#xconnect 3.3.3.3 45 encap mpls
    R1(config-if-xconn)#no sh
    R1(config-if)#exi

    R3

    R3(config)#int e0/1
    R3(config-if)#xconnect 1.1.1.1 45 encap mpls
    R3(config-if-xconn)#exi
    R3(config-if)#no sh
    R3(config-if)#exi

OSPF CE

Konfigurasi OSPF Untuk menghubungkan antar Router CE.

    R4

    R4(config)#router ospf 10
    R4(config-router)#net 4.4.4.4 0.0.0.0 are 0
    R4(config-router)#net 45.45.45.0 0.0.0.255 area 0
    R4(config-router)#exi

    R5

    R5(config)#router ospf 10
    R5(config-router)#net 5.5.5.5 0.0.0.0 ar 0
    R5(config-router)#net 45.45.45.0 0.0.0.255 area 0
    R5(config-router)#exi

    Setelah itu lakukan PING antar Interface loopback untuk menguji keberhasilan konfigurasi.

    R4#ping 5.5.5.5 source loopback 0
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
    Packet sent with a source address of 4.4.4.4
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Layer 2 VPN Ethernet over MPLS

Sebelumnya saya sudah membahas MPLS L3VPN, pada saat ini saya akan membahas lagi salah satu teknologi pada MPLS yaitu L2VPN. Teknologi ini hampir sama dengan L3VPN yaitu menghubungkan antar Customer Edge yang berada di Provider Edge yang berbeda, jika pada L3VPN antar CE berbeda segmen Network pada L2VPN antar CE berada di segmen Network yang sama.

L2VPN ini membuat sebuah jalur Bridge yang melewati MPLS Backbone, jalur ini bisa kita sebut dengan Psuedowire yaitu sebuah jalur logika yang berada di dalam jalur fisik, jadi Psuedowire ini yang akan menjadi jalur penghubung antar Segmen Network yang terpecah, Psuedowire memiliki alamat identifikasi VCID (Virtual Circuit ID), untuk membuat sebuah jalur Psuedowire kita harus melakukan peering atau menghubungkan antara satu PE dengan PE yang lainnya yang terdapat CE yang ingin dihubungkan.

Setelah sedikit teori yang saya ketahui saya bahas, sekarang kita lanjut pada praktek Lab MPLS L2VPN , kali ini protokol Layer2 yang ingin dibridge adalah Ethernet, Inshaa Allah selanjutnya akan saya bahas yang lainnya seperti PPP, Frame-Relay, dll. Kita lihat topologinya :

Dua CE R4 dan R5 berada di segmen Network yang sama (45.45.45.0/24) dan terhubung dengan PE yang berbeda, R4 dengan R1 dan R5 dengan R3, kemudian pada Lab ini kita ingin menghubungkan antara R4 dengan R5 dengan L2VPN Psuedowire yang melewati MPLS Backbone, perintah yang akan digunakan adalah xconnect untuk melakukan bridge.

IP Addressing

Kita konfigurasi IP Address pada tiap Interface Router yang ada di topologi ini terlebih dahulu

    R1

    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi

    R2

    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi

    R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi

    R4

    R4(config)#int e0/0
    R4(config-if)#ip add 45.45.45.4 255.255.255.0
    R4(config-if)#no sh
    R4(config-if)#exi
    R4(config)#int lo0
    R4(config-if)#ip add 4.4.4.4 255.255.255.255
    R4(config-if)#exi

    R5

    R5(config)#int e0/0
    R5(config-if)#ip add 45.45.45.5 255.255.255.0
    R5(config-if)#no sh
    R5(config-if)#exi
    R5(config)#int lo0
    R5(config-if)#ip add 5.5.5.5 255.255.255.255
    R5(config-if)#exi

Routing EIGRP

Konfigurasi EIGRP pada masing-masing Router yang ada di MPLS Backbone

    R1

    R1(config)#router eigrp 10
    R1(config-router)#no auto-summ
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#ex

    R2

    R2(config)#router eigrp 10
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#exi

    R3

    R3(config)#router eigrp 10
    R3(config-router)#no auto-summ
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#exi

MPLS LDP

Tiap interface pada Router MPLS Backbone, kita aktifkan LDP untuk mendistribusikan label kecuali Interface yang terhubung dengan Router CE.

    R1

    R1(config)#int e0/0
    R1(config-if)#mpls ip
    R1(config-if)#exi

    R2

    R2(config)#int ra e0/0-1
    R2(config-if-range)#mpls ip
    R2(config-if-range)#exi

    R3

    R3(config)#int e0/0
    R3(config-if)#mpls ip
    R3(config-if)#exi

Psuedowire

Kita buat psuedowire antara R1 dan R3, caranya dengan melakukan peering Interface loopback kedua Router dengan perintah xconnect pada interface yang terhubung dengan CE, jalur psuedowire ini yang akan menjadi penghubung antara R4 dan R5.

    R1

    R1(config)#int e0/1                   
    R1(config-if)#xconnect 3.3.3.3 45 encap mpls
    R1(config-if-xconn)#no sh
    R1(config-if)#exi

    R3

    R3(config)#int e0/1
    R3(config-if)#xconnect 1.1.1.1 45 encap mpls
    R3(config-if-xconn)#exi
    R3(config-if)#no sh
    R3(config-if)#exi

OSPF CE

Konfigurasi OSPF Untuk menghubungkan antar Router CE.

    R4

    R4(config)#router ospf 10
    R4(config-router)#net 4.4.4.4 0.0.0.0 are 0
    R4(config-router)#net 45.45.45.0 0.0.0.255 area 0
    R4(config-router)#exi

    R5

    R5(config)#router ospf 10
    R5(config-router)#net 5.5.5.5 0.0.0.0 ar 0
    R5(config-router)#net 45.45.45.0 0.0.0.255 area 0
    R5(config-router)#exi

    Setelah itu lakukan PING antar Interface loopback untuk menguji keberhasilan konfigurasi.

    R4#ping 5.5.5.5 source loopback 0
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
    Packet sent with a source address of 4.4.4.4
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Layer 2 VPN Point to Point Protocol over MPLS

Kali ini saya akan membahas kembali teknologi pada MPLS yaitu L2VPN yang merupakan teknologi untuk menghubungkan antar Segmen Network yang sama tetapi terpisah karena letaknya berjauhan atau masing-masing berada di Router PE yang berbeda. Jadi L2VPN ini adalah penghubung antar jaringan Layer 2 yang terpisah, sebelumnya saya sudah membahas bagaimana cara menghubungkan dua jaringan Ethernet yang terpisah karena berada di Router PE yang berbeda, pada kali ini saya akan membahas cara menghubungkan dua Router yang menggunakan protokol layer 2 PPP melalui jaringan MPLS.

Agar kedua Router dapat terhubung secara point-to-point lewat MPLS, maka kita akan mengkonfigurasi sebuah jalur bridge psuedowire, yaitu sebuah jalur yang ada didalam jalur lagi, konfigurasi psuedowire ini terjadi antar Router PE, antar Router PE akan membentuk jalur psuedowire ini.

Pengertian PPP

Saya jelaskan secara singkat tentang PPP ini, saya juga sudah pernah membahasnya pada posting saya yang ini, protokol ini merupakan protokol pada Layer 2 yang berfungsi untuk menghubungkan dua Router secara point to point, karena sesuai namannya yaitu Point-to-Point Protocol, kenapa harus PPP? Karena protokol ini sangat cocok untuk koneksi point to point selain dari HDLC, dengan PPP ini Router tidak perlu melakukan resolve ARP untuk terhubung dengan Router tetangganya.

PPP juga menawarkan fitur keamanan yaitu authentication PAP dan CHAP, pada contoh lab kali ini saya gunakan metode PAP saja yaitu menggunakan password untuk membentuk koneksi point-to-point antar Router.

Berikut ini adalah topologi yang saya konfigurasi :

IP Addressing

Pertama pada setiap Router kita konfigurasi IP Address dan MPLS di masing-masing interface-nya kecuali interface yang terhubung dengan Router CE.

    R1

    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#mpls ip
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi

    R2

    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#mpls ip
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#mpls ip
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi

    R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#mpls ip
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi

Routing EIGRP

Kemudian konfigurasi Routing EIGRP untuk mendistibusikan informasi Routing antar Router.

    R1

    R1(config)#router eigrp 10
    R1(config-router)#no auto-summ
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#exi

    R2

    R2(config)#router eigrp 10
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#exi

    R3

    R3(config)#router eigrp 10
    R3(config-router)#no auto-summ
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#exi

Psuedowire

Perintah xconnect untuk membentuk jalur psuedowire pada tiap Router PE, psuedowire memiliki alamat identifikasi VCID, pada tiap Router PE kita konfigurasi xconnect ke alamat IP Router PE yang satunya lagi agar terbentuk jalur psuedowire.

Dan jangan lupa diatur encapsulation menjadi PPP

    R1

    R1(config)#int s2/0
    R1(config-if)#encap ppp
    R1(config-if)#no sh
    R1(config-if)#xconnect 3.3.3.3 45 encap mpls
    R1(config-if-xconn)#exi

    Pada konfigurasi diatas Router PE akan membentuk psuedowire yang mengarah ke alamat IP 3.3.3.3 (R3) dengan VCID 45, dikirimkan didalam MPLS.

    R3

    R3(config)#int s2/0
    R3(config-if)#encap ppp
    R3(config-if)#no sh
    R3(config-if)#xconnect 1.1.1.1 45 encap mpls

    Pada Router R3 PE ini sebaliknya.

Point to Point Protocol

Kemudian konfigurasi pada Router CE yaitu R4 dan R5, Atur encapsulation menjadi PPP beserta username dan password untuk terhubung dengan CE sebelahnya.

    R4

    Buat Username dan password untuk PPP.

    R4(config)#username mpls password mpls

    Lalu konfigurasi PPP pada interface serial pada Router ini.

    R4(config)#int s2/0
    R4(config-if)#ip address 45.45.45.4 255.255.255.0
    R4(config-if)#encapsulation ppp
    R4(config-if)#ppp authentication pap
    R4(config-if)#ppp pap sent-username mpls password mpls
    R4(config-if)#no sh
    R4(config-if)#exi

    Konfigurasi Interface loopback dan OSPF.

    R4(config)#interface Loopback0
    R4(config-if)#ip address 4.4.4.4 255.255.255.255
    R4(config-if)#exi
    R4(config-if)#router ospf 10
    R4(config-router)#network 4.4.4.4 0.0.0.0 area 0
    R4(config-router)#network 45.45.45.0 0.0.0.255 area 0

    R5

    Dan konfigurasi Router CE yang satunya lagi.

    R5(config)#username mpls password mpls
    R5(config)#interface Loopback0
    R5(config-if)#ip address 5.5.5.5 255.255.255.255
    R5(config-if)#exit
    R5(config)#interface Serial2/0
    R5(config-if)#ip address 45.45.45.5 255.255.255.0
    R5(config-if)#encapsulation ppp
    R5(config-if)#ppp authentication pap
    R5(config-if)#ppp pap sent-username mpls password mpls
    R5(config-if)#exi
    R5(config)#router ospf 10
    R5(config-router)#network 5.5.5.5 0.0.0.0 area 0
    R5(config-router)#network 45.45.45.0 0.0.0.255 area 0
    R5(config-router)#exi

kemudian testing PING antar Router CE untuk mengecek keberhasilan konfigurasi.

R4#ping 5.5.5.5 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
Packet sent with a source address of 4.4.4.4
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 18/19/20 ms

Layer 2 VPN Point to Point Protocol over MPLS

Kali ini saya akan membahas kembali teknologi pada MPLS yaitu L2VPN yang merupakan teknologi untuk menghubungkan antar Segmen Network yang sama tetapi terpisah karena letaknya berjauhan atau masing-masing berada di Router PE yang berbeda. Jadi L2VPN ini adalah penghubung antar jaringan Layer 2 yang terpisah, sebelumnya saya sudah membahas bagaimana cara menghubungkan dua jaringan Ethernet yang terpisah karena berada di Router PE yang berbeda, pada kali ini saya akan membahas cara menghubungkan dua Router yang menggunakan protokol layer 2 PPP melalui jaringan MPLS.

Agar kedua Router dapat terhubung secara point-to-point lewat MPLS, maka kita akan mengkonfigurasi sebuah jalur bridge psuedowire, yaitu sebuah jalur yang ada didalam jalur lagi, konfigurasi psuedowire ini terjadi antar Router PE, antar Router PE akan membentuk jalur psuedowire ini.

Pengertian PPP

Saya jelaskan secara singkat tentang PPP ini, saya juga sudah pernah membahasnya pada posting saya yang ini, protokol ini merupakan protokol pada Layer 2 yang berfungsi untuk menghubungkan dua Router secara point to point, karena sesuai namannya yaitu Point-to-Point Protocol, kenapa harus PPP? Karena protokol ini sangat cocok untuk koneksi point to point selain dari HDLC, dengan PPP ini Router tidak perlu melakukan resolve ARP untuk terhubung dengan Router tetangganya.

PPP juga menawarkan fitur keamanan yaitu authentication PAP dan CHAP, pada contoh lab kali ini saya gunakan metode PAP saja yaitu menggunakan password untuk membentuk koneksi point-to-point antar Router.

Berikut ini adalah topologi yang saya konfigurasi :

IP Addressing

Pertama pada setiap Router kita konfigurasi IP Address dan MPLS di masing-masing interface-nya kecuali interface yang terhubung dengan Router CE.

    R1

    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#mpls ip
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi

    R2

    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#mpls ip
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#mpls ip
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi

    R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#mpls ip
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi

Routing EIGRP

Kemudian konfigurasi Routing EIGRP untuk mendistibusikan informasi Routing antar Router.

    R1

    R1(config)#router eigrp 10
    R1(config-router)#no auto-summ
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#exi

    R2

    R2(config)#router eigrp 10
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#exi

    R3

    R3(config)#router eigrp 10
    R3(config-router)#no auto-summ
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#exi

Psuedowire

Perintah xconnect untuk membentuk jalur psuedowire pada tiap Router PE, psuedowire memiliki alamat identifikasi VCID, pada tiap Router PE kita konfigurasi xconnect ke alamat IP Router PE yang satunya lagi agar terbentuk jalur psuedowire.

Dan jangan lupa diatur encapsulation menjadi PPP

    R1

    R1(config)#int s2/0
    R1(config-if)#encap ppp
    R1(config-if)#no sh
    R1(config-if)#xconnect 3.3.3.3 45 encap mpls
    R1(config-if-xconn)#exi

    Pada konfigurasi diatas Router PE akan membentuk psuedowire yang mengarah ke alamat IP 3.3.3.3 (R3) dengan VCID 45, dikirimkan didalam MPLS.

    R3

    R3(config)#int s2/0
    R3(config-if)#encap ppp
    R3(config-if)#no sh
    R3(config-if)#xconnect 1.1.1.1 45 encap mpls

    Pada Router R3 PE ini sebaliknya.

Point to Point Protocol

Kemudian konfigurasi pada Router CE yaitu R4 dan R5, Atur encapsulation menjadi PPP beserta username dan password untuk terhubung dengan CE sebelahnya.

    R4

    Buat Username dan password untuk PPP.

    R4(config)#username mpls password mpls

    Lalu konfigurasi PPP pada interface serial pada Router ini.

    R4(config)#int s2/0
    R4(config-if)#ip address 45.45.45.4 255.255.255.0
    R4(config-if)#encapsulation ppp
    R4(config-if)#ppp authentication pap
    R4(config-if)#ppp pap sent-username mpls password mpls
    R4(config-if)#no sh
    R4(config-if)#exi

    Konfigurasi Interface loopback dan OSPF.

    R4(config)#interface Loopback0
    R4(config-if)#ip address 4.4.4.4 255.255.255.255
    R4(config-if)#exi
    R4(config-if)#router ospf 10
    R4(config-router)#network 4.4.4.4 0.0.0.0 area 0
    R4(config-router)#network 45.45.45.0 0.0.0.255 area 0

    R5

    Dan konfigurasi Router CE yang satunya lagi.

    R5(config)#username mpls password mpls
    R5(config)#interface Loopback0
    R5(config-if)#ip address 5.5.5.5 255.255.255.255
    R5(config-if)#exit
    R5(config)#interface Serial2/0
    R5(config-if)#ip address 45.45.45.5 255.255.255.0
    R5(config-if)#encapsulation ppp
    R5(config-if)#ppp authentication pap
    R5(config-if)#ppp pap sent-username mpls password mpls
    R5(config-if)#exi
    R5(config)#router ospf 10
    R5(config-router)#network 5.5.5.5 0.0.0.0 area 0
    R5(config-router)#network 45.45.45.0 0.0.0.255 area 0
    R5(config-router)#exi

kemudian testing PING antar Router CE untuk mengecek keberhasilan konfigurasi.

R4#ping 5.5.5.5 source loopback 0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
Packet sent with a source address of 4.4.4.4
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 18/19/20 ms

Layer 2 VPN Frame Relay over MPLS

Kali ini saya akan kembali membahas tentang MPLS L2VPN, sebelumnya saya sudah membahas beberapa kali sebelumnya pada protokol Ethernet dan PPP, dan untuk sekarang adalah Frame Relay.
Teknologi MPLS L2VPN ini adalah sebuah penghubung antar segmen Network yang sama yang jaraknya berjauhan (terletak di PE yang berbeda) melalui Backbone MPLS, atau juga menghubungkan antar koneksi protokol Layer 2 yang jaraknya berjauhan (terletak di PE yang berbeda) seperti protokol Frame Relay ini.

Pengertian Frame Relay.

Frame Relay merupakan protokol encapsulation pada Layer 2, yang dapat menghubungkan dua atau lebih Router secara Multi-access tidak seperti PPP dan HDLC protokol point-to-point yang hanya dapat dua Router saja yang dihubungkan.

Untuk menghubungkan satu Router dengan Router lainnya Frame Relay menggunakan PVC, jika satu Router memiliki tetangga dua Router lainnya maka kita perlu membentuk dua PVC untuk masing-masing tetangga Router tersebut, jadi setiap koneksi antar Router memiliki jalur sendiri sendiri.

Setiap Router akan memiliki DLCI yang bersifat lokal untuk terhubung denga Router tetangga lainnya, jika ada dua tetangga Router maka Router tersebut akan memiliki dua DLCI untuk membentuk dua jalur PVC yang menuju ke dua Router tetangga tersebut.

Untuk menghubungkan antar Router, masing-masing Router akan terhubung dengan Frame Relay Switch, Switch ini yang akan melakukan pengalihan DLCI, jika pada MPLS yang akan menjadi Frame Relay Switch adalah Router PE, Router PE akan mengalihkan DLCI menuju Router PE lainnya.

Seperti yang sudah saya jelaskan sebelumnya, MPLS L2VPN akan membentuk jalur psuedowire untuk setiap koneksi Layer 2 yang ingin dibentuk, karena Frame Relay menggunakan PVC yang jumlahnya mungkin lebih dari satu dan juga karena Frame Relay tidak point-to-point mungkin kita akan mengkonfigurasi psuedowire lebih dari satu untuk konfigurasi saat ini.

Berikut ini adalah topolginya :

Pertama kita konfigurasi IP Address dan MPLS pada Router-Router yang bertindak sebagai MPLS Backbone.

    R1

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#mpls ip
    R1(config-if)#no sh
    R1(config-if)#exi

    R2

    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi
    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#mpls ip
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#mpls ip
    R2(config-if)#no sh
    R2(config-if)#exi

    R3

    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#mpls ip
    R3(config-if)#no sh
    R3(config-if)#exi

Lalu konfigurasi EIGRP agar antar Router tersebut dapat saling terhubung, dan MPLS dapat berjalan dengan baik.

    R1

    R1(config)#router eigrp 10
    R1(config-router)#no auto-summ
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#exi

    R2

    R2(config)#router eigrp 10
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#exi

    R3

    R3(config)#router eigrp 10
    R3(config-router)#no auto-summ
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#exi

Setelah selesai membuat MPLS Backbone, sekarang kita mulai konfigurasi L2VPN Frame Relay, kita berkonsentrasi konfigurasi pada Router PE saja yaitu R1 dan R3.

    R1
    Pertama konfigurasi Interface yang terhubung dengan CE, encapsulation menjadi frame relay.

    R1(config)#int s2/0    
    R1(config-if)#encapsulation frame-relay
    R1(config-if)#frame-relay intf-type dce
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int s2/1
    R1(config-if)#encapsulation frame-relay
    R1(config-if)#frame-relay intf-type dce
    R1(config-if)#no sh
    R1(config-if)#exi

    Aktifkan frame-relay switching.

    R1(config)#frame-relay switching 

    Kita buat psuedowire sebagai jalur masing-masing DLCI yaitu 45 dan 65 yang mengarah ke Router R3, dan ingat VCID keduanya harus berbeda.

    R1(config)#connect R4-to-R5 s2/0 45 l2transport
    R1(config-fr-pw-switching)#xconnect 3.3.3.3 45 encap mpls

    Yang diatas merupakan psuedowire untuk menghubungkan R4 dan R5 dengan VCID 45, DLCI R4 untuk ke R5 adalah 45 dan dikirimkan ke 3.3.3.3 (R3) lewat MPLS. kemudian konfigurasi psuedowire berikutnya.

    R1(config)#connect R6-to-R5 s2/1 65 l2transport
    R1(config-fr-pw-switching)#xconnect 3.3.3.3 65 encap mpls

    yang diatas itu psuedowire untuk R6 terhubung dengan R5.
    R3
    Dan kita lanjut pada Router R3, penjelasan konfigurasi tidak jauh berbeda.

    R3(config)#int s2/0
    R3(config-if)#encapsulation frame-relay
    R3(config-if)#frame-relay intf-type dce
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#frame-relay switching
    R3(config)#connect R5-to-R4 s2/0 54 l2transport
    R3(config-fr-pw-switching)#xconnect 1.1.1.1 45 encap mpls
    R3(config-xconn)#exi
    R3(config-fr-pw-switching)#exi
    R3(config)#connect R5-to-R6 s2/0 56 l2transport
    R3(config-fr-pw-switching)#xconnect 1.1.1.1 65 encap mpls
    R3(config-xconn)#exi
    R3(config-fr-pw-switching)#exi

Kemudian konfigurasi Frame Relay pada Router CE, metode menghubungkan antar Router kali ini saya menggunakan point to multipoint artinya satu Router (R5.Hub) akan menjadi perantara untuk menghubungkan Router lainnya, yaitu menghubungkan antara R4.spoke dan R6.spoke.

    R4
    Konfigurasi interface dan DLCI pada Router.

    R4(config)#int s2/0
    R4(config-if)#encap frame-relay
    R4(config-if)#frame-relay interface-dlci 45
    R4(config-fr-dlci)#ip add 45.45.45.4 255.255.255.0
    R4(config-if)#ip ospf network non-broadcast
    R4(config-if)#no sh
    R4(config-if)#exi
    R4(config)#int lo0
    R4(config-if)#ip add 4.4.4.4 255.255.255.255
    R4(config-if)#exi

    Dan konfigurasi Routing OSPF.

    R4(config)#router ospf 10
    R4(config-router)#neighbor 45.45.45.5
    R4(config-router)#net 45.45.45.0 0.0.0.255 area 0
    R4(config-router)#net 4.4.4.4 0.0.0.0 area 0
    R4(config-router)#exi

    R6

    R6(config)#int s2/0
    R6(config-if)#encap frame-relay
    R6(config-if)#frame-relay interface-dlci 65
    R6(config-fr-dlci)#ip add 56.56.56.6 255.255.255.0
    R6(config-if)#ip ospf network non-broadcast
    R6(config-if)#no sh
    R6(config-if)#exi
    R6(config)#int lo0
    R6(config-if)#ip add 6.6.6.6 255.255.255.255
    R6(config-if)#exi
    R6(config)#router ospf 10
    R6(config-router)#neighbor 56.56.56.5
    R6(config-router)#net 56.56.56.0 0.0.0.255 area 0
    R6(config-router)#net 6.6.6.6 0.0.0.0 area 0
    R6(config-router)#exi

    R5.Hub
    Konfigurasi Interface encapsulation frame-relay.

    R5(config)#int lo0
    R5(config-if)#ip add 5.5.5.5 255.255.255.255
    R5(config-if)#exi
    R5(config)#int s2/0
    R5(config-if)#encap frame-relay
    R5(config-if)#no sh
    R5(config-if)#exi

    Pada Router ini kita buat dua subinterface untuk terhubung dengan R4 dan R6, pertama kita buat sub interface untuk R4.

    R5(config)#int s2/0.54 point-to-point 
    R5(config-subif)#frame-relay interface-dlci 54
    R5(config-fr-dlci)#ip add 45.45.45.5 255.255.255.0
    R5(config-subif)#ip ospf network non-broadcast
    R5(config-subif)#no sh
    R5(config-subif)#exi

    Kemudian untuk R6.

    R5(config)#int s2/0.56 point-to-point
    R5(config-subif)#frame-relay interface-dlci 56
    R5(config-fr-dlci)#ip add 56.56.56.5 255.255.255.0
    R5(config-subif)#ip ospf network non-broadcast
    R5(config-subif)#no sh
    R5(config-subif)#exi

    Dan konfigurasi Routing OSPF untuk mendistribusikan informasi Routing antar Router CE.

    R5(config)#router ospf 10
    R5(config-router)#neighbor 45.45.45.4
    R5(config-router)#neighbor 56.56.56.6
    R5(config-router)#net 45.45.45.0 0.0.0.255 area 0
    R5(config-router)#net 56.56.56.0 0.0.0.255 area 0
    R5(config-router)#net 5.5.5.5 0.0.0.0 area 0

Konfirmasi

Untuk melakukan konfirmasi pertama kita lihat Routing table pada salah satu Router CE, apakah sudah dapat saling berkomunikasi menggunakan OSPF.

R6(config)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/129] via 56.56.56.5, 00:00:12, Serial2/0
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/65] via 56.56.56.5, 00:00:12, Serial2/0
6.0.0.0/32 is subnetted, 1 subnets
C 6.6.6.6 is directly connected, Loopback0
45.0.0.0/24 is subnetted, 1 subnets
O 45.45.45.0 [110/128] via 56.56.56.5, 00:00:12, Serial2/0
56.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 56.56.56.0/24 is directly connected, Serial2/0
L 56.56.56.6/32 is directly connected, Serial2/0

Lalu lakukan PING antar Router melalui interface loopback.

R6#ping 4.4.4.4 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 6.6.6.6
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 35/36/37 ms
R6#ping 5.5.5.5 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
Packet sent with a source address of 6.6.6.6
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 18/18/18 ms

Layer 2 VPN Frame Relay over MPLS

Kali ini saya akan kembali membahas tentang MPLS L2VPN, sebelumnya saya sudah membahas beberapa kali sebelumnya pada protokol Ethernet dan PPP, dan untuk sekarang adalah Frame Relay.
Teknologi MPLS L2VPN ini adalah sebuah penghubung antar segmen Network yang sama yang jaraknya berjauhan (terletak di PE yang berbeda) melalui Backbone MPLS, atau juga menghubungkan antar koneksi protokol Layer 2 yang jaraknya berjauhan (terletak di PE yang berbeda) seperti protokol Frame Relay ini.

Pengertian Frame Relay.

Frame Relay merupakan protokol encapsulation pada Layer 2, yang dapat menghubungkan dua atau lebih Router secara Multi-access tidak seperti PPP dan HDLC protokol point-to-point yang hanya dapat dua Router saja yang dihubungkan.

Untuk menghubungkan satu Router dengan Router lainnya Frame Relay menggunakan PVC, jika satu Router memiliki tetangga dua Router lainnya maka kita perlu membentuk dua PVC untuk masing-masing tetangga Router tersebut, jadi setiap koneksi antar Router memiliki jalur sendiri sendiri.

Setiap Router akan memiliki DLCI yang bersifat lokal untuk terhubung denga Router tetangga lainnya, jika ada dua tetangga Router maka Router tersebut akan memiliki dua DLCI untuk membentuk dua jalur PVC yang menuju ke dua Router tetangga tersebut.

Untuk menghubungkan antar Router, masing-masing Router akan terhubung dengan Frame Relay Switch, Switch ini yang akan melakukan pengalihan DLCI, jika pada MPLS yang akan menjadi Frame Relay Switch adalah Router PE, Router PE akan mengalihkan DLCI menuju Router PE lainnya.

Seperti yang sudah saya jelaskan sebelumnya, MPLS L2VPN akan membentuk jalur psuedowire untuk setiap koneksi Layer 2 yang ingin dibentuk, karena Frame Relay menggunakan PVC yang jumlahnya mungkin lebih dari satu dan juga karena Frame Relay tidak point-to-point mungkin kita akan mengkonfigurasi psuedowire lebih dari satu untuk konfigurasi saat ini.

Berikut ini adalah topolginya :

Pertama kita konfigurasi IP Address dan MPLS pada Router-Router yang bertindak sebagai MPLS Backbone.

    R1

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#mpls ip
    R1(config-if)#no sh
    R1(config-if)#exi

    R2

    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi
    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#mpls ip
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#mpls ip
    R2(config-if)#no sh
    R2(config-if)#exi

    R3

    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#mpls ip
    R3(config-if)#no sh
    R3(config-if)#exi

Lalu konfigurasi EIGRP agar antar Router tersebut dapat saling terhubung, dan MPLS dapat berjalan dengan baik.

    R1

    R1(config)#router eigrp 10
    R1(config-router)#no auto-summ
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#exi

    R2

    R2(config)#router eigrp 10
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#exi

    R3

    R3(config)#router eigrp 10
    R3(config-router)#no auto-summ
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#exi

Setelah selesai membuat MPLS Backbone, sekarang kita mulai konfigurasi L2VPN Frame Relay, kita berkonsentrasi konfigurasi pada Router PE saja yaitu R1 dan R3.

    R1
    Pertama konfigurasi Interface yang terhubung dengan CE, encapsulation menjadi frame relay.

    R1(config)#int s2/0    
    R1(config-if)#encapsulation frame-relay
    R1(config-if)#frame-relay intf-type dce
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int s2/1
    R1(config-if)#encapsulation frame-relay
    R1(config-if)#frame-relay intf-type dce
    R1(config-if)#no sh
    R1(config-if)#exi

    Aktifkan frame-relay switching.

    R1(config)#frame-relay switching 

    Kita buat psuedowire sebagai jalur masing-masing DLCI yaitu 45 dan 65 yang mengarah ke Router R3, dan ingat VCID keduanya harus berbeda.

    R1(config)#connect R4-to-R5 s2/0 45 l2transport
    R1(config-fr-pw-switching)#xconnect 3.3.3.3 45 encap mpls

    Yang diatas merupakan psuedowire untuk menghubungkan R4 dan R5 dengan VCID 45, DLCI R4 untuk ke R5 adalah 45 dan dikirimkan ke 3.3.3.3 (R3) lewat MPLS. kemudian konfigurasi psuedowire berikutnya.

    R1(config)#connect R6-to-R5 s2/1 65 l2transport
    R1(config-fr-pw-switching)#xconnect 3.3.3.3 65 encap mpls

    yang diatas itu psuedowire untuk R6 terhubung dengan R5.
    R3
    Dan kita lanjut pada Router R3, penjelasan konfigurasi tidak jauh berbeda.

    R3(config)#int s2/0
    R3(config-if)#encapsulation frame-relay
    R3(config-if)#frame-relay intf-type dce
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#frame-relay switching
    R3(config)#connect R5-to-R4 s2/0 54 l2transport
    R3(config-fr-pw-switching)#xconnect 1.1.1.1 45 encap mpls
    R3(config-xconn)#exi
    R3(config-fr-pw-switching)#exi
    R3(config)#connect R5-to-R6 s2/0 56 l2transport
    R3(config-fr-pw-switching)#xconnect 1.1.1.1 65 encap mpls
    R3(config-xconn)#exi
    R3(config-fr-pw-switching)#exi

Kemudian konfigurasi Frame Relay pada Router CE, metode menghubungkan antar Router kali ini saya menggunakan point to multipoint artinya satu Router (R5.Hub) akan menjadi perantara untuk menghubungkan Router lainnya, yaitu menghubungkan antara R4.spoke dan R6.spoke.

    R4
    Konfigurasi interface dan DLCI pada Router.

    R4(config)#int s2/0
    R4(config-if)#encap frame-relay
    R4(config-if)#frame-relay interface-dlci 45
    R4(config-fr-dlci)#ip add 45.45.45.4 255.255.255.0
    R4(config-if)#ip ospf network non-broadcast
    R4(config-if)#no sh
    R4(config-if)#exi
    R4(config)#int lo0
    R4(config-if)#ip add 4.4.4.4 255.255.255.255
    R4(config-if)#exi

    Dan konfigurasi Routing OSPF.

    R4(config)#router ospf 10
    R4(config-router)#neighbor 45.45.45.5
    R4(config-router)#net 45.45.45.0 0.0.0.255 area 0
    R4(config-router)#net 4.4.4.4 0.0.0.0 area 0
    R4(config-router)#exi

    R6

    R6(config)#int s2/0
    R6(config-if)#encap frame-relay
    R6(config-if)#frame-relay interface-dlci 65
    R6(config-fr-dlci)#ip add 56.56.56.6 255.255.255.0
    R6(config-if)#ip ospf network non-broadcast
    R6(config-if)#no sh
    R6(config-if)#exi
    R6(config)#int lo0
    R6(config-if)#ip add 6.6.6.6 255.255.255.255
    R6(config-if)#exi
    R6(config)#router ospf 10
    R6(config-router)#neighbor 56.56.56.5
    R6(config-router)#net 56.56.56.0 0.0.0.255 area 0
    R6(config-router)#net 6.6.6.6 0.0.0.0 area 0
    R6(config-router)#exi

    R5.Hub
    Konfigurasi Interface encapsulation frame-relay.

    R5(config)#int lo0
    R5(config-if)#ip add 5.5.5.5 255.255.255.255
    R5(config-if)#exi
    R5(config)#int s2/0
    R5(config-if)#encap frame-relay
    R5(config-if)#no sh
    R5(config-if)#exi

    Pada Router ini kita buat dua subinterface untuk terhubung dengan R4 dan R6, pertama kita buat sub interface untuk R4.

    R5(config)#int s2/0.54 point-to-point 
    R5(config-subif)#frame-relay interface-dlci 54
    R5(config-fr-dlci)#ip add 45.45.45.5 255.255.255.0
    R5(config-subif)#ip ospf network non-broadcast
    R5(config-subif)#no sh
    R5(config-subif)#exi

    Kemudian untuk R6.

    R5(config)#int s2/0.56 point-to-point
    R5(config-subif)#frame-relay interface-dlci 56
    R5(config-fr-dlci)#ip add 56.56.56.5 255.255.255.0
    R5(config-subif)#ip ospf network non-broadcast
    R5(config-subif)#no sh
    R5(config-subif)#exi

    Dan konfigurasi Routing OSPF untuk mendistribusikan informasi Routing antar Router CE.

    R5(config)#router ospf 10
    R5(config-router)#neighbor 45.45.45.4
    R5(config-router)#neighbor 56.56.56.6
    R5(config-router)#net 45.45.45.0 0.0.0.255 area 0
    R5(config-router)#net 56.56.56.0 0.0.0.255 area 0
    R5(config-router)#net 5.5.5.5 0.0.0.0 area 0

Konfirmasi

Untuk melakukan konfirmasi pertama kita lihat Routing table pada salah satu Router CE, apakah sudah dapat saling berkomunikasi menggunakan OSPF.

R6(config)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

4.0.0.0/32 is subnetted, 1 subnets
O 4.4.4.4 [110/129] via 56.56.56.5, 00:00:12, Serial2/0
5.0.0.0/32 is subnetted, 1 subnets
O 5.5.5.5 [110/65] via 56.56.56.5, 00:00:12, Serial2/0
6.0.0.0/32 is subnetted, 1 subnets
C 6.6.6.6 is directly connected, Loopback0
45.0.0.0/24 is subnetted, 1 subnets
O 45.45.45.0 [110/128] via 56.56.56.5, 00:00:12, Serial2/0
56.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 56.56.56.0/24 is directly connected, Serial2/0
L 56.56.56.6/32 is directly connected, Serial2/0

Lalu lakukan PING antar Router melalui interface loopback.

R6#ping 4.4.4.4 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
Packet sent with a source address of 6.6.6.6
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 35/36/37 ms
R6#ping 5.5.5.5 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds:
Packet sent with a source address of 6.6.6.6
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 18/18/18 ms