Pembahasan Soal Superlab Cisco IDN Competition 2017 : Section 1 Part 2

Joss, kita lanjutin lagi ke Section 1 part 2. Untuk Pembahasan sebelumnya bisa di clik disini Pembahasan Soal Superlab Cisco IDN Competition 2017 : Section 1 Part 1

1.3 Spanning Tree

1. Pada tahap ini kita diminta untuk mengkonfigurasikan beberapa device dengan ketentuan
sebagai berikut :

  • Konfigurasikan mode yang langsung membypass listening dan learning, konfigurasikan mode ini hanya pada port yang mengarah ke client (PC).

Jadi kita diminta untuk mengkonfigurasi spanning tree portfast pada port switch yang mengarah ke client (PC)

Switch yang perlu dikonfigurasi pada jaringan

  • Internet    : SW0 port fa0/3 (Disini masih kurang yakin perlu dikonfigurasi atau gk. Cuman diliat dari soalnya minta semua PC, jadi mungkin disini juga diminta)
  • Makassar : SW11 port fa0/3
  • Semarng  : SW-SMG port fa0/3-4
  • Solo          : SW7-SW10 port fa0/2-3 dan SW6 port fa0/9

Untuk perintah nya :

  • Masuk ke interface : interface fa0/nomor-interface.
    Jika ada 2 interface yang dikonfigurasi contoh pada SW-SMG, Gunakan range. Ex: interface range fa0/3-4

    • spanning-tree portfast : mengaktifkan fitur spanning tree portfast

Cukup 2 perintah tersebut

1.4 Implement WAN Technologies

1. Konfigurasikan WAN pada link ISP6 dan R19 di Jayapura dengan ketentuan sebagai berikut :

  •  Link WAN harus support negotiation dan authentication
  • Gunakan WAN Protocol yang memiliki fitur kompresi, authentikasi, dan error detection
  • Untuk authentikasinya gunakan mode yang support enkripsi
  • Jangan merubah hostname di kedua device gunakan password idnmantab

WAN Technologies, yang perlu kita konfigurasi itu adalah encapsulation pada interface serial di antar router. Disini yang diminta adalah ISP6 dan R19. Yang support negotiation dan authentication itu encapsulation menggunakan PPP. Authentication pada PPP ada 2, PAP sama CHAP. Tpi disini diminta yang mensupport enkripsi berarti kita menggunakan CHAP.

Selection_022
Link Serial ISP6-R19

ISP6

  • interface se0/0/1
    • no shutdown
      (karena pada router semua interface defaultnya dalam keadaan shutdown)
    • encapsulation ppp
    • ppp authentication chap
    • exit (perlu exit karena command selanjutnya digunakan pada global-config)
  • username R19 password idnmantab
    (Untuk authentikasi menggunakan chap kita membuat user dengan hostname lawan (R19) lalu password yang sama dikedua router)
  • Untuk penghecheckan bisa menggunakan perintah “show interface se0/0/1” lalu lihat pada bagian encapsulation apakah sudah PPP
  • Namun jika router pasangannya (R19) belum dikonfigurasi maka status interface akan down

R19

  • interface se0/0/0
    • no shutdown
    • encapsulation ppp
    • ppp authentication
    • exit
  • username ISP6 password idnmantab
  • Jika kedua router sudah di konfigurasi maka status interfacenya akan kembali up

2. Konfigurasikan WAN pada link ISP4 dan R13 di Semarang dengan ketentuan sebagai berikut:

  • Link WAN harus support negotiation dan authentication
  • Gunakan WAN Protocol yang memiliki fitur kompresi, authentikasi dan error detection
  • Gunakan authentikasi yang support enkripsi
  • Jangan merubah hostname di kedua device gunakan password idn

Disini juga sama saja seperti sebelumnya. Cuman beda di password saja

Selection_023.png
Link antar ISP4 – R13

ISP4

  • interface se0/1/1
    • no shutdown
    • encapsulation ppp
    • ppp authentication dot1q
    • exit
  • username R13 password idn

R13

  • interface se0/1/0
    • no shutdown
    • encapsulation ppp
    • ppp authentication dot1q
    • exit
  • username ISP4 password idn

3. Konfigurasikan WAN pada link ISP1 dan R2 di Jakarta dengan ketentuan sebagai berikut:

  • Gunakan Link WAN yang mempunyai encapsulation default untuk interface serial
  •  Jangan merubah hostname di kedua device

Disini kita diminta untuk mengkonfigurasi link antar ISP1 dan R2 di Jakarta menggunakan encapsulation default yaitu HDLC. Gk ada authentication disini, jadi hanya perlu menyalakan interface dan di ubah ke HDLC. 

Selection_024.png
Link ISP1 – R2

Jika kita check link antar ISP1 dan R2, Linknya menggunakan encapsulation PPP. Contoh check di R2

Selection_025.png
Check encapsulation interface serial 0/1/0 pada Router R2

R2

  • interface se0/1/0
    • no shutdown
    • encapsulation hdlc

ISP1

  • interface se0/0/0
    • no shutdown
    • encapsulation hdlc

Jika mau di check gunakan perintah “show interface inteface-number”

1.5 Implement VPN

Untuk yang VPN saya skip dulu. 😀 saya masih bingung yang diminta jadi VPN Server atau tunneling. Soalnya saya udah coba keduanya gk ada naik nilainya 😀
Mungkin nanti klo sudah dapat pencerahan dari yang buat, saya share lagi buat VPN

OK ? siap, Udah selesai yang section 1 semoga mudah dipahami dan dimengerti.

Post berikutnya lanjut ke Section 2 (Layer 3). Jadi pastikan pantau blognya yaa …

Pembahasan Soal Superlab Cisco IDN Competition 2017 : Section 1 Part 1

Kali ini akan membahas soal superlab cisco yang di adakan oleh ID-Networkers. Udah 2 kali coba dan nilainya cuman dapat 75% saja. OK gk masalah, bukan masalah nilai yang kita butuhkan yang penting kita dapat belajar hal baru lagi dengan mencoba soal ini. Aku masih belajar juga mungkin di pembahasan ini ada yang salah atau kurang benar mohon dikoreksi dan juga kedepannya ada beberapa service yang saya tidak masukkan karena saya juga masih bingung.

Sebelum mengerjakan juga diharapkan udah paham ya cara konfigurasi di cisco bagaimana. Beberapa service udah ada saya jelasin di blog, tinggal di cari saja. Misal VTP atau VLAN dll.

Untuk soal dan file .pka nya bisa di ambil di sini Soal dan Pka

Topologi Jaringan

A. Physical Topologi

Selection_009.png
Physical Topologi

B. Logical Topologi

Selection_010
Logical Topologi

Jangan terlalu pusing melihat topologinya yang besar. Kita kerjainnya satu-satu biar mudah. Fokus ke soal saja, kerjain per service yang diminta.

Section 1 : Switching

1.1 Switch Administration (VTP)

1. Konfigurasikan device di bagian Jakarta dengan ketentuan sebagai berikut :

  • VTP domain harus di set idncompetition2017
  • Jangan gunakan VTP versi default
  •  SW2 harus di set agar menerima informasi VTP dari SW1
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    IDNcompetition2017mantab

Kita pahamin dulu soalnya ok. Kita diminta untuk mengkonfigurasi VTP pada SW1 dan SW2 di Jakarta dengan ketentuan :

  • VTP Domain : idncompetition2017
  • VTP Version 2, karena VTP versi defaultnya adalah versi 1
  • SW1 modenya Server dan SW2 modenya Client
  • VTP password : IDNcompetition2017mantab

Konfigurasinya :

SW1

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode server
  4. vtp password IDNcompetition2017mantab

SW2

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode client
  4. vtp password IDNcompetition2017mantab

Untuk pengecheckan vtp nya bisa menggunakan perintah

  1. show vtp status
  2. show vtp password

2. Konfigurasikan device di bagian Samarinda dengan ketentuan sebagai berikut :

  • VTP domain harus di set idncompetition2017
  • Jangan gunakan VTP versi default
  • Pastikan MLS4 menerima update informasi VTP dari MLS3
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    IDNcompetition2017mantab

Hampir sama saja dengan yang dijakarta. Kita mengerjakannya di Samarinda dan disini MLS4 sebagai Client dan MLS3 sebagai Server

MLS3

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode server
  4. vtp password IDNcompetition2017mantab

MLS4

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode client
  4. vtp password IDNcompetition2017mantab

3. Konfigurasikan device di bagian Makasar dengan ketentuan sebagai berikut :

  • VTP domain harus di set IDNcompetition2017!
  • Jangan gunakan VTP versi default
  • Pastikan MLS5 dan MLS6 tidak menyebarkan informasi VTP ke switch lain
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    idnmantab

Kita mengerjakannya di Makasar. Hampir sama seperti sebelumnya. Bedanya disini kedua switch menggunakan mode VTP Transparent.

MLS5 & MLS6

  1. vtp domain IDNcompetition2017!
  2. vtp version 2
  3. vtp mode transparent
  4. vtp password idnmantab

4. Konfigurasikan device di bagian Semarang dengan ketentuan       sebagai berikut :

  • VTP domain harus di set idnid
  • Pastikan semua switch di area semarang mendapat update informasi VTP dari MLS8
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    idncompetition2017

Disini mungkin menggunakan vtp version 1 karena tidak diminta untuk mengubahnya. Semua switch di Semarang modenya adalah client kecuali MLS8 yang menggunakan mode server

MLS8

  1. vtp domain idnid
  2. vtp mode server
  3. vtp password idncompetition2017

MLS1, MLS2 & MLS7

  1. vtp domain idnid
  2. vtp mode client
  3. vtp password idncompetition2017

4. Konfigurasikan device di bagian Solo dengan ketentuan sebagai berikut :

  • VTP domain harus di set IDNcompetition2017!
  • Jangan gunakan VTP versi default
  •  Konfigurasikan agar SW3 mau menyebarkan update informasi VTP ke Swith lain yang ada di Solo
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    IDN@2017_competition

Disini SW3 sebagai server dan switch yang lainnya sebagai client

SW3

  1. vtp domain IDNcompetition2017!
  2. vtp version 2
  3. vtp mode server
  4. vtp password IDN@2017_competition

SW4-10

  1. vtp domain IDNcompetition2017!
  2. vtp version 2
  3. vtp mode client
  4. vtp password IDN@2017_competition

1.2 Layer 2 Ports

1. Pada tahap ini kita diminta untuk mengkonfigurasikan beberapa device dengan ketentuan sebagai berikut :

  • Konfigurasikan VLAN pada device sesuai dengan logical topologi.
  • Pastikan database VLAN antar switch sama.
  • Konfigurasikan link antara SW1-SW2 dan MLS3-MLS4 pastikan semua link up menggunakan tipe open standard.
  • Semua port switch pada topologi yang support up to 1000mb/s pastikan statusnya di assign ke vlan88 dan statusnya administratively down

Ini kita kerjakan di Jakarta dan Samarinda. Kita disuruh membuat VLAN dan assign interface ke VLAN menyesuaikan sesuai dengan logical topologi.

Jakarta


Untuk link antar switch menggunakan tipe dot1q lalu di trunk. Trus port interface gig itu dimasukkan ke vlan88 dan di shutdown biar statusnya jadi administratively down. Kita konfigurasi SW1 dulu untuk membuat VLAN karena SW1 sebagai VTP server. Dan juga memasukkan masing-masing interface sesuai logical topologi.

SW1

  1. Buat vlan sesuai logical yaitu VLAN 14,15,23,24,35,46,57,67,88 totalnya ada 9 VLAN
    • perintah “vlan vlan-number
    • Check dengan perintah “show vlan brief”
  2. Interface 21-23 kita ubah menjadi trunk
    • interface range fa0/21-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • Check dengan perintah “show interface fa0/21 switchport” atau “show run”
  3. Assign Vlan sesuai Logical topologi
    • interface fa0/6
      • switchport mode access
      • switchport access vlan 67
    • interface fa0/7
      • switchport mode access
      • switchport access vlan 67
    • interface fa0/4
      • switchport mode access
      • switchport access vlan 14
    • interface fa0/5
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
      • Dikonfigurasi Trunk karena pada fa0/5 terhubung ke R5-fa0/0 yang menggunakan interVLAN
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 24
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 35
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 14
    • Check dengan perintah “show vlan brief”
  4. Masukkan vlan 88 pada interface gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown
    • Check dengan perintah “show vlan brief” dan “show ip interface brief”

SW2

  1. Gk usah buat VLAN, karena sudah terbuat hasil dari VTP. bisa di check menggunakan “show vlan brief”
  2. Interface fa0/21-23 ubah menjadi trunk
    • interface range fa0/21-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign Vlan sesuai Logical topologi
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 23
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 23
    • interface fa0/4
      • switchport trunk encapsulation dot1q
      • switchport mode trunk (penjelasan sama seperti sebelumnya)
    • interface fa0/5
      • switchport mode access
      • switchport access vlan 15
    • interface fa0/6
      • switchport mode access
      • switchport access vlan 46
    • interface fa0/7
      • switchport mode access
      • switchport access vlan 57
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 15
  4. Masukkan vlan 88 pada interface gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown

Samarinda


Hampir sama dengan di Jakarta. Bedanya hanya di VLAN dan interfacenya. Kita buat VLANnya di MLS3 karena sebagai VTP Server

MLS3

  1. Membuat VLAN 89,108,118,109,119,110,88 total ada 7 vlan.
    • vlan vlan-number
  2. Ubah interface fa0/20-23 menjadi trunk
    • interface range fa0/20-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 89
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 109
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 108
    • interface fa0/4
      • switchport trunk encapsulation dot1q
      • switchport mode trunk (Diubah ke trunk karena fa0/0 pada R11 menggunakan interVLAN)
  4. Assign VLAN 88 ke gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown

MLS4

  1. Membuat VLAN 89,108,118,109,119,110,88 total ada 7 vlan.
    • vlan vlan-number
  2. Ubah interface fa0/20-23 menjadi trunk
    • interface range fa0/20-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/2
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/3
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  4. Assign VLAN 88 ke gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown

2. Konfigurasikan network device yang ada di Makassar dengan ketentuan sebagai berikut :

  • Pastikan database VLAN antar switch sama.
  • Konfigurasikan VLAN dan assign switchport sesuai dengan topologi logical.
  • Gunakan model dot1q trunk untuk menghubungkan SW5 dan SW6. (maksudnya MLS5 dan MLS6)
  • Trunk jangan di set auto negotiation ataupun etherchannel.

Sama seperti sebelumnya. Kita buat VLANnya dulu. Karena kedua VLAN menggunakan VTP transparent jadi keduanya membuat VLAN. Assign interface ke VLAN sesuai dengan logical topologi. Interface antar MLS5-MLS6 diganti ke trunk dengan dot1q.


MLS5

  1. Buat VLAN 156 dan 157 “vlan vlan-number”
  2. Interface fa0/11-13 ubah menjadi trunk
    • interface range fa0/11-13
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 156
    • Karena R16 terhubung ke VLAN 156 menggunakan interface e0/1/0 maka di MLS5 cuman 1 interface saja

MLS6

  1. Buat VLAN 156 dan 157 “vlan vlan-number”
  2. Interface fa0/11-13 ubah menjadi trunk
    • interface range fa0/11-13
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 157
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 157
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 156

3. Konfigurasikan network device yang ada di Semarang dengan ketentuan sebagai berikut :

  • Pastikan database VLAN antar switch sama.
  • Konfigurasikan VLAN dan assign switchport sesuai dengan topologi logical. Pastikan VLAN yang telah di assign banar dan sesuai topologi.
  • Trunk jangan di set auto negotiation ataupun etherchannel.

Sama seperti sebelumnya. Kita buat VLANnya hanya di MLS8 karena VTP modenya server dan switch lain VTP modenya client. Lalu assign sesuai topologi. Dan antar switchnya gunakan mode trunk.


MLS8

  1. Buat VLAN 212, 213, 214, 223, 224, 234 dengan perintah “vlan vlan-number”
  2. Interface fa0/21-22 modenya jadi trunk
    • interface range fa0/21-22
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 213
    • interface fa0/2
      • switchport trunk encapsulation dot1q
      • swithcport mode trunk

MLS7

  1. VLAN sudah terbuat, bisa di check dengan “show vlan brief”
  2. Interface fa0/22-23 kita ubah modenya jadi trunk
    • interface range fa0/22-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/2
      • switchport trunk encapsulation dot1q
      • switchport mode turnk

MLS1

  1. VLAN sudah terbuat, bisa di check dengan “show vlan brief”
  2. Interface fa0/20 dan fa0/23 diubah menjadi trunk (dan bukan sampai)
    • interface range fa0/20, fa0/23 (menggunakan “,” artinya dan”
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 234
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 214

MLS2

  1. VLAN sudah terbuat, bisa di check dengan “show vlan brief”
  2. Interface fa0/20-21 kita ubah modenya jadi trunk
    • interface range fa0/20-21
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/2
      • switchport mode access
      • switchpor access vlan 223

4. Konfigurasikan network device yang ada di Solo dengan ketentuan sebagai berikut :

  • Pastikan database VLAN antar switch sama
  • Konfigurasikan VLAN dan assign switchport sesuai dengan topologi logical
  • Pastikan semua link di setiap switch di gunakan untuk mengirimkan dan menerima data.
  • Untuk mengatasi permasalahan point C pada SW3 dan SW4 gunakan mode tanpa
    negotiations dan sisanya gunakan mode cisco propritary.
  • Gunakan Network 172.34.34.0/30 untuk menghubungkan SW3 dan SW4, IP terkecil
    gunakan untuk SW3 dan IP terbesar gunakan untuk SW4.

Untuk poin 1 dan 2 sama seperti sebelumnya. Kita buat VLANnya di SW3 karena menjadi VTP Server.  Untuk point ke-3  mintanya semua linknya aktif, jadi kita konfigurasi etherchannel disitu. Untuk poin ke-4 semua switch di Solo menggunakan mode pagp kecuali SW3 dan SW4 yang menggunakan mode on. Trus nanti antar switch kita ubah ke trunk kecuali SW3 dan SW4 yang linknya kita kasih IP Address.


SW3

  1. Membuat VLAN 7,8,9 dan 10 menggunakan perintah “vlan vlan-number”
  2. Konfigurasi Etherchannel, group number ada pada physical topologi.
    • interface range fa0/2-3 (Link SW3-SW5)
      • channel-group 35 mode desirable (disini aku gk tau modenya pake auto atau desirable soalnya di soal gk ada penjelasannya)
      • nanti akan terbuat port-channel 35, jadi interface fa0/2-3 digabung menjadi port-channel 35. disitu baru kita ubah ke mode trunk
      • channel-protocol pagp (optional)
    • interface port-channel 35
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/4-5 (Link SW3-SW6)
      • channel-group 36 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 36
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/10-12 (Link SW3-SW4)
      • no switchport (perlu kita definisikan dlu secara manual agar link antar SW3 dan SW4 sama sama menggunakan no switchport)
      • channel-group 34 mode on
    • interface port-channel 34
      • no switchport
      • ip address 172.34.34.1 255.255.255.252

SW4

  1. VLAN sudah terbuat
  2. Konfigurasi Etherchannel, group number sesuai dengan topologi
    • interface range fa0/2-3 (Link SW4-SW6)
      • channel-group 46 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 46
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/4-5 (Link SW4-SW5)
      • channel-group 45 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 45
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/10-12 (Link SW3-SW4)
      • no switchport
      • channel-group 34 mode on
    • interface port-channel 34
      • no switchport
      • ip address 172.34.34.1 255.255.255.252

SW5

  1. VLAN sudah terbuat
  2. Konfigurasi Trunk yang mengaraha ke Switch Client
    • interface range fa0/7-8
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Konfigurasi Etherchannel, group number sesuai dengan topologi
    • interface range fa0/1-2 (Link SW3-SW5)
      • channel-group 35 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 35
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/5-6(Link SW4-SW5)
      • channel-group 45 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 45
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/3-4(Link SW5-SW6)
      • channel-group 11 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 11
      • switchport trunk encapsulation dot1q
      • switchport mode trunk

SW6

  1. VLAN sudah terbuat
  2. Konfigurasi Trunk yang mengaraha ke Switch Client
    • interface range fa0/7-8
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN 10 pada interface fa0/9
    • interface fa0/9
      • switchport mode access
      • switchport access vlan 10
  4. Konfigurasi Etherchannel, group number sesuai dengan topologi
    • interface range fa0/1-2 (Link SW4-SW6)
      • channel-group 46 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 46
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/5-6(Link SW3-SW6)
      • channel-group 36 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 36
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/3-4(Link SW5-SW6)
      • channel-group 11 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 11
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  5. Untuk penghechekan etherchannelnya bisa menggunakan perintah “show etherchannel summary” apakah tandanya sudah “P” dan “SU”

SW7-SW10

  1. Pada interface fa0/1 menjadi mode trunk
    • Switchport mode trunk
  2. Assign VLAN sesuai topologi pada interface fa0/2-3

Untuk 1.3 dan Selanjutnya akan di bahas di Part 2. Selamat mencoba dan mudahan dimengerti

Cisco LAB.28 – NAT PAT

Tujuan :

  1. Mengetahui konfigurasi NAT PAT
  2. Mengubah IP Private menjadi hanya 1 IP Public saja

NAT PAT, PAT singkatan dari Port Address Translation. Penggunannya sama seperti sebelumnya, yaitu mengubah IP Address Private menjadi IP Address Public, namun PAT mengubah port nya. Jadi jika pada Static NAT atau Dynamic NAT kita harus memiliki lebih dari 1 IP Public. Bagaimana jika kita hanya dapat 1 IP Public saja ? maka NAT PAT adalah solusinya. Untuk topologinya gunakan LAB Sebelumnya

screenshot3

Topologi NAT PAT

Perbedaan antara Dynamic NAT dengan NAT PAT hanya terletak pada perintah overload. 

  1. Konfigurasi IP Address pada semua device.
  2. Konfigurasi Default Route pada R1
  3. Tambahkan Access-list yang berisi network Client
  4. Tambahkan konfigurasi NAT PAT

Hapus konfigurasi NAT Pool, lalu buat lagi namun hanya memberi 1 IP Public saja dan Dynamic NAT namun biarkan konfigurasi lainnya.

R1(config)#no ip nat inside source list 1 pool CLIENT

Dynamic mapping in use, do you want to delete all entries? [no]: yes
R1(config)#no ip nat pool CLIENT

Tambahkan NAT POOL

R1(config)#ip nat pool PAT 12.12.12.1 12.12.12.1 netmask 255.255.255.0

Lalu tambahkan konfigurasi NAT PAT, dengan tambahan overload

R1(config)#ip nat inside source list 1 pool PAT overload

Lalu test ping dari PC2 dan PC3

PC2> ping 100.100.100.2
100.100.100.2 icmp_seq=1 timeout
100.100.100.2 icmp_seq=2 timeout
84 bytes from 100.100.100.2 icmp_seq=3 ttl=62 time=26.001 ms
84 bytes from 100.100.100.2 icmp_seq=4 ttl=62 time=30.001 ms
84 bytes from 100.100.100.2 icmp_seq=5 ttl=62 time=52.003 ms
PC3> ping 100.100.100.2
84 bytes from 100.100.100.2 icmp_seq=1 ttl=62 time=32.002 ms
84 bytes from 100.100.100.2 icmp_seq=2 ttl=62 time=30.002 ms
84 bytes from 100.100.100.2 icmp_seq=3 ttl=62 time=52.003 ms
84 bytes from 100.100.100.2 icmp_seq=4 ttl=62 time=32.002 ms
84 bytes from 100.100.100.2 icmp_seq=5 ttl=62 time=29.002 ms

Dan jika kita lihat translationnya maka hanya menggunakan satu IP yaitu 12.12.12.1 namun portnya yang berbeda

R1#show ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
icmp 12.12.12.1:54883  192.168.1.2:54883  100.100.100.2:54883 100.100.100.2:54883
icmp 12.12.12.1:55139  192.168.1.2:55139  100.100.100.2:55139 100.100.100.2:55139
icmp 12.12.12.1:55395  192.168.1.2:55395  100.100.100.2:55395 100.100.100.2:55395
icmp 12.12.12.1:53091  192.168.1.3:53091  100.100.100.2:53091 100.100.100.2:53091
icmp 12.12.12.1:53603  192.168.1.3:53603  100.100.100.2:53603 100.100.100.2:53603
icmp 12.12.12.1:53859  192.168.1.3:53859  100.100.100.2:53859 100.100.100.2:53859
icmp 12.12.12.1:54115  192.168.1.3:54115  100.100.100.2:54115 100.100.100.2:54115
icmp 12.12.12.1:54371  192.168.1.3:54371  100.100.100.2:54371 100.100.100.2:54371

Cisco LAB.27 – Dynamic NAT (DNAT)

Tujuan :

  1. Mengetahui konfigurasi Dynamic NAT
  2. Mengubah IP private menjadi IP Public secara otomatis

Lab sebelumnya kita menggunakan SNAT. Namun kekurangannya adalah kita harus satu satu mendefinisikan IP address private apa menjadi IP address public apa. Masalah akan terjadi jika kita memiliki banyak client. Apa kita harus satu-satu mengubahnya ?. Maka dari itu digunakanlah DNAT yang akan mengubah sebuah network menjadi IP public. Untuk topologinya kita akan menggunakan topologi sebelumnya.

screenshot3

Topologi Dynamic NAT

Hapus konfigurasi Static NAT pada LAB sebelumnya.

R1(config)#no ip nat source static 192.168.1.2 12.12.12.100

Selanjutnya kita perlu definisikan network yang ingin di ubah dengan access-list.

R1(config)#access-list 1 permit 192.168.1.0 0.0.0.255

Setelah itu membuat pool IP Address public.

R1(config)#ip nat pool CLIENT 12.12.12.100 12.12.12.150 netmask 255.255.255.0

Jadi kita hanya akan mengubah menjadi IP Public 12.12.12.100 sampai 12.12.12.150 saja.
Lalu konfigurasi Dynamic NAT nya menggunakan pool dan access-list yang sudah kita buat sebelumnya

R1(config)#ip nat inside source list 1 pool CLIENT

Jangan lupa definisikan Inside dan Outsidenya

R1(config)#int fa0/1
R1(config-if)#ip nat inside

R1(config-if)#int fa0/0
R1(config-if)#ip nat outside

Kita coba test ping dari PC2 dan PC3 PC Server

PC2> ping 100.100.100.2
100.100.100.2 icmp_seq=1 timeout
84 bytes from 100.100.100.2 icmp_seq=2 ttl=62 time=30.002 ms
84 bytes from 100.100.100.2 icmp_seq=3 ttl=62 time=31.002 ms
84 bytes from 100.100.100.2 icmp_seq=4 ttl=62 time=29.001 ms
84 bytes from 100.100.100.2 icmp_seq=5 ttl=62 time=33.002 ms
PC3> ping 100.100.100.2
100.100.100.2 icmp_seq=1 timeout
100.100.100.2 icmp_seq=2 timeout
84 bytes from 100.100.100.2 icmp_seq=3 ttl=62 time=56.003 ms
84 bytes from 100.100.100.2 icmp_seq=4 ttl=62 time=26.001 ms
84 bytes from 100.100.100.2 icmp_seq=5 ttl=62 time=29.002 ms

Dan kita lihat pada translationnya, IP Private berapa akan diubah menjadi IP Public berapa. IP Private diubah mulai dari IP 12.12.12.100

R1#show ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
--- 12.12.12.101       192.168.1.2        ---                ---
--- 12.12.12.100       192.168.1.3        ---                ---

Cisco LAB.26 – Static NAT (SNAT)

Tujuan :

  1. Mengetahui konfigurasi Static NAT
  2. PC2 akan menggunakan IP network 12.12.12.100 untuk menuju PC Server

NAT merupakan singakatan dari Network Address Translation. Ini digunakan untuk mengubah IP Private ke IP Publik. Kenapa harus diubah ? karena IP Private tidak dikenal dalam jaringan internet dan yang dikenal hanya IP Publiknya saja. Kita akan menggunakan topologi seperti sebelumnya.

screenshot3

Topologi Static NAT

Konfigurasi sebelumnya dihapus terlebih dahulu. Setelah itu pasang IP Address, namun sekarang kita tidak akan menggunakan EIGRP. PC Server dan R2 kita anggap sebagai internet . Maka pada R1 kita tambahkan default route.

R1(config)#ip route 0.0.0.0 0.0.0.0 12.12.12.2

R1#ping 100.100.100.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 100.100.100.2, timeout is 2 seconds:
..!!!
Success rate is 60 percent (3/5), round-trip min/avg/max = 20/34/44 ms

Jika di ping dari R1 hasilnya pasti reply, karena R2 juga mengetahui network 12.12.12.0/24. Bagaimana dengan PC2 dan PC3 ?

PC2> ping 100.100.100.2
100.100.100.2 icmp_seq=1 timeout
100.100.100.2 icmp_seq=2 timeout
100.100.100.2 icmp_seq=3 timeout
100.100.100.2 icmp_seq=4 timeout
100.100.100.2 icmp_seq=5 timeout

Hasilnya akan RTO. Ini dikarenakan router R2 tidak mengetahui network yang dimiliki PC2 dan PC3 yaitu 192.168.1.0/24.
Konfigurasi Static NAT pada R1, yang akan mengubah IP Address 192.168.1.2 menjadi 12.12.12.100

R1(config)#ip nat inside source static 192.168.1.2 12.12.12.100

Lalu definisikan jaringan local dan jaringan internet.

R1(config)#int fa0/1
R1(config-if)#ip nat inside

R1(config-if)#int fa0/0
R1(config-if)#ip nat outside

Dan lakukan ping dari PC2 ke PC Server

PC2> ping 100.100.100.2
100.100.100.2 icmp_seq=1 timeout
84 bytes from 100.100.100.2 icmp_seq=2 ttl=62 time=50.003 ms
84 bytes from 100.100.100.2 icmp_seq=3 ttl=62 time=29.002 ms
84 bytes from 100.100.100.2 icmp_seq=4 ttl=62 time=29.001 ms
84 bytes from 100.100.100.2 icmp_seq=5 ttl=62 time=23.001 ms

Hasilnya akan reply. Dan jika kita lihat IP berapa yang ditranslasikan. Yaitu dari IP 192.168.1.2 diubah menjadi 12.12.12.100

R1#show ip nat translations
Pro Inside global      Inside local       Outside local      Outside global
icmp 12.12.12.100:22084 192.168.1.2:22084 100.100.100.2:22084 100.100.100.2:22084
icmp 12.12.12.100:22596 192.168.1.2:22596 100.100.100.2:22596 100.100.100.2:22596
icmp 12.12.12.100:22852 192.168.1.2:22852 100.100.100.2:22852 100.100.100.2:22852
icmp 12.12.12.100:23108 192.168.1.2:23108 100.100.100.2:23108 100.100.100.2:23108
icmp 12.12.12.100:23364 192.168.1.2:23364 100.100.100.2:23364 100.100.100.2:23364
--- 12.12.12.100       192.168.1.2        ---                ---

Cisco LAB.25 Extended Access-list

Tujuan :

  1. Mengetahui konfigurasi extended access-list
  2. Memfilter protocol ICMP

Access-list yang kedua adalah extended. Extended lebih advance karena dapat memfilter protocol-protocol yang dapat dilihat di bawah ini :

R1(config)#access-list 100 permit ?
    An IP protocol number
  ahp      Authentication Header Protocol
  eigrp    Cisco's EIGRP routing protocol
  esp      Encapsulation Security Payload
  gre      Cisco's GRE tunneling
  icmp     Internet Control Message Protocol
  igmp     Internet Gateway Message Protocol
  ip       Any Internet Protocol
  ipinip   IP in IP tunneling
  nos      KA9Q NOS compatible IP over IP tunneling
  ospf     OSPF routing protocol
  pcp      Payload Compression Protocol
  pim      Protocol Independent Multicast
  tcp      Transmission Control Protocol
  udp      User Datagram Protocol

Sekarang kita akan mencoba memfilter paket ICMP, ICMP merupakan paket yang digunakan untuk melakukan ping. Topologi seperti sebelumnya

screenshot3

Topologi Extended Access-list

Hapus konfigurasi standard access-list pada router R1.

R1(config)#no access-list 1
R1(config)#no access-list 2

Setelah dihapus, sekarang seharusnya PC2 dan PC3 bisa terhubung ke PC Server

PC2> ping 100.100.100.2
84 bytes from 100.100.100.2 icmp_seq=1 ttl=62 time=62.003 ms
84 bytes from 100.100.100.2 icmp_seq=2 ttl=62 time=43.002 ms
84 bytes from 100.100.100.2 icmp_seq=3 ttl=62 time=21.002 ms
84 bytes from 100.100.100.2 icmp_seq=4 ttl=62 time=31.002 ms
84 bytes from 100.100.100.2 icmp_seq=5 ttl=62 time=40.002 ms
PC3> ping 100.100.100.2
84 bytes from 100.100.100.2 icmp_seq=1 ttl=62 time=49.003 ms
84 bytes from 100.100.100.2 icmp_seq=2 ttl=62 time=32.002 ms
84 bytes from 100.100.100.2 icmp_seq=3 ttl=62 time=29.002 ms
84 bytes from 100.100.100.2 icmp_seq=4 ttl=62 time=30.002 ms
84 bytes from 100.100.100.2 icmp_seq=5 ttl=62 time=24.001 ms

Sekarang kita akan memblock hanya paket icmp mengarah ke R2. Di R2 juga kita akan mengaktifkan http-server (80).

R2(config)#ip http server

Lalu test apakah port 80 bisa terhubungi atau tidak

PC2> ping 100.100.100.1 -3 -p 80
Connect   80@100.100.100.1 seq=1 ttl=254 time=44.003 ms
SendData  80@100.100.100.1 seq=1 ttl=254 time=214.013 ms
Close     80@100.100.100.1 seq=1 ttl=254 time=24.002 ms
Connect   80@100.100.100.1 seq=2 ttl=254 time=20.001 ms
SendData  80@100.100.100.1 seq=2 ttl=254 time=248.014 ms
Close     80@100.100.100.1 seq=2 ttl=254 time=28.002 ms

Sekarang kita akan memblock paket icmp pada PC2 dan tetap membolehkan port yang lainnya.

R1(config)#access-list 100 deny icmp host 192.168.1.2 host 100.100.100.1
R1(config)#access-list 100 permit ip any any
R1(config)#int fa0/1
R1(config-if)#ip access-group 100 in

Lalu lakukan test ping dari PC2

PC2> ping 100.100.100.1
*192.168.1.1 icmp_seq=1 ttl=255 time=18.001 ms (ICMP type:3, code:13, Communication administratively prohibited)
*192.168.1.1 icmp_seq=2 ttl=255 time=9.001 ms (ICMP type:3, code:13, Communication administratively prohibited)
*192.168.1.1 icmp_seq=3 ttl=255 time=10.001 ms (ICMP type:3, code:13, Communication administratively prohibited)
*192.168.1.1 icmp_seq=4 ttl=255 time=10.000 ms (ICMP type:3, code:13, Communication administratively prohibited)
*192.168.1.1 icmp_seq=5 ttl=255 time=11.000 ms (ICMP type:3, code:13, Communication administratively prohibited)

Hasilnya akan RTO dan lakukan test ping lagi menggunakan port 80

PC2> ping 100.100.100.1 -3 -p 80
Connect   80@100.100.100.1 seq=1 ttl=254 time=20.001 ms
SendData  80@100.100.100.1 seq=1 ttl=254 time=303.017 ms
Close     80@100.100.100.1 seq=1 ttl=254 time=46.003 ms
Connect   80@100.100.100.1 seq=2 ttl=254 time=27.001 ms
SendData  80@100.100.100.1 seq=2 ttl=254 time=236.014 ms
Close     80@100.100.100.1 seq=2 ttl=254 time=26.001 ms
Connect   80@100.100.100.1 seq=3 ttl=254 time=30.002 ms

Cisco LAB.24 – Standard Access-list

Tujuan :

  1. Mengetahui konfigurasi standard access-list
  2. Memfilter network dan host

Access-list hampir sama seperti firewall pada linux. Tugasnya yaitu memfilter network di ijinkan atau tidak di ijinkan. Access-list juga digunakan untuk mendefinisikan network yang dapat digunakan untuk service lainnya seperti NAT, EIGRP dll.

Access-list ada dua jenis :

  1. Standard Access-list  (1-99) : Memfilter network atau host saja
  2. Extended Access-list  (100-199): Dapat memfilter port dan protocol

Lanjut konfigurasi standard access-list

screenshot3

Topologi Standard Access-list

Konfigurasi IP Address terlebih dahulu pada semua device.  Pada R2 mengarah ke PC1 Server mengunakan IP Address 100.100.100.1

Setelah itu mengkonfigurasi EIGRP pada kedua router dan menadvertise semua network yang dimilikinya.

R1

R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 12.12.12.0 0.0.0.255
R1(config-router)#network 192.168.1.0

network 192.168.1.0 merupakan kelas C dilihat dari “192” maka dari itu tidak usah mendefinisikan subnet-mask, karena otomatis sudah terkirim.

R2

R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#network 12.12.12.0 0.0.0.255
R2(config-router)#network 100.100.100.0 0.0.0.3

Setelah dikonfigurasi, maka test ping dari PC2 atau PC3 ke PC Server

PC2

PC2> ping 100.100.100.2
100.100.100.2 icmp_seq=1 timeout
84 bytes from 100.100.100.2 icmp_seq=2 ttl=62 time=21.002 ms
84 bytes from 100.100.100.2 icmp_seq=3 ttl=62 time=42.002 ms
84 bytes from 100.100.100.2 icmp_seq=4 ttl=62 time=60.003 ms
84 bytes from 100.100.100.2 icmp_seq=5 ttl=62 time=29.002 ms

PC3

PC3> ping 100.100.100.2
100.100.100.2 icmp_seq=1 timeout
100.100.100.2 icmp_seq=2 timeout
84 bytes from 100.100.100.2 icmp_seq=3 ttl=62 time=36.002 ms
84 bytes from 100.100.100.2 icmp_seq=4 ttl=62 time=44.002 ms
84 bytes from 100.100.100.2 icmp_seq=5 ttl=62 time=37.003 ms

Kedua PC tersebut sudah terkoneksi dengan PC Server. Sekarang kita akan menggunakan access-list. Yang pertama akan memblock host PC2 (192.168.1.2). Buat access-listnya.

R1(config)#access-list 1 deny host 192.168.1.2
R1(config)#access-list 1 permit any any

Definisikan pada interface, ada dua cara yaitu In dan Out. Jika IN maka yang masuk ke router sedangkan out berarti paketnya keluar dari router.

Jika IN

R1(config)#int fa0/1
R1(config-if)#ip access-group 1 in

Jika Out

R1(config)#int fa0/0
R1(config-if)#ip access-group 1 out

In berarti paket masuk dari interface fa0/1. Jika Out berarti paket keluar menuju PC Server melalui Fa0/0.
Sekarang coba test ping lagi dari PC2 mengarah ke PC Server

PC2> ping 100.100.100.2
*192.168.1.1 icmp_seq=1 ttl=255 time=23.002 ms (ICMP type:3, code:13, Communication administratively prohibited)
*192.168.1.1 icmp_seq=2 ttl=255 time=10.000 ms (ICMP type:3, code:13, Communication administratively prohibited)
*192.168.1.1 icmp_seq=3 ttl=255 time=10.000 ms (ICMP type:3, code:13, Communication administratively prohibited)
*192.168.1.1 icmp_seq=4 ttl=255 time=8.000 ms (ICMP type:3, code:13, Communication administratively prohibited)
*192.168.1.1 icmp_seq=5 ttl=255 time=11.001 ms (ICMP type:3, code:13, Communication administratively prohibited)

Dan pada PC3 masih bisa ping, karena yang kita block ada host PC2

PC3> ping 100.100.100.2
100.100.100.2 icmp_seq=1 timeout
100.100.100.2 icmp_seq=2 timeout
84 bytes from 100.100.100.2 icmp_seq=3 ttl=62 time=43.003 ms
84 bytes from 100.100.100.2 icmp_seq=4 ttl=62 time=32.002 ms
84 bytes from 100.100.100.2 icmp_seq=5 ttl=62 time=39.002 ms

Dan lihat pada Access-listnya, ada packet yang terfilter pada action deny.

R1#show access-lists
Standard IP access list 1
    10 deny   192.168.1.2 (15 matches)
    20 permit any (10 matches)

Itu jika kita menggunakan host, sekarang kita akan memfilter networknya dan menggunakan out.

R1(config)#access-list 2 deny 192.168.1.0 0.0.0.255
R1(config)#access-list 2 permit any
R1(config)#int fa0/0
R1(config-if)#ip access-group 2 out

Lalu lakukan test ping dari PC3 ke PC Server

PC3> ping 100.100.100.2
*192.168.1.1 icmp_seq=1 ttl=255 time=19.001 ms (ICMP type:3, code:13, Communication administratively prohibited)
*192.168.1.1 icmp_seq=2 ttl=255 time=10.001 ms (ICMP type:3, code:13, Communication administratively prohibited)
*192.168.1.1 icmp_seq=3 ttl=255 time=10.001 ms (ICMP type:3, code:13, Communication administratively prohibited)
*192.168.1.1 icmp_seq=4 ttl=255 time=4.000 ms (ICMP type:3, code:13, Communication administratively prohibited)
*192.168.1.1 icmp_seq=5 ttl=255 time=12.000 ms (ICMP type:3, code:13, Communication administratively prohibited)

Hasilnya akan RTO. Dan jika dilihat pada access-listnya

Standard IP access list 1
    10 deny   192.168.1.2 (15 matches)
    20 permit any (25 matches)
Standard IP access list 2
    10 deny   192.168.1.0, wildcard bits 0.0.0.255 (10 matches)
    20 permit any

Cisco LAB.31 – WAN Protocol (PPP -CHAP)

Tujuan :

  1. Memahami konfigurasi PPP CHAP

Authentikasi yang kedua adalah CHAP, CHAP lebih aman karena dalam authentikasinya menggunakan encryption. Gunakan topologi seperti sebelumnya

screenshot1

Topologi PPP CHAP

Karena kita sudah mengkonfigurasi menggunakan topologi ini. Maka kita bisa reset konfigurasinya. Lalu konfigurasi IP Address pada kedua router.

R1

R1(config)#int se1/0
R1(config-if)#no shutdown
R1(config-if)#ip address 12.12.12.1 255.255.255.252

R2

R2(config)#int se1/0
R2(config-if)#no shutdown
R2(config-if)#ip add 12.12.12.2 255.255.255.252

Check encapsulasi yang digunakan, yaitu

R1#show interfaces se1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 12.12.12.1/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
.....

Setelah itu, tambahkan username dan password. Namun kali ini username menggunakan hostname lawan dan password harus sama

R1(config)#username R2 password idn

R2(config)#username R1 password idn

Lalu konfigurasi PPP dengan authentikasi CHAP, sebelumnya aktifkan debug untuk melihat paket authentikasi yang dikirim dan diterima.

R1#debug ppp authentication
PPP authentication debugging is on

Konfigurasi PPP CHAP

R1

R1(config)#int se1/0
R1(config-if)#encapsulation ppp
R1(config-if)#ppp authentication chap

R2

R2(config)#int se1/0
R2(config-if)#encapsulation ppp
R2(config-if)#ppp authentication chap

Terlihat paket yang dikirim dan diterima pada router R1

R1(config-if)#
*Mar  1 00:12:55.987: Se1/0 PPP: Authorization required
*Mar  1 00:12:56.055: Se1/0 CHAP: O CHALLENGE id 2 len 23 from "R1"
*Mar  1 00:12:56.055: Se1/0 CHAP: I CHALLENGE id 1 len 23 from "R2"
*Mar  1 00:12:56.063: Se1/0 CHAP: Using hostname from unknown source
*Mar  1 00:12:56.067: Se1/0 CHAP: Using password from AAA
*Mar  1 00:12:56.067: Se1/0 CHAP: O RESPONSE id 1 len 23 from "R1"
*Mar  1 00:12:56.075: Se1/0 CHAP: I RESPONSE id 2 len 23 from "R2"
*Mar  1 00:12:56.079: Se1/0 PPP: Sent CHAP LOGIN Request
*Mar  1 00:12:56.079: Se1/0 PPP: Received LOGIN Response PASS
*Mar  1 00:12:56.079: Se1/0 PPP: Sent LCP AUTHOR Request
R1(config-if)#
*Mar  1 00:12:56.083: Se1/0 PPP: Sent IPCP AUTHOR Request
*Mar  1 00:12:56.083: Se1/0 LCP: Received AAA AUTHOR Response PASS
*Mar  1 00:12:56.083: Se1/0 IPCP: Received AAA AUTHOR Response PASS
*Mar  1 00:12:56.083: Se1/0 CHAP: O SUCCESS id 2 len 4
*Mar  1 00:12:56.095: Se1/0 CHAP: I SUCCESS id 1 len 4
*Mar  1 00:12:56.099: Se1/0 PPP: Sent CDPCP AUTHOR Request
*Mar  1 00:12:56.099: Se1/0 CDPCP: Received AAA AUTHOR Response PASS
*Mar  1 00:12:56.103: Se1/0 PPP: Sent IPCP AUTHOR Request

Dan pada interface serial 1/0

R1#show interfaces se1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 12.12.12.1/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Open: IPCP, CDPCP, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
....

Dan lakukan ping dari R1 ke R2

R1#ping 12.12.12.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/12 ms

Cisco LAB.30 – WAN Protocol (PPP-PAP)

Tujuan :

  1. Memahami konfigurasi PPP dengan authentikasinya PAP

PPP merupakan salah satu protocol WAN. PPP merupakan singkatan dari Point-to-Point. PPP merupakan Open Standard dan mendukung dua authentication :

  1. PAP     : Tidak Terenkripsi
  2. CHAP  : Terenkripsi

Langsung saja ke konfigurasi. Buat Topologi berikut

screenshot1

Topologi PPP PAP

Konfigurasi IP Address seperti biasa dan lihat awalnya pasti encapsulasinya menggunakan HDLC karena default konfigurasi cisco.

Konfigurasi IP Address pada kedua router, R1 dan R2

R1

R1(config)#int se1/0
R1(config-if)#no shutdown
R1(config-if)#ip address 12.12.12.1 255.255.255.252

R2

R2(config)#int se1/0
R2(config-if)#no shutdown
R2(config-if)#ip add 12.12.12.2 255.255.255.252

Check encapsulasi yang digunakan, yaitu

R1#show interfaces se1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 12.12.12.1/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
.....

Buat username dan password yang akan digunakan pada PAP pada kedua router.

R1(config)#username feri password feri

R2(config)#username idn password idn

format penulisannya adalah
username nama-user password password
Sebelum mengkonfigurasi PPP authentikasi PAP. Aktifkan debug yang akan melihatkan packet yang berjalan pada saat authentikasi

R1#debug ppp authentication
PPP authentication debugging is on

Lalu konfigurasi PPP PAP

R1

R1(config)#int se1/0
R1(config-if)#encapsulation ppp
R1(config-if)#ppp authentication pap
R1(config-if)#ppp pap sent-username idn password idn

R2

R2(config)#interface se1/0
R2(config-if)#encapsulation ppp
R2(config-if)#ppp authentication pap
R2(config-if)#ppp pap sent-username feri password feri

Maka paket yang terlihat adalah seperti berikut

R1(config-if)#
*Mar  1 01:18:54.603: Se1/0 PPP: Authorization required
*Mar  1 01:18:56.459: Se1/0 PAP: Using hostname from interface PAP
*Mar  1 01:18:56.459: Se1/0 PAP: Using password from interface PAP
*Mar  1 01:18:56.463: Se1/0 PAP: O AUTH-REQ id 1 len 12 from "idn"
*Mar  1 01:18:56.479: Se1/0 PAP: I AUTH-REQ id 1 len 14 from "feri"
*Mar  1 01:18:56.479: Se1/0 PAP: Authenticating peer feri
*Mar  1 01:18:56.483: Se1/0 PPP: Sent PAP LOGIN Request
*Mar  1 01:18:56.487: Se1/0 PPP: Received LOGIN Response PASS
*Mar  1 01:18:56.491: Se1/0 PPP: Sent LCP AUTHOR Request
*Mar  1 01:18:56.495: Se1/0 PPP: Sent IPCP AUTHOR Request
*Mar  1 01:18:56.495: Se1/0 PAP: I AUTH-ACK id 1 len 5
*Mar  1 01:18:56.503: Se1/0 LCP: Received AAA AUTHOR Response PASS
*Mar  1 01:18:56.503: Se1/0 IPCP: Received AAA AUTHOR Response PASS
*Mar  1 01:18:56.507: Se1/0 PAP: O AUTH-ACK id 1 len 5
*Mar  1 01:18:56.511: Se1/0 PPP: Sent CDPCP AUTHOR Request
*Mar  1 01:18:56.519: Se1/0 PPP: Sent IPCP AUTHOR Request
*Mar  1 01:18:56.523: Se1/0 CDPCP: Received AAA AUTHOR Response PASS

Bisa kita lihat juga pada interfacenya sekarang sudah menggunakan encapsulasi PPP

R1#show interfaces se1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 12.12.12.1/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation PPP, LCP Open
  Open: IPCP, CDPCP, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled

Dan misalkan kita memasukkan username yang salah, maka hasilnya akan seperti berikut

R1#ping 12.12.12.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/12 ms

Cisco LAB.29 – WAN Protocol (HDLC)

Tujuan :

  1. Mengetahui konfigurasi HDLC dan kegunaanya

HDLC singkatan dari High-Level Data Link Control protocol yang digunakan pada jaringan WAN. Artinya jaringan yang dihubungkan dengan jarak yang sangat jauh. Untuk media penghantarnya pun tidak menggunakan kabel UTP atau STP yang biasa kita gunakan. Namun menggunakan kabel Serial. HDLC merupakan cisco proprietary dan sudah terkonfigurasi secara default. Untuk lebih jelasnya, silahkan buat topologi berikut

screenshot1

Topologi HDLC

Konfigurasi IP Address pada kedua router, R1 dan R2

R1

R1(config)#int se1/0
R1(config-if)#no shutdown
R1(config-if)#ip address 12.12.12.1 255.255.255.252

R2

R2(config)#int se1/0
R2(config-if)#no shutdown
R2(config-if)#ip add 12.12.12.2 255.255.255.252

Konfigurasi HDLC sudah terkonfigurasi otomatis jika kita menggunakan kabel serial. Untuk mengechecknya dengan perintah

R1#show interfaces se1/0
Serial1/0 is up, line protocol is up
  Hardware is M4T
  Internet address is 12.12.12.1/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, crc 16, loopback not set
  Keepalive set (10 sec)
  Restart-Delay is 0 secs
  CRC checking enabled
  Last input 00:00:03, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
.....

Encapsulation nya menggunakan HDLC tanpa kita mengaturnya. Coba test ping antar router

R1#ping 12.12.12.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/24/40 ms