Pembahasan Soal Superlab Cisco IDN Competition 2017 : Section 1 Part 2

Joss, kita lanjutin lagi ke Section 1 part 2. Untuk Pembahasan sebelumnya bisa di clik disini Pembahasan Soal Superlab Cisco IDN Competition 2017 : Section 1 Part 1

1.3 Spanning Tree

1. Pada tahap ini kita diminta untuk mengkonfigurasikan beberapa device dengan ketentuan
sebagai berikut :

  • Konfigurasikan mode yang langsung membypass listening dan learning, konfigurasikan mode ini hanya pada port yang mengarah ke client (PC).

Jadi kita diminta untuk mengkonfigurasi spanning tree portfast pada port switch yang mengarah ke client (PC)

Switch yang perlu dikonfigurasi pada jaringan

  • Internet    : SW0 port fa0/3 (Disini masih kurang yakin perlu dikonfigurasi atau gk. Cuman diliat dari soalnya minta semua PC, jadi mungkin disini juga diminta)
  • Makassar : SW11 port fa0/3
  • Semarng  : SW-SMG port fa0/3-4
  • Solo          : SW7-SW10 port fa0/2-3 dan SW6 port fa0/9

Untuk perintah nya :

  • Masuk ke interface : interface fa0/nomor-interface.
    Jika ada 2 interface yang dikonfigurasi contoh pada SW-SMG, Gunakan range. Ex: interface range fa0/3-4

    • spanning-tree portfast : mengaktifkan fitur spanning tree portfast

Cukup 2 perintah tersebut

1.4 Implement WAN Technologies

1. Konfigurasikan WAN pada link ISP6 dan R19 di Jayapura dengan ketentuan sebagai berikut :

  •  Link WAN harus support negotiation dan authentication
  • Gunakan WAN Protocol yang memiliki fitur kompresi, authentikasi, dan error detection
  • Untuk authentikasinya gunakan mode yang support enkripsi
  • Jangan merubah hostname di kedua device gunakan password idnmantab

WAN Technologies, yang perlu kita konfigurasi itu adalah encapsulation pada interface serial di antar router. Disini yang diminta adalah ISP6 dan R19. Yang support negotiation dan authentication itu encapsulation menggunakan PPP. Authentication pada PPP ada 2, PAP sama CHAP. Tpi disini diminta yang mensupport enkripsi berarti kita menggunakan CHAP.

Selection_022
Link Serial ISP6-R19

ISP6

  • interface se0/0/1
    • no shutdown
      (karena pada router semua interface defaultnya dalam keadaan shutdown)
    • encapsulation ppp
    • ppp authentication chap
    • exit (perlu exit karena command selanjutnya digunakan pada global-config)
  • username R19 password idnmantab
    (Untuk authentikasi menggunakan chap kita membuat user dengan hostname lawan (R19) lalu password yang sama dikedua router)
  • Untuk penghecheckan bisa menggunakan perintah “show interface se0/0/1” lalu lihat pada bagian encapsulation apakah sudah PPP
  • Namun jika router pasangannya (R19) belum dikonfigurasi maka status interface akan down

R19

  • interface se0/0/0
    • no shutdown
    • encapsulation ppp
    • ppp authentication
    • exit
  • username ISP6 password idnmantab
  • Jika kedua router sudah di konfigurasi maka status interfacenya akan kembali up

2. Konfigurasikan WAN pada link ISP4 dan R13 di Semarang dengan ketentuan sebagai berikut:

  • Link WAN harus support negotiation dan authentication
  • Gunakan WAN Protocol yang memiliki fitur kompresi, authentikasi dan error detection
  • Gunakan authentikasi yang support enkripsi
  • Jangan merubah hostname di kedua device gunakan password idn

Disini juga sama saja seperti sebelumnya. Cuman beda di password saja

Selection_023.png
Link antar ISP4 – R13

ISP4

  • interface se0/1/1
    • no shutdown
    • encapsulation ppp
    • ppp authentication dot1q
    • exit
  • username R13 password idn

R13

  • interface se0/1/0
    • no shutdown
    • encapsulation ppp
    • ppp authentication dot1q
    • exit
  • username ISP4 password idn

3. Konfigurasikan WAN pada link ISP1 dan R2 di Jakarta dengan ketentuan sebagai berikut:

  • Gunakan Link WAN yang mempunyai encapsulation default untuk interface serial
  •  Jangan merubah hostname di kedua device

Disini kita diminta untuk mengkonfigurasi link antar ISP1 dan R2 di Jakarta menggunakan encapsulation default yaitu HDLC. Gk ada authentication disini, jadi hanya perlu menyalakan interface dan di ubah ke HDLC. 

Selection_024.png
Link ISP1 – R2

Jika kita check link antar ISP1 dan R2, Linknya menggunakan encapsulation PPP. Contoh check di R2

Selection_025.png
Check encapsulation interface serial 0/1/0 pada Router R2

R2

  • interface se0/1/0
    • no shutdown
    • encapsulation hdlc

ISP1

  • interface se0/0/0
    • no shutdown
    • encapsulation hdlc

Jika mau di check gunakan perintah “show interface inteface-number”

1.5 Implement VPN

Untuk yang VPN saya skip dulu. 😀 saya masih bingung yang diminta jadi VPN Server atau tunneling. Soalnya saya udah coba keduanya gk ada naik nilainya 😀
Mungkin nanti klo sudah dapat pencerahan dari yang buat, saya share lagi buat VPN

OK ? siap, Udah selesai yang section 1 semoga mudah dipahami dan dimengerti.

Post berikutnya lanjut ke Section 2 (Layer 3). Jadi pastikan pantau blognya yaa …

Pembahasan Soal Superlab Cisco IDN Competition 2017 : Section 1 Part 1

Kali ini akan membahas soal superlab cisco yang di adakan oleh ID-Networkers. Udah 2 kali coba dan nilainya cuman dapat 75% saja. OK gk masalah, bukan masalah nilai yang kita butuhkan yang penting kita dapat belajar hal baru lagi dengan mencoba soal ini. Aku masih belajar juga mungkin di pembahasan ini ada yang salah atau kurang benar mohon dikoreksi dan juga kedepannya ada beberapa service yang saya tidak masukkan karena saya juga masih bingung.

Sebelum mengerjakan juga diharapkan udah paham ya cara konfigurasi di cisco bagaimana. Beberapa service udah ada saya jelasin di blog, tinggal di cari saja. Misal VTP atau VLAN dll.

Untuk soal dan file .pka nya bisa di ambil di sini Soal dan Pka

Topologi Jaringan

A. Physical Topologi

Selection_009.png
Physical Topologi

B. Logical Topologi

Selection_010
Logical Topologi

Jangan terlalu pusing melihat topologinya yang besar. Kita kerjainnya satu-satu biar mudah. Fokus ke soal saja, kerjain per service yang diminta.

Section 1 : Switching

1.1 Switch Administration (VTP)

1. Konfigurasikan device di bagian Jakarta dengan ketentuan sebagai berikut :

  • VTP domain harus di set idncompetition2017
  • Jangan gunakan VTP versi default
  •  SW2 harus di set agar menerima informasi VTP dari SW1
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    IDNcompetition2017mantab

Kita pahamin dulu soalnya ok. Kita diminta untuk mengkonfigurasi VTP pada SW1 dan SW2 di Jakarta dengan ketentuan :

  • VTP Domain : idncompetition2017
  • VTP Version 2, karena VTP versi defaultnya adalah versi 1
  • SW1 modenya Server dan SW2 modenya Client
  • VTP password : IDNcompetition2017mantab

Konfigurasinya :

SW1

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode server
  4. vtp password IDNcompetition2017mantab

SW2

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode client
  4. vtp password IDNcompetition2017mantab

Untuk pengecheckan vtp nya bisa menggunakan perintah

  1. show vtp status
  2. show vtp password

2. Konfigurasikan device di bagian Samarinda dengan ketentuan sebagai berikut :

  • VTP domain harus di set idncompetition2017
  • Jangan gunakan VTP versi default
  • Pastikan MLS4 menerima update informasi VTP dari MLS3
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    IDNcompetition2017mantab

Hampir sama saja dengan yang dijakarta. Kita mengerjakannya di Samarinda dan disini MLS4 sebagai Client dan MLS3 sebagai Server

MLS3

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode server
  4. vtp password IDNcompetition2017mantab

MLS4

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode client
  4. vtp password IDNcompetition2017mantab

3. Konfigurasikan device di bagian Makasar dengan ketentuan sebagai berikut :

  • VTP domain harus di set IDNcompetition2017!
  • Jangan gunakan VTP versi default
  • Pastikan MLS5 dan MLS6 tidak menyebarkan informasi VTP ke switch lain
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    idnmantab

Kita mengerjakannya di Makasar. Hampir sama seperti sebelumnya. Bedanya disini kedua switch menggunakan mode VTP Transparent.

MLS5 & MLS6

  1. vtp domain IDNcompetition2017!
  2. vtp version 2
  3. vtp mode transparent
  4. vtp password idnmantab

4. Konfigurasikan device di bagian Semarang dengan ketentuan       sebagai berikut :

  • VTP domain harus di set idnid
  • Pastikan semua switch di area semarang mendapat update informasi VTP dari MLS8
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    idncompetition2017

Disini mungkin menggunakan vtp version 1 karena tidak diminta untuk mengubahnya. Semua switch di Semarang modenya adalah client kecuali MLS8 yang menggunakan mode server

MLS8

  1. vtp domain idnid
  2. vtp mode server
  3. vtp password idncompetition2017

MLS1, MLS2 & MLS7

  1. vtp domain idnid
  2. vtp mode client
  3. vtp password idncompetition2017

4. Konfigurasikan device di bagian Solo dengan ketentuan sebagai berikut :

  • VTP domain harus di set IDNcompetition2017!
  • Jangan gunakan VTP versi default
  •  Konfigurasikan agar SW3 mau menyebarkan update informasi VTP ke Swith lain yang ada di Solo
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    IDN@2017_competition

Disini SW3 sebagai server dan switch yang lainnya sebagai client

SW3

  1. vtp domain IDNcompetition2017!
  2. vtp version 2
  3. vtp mode server
  4. vtp password IDN@2017_competition

SW4-10

  1. vtp domain IDNcompetition2017!
  2. vtp version 2
  3. vtp mode client
  4. vtp password IDN@2017_competition

1.2 Layer 2 Ports

1. Pada tahap ini kita diminta untuk mengkonfigurasikan beberapa device dengan ketentuan sebagai berikut :

  • Konfigurasikan VLAN pada device sesuai dengan logical topologi.
  • Pastikan database VLAN antar switch sama.
  • Konfigurasikan link antara SW1-SW2 dan MLS3-MLS4 pastikan semua link up menggunakan tipe open standard.
  • Semua port switch pada topologi yang support up to 1000mb/s pastikan statusnya di assign ke vlan88 dan statusnya administratively down

Ini kita kerjakan di Jakarta dan Samarinda. Kita disuruh membuat VLAN dan assign interface ke VLAN menyesuaikan sesuai dengan logical topologi.

Jakarta


Untuk link antar switch menggunakan tipe dot1q lalu di trunk. Trus port interface gig itu dimasukkan ke vlan88 dan di shutdown biar statusnya jadi administratively down. Kita konfigurasi SW1 dulu untuk membuat VLAN karena SW1 sebagai VTP server. Dan juga memasukkan masing-masing interface sesuai logical topologi.

SW1

  1. Buat vlan sesuai logical yaitu VLAN 14,15,23,24,35,46,57,67,88 totalnya ada 9 VLAN
    • perintah “vlan vlan-number
    • Check dengan perintah “show vlan brief”
  2. Interface 21-23 kita ubah menjadi trunk
    • interface range fa0/21-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • Check dengan perintah “show interface fa0/21 switchport” atau “show run”
  3. Assign Vlan sesuai Logical topologi
    • interface fa0/6
      • switchport mode access
      • switchport access vlan 67
    • interface fa0/7
      • switchport mode access
      • switchport access vlan 67
    • interface fa0/4
      • switchport mode access
      • switchport access vlan 14
    • interface fa0/5
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
      • Dikonfigurasi Trunk karena pada fa0/5 terhubung ke R5-fa0/0 yang menggunakan interVLAN
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 24
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 35
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 14
    • Check dengan perintah “show vlan brief”
  4. Masukkan vlan 88 pada interface gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown
    • Check dengan perintah “show vlan brief” dan “show ip interface brief”

SW2

  1. Gk usah buat VLAN, karena sudah terbuat hasil dari VTP. bisa di check menggunakan “show vlan brief”
  2. Interface fa0/21-23 ubah menjadi trunk
    • interface range fa0/21-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign Vlan sesuai Logical topologi
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 23
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 23
    • interface fa0/4
      • switchport trunk encapsulation dot1q
      • switchport mode trunk (penjelasan sama seperti sebelumnya)
    • interface fa0/5
      • switchport mode access
      • switchport access vlan 15
    • interface fa0/6
      • switchport mode access
      • switchport access vlan 46
    • interface fa0/7
      • switchport mode access
      • switchport access vlan 57
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 15
  4. Masukkan vlan 88 pada interface gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown

Samarinda


Hampir sama dengan di Jakarta. Bedanya hanya di VLAN dan interfacenya. Kita buat VLANnya di MLS3 karena sebagai VTP Server

MLS3

  1. Membuat VLAN 89,108,118,109,119,110,88 total ada 7 vlan.
    • vlan vlan-number
  2. Ubah interface fa0/20-23 menjadi trunk
    • interface range fa0/20-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 89
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 109
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 108
    • interface fa0/4
      • switchport trunk encapsulation dot1q
      • switchport mode trunk (Diubah ke trunk karena fa0/0 pada R11 menggunakan interVLAN)
  4. Assign VLAN 88 ke gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown

MLS4

  1. Membuat VLAN 89,108,118,109,119,110,88 total ada 7 vlan.
    • vlan vlan-number
  2. Ubah interface fa0/20-23 menjadi trunk
    • interface range fa0/20-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/2
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/3
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  4. Assign VLAN 88 ke gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown

2. Konfigurasikan network device yang ada di Makassar dengan ketentuan sebagai berikut :

  • Pastikan database VLAN antar switch sama.
  • Konfigurasikan VLAN dan assign switchport sesuai dengan topologi logical.
  • Gunakan model dot1q trunk untuk menghubungkan SW5 dan SW6. (maksudnya MLS5 dan MLS6)
  • Trunk jangan di set auto negotiation ataupun etherchannel.

Sama seperti sebelumnya. Kita buat VLANnya dulu. Karena kedua VLAN menggunakan VTP transparent jadi keduanya membuat VLAN. Assign interface ke VLAN sesuai dengan logical topologi. Interface antar MLS5-MLS6 diganti ke trunk dengan dot1q.


MLS5

  1. Buat VLAN 156 dan 157 “vlan vlan-number”
  2. Interface fa0/11-13 ubah menjadi trunk
    • interface range fa0/11-13
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 156
    • Karena R16 terhubung ke VLAN 156 menggunakan interface e0/1/0 maka di MLS5 cuman 1 interface saja

MLS6

  1. Buat VLAN 156 dan 157 “vlan vlan-number”
  2. Interface fa0/11-13 ubah menjadi trunk
    • interface range fa0/11-13
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 157
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 157
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 156

3. Konfigurasikan network device yang ada di Semarang dengan ketentuan sebagai berikut :

  • Pastikan database VLAN antar switch sama.
  • Konfigurasikan VLAN dan assign switchport sesuai dengan topologi logical. Pastikan VLAN yang telah di assign banar dan sesuai topologi.
  • Trunk jangan di set auto negotiation ataupun etherchannel.

Sama seperti sebelumnya. Kita buat VLANnya hanya di MLS8 karena VTP modenya server dan switch lain VTP modenya client. Lalu assign sesuai topologi. Dan antar switchnya gunakan mode trunk.


MLS8

  1. Buat VLAN 212, 213, 214, 223, 224, 234 dengan perintah “vlan vlan-number”
  2. Interface fa0/21-22 modenya jadi trunk
    • interface range fa0/21-22
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 213
    • interface fa0/2
      • switchport trunk encapsulation dot1q
      • swithcport mode trunk

MLS7

  1. VLAN sudah terbuat, bisa di check dengan “show vlan brief”
  2. Interface fa0/22-23 kita ubah modenya jadi trunk
    • interface range fa0/22-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/2
      • switchport trunk encapsulation dot1q
      • switchport mode turnk

MLS1

  1. VLAN sudah terbuat, bisa di check dengan “show vlan brief”
  2. Interface fa0/20 dan fa0/23 diubah menjadi trunk (dan bukan sampai)
    • interface range fa0/20, fa0/23 (menggunakan “,” artinya dan”
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 234
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 214

MLS2

  1. VLAN sudah terbuat, bisa di check dengan “show vlan brief”
  2. Interface fa0/20-21 kita ubah modenya jadi trunk
    • interface range fa0/20-21
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/2
      • switchport mode access
      • switchpor access vlan 223

4. Konfigurasikan network device yang ada di Solo dengan ketentuan sebagai berikut :

  • Pastikan database VLAN antar switch sama
  • Konfigurasikan VLAN dan assign switchport sesuai dengan topologi logical
  • Pastikan semua link di setiap switch di gunakan untuk mengirimkan dan menerima data.
  • Untuk mengatasi permasalahan point C pada SW3 dan SW4 gunakan mode tanpa
    negotiations dan sisanya gunakan mode cisco propritary.
  • Gunakan Network 172.34.34.0/30 untuk menghubungkan SW3 dan SW4, IP terkecil
    gunakan untuk SW3 dan IP terbesar gunakan untuk SW4.

Untuk poin 1 dan 2 sama seperti sebelumnya. Kita buat VLANnya di SW3 karena menjadi VTP Server.  Untuk point ke-3  mintanya semua linknya aktif, jadi kita konfigurasi etherchannel disitu. Untuk poin ke-4 semua switch di Solo menggunakan mode pagp kecuali SW3 dan SW4 yang menggunakan mode on. Trus nanti antar switch kita ubah ke trunk kecuali SW3 dan SW4 yang linknya kita kasih IP Address.


SW3

  1. Membuat VLAN 7,8,9 dan 10 menggunakan perintah “vlan vlan-number”
  2. Konfigurasi Etherchannel, group number ada pada physical topologi.
    • interface range fa0/2-3 (Link SW3-SW5)
      • channel-group 35 mode desirable (disini aku gk tau modenya pake auto atau desirable soalnya di soal gk ada penjelasannya)
      • nanti akan terbuat port-channel 35, jadi interface fa0/2-3 digabung menjadi port-channel 35. disitu baru kita ubah ke mode trunk
      • channel-protocol pagp (optional)
    • interface port-channel 35
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/4-5 (Link SW3-SW6)
      • channel-group 36 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 36
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/10-12 (Link SW3-SW4)
      • no switchport (perlu kita definisikan dlu secara manual agar link antar SW3 dan SW4 sama sama menggunakan no switchport)
      • channel-group 34 mode on
    • interface port-channel 34
      • no switchport
      • ip address 172.34.34.1 255.255.255.252

SW4

  1. VLAN sudah terbuat
  2. Konfigurasi Etherchannel, group number sesuai dengan topologi
    • interface range fa0/2-3 (Link SW4-SW6)
      • channel-group 46 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 46
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/4-5 (Link SW4-SW5)
      • channel-group 45 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 45
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/10-12 (Link SW3-SW4)
      • no switchport
      • channel-group 34 mode on
    • interface port-channel 34
      • no switchport
      • ip address 172.34.34.1 255.255.255.252

SW5

  1. VLAN sudah terbuat
  2. Konfigurasi Trunk yang mengaraha ke Switch Client
    • interface range fa0/7-8
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Konfigurasi Etherchannel, group number sesuai dengan topologi
    • interface range fa0/1-2 (Link SW3-SW5)
      • channel-group 35 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 35
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/5-6(Link SW4-SW5)
      • channel-group 45 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 45
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/3-4(Link SW5-SW6)
      • channel-group 11 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 11
      • switchport trunk encapsulation dot1q
      • switchport mode trunk

SW6

  1. VLAN sudah terbuat
  2. Konfigurasi Trunk yang mengaraha ke Switch Client
    • interface range fa0/7-8
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN 10 pada interface fa0/9
    • interface fa0/9
      • switchport mode access
      • switchport access vlan 10
  4. Konfigurasi Etherchannel, group number sesuai dengan topologi
    • interface range fa0/1-2 (Link SW4-SW6)
      • channel-group 46 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 46
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/5-6(Link SW3-SW6)
      • channel-group 36 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 36
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/3-4(Link SW5-SW6)
      • channel-group 11 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 11
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  5. Untuk penghechekan etherchannelnya bisa menggunakan perintah “show etherchannel summary” apakah tandanya sudah “P” dan “SU”

SW7-SW10

  1. Pada interface fa0/1 menjadi mode trunk
    • Switchport mode trunk
  2. Assign VLAN sesuai topologi pada interface fa0/2-3

Untuk 1.3 dan Selanjutnya akan di bahas di Part 2. Selamat mencoba dan mudahan dimengerti

Apa itu Broadcast Domain ?

Banyak penjelasan di google atau buku yang agak susah untuk dipahami. Namun kesimpulan yang lebih mudah di pahami. Broadcast domain adalah jaringan yang memiliki wilayah  yang sama. Misal dalam switch defaultnya memiliki 1 Broadcast domain. Maka semua PC/host yang ada di switch masuk dalam wilayah yang sama. Namun jika kita konfigurasi VLAN, maka bisa saja kita memisah broadcast domain tersebut. Misal ada 2 VLAN di switch tersebut. Maka akan terbentuk 2 broadcast domain, artinya ada 2 wilayah yang berbeda dalam switch.

Selection_008
Jaringan yang menggunakan Router

Pada tiap port yang dimiliki router memiliki broadcast domain masing-masing dan juga memiliki collision domain masing-masing. Disini kita memiliki 2 broadcast domain yaitu switch kiri dan switch kanan yang terkoneksi dengan router.

Didalam topology tersebut terdapat berapa collision domain dan broadcast domain ?

Ada 8 collision domain dan 2 broadcast domain. 8 didapat dari port yang terhubung ke switch.

Itu saja tentang broadcast domain. Semoga mudah dimengerti dan dipahami. Tetap pelajari ilmu baru tiap harinya…

Lab 146 – IOS XR IBGP Confederation

Pada lab sebelumnya kita telah belajar tentang IBGP Route Reflcetor pada IOS XR.. selanjutnya pada lab ini kita akan belajar tentang IBGP Confederation..

Berikut topologi yang akan kita gunakan

Pertama kita harus konfigurasi IP Address dan routing protocol IGP pada jaringan diatas.. pada lab ini kita akan menggunakan EIGRP yaaa.. jika ada yg belum bisa konfigurasi EIGRP di IOS XR bisa merujuk ke artikel berikut : Konfigurasi EIGRP di IOS XR..

Setelah konfigurasi EIGRP, hasilnya adalah sebagai berikut

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:47:34.279 UTC

D 2.2.2.2/32 [90/10752] via 12.12.12.2, 00:03:03, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/15872] via 12.12.12.2, 00:01:12, GigabitEthernet0/0/0/0
D 4.4.4.4/32 [90/20992] via 12.12.12.2, 00:00:32, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 12.12.12.2, 00:03:03, GigabitEthernet0/0/0/0
D 34.34.34.0/24 [90/20480] via 12.12.12.2, 00:01:12, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:48:06.896 UTC

D 1.1.1.1/32 [90/10752] via 12.12.12.1, 00:03:17, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/10752] via 23.23.23.3, 00:01:45, GigabitEthernet0/0/0/1
D 4.4.4.4/32 [90/15872] via 23.23.23.3, 00:01:05, GigabitEthernet0/0/0/1
D 34.34.34.0/24 [90/15360] via 23.23.23.3, 00:01:45, GigabitEthernet0/0/0/1
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:48:30.135 UTC

D 1.1.1.1/32 [90/15872] via 23.23.23.2, 00:01:54, GigabitEthernet0/0/0/0
D 2.2.2.2/32 [90/10752] via 23.23.23.2, 00:01:54, GigabitEthernet0/0/0/0
D 4.4.4.4/32 [90/10752] via 34.34.34.4, 00:01:29, GigabitEthernet0/0/0/1
D 12.12.12.0/24 [90/15360] via 23.23.23.2, 00:01:54, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR4(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:48:48.963 UTC

D 1.1.1.1/32 [90/20992] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 2.2.2.2/32 [90/15872] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/10752] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 12.12.12.0/24 [90/20480] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0

Oke.. pastikan hasilnya sudah seperti itu ya.. pastikan juga masing-masing router sudah bisa ping ke loopback0 router lainnya.. berikut contoh ping dari IOS-XR1 ke loopback0 router lainnya

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping ipv4 2.2.2.2
Wed Jun 7 06:51:23.093 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping ipv4 3.3.3.3
Wed Jun 7 06:51:25.653 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/19 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping ipv4 4.4.4.4
Wed Jun 7 06:51:30.342 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

Oke kalu sudah berhasil seperti diatas, selanjutnya kita akan konfigurasi IBGP dengan confederation..

Perhatikan topologi diatas, IOS-XR1 dan IOS-XR2 menggunaakn AS confederation 12 sedangkan IOS-XR3 dan IOS-XR4 menggunakan AS confederation 34..

Berikut konfigurasi pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router bgp 12
RP/0/0/CPU0:IOS-XR1(config-bgp)#bgp confederation identifier 12

RP/0/0/CPU0:IOS-XR1(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#network 11.11.11.11/32
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR1(config-bgp)#neighbor 2.2.2.2
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#remote-as 12
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#commit

Selanjutnya berikut konfigurasi pada IOS-XR2

RP/0/0/CPU0:IOS-XR2(config)#router bgp 12
RP/0/0/CPU0:IOS-XR2(config-bgp)#bgp confederation identifier 12
RP/0/0/CPU0:IOS-XR2(config-bgp)#bgp confederation peers 34

RP/0/0/CPU0:IOS-XR2(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#network 22.22.22.22/32
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR2(config-bgp)#neighbor 1.1.1.1
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#remote-as 12
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR2(config-bgp-nbr-af)#neighbor 3.3.3.3
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#remote-as 34
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR2(config-bgp-nbr-af)#commit

Perhatikan bahwa pada IOS-XR2 kita perlu mengkonfigurisakan ebgp-multihop saat neighbor 3.3.3.3.. ini dikarenakan IOS-XR2 menganggap IOS-XR3 seolah-olah adalah external AS.. sedangkan untuk peering EBGP nilai ttl nya adalah 1.. jadi kita harus memperbesar nilai ttl menggunakan perintah ebgp-multihop ini..

Selanjutnya berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config)#router bgp 34
RP/0/0/CPU0:IOS-XR3(config-bgp)#bgp confederation identifier 1234
RP/0/0/CPU0:IOS-XR3(config-bgp)#bgp confederation peers 12

RP/0/0/CPU0:IOS-XR3(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#network 33.33.33.33/32
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR3(config-bgp)#neighbor 2.2.2.2
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#remote-as 12
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR3(config-bgp-nbr-af)#neighbor 4.4.4.4
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#remote-as 34
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR3(config-bgp-nbr-af)#commit

Perhatikan bahwa kita juga perlu mengkonfigurasikan ebgp-multihop pada IOS-XR3

Yang terahir, berikut konfigurasi pada IOS-XR4

RP/0/0/CPU0:IOS-XR4(config)#router bgp 34
RP/0/0/CPU0:IOS-XR4(config-bgp)#bgp confederation identifier 1234

RP/0/0/CPU0:IOS-XR4(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#network 44.44.44.44/32
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR4(config-bgp)#neighbor 3.3.3.3
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#remote-as 34
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr-af)#commit

Oke.. konfigurasi sudah selesai.. Untuk pengujian,, pastikan IOS-XR1 menerima network dari IOS-XR2, IOS-XR3, dan IOS-XR4

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do sh bgp
Wed Jun 7 07:31:04.430 UTC
BGP router identifier 1.1.1.1, local AS number 12
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.11.11.11/32 0.0.0.0 0 32768 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i33.33.33.33/32 3.3.3.3 0 100 0 (34) i
*>i44.44.44.44/32 4.4.4.4 0 100 0 (34) i

Processed 4 prefixes, 4 paths

Oke sudah berhasil ya.. untuk lebih memastikan, kita coba lihat tabel routing di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do sh route bgp
Wed Jun 7 07:31:43.497 UTC

B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:11:32
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:09:05
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:08:35

Oke sudah lengkap… sekarang kita coba lakukan ping yaa

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do ping 22.22.22.22 sou l1
Wed Jun 7 07:32:10.695 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do ping 33.33.33.33 sou l1
Wed Jun 7 07:32:14.505 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do ping 44.44.44.44 sou l1
Wed Jun 7 07:32:18.435 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 44.44.44.44, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke sudah berhasil yaaa… Sampai saat ini kita sudah selesai dan berhasil melakukan konfigurasi IBGP confederation pada IOS XR.. sampai jumpa di artikel selanjutnya yaa…. In Syaa Allah masih akan membahas seputar IOS XR..

Lab 146 – IOS XR IBGP Confederation

Pada lab sebelumnya kita telah belajar tentang IBGP Route Reflcetor pada IOS XR.. selanjutnya pada lab ini kita akan belajar tentang IBGP Confederation..

Berikut topologi yang akan kita gunakan

Pertama kita harus konfigurasi IP Address dan routing protocol IGP pada jaringan diatas.. pada lab ini kita akan menggunakan EIGRP yaaa.. jika ada yg belum bisa konfigurasi EIGRP di IOS XR bisa merujuk ke artikel berikut : Konfigurasi EIGRP di IOS XR..

Setelah konfigurasi EIGRP, hasilnya adalah sebagai berikut

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:47:34.279 UTC

D 2.2.2.2/32 [90/10752] via 12.12.12.2, 00:03:03, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/15872] via 12.12.12.2, 00:01:12, GigabitEthernet0/0/0/0
D 4.4.4.4/32 [90/20992] via 12.12.12.2, 00:00:32, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 12.12.12.2, 00:03:03, GigabitEthernet0/0/0/0
D 34.34.34.0/24 [90/20480] via 12.12.12.2, 00:01:12, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:48:06.896 UTC

D 1.1.1.1/32 [90/10752] via 12.12.12.1, 00:03:17, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/10752] via 23.23.23.3, 00:01:45, GigabitEthernet0/0/0/1
D 4.4.4.4/32 [90/15872] via 23.23.23.3, 00:01:05, GigabitEthernet0/0/0/1
D 34.34.34.0/24 [90/15360] via 23.23.23.3, 00:01:45, GigabitEthernet0/0/0/1
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:48:30.135 UTC

D 1.1.1.1/32 [90/15872] via 23.23.23.2, 00:01:54, GigabitEthernet0/0/0/0
D 2.2.2.2/32 [90/10752] via 23.23.23.2, 00:01:54, GigabitEthernet0/0/0/0
D 4.4.4.4/32 [90/10752] via 34.34.34.4, 00:01:29, GigabitEthernet0/0/0/1
D 12.12.12.0/24 [90/15360] via 23.23.23.2, 00:01:54, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR4(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:48:48.963 UTC

D 1.1.1.1/32 [90/20992] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 2.2.2.2/32 [90/15872] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/10752] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 12.12.12.0/24 [90/20480] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0

Oke.. pastikan hasilnya sudah seperti itu ya.. pastikan juga masing-masing router sudah bisa ping ke loopback0 router lainnya.. berikut contoh ping dari IOS-XR1 ke loopback0 router lainnya

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping ipv4 2.2.2.2
Wed Jun 7 06:51:23.093 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping ipv4 3.3.3.3
Wed Jun 7 06:51:25.653 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/19 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping ipv4 4.4.4.4
Wed Jun 7 06:51:30.342 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

Oke kalu sudah berhasil seperti diatas, selanjutnya kita akan konfigurasi IBGP dengan confederation..

Perhatikan topologi diatas, IOS-XR1 dan IOS-XR2 menggunaakn AS confederation 12 sedangkan IOS-XR3 dan IOS-XR4 menggunakan AS confederation 34..

Berikut konfigurasi pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router bgp 12
RP/0/0/CPU0:IOS-XR1(config-bgp)#bgp confederation identifier 12

RP/0/0/CPU0:IOS-XR1(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#network 11.11.11.11/32
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR1(config-bgp)#neighbor 2.2.2.2
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#remote-as 12
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#commit

Selanjutnya berikut konfigurasi pada IOS-XR2

RP/0/0/CPU0:IOS-XR2(config)#router bgp 12
RP/0/0/CPU0:IOS-XR2(config-bgp)#bgp confederation identifier 12
RP/0/0/CPU0:IOS-XR2(config-bgp)#bgp confederation peers 34

RP/0/0/CPU0:IOS-XR2(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#network 22.22.22.22/32
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR2(config-bgp)#neighbor 1.1.1.1
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#remote-as 12
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR2(config-bgp-nbr-af)#neighbor 3.3.3.3
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#remote-as 34
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR2(config-bgp-nbr-af)#commit

Perhatikan bahwa pada IOS-XR2 kita perlu mengkonfigurisakan ebgp-multihop saat neighbor 3.3.3.3.. ini dikarenakan IOS-XR2 menganggap IOS-XR3 seolah-olah adalah external AS.. sedangkan untuk peering EBGP nilai ttl nya adalah 1.. jadi kita harus memperbesar nilai ttl menggunakan perintah ebgp-multihop ini..

Selanjutnya berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config)#router bgp 34
RP/0/0/CPU0:IOS-XR3(config-bgp)#bgp confederation identifier 1234
RP/0/0/CPU0:IOS-XR3(config-bgp)#bgp confederation peers 12

RP/0/0/CPU0:IOS-XR3(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#network 33.33.33.33/32
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR3(config-bgp)#neighbor 2.2.2.2
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#remote-as 12
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR3(config-bgp-nbr-af)#neighbor 4.4.4.4
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#remote-as 34
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR3(config-bgp-nbr-af)#commit

Perhatikan bahwa kita juga perlu mengkonfigurasikan ebgp-multihop pada IOS-XR3

Yang terahir, berikut konfigurasi pada IOS-XR4

RP/0/0/CPU0:IOS-XR4(config)#router bgp 34
RP/0/0/CPU0:IOS-XR4(config-bgp)#bgp confederation identifier 1234

RP/0/0/CPU0:IOS-XR4(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#network 44.44.44.44/32
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR4(config-bgp)#neighbor 3.3.3.3
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#remote-as 34
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr-af)#commit

Oke.. konfigurasi sudah selesai.. Untuk pengujian,, pastikan IOS-XR1 menerima network dari IOS-XR2, IOS-XR3, dan IOS-XR4

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do sh bgp
Wed Jun 7 07:31:04.430 UTC
BGP router identifier 1.1.1.1, local AS number 12
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.11.11.11/32 0.0.0.0 0 32768 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i33.33.33.33/32 3.3.3.3 0 100 0 (34) i
*>i44.44.44.44/32 4.4.4.4 0 100 0 (34) i

Processed 4 prefixes, 4 paths

Oke sudah berhasil ya.. untuk lebih memastikan, kita coba lihat tabel routing di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do sh route bgp
Wed Jun 7 07:31:43.497 UTC

B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:11:32
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:09:05
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:08:35

Oke sudah lengkap… sekarang kita coba lakukan ping yaa

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do ping 22.22.22.22 sou l1
Wed Jun 7 07:32:10.695 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do ping 33.33.33.33 sou l1
Wed Jun 7 07:32:14.505 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do ping 44.44.44.44 sou l1
Wed Jun 7 07:32:18.435 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 44.44.44.44, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke sudah berhasil yaaa… Sampai saat ini kita sudah selesai dan berhasil melakukan konfigurasi IBGP confederation pada IOS XR.. sampai jumpa di artikel selanjutnya yaa…. In Syaa Allah masih akan membahas seputar IOS XR..

Lab 145 – IOS XR IBGP Route Reflector

Sebelumnya kita telah belajar tentang IGP di IOS XR,,. yaitu OSPF dan EIGRP.. selanjutnya pada lab ini kita akan belajar tentang EGP,, yaitu BGP..

Kita akan ngelab IBGP dengan menggunakan Route Reflector.. berikut topologi yang akan kita gunakan

Perhatikan masing-masing router mempunyai dua IP Loopback.. nantinya interface loopback0 pada masing-masing router akan kita advertise ke OSPF.. selanjutnya interface loopback1 pada masing-masing router akan kita advertise ke IBGP..

Oke langsung saja, Diasumsikan kita sudah konfigurasi OSPF ya.. nanti hasilnya harus nya seperti ini..

RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:24:16.743 UTC

O 2.2.2.2/32 [110/2] via 12.12.12.2, 00:02:03, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/3] via 12.12.12.2, 00:00:59, GigabitEthernet0/0/0/0
O 4.4.4.4/32 [110/4] via 12.12.12.2, 00:00:06, GigabitEthernet0/0/0/0
O 23.23.23.0/24 [110/2] via 12.12.12.2, 00:02:03, GigabitEthernet0/0/0/0
O 34.34.34.0/24 [110/3] via 12.12.12.2, 00:00:59, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:24:41.661 UTC

O 1.1.1.1/32 [110/2] via 12.12.12.1, 00:02:27, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/2] via 23.23.23.3, 00:01:28, GigabitEthernet0/0/0/1
O 4.4.4.4/32 [110/3] via 23.23.23.3, 00:00:30, GigabitEthernet0/0/0/1
O 34.34.34.0/24 [110/2] via 23.23.23.3, 00:01:28, GigabitEthernet0/0/0/1
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:24:57.810 UTC

O 1.1.1.1/32 [110/3] via 23.23.23.2, 00:01:44, GigabitEthernet0/0/0/0
O 2.2.2.2/32 [110/2] via 23.23.23.2, 00:01:44, GigabitEthernet0/0/0/0
O 4.4.4.4/32 [110/2] via 34.34.34.4, 00:00:52, GigabitEthernet0/0/0/1
O 12.12.12.0/24 [110/2] via 23.23.23.2, 00:01:44, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR4(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:25:11.609 UTC

O 1.1.1.1/32 [110/4] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 2.2.2.2/32 [110/3] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/2] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 12.12.12.0/24 [110/3] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 23.23.23.0/24 [110/2] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0

Kalau masih ada yang belum bisa konfigurasi OSPF di IOS XR, bisa merujuk ke artikel berikut ya : Konfigurasi OSPF di IOS XR

Oke.. setelah konfigurasi OSPF selesai.. pastikan masing-masing router bisa ping ke loopback0 dari router lain ya.. kita coba ping dari IOS-XR1 ke loopback0 IOS-XR2-4

RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do ping 2.2.2.2
Mon Jun 5 01:26:51.382 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do ping 3.3.3.3
Mon Jun 5 01:26:53.402 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/19 ms
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do ping 4.4.4.4
Mon Jun 5 01:26:55.782 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

Oke sudah jalan semua ya.. sekarang saatnya kita mengkonfigurasi IBGP… pada topologi ini IOS-XR4 akan menjadi Route Reflector ya.. jadi nanti IOS-XR1, 2, dan 3 hanya perlua peering ke IOS-XR4..

Oke langsung saja.. berikut konfigurasi di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router bgp 1234
RP/0/0/CPU0:IOS-XR1(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#network 11.11.11.11/32
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR1(config-bgp)#nei 4.4.4.4
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#remote-as 1234
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#commit

Berikut konfigurasi di IOS-XR2

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#router bgp 1234
RP/0/0/CPU0:IOS-XR2(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#net 22.22.22.22/32
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR2(config-bgp)#nei 4.4.4.4
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#remote-as 1234
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#update-sou lo0
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr-af)#commit

Berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#router bgp 1234
RP/0/0/CPU0:IOS-XR3(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#net 33.33.33.33/32
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR3(config-bgp)#nei 4.4.4.4
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#remote-as 1234
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#update-sou lo0
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr-af)#commit

Berikut konfigurasi di IOS-XR4.. pada IOS-XR4 ini kita akan konfiguruasi peering group ya.. karena IOS-XR4 harus peering ke 3 router.. kalau peering satu-satu kelamaan.. jadi lebih baik pake group aja

RP/0/0/CPU0:IOS-XR4(config)#router bgp 1234
RP/0/0/CPU0:IOS-XR4(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#net 44.44.44.44/32
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR4(config-bgp)#neighbor-group IBGP
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#remote-as 1234
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#update-source lo0
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp-af)#route-reflector-client
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp-af)#exit
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#exit

RP/0/0/CPU0:IOS-XR4(config-bgp)#neigh 1.1.1.1
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#use neighbor-group IBGP

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#nei 2.2.2.2
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#use neighbor-group IBGP

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#nei 3.3.3.3
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#use neighbor-group IBGP
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#commit

Oke untuk pengujian, kita bisa menggunakan perintah berikut

RP/0/0/CPU0:IOS-XR1(config-if)#do sh bgp sum
Mon Jun 5 01:50:04.631 UTC
BGP router identifier 1.1.1.1, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Not Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 6 6 6 6 6 0

Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
4.4.4.4 0 1234 9 5 6 0 0 00:01:21 3

Perhatikan bahwa IOS-XR1 sudah menerima 3 prefix dari IOS-XR4.. kita coba lihat prefix berapa saja yang dimaksud

RP/0/0/CPU0:IOS-XR1(config-if)#do sh bgp
Mon Jun 5 01:51:25.296 UTC
BGP router identifier 1.1.1.1, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.11.11.11/32 0.0.0.0 0 32768 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i33.33.33.33/32 3.3.3.3 0 100 0 i
*>i44.44.44.44/32 4.4.4.4 0 100 0 i

Processed 4 prefixes, 4 paths

Perhatikan bahwa IOS-XR1 sudah menerima prefix yang lengkap.. kita coba lihat yang di Route Reflector ya

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#do sh bgp sum
Mon Jun 5 01:52:49.450 UTC
BGP router identifier 4.4.4.4, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 6 6 6 6 6 0

Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
1.1.1.1 0 1234 8 12 6 0 0 00:04:06 1
2.2.2.2 0 1234 11 14 6 0 0 00:07:01 1
3.3.3.3 0 1234 11 15 6 0 0 00:07:03 1

Route Reflector peering dengan tiga router lainnya., dan menerima 1 prefix dari setiap router.. kita coba lihat prefix berapa saja yg diterima oleh IOS-XR4

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#do sh bgp
Mon Jun 5 01:53:41.046 UTC
BGP router identifier 4.4.4.4, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i11.11.11.11/32 1.1.1.1 0 100 0 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i33.33.33.33/32 3.3.3.3 0 100 0 i
*> 44.44.44.44/32 0.0.0.0 0 32768 i

Processed 4 prefixes, 4 paths

Oke lengkap ya…

Untuk pengujian selanjutnya kita bisa mencoba untuk melihat tabel routing.. berikut tabel routing di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-if)#do sh route bgp
Mon Jun 5 01:54:26.033 UTC

B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:05:37
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:05:37
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:05:37

Berikut tabel routing di IOS-XR2

RP/0/0/CPU0:IOS-XR2#sh route bgp
Mon Jun 5 01:54:59.551 UTC

B 11.11.11.11/32 [200/0] via 1.1.1.1, 00:06:11
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:07:13
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:07:13

Berikut tabel routing BGP di IOS-XR3

RP/0/0/CPU0:IOS-XR3#sh route bgp
Mon Jun 5 01:55:27.709 UTC

B 11.11.11.11/32 [200/0] via 1.1.1.1, 00:06:39
B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:07:41
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:07:41

Berikut tabel routing BGP di IOS-XR4

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#do sh route bgp
Mon Jun 5 01:55:48.918 UTC

B 11.11.11.11/32 [200/0] via 1.1.1.1, 00:07:00
B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:08:02
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:08:02

Oke.. sudah lengkap semua kan ya…

Pengujain terahir, kita coba lakukan ping yaa.. Berikut percobaan ping dari IOS-XR1 ke loopback router lainnya

RP/0/0/CPU0:IOS-XR1(config-if)#do ping 22.22.22.22 sou l1
Mon Jun 5 01:56:32.855 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-if)#do ping 33.33.33.33 sou l1
Mon Jun 5 01:56:37.354 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1(config-if)#do ping 44.44.44.44 sou l1
Mon Jun 5 01:56:41.684 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 44.44.44.44, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke jalan semua ya….

Alhamdulillah Lab IBGP pada IOS XR kita sudah selesai… In Syaa Allah selanjutnya kita masih akan membahas tentang IBGP pada IOS XR.. namun menggunakan Confederation.. Oke sampai ketemu di artikel selanjutnya yaaa

Lab 145 – IOS XR IBGP Route Reflector

Sebelumnya kita telah belajar tentang IGP di IOS XR,,. yaitu OSPF dan EIGRP.. selanjutnya pada lab ini kita akan belajar tentang EGP,, yaitu BGP..

Kita akan ngelab IBGP dengan menggunakan Route Reflector.. berikut topologi yang akan kita gunakan

Perhatikan masing-masing router mempunyai dua IP Loopback.. nantinya interface loopback0 pada masing-masing router akan kita advertise ke OSPF.. selanjutnya interface loopback1 pada masing-masing router akan kita advertise ke IBGP..

Oke langsung saja, Diasumsikan kita sudah konfigurasi OSPF ya.. nanti hasilnya harus nya seperti ini..

RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:24:16.743 UTC

O 2.2.2.2/32 [110/2] via 12.12.12.2, 00:02:03, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/3] via 12.12.12.2, 00:00:59, GigabitEthernet0/0/0/0
O 4.4.4.4/32 [110/4] via 12.12.12.2, 00:00:06, GigabitEthernet0/0/0/0
O 23.23.23.0/24 [110/2] via 12.12.12.2, 00:02:03, GigabitEthernet0/0/0/0
O 34.34.34.0/24 [110/3] via 12.12.12.2, 00:00:59, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:24:41.661 UTC

O 1.1.1.1/32 [110/2] via 12.12.12.1, 00:02:27, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/2] via 23.23.23.3, 00:01:28, GigabitEthernet0/0/0/1
O 4.4.4.4/32 [110/3] via 23.23.23.3, 00:00:30, GigabitEthernet0/0/0/1
O 34.34.34.0/24 [110/2] via 23.23.23.3, 00:01:28, GigabitEthernet0/0/0/1
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:24:57.810 UTC

O 1.1.1.1/32 [110/3] via 23.23.23.2, 00:01:44, GigabitEthernet0/0/0/0
O 2.2.2.2/32 [110/2] via 23.23.23.2, 00:01:44, GigabitEthernet0/0/0/0
O 4.4.4.4/32 [110/2] via 34.34.34.4, 00:00:52, GigabitEthernet0/0/0/1
O 12.12.12.0/24 [110/2] via 23.23.23.2, 00:01:44, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR4(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:25:11.609 UTC

O 1.1.1.1/32 [110/4] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 2.2.2.2/32 [110/3] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/2] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 12.12.12.0/24 [110/3] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 23.23.23.0/24 [110/2] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0

Kalau masih ada yang belum bisa konfigurasi OSPF di IOS XR, bisa merujuk ke artikel berikut ya : Konfigurasi OSPF di IOS XR

Oke.. setelah konfigurasi OSPF selesai.. pastikan masing-masing router bisa ping ke loopback0 dari router lain ya.. kita coba ping dari IOS-XR1 ke loopback0 IOS-XR2-4

RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do ping 2.2.2.2
Mon Jun 5 01:26:51.382 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do ping 3.3.3.3
Mon Jun 5 01:26:53.402 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/19 ms
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do ping 4.4.4.4
Mon Jun 5 01:26:55.782 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

Oke sudah jalan semua ya.. sekarang saatnya kita mengkonfigurasi IBGP… pada topologi ini IOS-XR4 akan menjadi Route Reflector ya.. jadi nanti IOS-XR1, 2, dan 3 hanya perlua peering ke IOS-XR4..

Oke langsung saja.. berikut konfigurasi di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router bgp 1234
RP/0/0/CPU0:IOS-XR1(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#network 11.11.11.11/32
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR1(config-bgp)#nei 4.4.4.4
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#remote-as 1234
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#commit

Berikut konfigurasi di IOS-XR2

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#router bgp 1234
RP/0/0/CPU0:IOS-XR2(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#net 22.22.22.22/32
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR2(config-bgp)#nei 4.4.4.4
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#remote-as 1234
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#update-sou lo0
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr-af)#commit

Berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#router bgp 1234
RP/0/0/CPU0:IOS-XR3(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#net 33.33.33.33/32
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR3(config-bgp)#nei 4.4.4.4
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#remote-as 1234
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#update-sou lo0
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr-af)#commit

Berikut konfigurasi di IOS-XR4.. pada IOS-XR4 ini kita akan konfiguruasi peering group ya.. karena IOS-XR4 harus peering ke 3 router.. kalau peering satu-satu kelamaan.. jadi lebih baik pake group aja

RP/0/0/CPU0:IOS-XR4(config)#router bgp 1234
RP/0/0/CPU0:IOS-XR4(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#net 44.44.44.44/32
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR4(config-bgp)#neighbor-group IBGP
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#remote-as 1234
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#update-source lo0
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp-af)#route-reflector-client
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp-af)#exit
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#exit

RP/0/0/CPU0:IOS-XR4(config-bgp)#neigh 1.1.1.1
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#use neighbor-group IBGP

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#nei 2.2.2.2
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#use neighbor-group IBGP

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#nei 3.3.3.3
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#use neighbor-group IBGP
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#commit

Oke untuk pengujian, kita bisa menggunakan perintah berikut

RP/0/0/CPU0:IOS-XR1(config-if)#do sh bgp sum
Mon Jun 5 01:50:04.631 UTC
BGP router identifier 1.1.1.1, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Not Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 6 6 6 6 6 0

Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
4.4.4.4 0 1234 9 5 6 0 0 00:01:21 3

Perhatikan bahwa IOS-XR1 sudah menerima 3 prefix dari IOS-XR4.. kita coba lihat prefix berapa saja yang dimaksud

RP/0/0/CPU0:IOS-XR1(config-if)#do sh bgp
Mon Jun 5 01:51:25.296 UTC
BGP router identifier 1.1.1.1, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.11.11.11/32 0.0.0.0 0 32768 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i33.33.33.33/32 3.3.3.3 0 100 0 i
*>i44.44.44.44/32 4.4.4.4 0 100 0 i

Processed 4 prefixes, 4 paths

Perhatikan bahwa IOS-XR1 sudah menerima prefix yang lengkap.. kita coba lihat yang di Route Reflector ya

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#do sh bgp sum
Mon Jun 5 01:52:49.450 UTC
BGP router identifier 4.4.4.4, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 6 6 6 6 6 0

Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
1.1.1.1 0 1234 8 12 6 0 0 00:04:06 1
2.2.2.2 0 1234 11 14 6 0 0 00:07:01 1
3.3.3.3 0 1234 11 15 6 0 0 00:07:03 1

Route Reflector peering dengan tiga router lainnya., dan menerima 1 prefix dari setiap router.. kita coba lihat prefix berapa saja yg diterima oleh IOS-XR4

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#do sh bgp
Mon Jun 5 01:53:41.046 UTC
BGP router identifier 4.4.4.4, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i11.11.11.11/32 1.1.1.1 0 100 0 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i33.33.33.33/32 3.3.3.3 0 100 0 i
*> 44.44.44.44/32 0.0.0.0 0 32768 i

Processed 4 prefixes, 4 paths

Oke lengkap ya…

Untuk pengujian selanjutnya kita bisa mencoba untuk melihat tabel routing.. berikut tabel routing di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-if)#do sh route bgp
Mon Jun 5 01:54:26.033 UTC

B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:05:37
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:05:37
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:05:37

Berikut tabel routing di IOS-XR2

RP/0/0/CPU0:IOS-XR2#sh route bgp
Mon Jun 5 01:54:59.551 UTC

B 11.11.11.11/32 [200/0] via 1.1.1.1, 00:06:11
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:07:13
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:07:13

Berikut tabel routing BGP di IOS-XR3

RP/0/0/CPU0:IOS-XR3#sh route bgp
Mon Jun 5 01:55:27.709 UTC

B 11.11.11.11/32 [200/0] via 1.1.1.1, 00:06:39
B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:07:41
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:07:41

Berikut tabel routing BGP di IOS-XR4

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#do sh route bgp
Mon Jun 5 01:55:48.918 UTC

B 11.11.11.11/32 [200/0] via 1.1.1.1, 00:07:00
B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:08:02
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:08:02

Oke.. sudah lengkap semua kan ya…

Pengujain terahir, kita coba lakukan ping yaa.. Berikut percobaan ping dari IOS-XR1 ke loopback router lainnya

RP/0/0/CPU0:IOS-XR1(config-if)#do ping 22.22.22.22 sou l1
Mon Jun 5 01:56:32.855 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-if)#do ping 33.33.33.33 sou l1
Mon Jun 5 01:56:37.354 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1(config-if)#do ping 44.44.44.44 sou l1
Mon Jun 5 01:56:41.684 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 44.44.44.44, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke jalan semua ya….

Alhamdulillah Lab IBGP pada IOS XR kita sudah selesai… In Syaa Allah selanjutnya kita masih akan membahas tentang IBGP pada IOS XR.. namun menggunakan Confederation.. Oke sampai ketemu di artikel selanjutnya yaaa

Lab 144 – IOS XR EIGRP Routing

Oke sesuai janji, kita masih lanjut belajar IOS XR yaa.. setelah sebelumnya kita belajar tentang konfigurasi OSPF di IOS XR, selanjutnya pada lab ini kita akan belajar konfigurasi routing protocol EIGRP pada IOS XR..

Untuk topologinya kita akan menggunakan topologi seperti berikut yaa

Pertama kita konfigurasi addressingnya dulu yaa..

RP/0/0/CPU0:IOS-XR1(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-if)#no sh
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 12.12.12.1/24

RP/0/0/CPU0:IOS-XR1(config-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 1.1.1.1/32

RP/0/0/CPU0:IOS-XR1(config-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 11.11.11.11/32

RP/0/0/CPU0:IOS-XR1(config-if)#commit
Sat Jun 3 15:06:51.991 UTC
RP/0/0/CPU0:IOS-XR2(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 12.12.12.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 2.2.2.2/32

RP/0/0/CPU0:IOS-XR2(config-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 22.22.22.22/32

RP/0/0/CPU0:IOS-XR2(config-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 23.23.23.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#commit
RP/0/0/CPU0:IOS-XR3(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-if)#no sh
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 23.23.23.3/24

RP/0/0/CPU0:IOS-XR3(config-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 3.3.3.3/32

RP/0/0/CPU0:IOS-XR3(config-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 33.33.33.33/32

RP/0/0/CPU0:IOS-XR3(config-if)#commit

Oke.. lanjut sekarang kita konfigurasikan EIGRP pada ketiga router tersebut… Berikut konfigurasi di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router eigrp 1
RP/0/0/CPU0:IOS-XR1(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR1(config-eigrp-af)#interface g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#commit

Berikut konfigurasi di IOS-XR2

RP/0/0/CPU0:IOS-XR2(config)#router eigrp AS1
RP/0/0/CPU0:IOS-XR2(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR2(config-eigrp-af)#autonomous-system 1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#commit

Berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config)#router eigrp 1
RP/0/0/CPU0:IOS-XR3(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR3(config-eigrp-af)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#commit

Untuk pengujian, pertama kita coba lihat apakah masing-masing router sudah menjalankan routing protocol eigrp dengan perintah berikut

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh protocol eigrp
Sat Jun 3 16:43:22.814 UTC

Routing Protocol: EIGRP, instance 1
Default context AS: 1, Router ID: 1.1.1.1
Address Family: IPv4
Default networks not flagged in outgoing updates
Default networks not accepted from incoming updates
Distance: internal 90, external 170
Maximum paths: 4
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0, K6=0
EIGRP metric rib scale 128
EIGRP metric version 64-bit
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
EIGRP NSF: enabled
NSF-aware route hold timer is 480s
NSF signal timer is 20s
NSF converge timer is 300s
Time since last restart is 00:13:09
SIA Active timer is 180s
Interfaces:
Loopback0
Loopback1
GigabitEthernet0/0/0/0

Perhatikan bahwa IOS-XR1 sudah menjalankan routing protocol EIGRP dengan AS 1, router-id 1.1.1.1, metric version 64 bit, dll. kita bisa melihat informasi tentang routing protocol EIGRP yang sedang berjalan dengan perintah diatas..

Selanjutnya, kita juga bisa melihat neighbor untuk melakukan pengujian, kita akan coba lihat neighbor di IOS-XR2

RP/0/0/CPU0:IOS-XR2#show eigrp neighbors
Sat Jun 3 16:46:44.920 UTC

IPv4-EIGRP VR(AS1) Neighbors for AS(1) VRF default

H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 23.23.23.3 Gi0/0/0/1 13 00:00:15 25 200 0 3
0 12.12.12.1 Gi0/0/0/0 11 00:09:35 7 200 0 7

Perhatikan bahwa IOS-XR2 sudah adjacency dengan IOS-XR1 dan IOS-XR3.. Selanjutnya kita juga bisa melihat tabel routing untuk melakukan pengujian.. Berikut tabel routing pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh route eigrp
Sat Jun 3 16:47:45.816 UTC

D 2.2.2.2/32 [90/10752] via 12.12.12.2, 00:10:36, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/15872] via 12.12.12.2, 00:01:16, GigabitEthernet0/0/0/0
D 22.22.22.22/32 [90/10752] via 12.12.12.2, 00:10:36, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 12.12.12.2, 00:01:18, GigabitEthernet0/0/0/0
D 33.33.33.33/32 [90/15872] via 12.12.12.2, 00:01:16, GigabitEthernet0/0/0/0

Perhatikan bahwa IOS-XR1 sudah memiliki tabel routing yang lengkap.. selanjutnya pengujian terahir yang dapat kita lakukan adalah dengan melakukan ping.. berikut percobaan ping dari IOS-XR1 ke loopback XR2 dan XR3

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping 2.2.2.2
Sat Jun 3 16:48:44.142 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping 3.3.3.3
Sat Jun 3 16:48:49.172 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke.. sudah work semua yaaaa…

Alhamdulillah lab ke tiga kita tentang IOS XR sudah selesai.. semoga bermanfaat ya.. In Syaa Allah besok kita masih akan belajar tentang IOS XR… keep spirit yaa!!!

Lab 144 – IOS XR EIGRP Routing

Oke sesuai janji, kita masih lanjut belajar IOS XR yaa.. setelah sebelumnya kita belajar tentang konfigurasi OSPF di IOS XR, selanjutnya pada lab ini kita akan belajar konfigurasi routing protocol EIGRP pada IOS XR..

Untuk topologinya kita akan menggunakan topologi seperti berikut yaa

Pertama kita konfigurasi addressingnya dulu yaa..

RP/0/0/CPU0:IOS-XR1(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-if)#no sh
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 12.12.12.1/24

RP/0/0/CPU0:IOS-XR1(config-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 1.1.1.1/32

RP/0/0/CPU0:IOS-XR1(config-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 11.11.11.11/32

RP/0/0/CPU0:IOS-XR1(config-if)#commit
Sat Jun 3 15:06:51.991 UTC
RP/0/0/CPU0:IOS-XR2(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 12.12.12.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 2.2.2.2/32

RP/0/0/CPU0:IOS-XR2(config-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 22.22.22.22/32

RP/0/0/CPU0:IOS-XR2(config-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 23.23.23.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#commit
RP/0/0/CPU0:IOS-XR3(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-if)#no sh
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 23.23.23.3/24

RP/0/0/CPU0:IOS-XR3(config-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 3.3.3.3/32

RP/0/0/CPU0:IOS-XR3(config-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 33.33.33.33/32

RP/0/0/CPU0:IOS-XR3(config-if)#commit

Oke.. lanjut sekarang kita konfigurasikan EIGRP pada ketiga router tersebut… Berikut konfigurasi di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router eigrp 1
RP/0/0/CPU0:IOS-XR1(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR1(config-eigrp-af)#interface g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#commit

Berikut konfigurasi di IOS-XR2

RP/0/0/CPU0:IOS-XR2(config)#router eigrp AS1
RP/0/0/CPU0:IOS-XR2(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR2(config-eigrp-af)#autonomous-system 1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#commit

Berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config)#router eigrp 1
RP/0/0/CPU0:IOS-XR3(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR3(config-eigrp-af)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#commit

Untuk pengujian, pertama kita coba lihat apakah masing-masing router sudah menjalankan routing protocol eigrp dengan perintah berikut

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh protocol eigrp
Sat Jun 3 16:43:22.814 UTC

Routing Protocol: EIGRP, instance 1
Default context AS: 1, Router ID: 1.1.1.1
Address Family: IPv4
Default networks not flagged in outgoing updates
Default networks not accepted from incoming updates
Distance: internal 90, external 170
Maximum paths: 4
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0, K6=0
EIGRP metric rib scale 128
EIGRP metric version 64-bit
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
EIGRP NSF: enabled
NSF-aware route hold timer is 480s
NSF signal timer is 20s
NSF converge timer is 300s
Time since last restart is 00:13:09
SIA Active timer is 180s
Interfaces:
Loopback0
Loopback1
GigabitEthernet0/0/0/0

Perhatikan bahwa IOS-XR1 sudah menjalankan routing protocol EIGRP dengan AS 1, router-id 1.1.1.1, metric version 64 bit, dll. kita bisa melihat informasi tentang routing protocol EIGRP yang sedang berjalan dengan perintah diatas..

Selanjutnya, kita juga bisa melihat neighbor untuk melakukan pengujian, kita akan coba lihat neighbor di IOS-XR2

RP/0/0/CPU0:IOS-XR2#show eigrp neighbors
Sat Jun 3 16:46:44.920 UTC

IPv4-EIGRP VR(AS1) Neighbors for AS(1) VRF default

H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 23.23.23.3 Gi0/0/0/1 13 00:00:15 25 200 0 3
0 12.12.12.1 Gi0/0/0/0 11 00:09:35 7 200 0 7

Perhatikan bahwa IOS-XR2 sudah adjacency dengan IOS-XR1 dan IOS-XR3.. Selanjutnya kita juga bisa melihat tabel routing untuk melakukan pengujian.. Berikut tabel routing pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh route eigrp
Sat Jun 3 16:47:45.816 UTC

D 2.2.2.2/32 [90/10752] via 12.12.12.2, 00:10:36, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/15872] via 12.12.12.2, 00:01:16, GigabitEthernet0/0/0/0
D 22.22.22.22/32 [90/10752] via 12.12.12.2, 00:10:36, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 12.12.12.2, 00:01:18, GigabitEthernet0/0/0/0
D 33.33.33.33/32 [90/15872] via 12.12.12.2, 00:01:16, GigabitEthernet0/0/0/0

Perhatikan bahwa IOS-XR1 sudah memiliki tabel routing yang lengkap.. selanjutnya pengujian terahir yang dapat kita lakukan adalah dengan melakukan ping.. berikut percobaan ping dari IOS-XR1 ke loopback XR2 dan XR3

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping 2.2.2.2
Sat Jun 3 16:48:44.142 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping 3.3.3.3
Sat Jun 3 16:48:49.172 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke.. sudah work semua yaaaa…

Alhamdulillah lab ke tiga kita tentang IOS XR sudah selesai.. semoga bermanfaat ya.. In Syaa Allah besok kita masih akan belajar tentang IOS XR… keep spirit yaa!!!

Lab 143 – IOS XR OSPF Routing

Pada lab sebelumnya kita sudah belajar tentang konfigurasi static routing di IOS XR.. Selanjutnya pada lab ini kita akan belajar konfigurasi routing OSPF pada IOS XR. Berikut topologi yang akan kita gunakan pada lab ini

Pada topologi diatas kita juga harus konfigurasi virtual link ya.. karena Area 2 tidak terhubung langsung dengan Area 0..

Oke pertama kita konfigurasikan ip address pada ketiga IOS XR sesuai topologi diatas

RP/0/0/CPU0:IOS-XR1(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-if)#no sh
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 12.12.12.1/24

RP/0/0/CPU0:IOS-XR1(config-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 1.1.1.1/32

RP/0/0/CPU0:IOS-XR1(config-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 11.11.11.11/32

RP/0/0/CPU0:IOS-XR1(config-if)#commit
Sat Jun 3 15:06:51.991 UTC
RP/0/0/CPU0:IOS-XR2(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 12.12.12.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 2.2.2.2/32

RP/0/0/CPU0:IOS-XR2(config-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 22.22.22.22/32

RP/0/0/CPU0:IOS-XR2(config-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 23.23.23.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#commit
RP/0/0/CPU0:IOS-XR3(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-if)#no sh
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 23.23.23.3/24

RP/0/0/CPU0:IOS-XR3(config-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 3.3.3.3/32

RP/0/0/CPU0:IOS-XR3(config-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 33.33.33.33/32

RP/0/0/CPU0:IOS-XR3(config-if)#commit

Oke.. konfigurasi ip address sudah selesai ya.. untuk pengujian, kita coba lakukan uji ping ke directly connected network masing2 router.. Berikut pengujian ping dari IOS-XR1 ke IOS-XR2

RP/0/0/CPU0:IOS-XR1(config-if)#do ping ipv4 12.12.12.2
Sat Jun 3 15:10:34.386 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/14/59 ms

Oke dari IOS-XR1 ke IOS-XR2 berhasil.. sekarang kita coba dari IOS-XR2 ke IOS-XR3

RP/0/0/CPU0:IOS-XR2(config-if)#do ping ipv4 23.23.23.3
Sat Jun 3 15:11:08.853 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/10/39 ms

Oke.. sudah berhasil juga ya..

Lanjut kita konfigurasi OSPF pada ketiga router tersebut.. perhatikan konfigurasinya harus sesuai topologi ya.. pada topologi kita diminta untuk mengkonfigurasi OSPF dengan 3 area..

Oke langsung saja, berikut konfigurasi OSPF pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router ospf 1
RP/0/0/CPU0:IOS-XR1(config-ospf)#router-id 1.1.1.1

RP/0/0/CPU0:IOS-XR1(config-ospf)#area 0
RP/0/0/CPU0:IOS-XR1(config-ospf-ar)#interface lo0
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#int l1

RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#area 1
RP/0/0/CPU0:IOS-XR1(config-ospf-ar)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#commit

Perhatikan bahwa kita tidak menggunakan perintah network pada IOS XR, kita menggunakan perintah interface seperti diatas, untuk pengujian kita coba lihat running-config nya ya

RP/0/0/CPU0:IOS-XR1(config-ospf)#do sh run router ospf
Sat Jun 3 15:21:25.241 UTC
router ospf 1
router-id 1.1.1.1
area 0
interface Loopback0
interface Loopback1
!
!
area 1
interface GigabitEthernet0/0/0/0
!
!

Oke.. sekarang lanjut konfigurasi di IOS-XR2 yaa

RP/0/0/CPU0:IOS-XR2(config)#router ospf 2
RP/0/0/CPU0:IOS-XR2(config-ospf)#router-id 2.2.2.2

RP/0/0/CPU0:IOS-XR2(config-ospf)#area 1
RP/0/0/CPU0:IOS-XR2(config-ospf-ar)#int lo0
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#int g0/0/0/0

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#area 2
RP/0/0/CPU0:IOS-XR2(config-ospf-ar)#int lo1
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#int g0/0/0/1

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#commit
Sat Jun 3 15:25:53.883 UTC
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh run router ospf
Sat Jun 3 15:27:19.337 UTC
router ospf 2
router-id 2.2.2.2
area 1
interface Loopback0
interface GigabitEthernet0/0/0/0
!
area 2
interface Loopback1
interface GigabitEthernet0/0/0/1
!
!

Setelah konfigurasi di IOS-XR1 dan IOS-XR2, seharusnya kedua router tersebut sudah adjacency OSPF.. kita coba lihat dulu yaa

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh ospf neig
Sat Jun 3 15:29:20.029 UTC

* Indicates MADJ interface

Neighbors for OSPF 2

Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 1 FULL/DR 00:00:34 12.12.12.1 GigabitEth0/0/0/0
Neighbor is up for 00:03:15

Total neighbor count: 1

Perhatikan bahwa state nya sudah full… Sekarang kita lanjut konfigurasi di IOS-XR3 yaa

RP/0/0/CPU0:IOS-XR3(config)#router ospf 3
RP/0/0/CPU0:IOS-XR3(config-ospf)#router-id 3.3.3.3

RP/0/0/CPU0:IOS-XR3(config-ospf)#area 2
RP/0/0/CPU0:IOS-XR3(config-ospf-ar)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#int l1

RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#commit
Sat Jun 3 15:32:09.727 UTC
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#do sh run router ospf
Sat Jun 3 15:32:18.186 UTC
router ospf 3
router-id 3.3.3.3
area 2
interface Loopback0
interface Loopback1
interface GigabitEthernet0/0/0/0
!
!

Kita coba lihat neighbor tabel di IOS-XR2 ya.. seharusnya IOS-XR2 punya 2 neighbor

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh ospf neigh
Sat Jun 3 15:34:20.278 UTC

* Indicates MADJ interface

Neighbors for OSPF 2

Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 1 FULL/DR 00:00:38 12.12.12.1 GigabitEth0/0/0/0
Neighbor is up for 00:08:15
3.3.3.3 1 FULL/BDR 00:00:35 23.23.23.3 GigabitEth0/0/0/1
Neighbor is up for 00:01:59

Total neighbor count: 2

Oke IOS-XR2 sudah punya 2 neighbor ya.. dan statenya sudah full semua.. terahir kita akan konfigurasikan virtual link antara IOS-XR1 dan IOS-XR2..

RP/0/0/CPU0:IOS-XR1(config)#router ospf 1
RP/0/0/CPU0:IOS-XR1(config-ospf)#area 1
RP/0/0/CPU0:IOS-XR1(config-ospf-ar)#virtual-link 2.2.2.2
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-vl)#commit
RP/0/0/CPU0:IOS-XR2(config)#router ospf 2
RP/0/0/CPU0:IOS-XR2(config-ospf)#area 1
RP/0/0/CPU0:IOS-XR2(config-ospf-ar)#virtual-link 1.1.1.1
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-vl)#commit

Oke, untuk pengujian, pastikan tabel routing di seluruh router sudah lengkap

RP/0/0/CPU0:IOS-XR1#show route ospf
Sat Jun 3 15:56:53.025 UTC

O 2.2.2.2/32 [110/2] via 12.12.12.2, 00:00:40, GigabitEthernet0/0/0/0
O IA 3.3.3.3/32 [110/3] via 12.12.12.2, 00:00:30, GigabitEthernet0/0/0/0
O IA 22.22.22.22/32 [110/2] via 12.12.12.2, 00:00:30, GigabitEthernet0/0/0/0
O IA 23.23.23.0/24 [110/2] via 12.12.12.2, 00:00:30, GigabitEthernet0/0/0/0
O IA 33.33.33.33/32 [110/3] via 12.12.12.2, 00:00:30, GigabitEthernet0/0/0/0

Perhatikan bahwa IOS XR1 sudah punya tabel routing OSPF lengkap, kita coba cek di IOS-XR2 dan IOS-XR3

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh route ospf
Sat Jun 3 15:58:15.940 UTC

O 1.1.1.1/32 [110/2] via 12.12.12.1, 00:01:52, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/2] via 23.23.23.3, 00:02:06, GigabitEthernet0/0/0/1
O 11.11.11.11/32 [110/2] via 12.12.12.1, 00:01:52, GigabitEthernet0/0/0/0
O 33.33.33.33/32 [110/2] via 23.23.23.3, 00:02:06, GigabitEthernet0/0/0/1
RP/0/0/CPU0:IOS-XR3#show route ospf
Sat Jun 3 15:58:35.758 UTC

O IA 1.1.1.1/32 [110/3] via 23.23.23.2, 00:02:12, GigabitEthernet0/0/0/0
O IA 2.2.2.2/32 [110/2] via 23.23.23.2, 00:02:22, GigabitEthernet0/0/0/0
O IA 11.11.11.11/32 [110/3] via 23.23.23.2, 00:02:12, GigabitEthernet0/0/0/0
O IA 12.12.12.0/24 [110/2] via 23.23.23.2, 00:02:22, GigabitEthernet0/0/0/0
O 22.22.22.22/32 [110/2] via 23.23.23.2, 00:02:26, GigabitEthernet0/0/0/0

Oke tabel routing di IOS-XR2 dan IOS-XR3 juga sudah lengkap.. Untuk lebih memastikan kita coba ping ya.. kita akan coba ping dari IOS-XR1 ke loopback XR2 dan XR3

RP/0/0/CPU0:IOS-XR1#ping 2.2.2.2
Sat Jun 3 16:02:21.183 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1#ping 22.22.22.22
Sat Jun 3 16:02:23.943 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1#ping 3.3.3.3
Sat Jun 3 16:02:25.882 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/19 ms
RP/0/0/CPU0:IOS-XR1#ping 33.33.33.33
Sat Jun 3 16:02:28.582 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

Oke ping sudah jalan semua ya…

Alhamdulillah lab kedua kita tentang IOS XR sudah berhasil.. sampai ketemu di artikel selanjutnya yaa.. In Syaa Allah masih akan tetap tentang IOS XR