Lab 144 – IOS XR EIGRP Routing

Oke sesuai janji, kita masih lanjut belajar IOS XR yaa.. setelah sebelumnya kita belajar tentang konfigurasi OSPF di IOS XR, selanjutnya pada lab ini kita akan belajar konfigurasi routing protocol EIGRP pada IOS XR..

Untuk topologinya kita akan menggunakan topologi seperti berikut yaa

Pertama kita konfigurasi addressingnya dulu yaa..

RP/0/0/CPU0:IOS-XR1(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-if)#no sh
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 12.12.12.1/24

RP/0/0/CPU0:IOS-XR1(config-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 1.1.1.1/32

RP/0/0/CPU0:IOS-XR1(config-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 11.11.11.11/32

RP/0/0/CPU0:IOS-XR1(config-if)#commit
Sat Jun 3 15:06:51.991 UTC
RP/0/0/CPU0:IOS-XR2(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 12.12.12.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 2.2.2.2/32

RP/0/0/CPU0:IOS-XR2(config-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 22.22.22.22/32

RP/0/0/CPU0:IOS-XR2(config-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 23.23.23.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#commit
RP/0/0/CPU0:IOS-XR3(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-if)#no sh
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 23.23.23.3/24

RP/0/0/CPU0:IOS-XR3(config-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 3.3.3.3/32

RP/0/0/CPU0:IOS-XR3(config-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 33.33.33.33/32

RP/0/0/CPU0:IOS-XR3(config-if)#commit

Oke.. lanjut sekarang kita konfigurasikan EIGRP pada ketiga router tersebut… Berikut konfigurasi di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router eigrp 1
RP/0/0/CPU0:IOS-XR1(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR1(config-eigrp-af)#interface g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#commit

Berikut konfigurasi di IOS-XR2

RP/0/0/CPU0:IOS-XR2(config)#router eigrp AS1
RP/0/0/CPU0:IOS-XR2(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR2(config-eigrp-af)#autonomous-system 1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#commit

Berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config)#router eigrp 1
RP/0/0/CPU0:IOS-XR3(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR3(config-eigrp-af)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#commit

Untuk pengujian, pertama kita coba lihat apakah masing-masing router sudah menjalankan routing protocol eigrp dengan perintah berikut

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh protocol eigrp
Sat Jun 3 16:43:22.814 UTC

Routing Protocol: EIGRP, instance 1
Default context AS: 1, Router ID: 1.1.1.1
Address Family: IPv4
Default networks not flagged in outgoing updates
Default networks not accepted from incoming updates
Distance: internal 90, external 170
Maximum paths: 4
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0, K6=0
EIGRP metric rib scale 128
EIGRP metric version 64-bit
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
EIGRP NSF: enabled
NSF-aware route hold timer is 480s
NSF signal timer is 20s
NSF converge timer is 300s
Time since last restart is 00:13:09
SIA Active timer is 180s
Interfaces:
Loopback0
Loopback1
GigabitEthernet0/0/0/0

Perhatikan bahwa IOS-XR1 sudah menjalankan routing protocol EIGRP dengan AS 1, router-id 1.1.1.1, metric version 64 bit, dll. kita bisa melihat informasi tentang routing protocol EIGRP yang sedang berjalan dengan perintah diatas..

Selanjutnya, kita juga bisa melihat neighbor untuk melakukan pengujian, kita akan coba lihat neighbor di IOS-XR2

RP/0/0/CPU0:IOS-XR2#show eigrp neighbors
Sat Jun 3 16:46:44.920 UTC

IPv4-EIGRP VR(AS1) Neighbors for AS(1) VRF default

H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 23.23.23.3 Gi0/0/0/1 13 00:00:15 25 200 0 3
0 12.12.12.1 Gi0/0/0/0 11 00:09:35 7 200 0 7

Perhatikan bahwa IOS-XR2 sudah adjacency dengan IOS-XR1 dan IOS-XR3.. Selanjutnya kita juga bisa melihat tabel routing untuk melakukan pengujian.. Berikut tabel routing pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh route eigrp
Sat Jun 3 16:47:45.816 UTC

D 2.2.2.2/32 [90/10752] via 12.12.12.2, 00:10:36, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/15872] via 12.12.12.2, 00:01:16, GigabitEthernet0/0/0/0
D 22.22.22.22/32 [90/10752] via 12.12.12.2, 00:10:36, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 12.12.12.2, 00:01:18, GigabitEthernet0/0/0/0
D 33.33.33.33/32 [90/15872] via 12.12.12.2, 00:01:16, GigabitEthernet0/0/0/0

Perhatikan bahwa IOS-XR1 sudah memiliki tabel routing yang lengkap.. selanjutnya pengujian terahir yang dapat kita lakukan adalah dengan melakukan ping.. berikut percobaan ping dari IOS-XR1 ke loopback XR2 dan XR3

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping 2.2.2.2
Sat Jun 3 16:48:44.142 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping 3.3.3.3
Sat Jun 3 16:48:49.172 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke.. sudah work semua yaaaa…

Alhamdulillah lab ke tiga kita tentang IOS XR sudah selesai.. semoga bermanfaat ya.. In Syaa Allah besok kita masih akan belajar tentang IOS XR… keep spirit yaa!!!

Lab 144 – IOS XR EIGRP Routing

Oke sesuai janji, kita masih lanjut belajar IOS XR yaa.. setelah sebelumnya kita belajar tentang konfigurasi OSPF di IOS XR, selanjutnya pada lab ini kita akan belajar konfigurasi routing protocol EIGRP pada IOS XR..

Untuk topologinya kita akan menggunakan topologi seperti berikut yaa

Pertama kita konfigurasi addressingnya dulu yaa..

RP/0/0/CPU0:IOS-XR1(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-if)#no sh
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 12.12.12.1/24

RP/0/0/CPU0:IOS-XR1(config-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 1.1.1.1/32

RP/0/0/CPU0:IOS-XR1(config-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 11.11.11.11/32

RP/0/0/CPU0:IOS-XR1(config-if)#commit
Sat Jun 3 15:06:51.991 UTC
RP/0/0/CPU0:IOS-XR2(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 12.12.12.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 2.2.2.2/32

RP/0/0/CPU0:IOS-XR2(config-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 22.22.22.22/32

RP/0/0/CPU0:IOS-XR2(config-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 23.23.23.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#commit
RP/0/0/CPU0:IOS-XR3(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-if)#no sh
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 23.23.23.3/24

RP/0/0/CPU0:IOS-XR3(config-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 3.3.3.3/32

RP/0/0/CPU0:IOS-XR3(config-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 33.33.33.33/32

RP/0/0/CPU0:IOS-XR3(config-if)#commit

Oke.. lanjut sekarang kita konfigurasikan EIGRP pada ketiga router tersebut… Berikut konfigurasi di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router eigrp 1
RP/0/0/CPU0:IOS-XR1(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR1(config-eigrp-af)#interface g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#commit

Berikut konfigurasi di IOS-XR2

RP/0/0/CPU0:IOS-XR2(config)#router eigrp AS1
RP/0/0/CPU0:IOS-XR2(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR2(config-eigrp-af)#autonomous-system 1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#commit

Berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config)#router eigrp 1
RP/0/0/CPU0:IOS-XR3(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR3(config-eigrp-af)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#commit

Untuk pengujian, pertama kita coba lihat apakah masing-masing router sudah menjalankan routing protocol eigrp dengan perintah berikut

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh protocol eigrp
Sat Jun 3 16:43:22.814 UTC

Routing Protocol: EIGRP, instance 1
Default context AS: 1, Router ID: 1.1.1.1
Address Family: IPv4
Default networks not flagged in outgoing updates
Default networks not accepted from incoming updates
Distance: internal 90, external 170
Maximum paths: 4
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0, K6=0
EIGRP metric rib scale 128
EIGRP metric version 64-bit
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
EIGRP NSF: enabled
NSF-aware route hold timer is 480s
NSF signal timer is 20s
NSF converge timer is 300s
Time since last restart is 00:13:09
SIA Active timer is 180s
Interfaces:
Loopback0
Loopback1
GigabitEthernet0/0/0/0

Perhatikan bahwa IOS-XR1 sudah menjalankan routing protocol EIGRP dengan AS 1, router-id 1.1.1.1, metric version 64 bit, dll. kita bisa melihat informasi tentang routing protocol EIGRP yang sedang berjalan dengan perintah diatas..

Selanjutnya, kita juga bisa melihat neighbor untuk melakukan pengujian, kita akan coba lihat neighbor di IOS-XR2

RP/0/0/CPU0:IOS-XR2#show eigrp neighbors
Sat Jun 3 16:46:44.920 UTC

IPv4-EIGRP VR(AS1) Neighbors for AS(1) VRF default

H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 23.23.23.3 Gi0/0/0/1 13 00:00:15 25 200 0 3
0 12.12.12.1 Gi0/0/0/0 11 00:09:35 7 200 0 7

Perhatikan bahwa IOS-XR2 sudah adjacency dengan IOS-XR1 dan IOS-XR3.. Selanjutnya kita juga bisa melihat tabel routing untuk melakukan pengujian.. Berikut tabel routing pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh route eigrp
Sat Jun 3 16:47:45.816 UTC

D 2.2.2.2/32 [90/10752] via 12.12.12.2, 00:10:36, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/15872] via 12.12.12.2, 00:01:16, GigabitEthernet0/0/0/0
D 22.22.22.22/32 [90/10752] via 12.12.12.2, 00:10:36, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 12.12.12.2, 00:01:18, GigabitEthernet0/0/0/0
D 33.33.33.33/32 [90/15872] via 12.12.12.2, 00:01:16, GigabitEthernet0/0/0/0

Perhatikan bahwa IOS-XR1 sudah memiliki tabel routing yang lengkap.. selanjutnya pengujian terahir yang dapat kita lakukan adalah dengan melakukan ping.. berikut percobaan ping dari IOS-XR1 ke loopback XR2 dan XR3

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping 2.2.2.2
Sat Jun 3 16:48:44.142 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping 3.3.3.3
Sat Jun 3 16:48:49.172 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke.. sudah work semua yaaaa…

Alhamdulillah lab ke tiga kita tentang IOS XR sudah selesai.. semoga bermanfaat ya.. In Syaa Allah besok kita masih akan belajar tentang IOS XR… keep spirit yaa!!!

EIGRP Un-Equal load balance

Routing protocol EIGRP dapat melakukan load balance jika terdapat dua atau lebih jalur yang masing-masing nilai metricnya sama, tetapi terkadang muncul suatu keadaan dimana ada beberapa jalur yang tujuannya sama tetapi nilai metricnya berbeda, hal ini menyebabkan EIGRP hanya memilih satu jalur saja (redundant), tetapi sebenarnya kita dapat mengakalinya agar dapat load balance meski nilai metric pada masing-masing jalur berbeda.

Untuk melakukan Un-Equal load balance kita perlu mengkonfigurasi nilai variance, nilai ini didapatkan dari hasi bagi nilai FD masing-masing jalur. Berikut ini adalah topologinya :

Untuk mencapai R4 dari R1 terdapat dua jalur yaitu lewat e0/0 dan e0/1, kemudian nilai bandwidth pada e0/1 kita kecilkan agar nilai metric antara e0/0 dan e0/1 berbeda sehingga jalur di e0/0 akan dipilih menjadi jalur utama, kemudian kita konfigurasi variance agar dapat melakukan load balance meskipun nilai metricnya berbeda.

Pertama kita ubah nilai bandwitdh di interface e0/1 Router R1 agar nilai metricnya berubah dan tidak sama dengan e0/0 :

R1(config)#int e0/1
R1(config-if)#band 500
R1(config-if)#exi

IP Addressing

    R1

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int e0/1
    R1(config-if)#ip add 13.13.13.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi

    R2

    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi
    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 24.24.24.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi

    R3

    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#int e0/0
    R3(config-if)#ip add 13.13.13.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int e0/1
    R3(config-if)#ip add 34.34.34.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi

    R4

    R4(config)#int lo0
    R4(config-if)#ip add 4.4.4.4 255.255.255.255
    R4(config-if)#ex
    R4(config)#int e0/0
    R4(config-if)#ip add 24.24.24.4 255.255.255.0
    R4(config-if)#no sh
    R4(config-if)#exi
    R4(config)#int e0/1
    R4(config-if)#ip add 34.34.34.4 255.255.255.0
    R4(config-if)#no sh
    R4(config-if)#exi

Routing EIGRP

    R1

    R1(config)#router eigrp 1
    R1(config-router)#no auto-summ
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#net 13.13.13.0 0.0.0.255
    R1(config-router)#exi

    R2

    R2(config)#router eigrp 1
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 24.24.24.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#exi

    R3

    R3(config)#router eigrp 1
    R3(config-router)#no auto-summ
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 13.13.13.0 0.0.0.255
    R3(config-router)#net 34.34.34.0 0.0.0.255
    R3(config-router)#exi

    R4

    R4(config)#router eigrp 1
    R4(config-router)#no auto-summ
    R4(config-router)#net 4.4.4.4 0.0.0.0
    R4(config-router)#net 24.24.24.0 0.0.0.255
    R4(config-router)#net 34.34.34.0 0.0.0.255
    R4(config-router)#exi

Lalu kita lihat Routing table di R1

R1(config)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 12.12.12.2, 03:01:27, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/460800] via 12.12.12.2, 00:00:26, Ethernet0/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/435200] via 12.12.12.2, 00:00:26, Ethernet0/0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.1/32 is directly connected, Ethernet0/0
13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 13.13.13.0/24 is directly connected, Ethernet0/1
L 13.13.13.1/32 is directly connected, Ethernet0/1
24.0.0.0/24 is subnetted, 1 subnets
D 24.24.24.0 [90/307200] via 12.12.12.2, 00:00:26, Ethernet0/0
34.0.0.0/24 is subnetted, 1 subnets
D 34.34.34.0 [90/332800] via 12.12.12.2, 00:00:26, Ethernet0/0

Dan terlihat 4.4.4.4 hanya memiliki satu jalur, kemudian kita lihat nilai metric pada masing-masing jalur :

R1#sh ip eigrp topology 4.4.4.4/32
EIGRP-IPv4 Topology Entry for AS(1)/ID(1.1.1.1) for 4.4.4.4/32
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 435200
Descriptor Blocks:
12.12.12.2 (Ethernet0/0), from 12.12.12.2, Send flag is 0x0
Composite metric is (435200/409600), route is Internal
Vector metric:
Minimum bandwidth is 10000 Kbit
Total delay is 7000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 2
Originating router is 4.4.4.4
13.13.13.3 (Ethernet0/1), from 13.13.13.3, Send flag is 0x0
Composite metric is (5299200/409600), route is Internal
Vector metric:
Minimum bandwidth is 500 Kbit
Total delay is 7000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 2

Kemudian kedua nilai yang ditebalkan itu kita bagi 5299200 dengan 435200 dan hasilnya 12,176470588 jika komanya berlebih berapapun nilainya bulatkan saja, maka nilai variancenya adalah 13.

R1(config)#router eigrp 1
R1(config-router)#variance 13
R1(config-router)#ex

Dan kita lihat hasilnya pada Routing table R1.

R1(config)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 12.12.12.2, 00:00:30, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/5273600] via 13.13.13.3, 00:00:30, Ethernet0/1
[90/460800] via 12.12.12.2, 00:00:30, Ethernet0/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/5299200] via 13.13.13.3, 00:00:30, Ethernet0/1
[90/435200] via 12.12.12.2, 00:00:30, Ethernet0/0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.1/32 is directly connected, Ethernet0/0
13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 13.13.13.0/24 is directly connected, Ethernet0/1
L 13.13.13.1/32 is directly connected, Ethernet0/1
24.0.0.0/24 is subnetted, 1 subnets
D 24.24.24.0 [90/307200] via 12.12.12.2, 00:00:30, Ethernet0/0
34.0.0.0/24 is subnetted, 1 subnets
D 34.34.34.0 [90/332800] via 12.12.12.2, 00:00:30, Ethernet0/0

Dan terlihat jalur sudah di load balance kembali, untuk membuktikannya kita lakukan traceroute.

R1#traceroute 4.4.4.4 so lo0
Type escape sequence to abort.
Tracing the route to 4.4.4.4
VRF info: (vrf in name/id, vrf out name/id)
1 12.12.12.2 0 msec 0 msec 1 msec
2 24.24.24.4 0 msec
34.34.34.4 0 msec
24.24.24.4 1 msec

EIGRP Un-Equal load balance

Routing protocol EIGRP dapat melakukan load balance jika terdapat dua atau lebih jalur yang masing-masing nilai metricnya sama, tetapi terkadang muncul suatu keadaan dimana ada beberapa jalur yang tujuannya sama tetapi nilai metricnya berbeda, hal ini menyebabkan EIGRP hanya memilih satu jalur saja (redundant), tetapi sebenarnya kita dapat mengakalinya agar dapat load balance meski nilai metric pada masing-masing jalur berbeda.

Untuk melakukan Un-Equal load balance kita perlu mengkonfigurasi nilai variance, nilai ini didapatkan dari hasi bagi nilai FD masing-masing jalur. Berikut ini adalah topologinya :

Untuk mencapai R4 dari R1 terdapat dua jalur yaitu lewat e0/0 dan e0/1, kemudian nilai bandwidth pada e0/1 kita kecilkan agar nilai metric antara e0/0 dan e0/1 berbeda sehingga jalur di e0/0 akan dipilih menjadi jalur utama, kemudian kita konfigurasi variance agar dapat melakukan load balance meskipun nilai metricnya berbeda.

Pertama kita ubah nilai bandwitdh di interface e0/1 Router R1 agar nilai metricnya berubah dan tidak sama dengan e0/0 :

R1(config)#int e0/1
R1(config-if)#band 500
R1(config-if)#exi

IP Addressing

    R1

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int e0/1
    R1(config-if)#ip add 13.13.13.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi

    R2

    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi
    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 24.24.24.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi

    R3

    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#int e0/0
    R3(config-if)#ip add 13.13.13.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int e0/1
    R3(config-if)#ip add 34.34.34.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi

    R4

    R4(config)#int lo0
    R4(config-if)#ip add 4.4.4.4 255.255.255.255
    R4(config-if)#ex
    R4(config)#int e0/0
    R4(config-if)#ip add 24.24.24.4 255.255.255.0
    R4(config-if)#no sh
    R4(config-if)#exi
    R4(config)#int e0/1
    R4(config-if)#ip add 34.34.34.4 255.255.255.0
    R4(config-if)#no sh
    R4(config-if)#exi

Routing EIGRP

    R1

    R1(config)#router eigrp 1
    R1(config-router)#no auto-summ
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#net 13.13.13.0 0.0.0.255
    R1(config-router)#exi

    R2

    R2(config)#router eigrp 1
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 24.24.24.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#exi

    R3

    R3(config)#router eigrp 1
    R3(config-router)#no auto-summ
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 13.13.13.0 0.0.0.255
    R3(config-router)#net 34.34.34.0 0.0.0.255
    R3(config-router)#exi

    R4

    R4(config)#router eigrp 1
    R4(config-router)#no auto-summ
    R4(config-router)#net 4.4.4.4 0.0.0.0
    R4(config-router)#net 24.24.24.0 0.0.0.255
    R4(config-router)#net 34.34.34.0 0.0.0.255
    R4(config-router)#exi

Lalu kita lihat Routing table di R1

R1(config)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 12.12.12.2, 03:01:27, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/460800] via 12.12.12.2, 00:00:26, Ethernet0/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/435200] via 12.12.12.2, 00:00:26, Ethernet0/0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.1/32 is directly connected, Ethernet0/0
13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 13.13.13.0/24 is directly connected, Ethernet0/1
L 13.13.13.1/32 is directly connected, Ethernet0/1
24.0.0.0/24 is subnetted, 1 subnets
D 24.24.24.0 [90/307200] via 12.12.12.2, 00:00:26, Ethernet0/0
34.0.0.0/24 is subnetted, 1 subnets
D 34.34.34.0 [90/332800] via 12.12.12.2, 00:00:26, Ethernet0/0

Dan terlihat 4.4.4.4 hanya memiliki satu jalur, kemudian kita lihat nilai metric pada masing-masing jalur :

R1#sh ip eigrp topology 4.4.4.4/32
EIGRP-IPv4 Topology Entry for AS(1)/ID(1.1.1.1) for 4.4.4.4/32
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 435200
Descriptor Blocks:
12.12.12.2 (Ethernet0/0), from 12.12.12.2, Send flag is 0x0
Composite metric is (435200/409600), route is Internal
Vector metric:
Minimum bandwidth is 10000 Kbit
Total delay is 7000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 2
Originating router is 4.4.4.4
13.13.13.3 (Ethernet0/1), from 13.13.13.3, Send flag is 0x0
Composite metric is (5299200/409600), route is Internal
Vector metric:
Minimum bandwidth is 500 Kbit
Total delay is 7000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 2

Kemudian kedua nilai yang ditebalkan itu kita bagi 5299200 dengan 435200 dan hasilnya 12,176470588 jika komanya berlebih berapapun nilainya bulatkan saja, maka nilai variancenya adalah 13.

R1(config)#router eigrp 1
R1(config-router)#variance 13
R1(config-router)#ex

Dan kita lihat hasilnya pada Routing table R1.

R1(config)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 12.12.12.2, 00:00:30, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/5273600] via 13.13.13.3, 00:00:30, Ethernet0/1
[90/460800] via 12.12.12.2, 00:00:30, Ethernet0/0
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/5299200] via 13.13.13.3, 00:00:30, Ethernet0/1
[90/435200] via 12.12.12.2, 00:00:30, Ethernet0/0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.1/32 is directly connected, Ethernet0/0
13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 13.13.13.0/24 is directly connected, Ethernet0/1
L 13.13.13.1/32 is directly connected, Ethernet0/1
24.0.0.0/24 is subnetted, 1 subnets
D 24.24.24.0 [90/307200] via 12.12.12.2, 00:00:30, Ethernet0/0
34.0.0.0/24 is subnetted, 1 subnets
D 34.34.34.0 [90/332800] via 12.12.12.2, 00:00:30, Ethernet0/0

Dan terlihat jalur sudah di load balance kembali, untuk membuktikannya kita lakukan traceroute.

R1#traceroute 4.4.4.4 so lo0
Type escape sequence to abort.
Tracing the route to 4.4.4.4
VRF info: (vrf in name/id, vrf out name/id)
1 12.12.12.2 0 msec 0 msec 1 msec
2 24.24.24.4 0 msec
34.34.34.4 0 msec
24.24.24.4 1 msec

EIGRP Equal load balance

Routing protocol EIGRP berfungsi untuk mendistribusikan informasi Routing dan membentuk sebuah jalur untuk menuju suatu rute network, jika ada lebih dari satu jalur yang terbentuk maka EIGRP dapat membuat jalur redundant ada yang utama dan cadangan, atau load balance seluruh jalur yang ada digunakan.

Jalur load balance adalah jalur yang lebih dari satu tetapi menuju tujuan yang sama, setiap traffic akan dibagi-bagi jalurnya, berbeda dengan redundant hanya satu jalur yang digunakan dan yang lainnya cadangan, dengan load balance semua jalur akan digunakan, dan pembagiannya merata.

EIGRP akan membentuk load balance jika ada dua jalur yang nilai metric atau jarak jauhnya memiliki nilai yang sama, misalnya kita akan mempraktekan topologi ini :

Dari R1 ingin menuju R4 terdapat dua jalur yang dapat ditempuh dan jaraknya sama, yaitu lewat R2 atau R3, kedua jalur ini akan secara otomatis di load balance oleh EIGRP, dan kita lanjut ke konfigurasinya :

IP Addressing

    R1

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int e0/1
    R1(config-if)#ip add 13.13.13.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi

    R2

    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi
    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 24.24.24.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi

    R3

    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#int e0/0
    R3(config-if)#ip add 13.13.13.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int e0/1
    R3(config-if)#ip add 34.34.34.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi

    R4

    R4(config)#int lo0
    R4(config-if)#ip add 4.4.4.4 255.255.255.255
    R4(config-if)#ex
    R4(config)#int e0/0
    R4(config-if)#ip add 24.24.24.4 255.255.255.0
    R4(config-if)#no sh
    R4(config-if)#exi
    R4(config)#int e0/1
    R4(config-if)#ip add 34.34.34.4 255.255.255.0
    R4(config-if)#no sh
    R4(config-if)#exi

Routing EIGRP

    R1

    R1(config)#router eigrp 1
    R1(config-router)#no auto-summ
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#net 13.13.13.0 0.0.0.255
    R1(config-router)#exi

    R2

    R2(config)#router eigrp 1
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 24.24.24.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#exi

    R3

    R3(config)#router eigrp 1
    R3(config-router)#no auto-summ
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 13.13.13.0 0.0.0.255
    R3(config-router)#net 34.34.34.0 0.0.0.255
    R3(config-router)#exi

    R4

    R4(config)#router eigrp 1
    R4(config-router)#no auto-summ
    R4(config-router)#net 4.4.4.4 0.0.0.0
    R4(config-router)#net 24.24.24.0 0.0.0.255
    R4(config-router)#net 34.34.34.0 0.0.0.255
    R4(config-router)#exi

Setelah selesai semua konfigurasi, kita coba lihat pada Routing table di R1.

R1(config)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 12.12.12.2, 00:04:13, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 13.13.13.3, 00:03:20, Ethernet0/1
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/435200] via 13.13.13.3, 00:01:53, Ethernet0/1
[90/435200] via 12.12.12.2, 00:01:53, Ethernet0/0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.1/32 is directly connected, Ethernet0/0
13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 13.13.13.0/24 is directly connected, Ethernet0/1
L 13.13.13.1/32 is directly connected, Ethernet0/1
24.0.0.0/24 is subnetted, 1 subnets
D 24.24.24.0 [90/307200] via 12.12.12.2, 00:01:53, Ethernet0/0
34.0.0.0/24 is subnetted, 1 subnets
D 34.34.34.0 [90/307200] via 13.13.13.3, 00:01:54, Ethernet0/1

Bisa kita lihat rute network 4.4.4.4/32 memiliki dua jalur yang dapat digunakan dua duanya secara load balance, untuk membuktikan jalur load balance, lakukan traceroute dari R1 ke R4.

R1#traceroute 4.4.4.4 source lo0
Type escape sequence to abort.
Tracing the route to 4.4.4.4
VRF info: (vrf in name/id, vrf out name/id)
1 12.12.12.2 0 msec
13.13.13.3 1 msec
12.12.12.2 0 msec
2 34.34.34.4 0 msec
24.24.24.4 1 msec
34.34.34.4 1 msec

EIGRP Equal load balance

Routing protocol EIGRP berfungsi untuk mendistribusikan informasi Routing dan membentuk sebuah jalur untuk menuju suatu rute network, jika ada lebih dari satu jalur yang terbentuk maka EIGRP dapat membuat jalur redundant ada yang utama dan cadangan, atau load balance seluruh jalur yang ada digunakan.

Jalur load balance adalah jalur yang lebih dari satu tetapi menuju tujuan yang sama, setiap traffic akan dibagi-bagi jalurnya, berbeda dengan redundant hanya satu jalur yang digunakan dan yang lainnya cadangan, dengan load balance semua jalur akan digunakan, dan pembagiannya merata.

EIGRP akan membentuk load balance jika ada dua jalur yang nilai metric atau jarak jauhnya memiliki nilai yang sama, misalnya kita akan mempraktekan topologi ini :

Dari R1 ingin menuju R4 terdapat dua jalur yang dapat ditempuh dan jaraknya sama, yaitu lewat R2 atau R3, kedua jalur ini akan secara otomatis di load balance oleh EIGRP, dan kita lanjut ke konfigurasinya :

IP Addressing

    R1

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int e0/1
    R1(config-if)#ip add 13.13.13.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi

    R2

    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi
    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 24.24.24.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi

    R3

    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#int e0/0
    R3(config-if)#ip add 13.13.13.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int e0/1
    R3(config-if)#ip add 34.34.34.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi

    R4

    R4(config)#int lo0
    R4(config-if)#ip add 4.4.4.4 255.255.255.255
    R4(config-if)#ex
    R4(config)#int e0/0
    R4(config-if)#ip add 24.24.24.4 255.255.255.0
    R4(config-if)#no sh
    R4(config-if)#exi
    R4(config)#int e0/1
    R4(config-if)#ip add 34.34.34.4 255.255.255.0
    R4(config-if)#no sh
    R4(config-if)#exi

Routing EIGRP

    R1

    R1(config)#router eigrp 1
    R1(config-router)#no auto-summ
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#net 13.13.13.0 0.0.0.255
    R1(config-router)#exi

    R2

    R2(config)#router eigrp 1
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 24.24.24.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#exi

    R3

    R3(config)#router eigrp 1
    R3(config-router)#no auto-summ
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 13.13.13.0 0.0.0.255
    R3(config-router)#net 34.34.34.0 0.0.0.255
    R3(config-router)#exi

    R4

    R4(config)#router eigrp 1
    R4(config-router)#no auto-summ
    R4(config-router)#net 4.4.4.4 0.0.0.0
    R4(config-router)#net 24.24.24.0 0.0.0.255
    R4(config-router)#net 34.34.34.0 0.0.0.255
    R4(config-router)#exi

Setelah selesai semua konfigurasi, kita coba lihat pada Routing table di R1.

R1(config)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
D 2.2.2.2 [90/409600] via 12.12.12.2, 00:04:13, Ethernet0/0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 13.13.13.3, 00:03:20, Ethernet0/1
4.0.0.0/32 is subnetted, 1 subnets
D 4.4.4.4 [90/435200] via 13.13.13.3, 00:01:53, Ethernet0/1
[90/435200] via 12.12.12.2, 00:01:53, Ethernet0/0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.1/32 is directly connected, Ethernet0/0
13.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 13.13.13.0/24 is directly connected, Ethernet0/1
L 13.13.13.1/32 is directly connected, Ethernet0/1
24.0.0.0/24 is subnetted, 1 subnets
D 24.24.24.0 [90/307200] via 12.12.12.2, 00:01:53, Ethernet0/0
34.0.0.0/24 is subnetted, 1 subnets
D 34.34.34.0 [90/307200] via 13.13.13.3, 00:01:54, Ethernet0/1

Bisa kita lihat rute network 4.4.4.4/32 memiliki dua jalur yang dapat digunakan dua duanya secara load balance, untuk membuktikan jalur load balance, lakukan traceroute dari R1 ke R4.

R1#traceroute 4.4.4.4 source lo0
Type escape sequence to abort.
Tracing the route to 4.4.4.4
VRF info: (vrf in name/id, vrf out name/id)
1 12.12.12.2 0 msec
13.13.13.3 1 msec
12.12.12.2 0 msec
2 34.34.34.4 0 msec
24.24.24.4 1 msec
34.34.34.4 1 msec

Cara memindah jalur di EIGRP

Routing protocol seperti EIGRP akan secara dinamis menentukan jalur untuk menuju suatu tujuan Network berdasarkan nilai metric yang ada, kita juga bisa mengubah jalur yang ditentukan oleh EIGRP sesuai selera kita, ada beberapa parameter untuk melakukan pemindahan jalur dari biasanya pada EIGRP :

  • Bandwidth
  • Delay
  • Offset-list
Semua parameter diatas sudah ada pengaturan defaultnya pada masing-masing interface Router, kita dapat memanipuliasinya untuk mengubah jalur default yang sudah ditentukan oleh EIGRP sebelumnya. Kita akan coba praktekan pada topologi ini :

Ketika R1 Ingin mencapai IP Loopback R3 secara default melewati link yang terhubung dengan interface e0/0 karena merupakan link jalur terdekat, kita akan memanipulasi paremeter yang ada di e0/0 agar jalur berpindah ke e0/1.

IP Addressing

Konfigurasi IP Address dan interface loopback pada Router.

    R1

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int e0/0
    R1(config-if)#ip add 13.13.13.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int e0/1
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi

    R2

    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#ex
    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi

    R3

    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#int e0/0
    R3(config-if)#ip add 13.13.13.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#ex
    R3(config)#int e0/1
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi

Routing EIGRP

Kemudian konfigurasi dasar EIGRP pada seluruh Router.

    R1

    R1(config)#router eigrp 1
    R1(config-router)#no auto-sum
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#net 13.13.13.0 0.0.0.255
    R1(config-router)#exi

    R2

    R2(config)#router eigrp 1
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#exi

    R3

    R3(config)#router eigrp 1
    R3(config-router)#no auto-summ
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#net 13.13.13.0 0.0.0.255
    R3(config-router)#exi

    Kemudian lakukan traceroute ke interface loopback R3 dari R1.

    R1#traceroute 3.3.3.3 source lo0
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3
    VRF info: (vrf in name/id, vrf out name/id)
    1 13.13.13.3 0 msec 1 msec 0 msec

    Dan ini masih secara default melewati e0/0, dan kita akan mengubahnya.

Mindah jalur (Bandwidth)

Parameter ini menjadi salah satu penentuan jalur yang akan digunakan oleh EIGRP, makin besar nilai bandwitdh pada sebuah interface maka akan semakin diprioritaskan untuk menjadi jalur utama yang dipilih EIGRP dan sebaliknya jika makin kecil maka tidak akan dipilih sebagai jalur utama, nilai bandwitdh secara default sesuai dengan bandwitdh interface fisik tersebut. kita lihat nilai bandwitdh pada interface e0/0 :

    R1#sh interfaces ethernet 0/0
    Ethernet0/0 is up, line protocol is up
    Hardware is AmdP2, address is aabb.cc00.0100 (bia aabb.cc00.0100)
    Internet address is 13.13.13.1/24
    MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set

    Nilai bandwitdh e0/0 adalah 10000 atau 10 Mbps karena masih menggunakan teknologi ethernet. Kemudian kita lihat nilai bandwitdh pada e0/1 :

    R1#sh interfaces ethernet 0/1
    Ethernet0/1 is up, line protocol is up
    Hardware is AmdP2, address is aabb.cc00.0110 (bia aabb.cc00.0110)
    Internet address is 12.12.12.1/24
    MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set

    Ternyata kedua interface tersebut memiliki nilai bandwitdh yang sama, kita akan memanipuliasi nilai bandwitdh di e0/1 akan kita besarkan nilainya dari e0/0.

    R1(config)#int e0/1
    R1(config-if)#bandwidth 100000
    R1(config-if)#exi
    R1(config)#int e0/0
    R1(config-if)#bandwidth 1000
    R1(config-if)#exi

    Kemudian kita lihat perubahannya pada kedua Interface tersebut, dengan melakukan traceroute

    R1(config-if)#do traceroute 3.3.3.3 
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3
    VRF info: (vrf in name/id, vrf out name/id)
    1 12.12.12.2 0 msec 1 msec 0 msec
    2 23.23.23.3 0 msec 1 msec 0 msec

    Dan terlihat jalur sudah berubah.

Mindah jalur (Delay)

Parameter ini sama seperti bandwidth yang menjadi penentu jalur yang akan dipilih EIGRP, nilai delay pada tiap Interface berdasarkan lamanya jeda waktu yang dibutuhkan interface untuk merespon lalu lintas, kita dapat mengubah atau memanipulasi nilai delay, semakin kecil nilai delay semakin bagus, dan semakin besar nilai delay akan semakin jelek.

    Pertama kembalikan nilai bandwitdh pada kedua interface tersebut.

    R1(config)#int e0/0
    R1(config-if)#no band 1000
    R1(config-if)#exi
    R1(config)#int e0/1
    R1(config-if)#no band 100000
    R1(config-if)#exi

    Dan lakukan tracereote, pastikan jalurnya kembali ke default.

    R1#traceroute 3.3.3.3
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3
    VRF info: (vrf in name/id, vrf out name/id)
    1 13.13.13.3 1 msec 0 msec 1 msec

    Kemudian kita lihat nilai delay pada Interface e0/0 dan e0/1.

    R1#sh int e0/0
    Ethernet0/0 is up, line protocol is up
    Hardware is AmdP2, address is aabb.cc00.0100 (bia aabb.cc00.0100)
    Internet address is 13.13.13.1/24
    MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    ---------------------
    R1#sh int e0/1
    Ethernet0/1 is up, line protocol is up
    Hardware is AmdP2, address is aabb.cc00.0110 (bia aabb.cc00.0110)
    Internet address is 12.12.12.1/24
    MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255

    Agar jalur berpindah ke e0/1 kita besarkan nilai delay pada e0/0 dan kecilkan nilai delay e0/1

    R1(config)#int e0/0
    R1(config-if)#delay 10000
    R1(config-if)#exi
    R1(config)#int e0/1
    R1(config-if)#delay 100
    R1(config-if)#exi

    Lalu lakukan traceroute dan pastikan jalurnya sudah berpindah ke Interface e0/1

    R1#traceroute 3.3.3.3
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3
    VRF info: (vrf in name/id, vrf out name/id)
    1 12.12.12.2 0 msec 1 msec 0 msec
    2 23.23.23.3 0 msec 0 msec 0 msec

Mindah jalur (Offset List)

Paramter ini digunakan untuk mengubah nilai delay untuk daftar network-network tertentu yang masuk atau keluar melalui suatu interface, semakin besar nilai offset maka akan semakin jelek, dan semakin kecil akan semakin bagus. Kita bisa menggunakan access-list untuk menentukan daftar network yang akan diubah nilai offsetnya, kali ini saya gunakan access-list 0 yang artinya berlaku untuk semuanya.

    Pertama kembalikan nilai default delay sebelumnya.

    R1(config)#int e0/0
    R1(config-if)#no delay 10000
    R1(config-if)#exi
    R1(config)#int e0/1
    R1(config-if)#no delay 100
    R1(config-if)#exi

    Kemudian kita atur nilai offset di e0/0 lebih besar dari interface e0/1 agar jalur di e0/1 lebih dipilih.

    R1(config)#router eigrp 1
    R1(config-router)#offset-list 0 in 200000 e0/0
    R1(config-router)#offset-list 0 in 100 e0/1

    Kita lakukan testing tracereoute dan pastikan jalur sudah berpindah ke e0/1

    R1#traceroute 3.3.3.3
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3
    VRF info: (vrf in name/id, vrf out name/id)
    1 12.12.12.2 0 msec 1 msec 0 msec
    2 23.23.23.3 1 msec 1 msec 0 msec

Cara memindah jalur di EIGRP

Routing protocol seperti EIGRP akan secara dinamis menentukan jalur untuk menuju suatu tujuan Network berdasarkan nilai metric yang ada, kita juga bisa mengubah jalur yang ditentukan oleh EIGRP sesuai selera kita, ada beberapa parameter untuk melakukan pemindahan jalur dari biasanya pada EIGRP :

  • Bandwidth
  • Delay
  • Offset-list
Semua parameter diatas sudah ada pengaturan defaultnya pada masing-masing interface Router, kita dapat memanipuliasinya untuk mengubah jalur default yang sudah ditentukan oleh EIGRP sebelumnya. Kita akan coba praktekan pada topologi ini :

Ketika R1 Ingin mencapai IP Loopback R3 secara default melewati link yang terhubung dengan interface e0/0 karena merupakan link jalur terdekat, kita akan memanipulasi paremeter yang ada di e0/0 agar jalur berpindah ke e0/1.

IP Addressing

Konfigurasi IP Address dan interface loopback pada Router.

    R1

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int e0/0
    R1(config-if)#ip add 13.13.13.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int e0/1
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi

    R2

    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#ex
    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi

    R3

    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#int e0/0
    R3(config-if)#ip add 13.13.13.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#ex
    R3(config)#int e0/1
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi

Routing EIGRP

Kemudian konfigurasi dasar EIGRP pada seluruh Router.

    R1

    R1(config)#router eigrp 1
    R1(config-router)#no auto-sum
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#net 13.13.13.0 0.0.0.255
    R1(config-router)#exi

    R2

    R2(config)#router eigrp 1
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#exi

    R3

    R3(config)#router eigrp 1
    R3(config-router)#no auto-summ
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#net 13.13.13.0 0.0.0.255
    R3(config-router)#exi

    Kemudian lakukan traceroute ke interface loopback R3 dari R1.

    R1#traceroute 3.3.3.3 source lo0
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3
    VRF info: (vrf in name/id, vrf out name/id)
    1 13.13.13.3 0 msec 1 msec 0 msec

    Dan ini masih secara default melewati e0/0, dan kita akan mengubahnya.

Mindah jalur (Bandwidth)

Parameter ini menjadi salah satu penentuan jalur yang akan digunakan oleh EIGRP, makin besar nilai bandwitdh pada sebuah interface maka akan semakin diprioritaskan untuk menjadi jalur utama yang dipilih EIGRP dan sebaliknya jika makin kecil maka tidak akan dipilih sebagai jalur utama, nilai bandwitdh secara default sesuai dengan bandwitdh interface fisik tersebut. kita lihat nilai bandwitdh pada interface e0/0 :

    R1#sh interfaces ethernet 0/0
    Ethernet0/0 is up, line protocol is up
    Hardware is AmdP2, address is aabb.cc00.0100 (bia aabb.cc00.0100)
    Internet address is 13.13.13.1/24
    MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set

    Nilai bandwitdh e0/0 adalah 10000 atau 10 Mbps karena masih menggunakan teknologi ethernet. Kemudian kita lihat nilai bandwitdh pada e0/1 :

    R1#sh interfaces ethernet 0/1
    Ethernet0/1 is up, line protocol is up
    Hardware is AmdP2, address is aabb.cc00.0110 (bia aabb.cc00.0110)
    Internet address is 12.12.12.1/24
    MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set

    Ternyata kedua interface tersebut memiliki nilai bandwitdh yang sama, kita akan memanipuliasi nilai bandwitdh di e0/1 akan kita besarkan nilainya dari e0/0.

    R1(config)#int e0/1
    R1(config-if)#bandwidth 100000
    R1(config-if)#exi
    R1(config)#int e0/0
    R1(config-if)#bandwidth 1000
    R1(config-if)#exi

    Kemudian kita lihat perubahannya pada kedua Interface tersebut, dengan melakukan traceroute

    R1(config-if)#do traceroute 3.3.3.3 
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3
    VRF info: (vrf in name/id, vrf out name/id)
    1 12.12.12.2 0 msec 1 msec 0 msec
    2 23.23.23.3 0 msec 1 msec 0 msec

    Dan terlihat jalur sudah berubah.

Mindah jalur (Delay)

Parameter ini sama seperti bandwidth yang menjadi penentu jalur yang akan dipilih EIGRP, nilai delay pada tiap Interface berdasarkan lamanya jeda waktu yang dibutuhkan interface untuk merespon lalu lintas, kita dapat mengubah atau memanipulasi nilai delay, semakin kecil nilai delay semakin bagus, dan semakin besar nilai delay akan semakin jelek.

    Pertama kembalikan nilai bandwitdh pada kedua interface tersebut.

    R1(config)#int e0/0
    R1(config-if)#no band 1000
    R1(config-if)#exi
    R1(config)#int e0/1
    R1(config-if)#no band 100000
    R1(config-if)#exi

    Dan lakukan tracereote, pastikan jalurnya kembali ke default.

    R1#traceroute 3.3.3.3
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3
    VRF info: (vrf in name/id, vrf out name/id)
    1 13.13.13.3 1 msec 0 msec 1 msec

    Kemudian kita lihat nilai delay pada Interface e0/0 dan e0/1.

    R1#sh int e0/0
    Ethernet0/0 is up, line protocol is up
    Hardware is AmdP2, address is aabb.cc00.0100 (bia aabb.cc00.0100)
    Internet address is 13.13.13.1/24
    MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    ---------------------
    R1#sh int e0/1
    Ethernet0/1 is up, line protocol is up
    Hardware is AmdP2, address is aabb.cc00.0110 (bia aabb.cc00.0110)
    Internet address is 12.12.12.1/24
    MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255

    Agar jalur berpindah ke e0/1 kita besarkan nilai delay pada e0/0 dan kecilkan nilai delay e0/1

    R1(config)#int e0/0
    R1(config-if)#delay 10000
    R1(config-if)#exi
    R1(config)#int e0/1
    R1(config-if)#delay 100
    R1(config-if)#exi

    Lalu lakukan traceroute dan pastikan jalurnya sudah berpindah ke Interface e0/1

    R1#traceroute 3.3.3.3
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3
    VRF info: (vrf in name/id, vrf out name/id)
    1 12.12.12.2 0 msec 1 msec 0 msec
    2 23.23.23.3 0 msec 0 msec 0 msec

Mindah jalur (Offset List)

Paramter ini digunakan untuk mengubah nilai delay untuk daftar network-network tertentu yang masuk atau keluar melalui suatu interface, semakin besar nilai offset maka akan semakin jelek, dan semakin kecil akan semakin bagus. Kita bisa menggunakan access-list untuk menentukan daftar network yang akan diubah nilai offsetnya, kali ini saya gunakan access-list 0 yang artinya berlaku untuk semuanya.

    Pertama kembalikan nilai default delay sebelumnya.

    R1(config)#int e0/0
    R1(config-if)#no delay 10000
    R1(config-if)#exi
    R1(config)#int e0/1
    R1(config-if)#no delay 100
    R1(config-if)#exi

    Kemudian kita atur nilai offset di e0/0 lebih besar dari interface e0/1 agar jalur di e0/1 lebih dipilih.

    R1(config)#router eigrp 1
    R1(config-router)#offset-list 0 in 200000 e0/0
    R1(config-router)#offset-list 0 in 100 e0/1

    Kita lakukan testing tracereoute dan pastikan jalur sudah berpindah ke e0/1

    R1#traceroute 3.3.3.3
    Type escape sequence to abort.
    Tracing the route to 3.3.3.3
    VRF info: (vrf in name/id, vrf out name/id)
    1 12.12.12.2 0 msec 1 msec 0 msec
    2 23.23.23.3 1 msec 1 msec 0 msec

Menghubungkan EIGRP dengan Routing Protocol lain (Redistribution)

Ketika kita membuat sebuah jaringan yang menggunakan Routing protocol berbeda beda seperti EIGRP dengan OSPF ataupun dengan RIP secara default antar mereka tidak dapat saling terhubung, agar dapat saling terhubung kita perlu mengkonfigurasi Redistribution pada jaringan tersebut. Cara kerja dari Redistribution ini sama seperti namanya, yaitu informasi yang didapatkan dari suatu protocol seperti OSPF didistribusikan kembali dalam bentuk protocol yang berbeda seperti EIGRP.

Untuk melakukan konfigurasi Redistribution kita harus menentukan Router yang akan menjadi perantara antara satu Routing protocol dengan yang lainnya, dalam OSPF disebut dengan ASBR, Router ini yang menjalankan dua atau lebih Routing protocol sekaligus, misalkan menjalankan EIGRP dan juga OSPF atau RIP, di Router inilah yang akan melakukan redistribution.
Karena perhitungan metric OSPF dan RIP dengan EIGRP berbeda maka kita perlu menentukan metric EIGRP secara manual ketika melakukan konfigurasi Redistribution, metric EIGRP itu ada 5 macam yaitu :
  • Bandwidth (nilai dari 1 s/d 4294967295)
  • Delay (nilai dari 0 s/d 4294967295)
  • Reliablility (nilai dai 0 s/d 255)
  • Effective bandwitdh (nilai dari 1 s/d 255)
  • MTU (nilai dari 1 s/d 65535)
Nilai metric kita bebas menentukannya, tidak berpengaruh pada hasil di Routing table hanya berbeda nilai metricnya saja, berikut ini adalah topologi yang akan kita praktekan :
Di R2 dan R3 akan kita konfigurasi redistribution karena selain menjalankan EIGRP juga menjalankan OSPF dan juga RIP.

IP Addressing

Konfigurasi IP Address tiap interface fisik Router dan juga interface loopback.

    R1

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi

    R2

    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi
    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi

    R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#int lo1
    R3(config-if)#ip add 10.10.10.1 255.255.255.255
    R3(config-if)#exi
    R3(config)#int lo2
    R3(config-if)#ip add 10.10.10.2 255.255.255.255
    R3(config-if)#exi
    R3(config)#int lo3
    R3(config-if)#ip add 10.10.10.3 255.255.255.255
    R3(config-if)#exi

Routing OSPF

Kita konfigurasi Routing OSPF terlebih dahulu pada Router R1 dan R2.

    R1

    R1(config)#router ospf 1
    R1(config-router)#net 1.1.1.1 0.0.0.0 area 0
    R1(config-router)#net 12.12.12.0 0.0.0.255 area 0
    R1(config-router)#exi

    R2

    R2(config)#router ospf 1
    R2(config-router)#net 12.12.12.0 0.0.0.255 area 0

    Dan ini adalah konfigurasi untuk melakukan redistribute dari EIGRP ke OSPF.

    R2(config-router)#redistribute eigrp 1 subnets   

Routing EIGRP

Kemudian konfigurasi Routing EIGRP pada R2 dan R3, beserta redistribution antara OSPF dan RIP dengan EIGRP.

    R2

    R2(config)#router eigrp 1
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 23.23.23.0 0.0.0.255

    Lalu konfigurasi redistribution OSPF ke EIGRP beserta nilai metric -nya , pernulisan nilai metric nya berurutan, dan nilai bebas kali ini saya set semua nilai metricnya menjadi 1.

    R2(config-router)#redistribute ospf 1 metric ?
    <1-4294967295> Bandwidth metric in Kbits per second

    R2(config-router)#redistribute ospf 1 metric 1 ?
    <0-4294967295> EIGRP delay metric, in 10 microsecond units

    R2(config-router)#redistribute ospf 1 metric 1 1 ?
    <0-255> EIGRP reliability metric where 255 is 100% reliable

    R2(config-router)#redistribute ospf 1 metric 1 1 1 ?
    <1-255> EIGRP Effective bandwidth metric (Loading) where 255 is 100% loaded

    R2(config-router)#redistribute ospf 1 metric 1 1 1 1 ?
    <1-65535> EIGRP MTU of the path

    R2(config-router)#redistribute ospf 1 metric 1 1 1 1 1

    R3

    R3(config)#router eigrp 1
    R3(config-router)#router-id 3.3.3.3
    R3(config-router)#no auto-sum
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#redistribute rip metric 1 1 1 1 1
    R3(config-router)#exi

    Konfigurasi RIP.

    R3(config)#router rip
    R3(config-router)#ver 2
    R3(config-router)#no auto-summ
    R3(config-router)#net 10.10.10.0
    R3(config-router)#exi

Kemudian kita lihat hasilnya pada Routing table salah satu Router.

R2(config)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/11] via 12.12.12.1, 00:06:50, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 23.23.23.3, 00:02:03, Ethernet0/1
10.0.0.0/32 is subnetted, 3 subnets
D EX 10.10.10.1 [170/2560025856] via 23.23.23.3, 00:00:40, Ethernet0/1
D EX 10.10.10.2 [170/2560025856] via 23.23.23.3, 00:00:40, Ethernet0/1
D EX 10.10.10.3 [170/2560025856] via 23.23.23.3, 00:00:40, Ethernet0/1

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.2/32 is directly connected, Ethernet0/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, Ethernet0/1
L 23.23.23.2/32 is directly connected, Ethernet0/1

Terlihat bahwa antar Routing protocol dapat saling terhubung dengan redistribution, yang ada tanda EX itu artinya informasi yang berasal dari hasil redistribute.

Menghubungkan EIGRP dengan Routing Protocol lain (Redistribution)

Ketika kita membuat sebuah jaringan yang menggunakan Routing protocol berbeda beda seperti EIGRP dengan OSPF ataupun dengan RIP secara default antar mereka tidak dapat saling terhubung, agar dapat saling terhubung kita perlu mengkonfigurasi Redistribution pada jaringan tersebut. Cara kerja dari Redistribution ini sama seperti namanya, yaitu informasi yang didapatkan dari suatu protocol seperti OSPF didistribusikan kembali dalam bentuk protocol yang berbeda seperti EIGRP.

Untuk melakukan konfigurasi Redistribution kita harus menentukan Router yang akan menjadi perantara antara satu Routing protocol dengan yang lainnya, dalam OSPF disebut dengan ASBR, Router ini yang menjalankan dua atau lebih Routing protocol sekaligus, misalkan menjalankan EIGRP dan juga OSPF atau RIP, di Router inilah yang akan melakukan redistribution.
Karena perhitungan metric OSPF dan RIP dengan EIGRP berbeda maka kita perlu menentukan metric EIGRP secara manual ketika melakukan konfigurasi Redistribution, metric EIGRP itu ada 5 macam yaitu :
  • Bandwidth (nilai dari 1 s/d 4294967295)
  • Delay (nilai dari 0 s/d 4294967295)
  • Reliablility (nilai dai 0 s/d 255)
  • Effective bandwitdh (nilai dari 1 s/d 255)
  • MTU (nilai dari 1 s/d 65535)
Nilai metric kita bebas menentukannya, tidak berpengaruh pada hasil di Routing table hanya berbeda nilai metricnya saja, berikut ini adalah topologi yang akan kita praktekan :
Di R2 dan R3 akan kita konfigurasi redistribution karena selain menjalankan EIGRP juga menjalankan OSPF dan juga RIP.

IP Addressing

Konfigurasi IP Address tiap interface fisik Router dan juga interface loopback.

    R1

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi

    R2

    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi
    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi

    R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#int lo1
    R3(config-if)#ip add 10.10.10.1 255.255.255.255
    R3(config-if)#exi
    R3(config)#int lo2
    R3(config-if)#ip add 10.10.10.2 255.255.255.255
    R3(config-if)#exi
    R3(config)#int lo3
    R3(config-if)#ip add 10.10.10.3 255.255.255.255
    R3(config-if)#exi

Routing OSPF

Kita konfigurasi Routing OSPF terlebih dahulu pada Router R1 dan R2.

    R1

    R1(config)#router ospf 1
    R1(config-router)#net 1.1.1.1 0.0.0.0 area 0
    R1(config-router)#net 12.12.12.0 0.0.0.255 area 0
    R1(config-router)#exi

    R2

    R2(config)#router ospf 1
    R2(config-router)#net 12.12.12.0 0.0.0.255 area 0

    Dan ini adalah konfigurasi untuk melakukan redistribute dari EIGRP ke OSPF.

    R2(config-router)#redistribute eigrp 1 subnets   

Routing EIGRP

Kemudian konfigurasi Routing EIGRP pada R2 dan R3, beserta redistribution antara OSPF dan RIP dengan EIGRP.

    R2

    R2(config)#router eigrp 1
    R2(config-router)#no auto-summ
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 23.23.23.0 0.0.0.255

    Lalu konfigurasi redistribution OSPF ke EIGRP beserta nilai metric -nya , pernulisan nilai metric nya berurutan, dan nilai bebas kali ini saya set semua nilai metricnya menjadi 1.

    R2(config-router)#redistribute ospf 1 metric ?
    <1-4294967295> Bandwidth metric in Kbits per second

    R2(config-router)#redistribute ospf 1 metric 1 ?
    <0-4294967295> EIGRP delay metric, in 10 microsecond units

    R2(config-router)#redistribute ospf 1 metric 1 1 ?
    <0-255> EIGRP reliability metric where 255 is 100% reliable

    R2(config-router)#redistribute ospf 1 metric 1 1 1 ?
    <1-255> EIGRP Effective bandwidth metric (Loading) where 255 is 100% loaded

    R2(config-router)#redistribute ospf 1 metric 1 1 1 1 ?
    <1-65535> EIGRP MTU of the path

    R2(config-router)#redistribute ospf 1 metric 1 1 1 1 1

    R3

    R3(config)#router eigrp 1
    R3(config-router)#router-id 3.3.3.3
    R3(config-router)#no auto-sum
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#redistribute rip metric 1 1 1 1 1
    R3(config-router)#exi

    Konfigurasi RIP.

    R3(config)#router rip
    R3(config-router)#ver 2
    R3(config-router)#no auto-summ
    R3(config-router)#net 10.10.10.0
    R3(config-router)#exi

Kemudian kita lihat hasilnya pada Routing table salah satu Router.

R2(config)#do sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
O 1.1.1.1 [110/11] via 12.12.12.1, 00:06:50, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 23.23.23.3, 00:02:03, Ethernet0/1
10.0.0.0/32 is subnetted, 3 subnets
D EX 10.10.10.1 [170/2560025856] via 23.23.23.3, 00:00:40, Ethernet0/1
D EX 10.10.10.2 [170/2560025856] via 23.23.23.3, 00:00:40, Ethernet0/1
D EX 10.10.10.3 [170/2560025856] via 23.23.23.3, 00:00:40, Ethernet0/1

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.2/32 is directly connected, Ethernet0/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, Ethernet0/1
L 23.23.23.2/32 is directly connected, Ethernet0/1

Terlihat bahwa antar Routing protocol dapat saling terhubung dengan redistribution, yang ada tanda EX itu artinya informasi yang berasal dari hasil redistribute.