Lab 117 – Network Monitoring System (PRTG)

Pada lab sebelumnya kita telah belajar NMS menggunakan WhatsUp Gold. Selanjutnya pada lab ini kita akan belajar NMS menggunakan PRTG. Bedanya apa sih? silahkan disimpulkan sendiri setelah belajar lab ini ya.. :D.
Adapun jaringan yang akan kita monitoring pada lab ini sama dengan jaringan yang kita buat pada lab NMS WhatsUp Gold. Silahkan merujuk pada lab tersebut untuk setup jaringannya. Berikut topologi yang akan kita gunakan
Gambar 1 Topologi jaringan
Diasumsikan jaringan sudah tersetup dengan baik dan windows sudah bisa melakukan ping ke R1, R2, dan R3. 
Lanjut kita install PRTG nya. Silahkan download disini. Untuk cara installnya tinggal next next saja. Berikut tampilan awal PRTG
Gambar 2 Tampilan awal PRTG
Sebelum melanjutkan konfigurasi PRTG, kita harus mengaktifkan SNMP pada ketiga router terlebih dahulu
Gambar 3 Aktifkan SNMP Server R1
Gambar 4 Aktifkan SNMP Server R2
Gambar 5 Aktifkan SNMP Server R3
Oke sekarang kita konfigurasi di PRTG.
Gambar 6 Konfigurasi PRTG
Gambar 7 Konfigurasi PRTG
Gambar 8 Konrigurasi PRTG
Gambar 9 Konfigurasi PRTG
Gambar 10 Konfigurasi PRTG
Selanjutnya PRTG akan melakukan discovery SNMP terhadap device yang kita konfigurasikan. Dalam hal ini adalah R1. Jika discovery berhasil, maka kita akan diminta untuk memilih interface yang ingin kita monitoring seperti berikut. Kita centang pada interface yang aktif saja
Gambar 11 Konfigurasi PRTG
Gambar 12 Konfigurasi PRTG
Berikut tampilan setelah kita selesai memasukkan R1 ke PRTG
Gambar 13 Hasil setup PRTG
Lakukan hal yang sama seperti diatas untuk memasukkan R2 dan R3. Untuk menambahkan device, kita bisa menekan tombol add berikut
Gambar 14 Setup device baru
Berikut tampilan setelah kita selesai setup R1, R2, dan R3
Gambar 15 Hasil setup R1,R2, dan R3
Oke.. untuk pengujian, kita coba lakukan test ping dari windows ke R3 dengan parameter -l 100 yang artinya paket yang kita kirim 1000 byte.
Gambar 16 Ping dari windows ke R3
Kita coba lihat di PRTG nya,
Gambar 17 Tampilan trafic PRTG
Perhatikan bahwa saat ini PRTG sudah berhasil menangkap trafiknya.
Oke jadi gimana? bisa kan menarik kesimpulan perbedaan antara WhatsUp Golde dengan PRTG? oke oke selamat belajar dan jangan lupa berbagi ya..

Lab 117 – Network Monitoring System (PRTG)

Pada lab sebelumnya kita telah belajar NMS menggunakan WhatsUp Gold. Selanjutnya pada lab ini kita akan belajar NMS menggunakan PRTG. Bedanya apa sih? silahkan disimpulkan sendiri setelah belajar lab ini ya.. :D.
Adapun jaringan yang akan kita monitoring pada lab ini sama dengan jaringan yang kita buat pada lab NMS WhatsUp Gold. Silahkan merujuk pada lab tersebut untuk setup jaringannya. Berikut topologi yang akan kita gunakan
Gambar 1 Topologi jaringan
Diasumsikan jaringan sudah tersetup dengan baik dan windows sudah bisa melakukan ping ke R1, R2, dan R3. 
Lanjut kita install PRTG nya. Silahkan download disini. Untuk cara installnya tinggal next next saja. Berikut tampilan awal PRTG
Gambar 2 Tampilan awal PRTG
Sebelum melanjutkan konfigurasi PRTG, kita harus mengaktifkan SNMP pada ketiga router terlebih dahulu
Gambar 3 Aktifkan SNMP Server R1
Gambar 4 Aktifkan SNMP Server R2
Gambar 5 Aktifkan SNMP Server R3
Oke sekarang kita konfigurasi di PRTG.
Gambar 6 Konfigurasi PRTG
Gambar 7 Konfigurasi PRTG
Gambar 8 Konrigurasi PRTG
Gambar 9 Konfigurasi PRTG
Gambar 10 Konfigurasi PRTG
Selanjutnya PRTG akan melakukan discovery SNMP terhadap device yang kita konfigurasikan. Dalam hal ini adalah R1. Jika discovery berhasil, maka kita akan diminta untuk memilih interface yang ingin kita monitoring seperti berikut. Kita centang pada interface yang aktif saja
Gambar 11 Konfigurasi PRTG
Gambar 12 Konfigurasi PRTG
Berikut tampilan setelah kita selesai memasukkan R1 ke PRTG
Gambar 13 Hasil setup PRTG
Lakukan hal yang sama seperti diatas untuk memasukkan R2 dan R3. Untuk menambahkan device, kita bisa menekan tombol add berikut
Gambar 14 Setup device baru
Berikut tampilan setelah kita selesai setup R1, R2, dan R3
Gambar 15 Hasil setup R1,R2, dan R3
Oke.. untuk pengujian, kita coba lakukan test ping dari windows ke R3 dengan parameter -l 100 yang artinya paket yang kita kirim 1000 byte.
Gambar 16 Ping dari windows ke R3
Kita coba lihat di PRTG nya,
Gambar 17 Tampilan trafic PRTG
Perhatikan bahwa saat ini PRTG sudah berhasil menangkap trafiknya.
Oke jadi gimana? bisa kan menarik kesimpulan perbedaan antara WhatsUp Golde dengan PRTG? oke oke selamat belajar dan jangan lupa berbagi ya..

Lab 115 – Menyambungkan Windows dengan GNS3

Oke pada lab ini kita akan belajar cara menghubungkan komputer windows kita dengan GNS3. Diasumsikan kita telah menginstall GNS3 dengan baik.

Pertama yang harus kita lakukan adalah membuat loopback adapter pada windows. Masuk run pada windows (windows+r) kemudian ketikkan hdwwiz dan enter hinggga muncul tampilan seperti berikut

Gambar 1 Konfigurasi loopback adapter
Gambar 2 Konfigurasi loopback adapter
Gambar 3 Konfiguras loopback adapter
Gambar 4 Konfigurasi loopback adapter
Gambar 5 Konfigurasi loopback adapter
Gambar 6 Konfigurasi loopback adapter
Gambar 7 Konfigurasi loopback adapter

Oke sampai saat ini kita sudah selesai konfiguras loopback adapter. Selanjutnya kita harus restart komputer kita.

Setelah restart, kita coba buka network and sharing center untuk melihat loopback adapter yang baru saja kita buat terletak pada ethernet berapa,

Gambar 8 Network and sharing center

Perhatikan bahwa loopback adapter yang baru kita buat terletak pada ethernet 2. Selanjutnya kita buka gns3 kemudian masukkan router dan host. Untuk saat ini kita menggunakan router cisco

Gambar 9 GNS3

Pada host, tancapkan kabel ke ethernet loopback yang kita buat sebelumnya. Selanjutnya nyalakan router dan lakukan konfigurasi IP Address

Gambar 10 Konfiguras ip address di cisco

Selanjutnya kita konfigurasikan IP Address di windows

Gambar 11 Konfigurasi IP Address di windows

Sekarang kita coba lakukan ping dari windows ke cisco yang ada di GNS3

Gambar 12 Ping dari windows ke gns3

Oke sampai saat ini kita sudah berhasil menghubungkan windows dengan gns3

Lab 115 – Menyambungkan Windows dengan GNS3

Oke pada lab ini kita akan belajar cara menghubungkan komputer windows kita dengan GNS3. Diasumsikan kita telah menginstall GNS3 dengan baik.

Pertama yang harus kita lakukan adalah membuat loopback adapter pada windows. Masuk run pada windows (windows+r) kemudian ketikkan hdwwiz dan enter hinggga muncul tampilan seperti berikut

Gambar 1 Konfigurasi loopback adapter
Gambar 2 Konfigurasi loopback adapter
Gambar 3 Konfiguras loopback adapter
Gambar 4 Konfigurasi loopback adapter
Gambar 5 Konfigurasi loopback adapter
Gambar 6 Konfigurasi loopback adapter
Gambar 7 Konfigurasi loopback adapter

Oke sampai saat ini kita sudah selesai konfiguras loopback adapter. Selanjutnya kita harus restart komputer kita.

Setelah restart, kita coba buka network and sharing center untuk melihat loopback adapter yang baru saja kita buat terletak pada ethernet berapa,

Gambar 8 Network and sharing center

Perhatikan bahwa loopback adapter yang baru kita buat terletak pada ethernet 2. Selanjutnya kita buka gns3 kemudian masukkan router dan host. Untuk saat ini kita menggunakan router cisco

Gambar 9 GNS3

Pada host, tancapkan kabel ke ethernet loopback yang kita buat sebelumnya. Selanjutnya nyalakan router dan lakukan konfigurasi IP Address

Gambar 10 Konfiguras ip address di cisco

Selanjutnya kita konfigurasikan IP Address di windows

Gambar 11 Konfigurasi IP Address di windows

Sekarang kita coba lakukan ping dari windows ke cisco yang ada di GNS3

Gambar 12 Ping dari windows ke gns3

Oke sampai saat ini kita sudah berhasil menghubungkan windows dengan gns3

Cara konfigurasi OSPF Plain Text Authentication

Setiap Routing Protokol seperti OSPF pasti memiliki fitur Authentication yang bertujuan untuk keamanan, dengan adanya authentication kita dapat mencegah Router-Router asing yang tidak dikenal berusaha berhubungan dengan Router kita dan mengirimkan informasi Routing yang tidak dikenal yang tidak kita inginkan. Kita dapat menerapkan authentication pada Interface Router, sehingga setiap Router tetangga yang terhubung dengan Interface tersebut dan ingin berkomunikasi dengan OSPF harus melakukan authentication sebelum berkomunikasi.

Authentication menggunakan key atau yang biasa kita sebut dengan password, key antara Router satu dengan Router lainnya harus sama, jika tidak sama maka keduanya tidak dapat saling berkomunikasi. ada dua tipe Authentication pada OSPF yaitu :

  • Plain Text Authentication
  • MD5
Kali ini saya akan membahas authentication menggunakan Plain Text. tipe ini adalah authentication paling simpel dan sederhana pada OSPF. Seperti yang sudah saya bilang sebelumnya, untuk menerapkan authentication pada Interface Router, jika pada salah satu interface misalkan G0/0 maka setiap Router yang terhubung dengan interface G0/0 tersebut harus melakukan authentication untuk berkomunikasi menggunakan OSPF, dan kedua Interface Router harus memiliki key atau password yang sama agar dapat terhubung.

Sebelum sampai pada authentication pertama kita berikan alamat IP pada masing-masing Interface Router.


R1 IP Address


R1(config)#int g1/0
R1(config-if)#ip add 10.10.10.1 255.255.255.252
R1(config-if)#no sh
R1(config-if)#exit


R2 IP Address


R2(config)#int g1/0
R2(config-if)#ip add 10.10.10.2 255.255.255.252
R2(config-if)#no sh
R2(config-if)#exit

Setelah IP Address kita lanjut pada OSPF, aktifkan OSPF pada kedua Router.


R1 OSPF


R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.10.10.0 0.0.0.3 area 0
R1(config-router)#exit


R2 OSPF


R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 10.10.10.0 0.0.0.3 area 0
R2(config-router)#exit

OSPF Authentication

Sekarang pada masing-masing interface Router R1 dan R2 yang saling berhubungan kita gunakan authentication, keduanya kita coba menggunakan key atau password “rahasia”. masuk pada mode konfigurasi interface yang ingin menggunakan authentication :


R1 Authentication


R1(config)#int g1/0
R1(config-if)#ip ospf authentication-key rahasia
R1(config-if)#ip ospf authentication
R1(config-if)#exit

Perintah “ip ospf authentication-key” untuk menetukan key atau password untuk memasuki interface tersebut, dan perintah “ip ospf authentication” untuk mengaktifkan authentication pada interface tersebut. setelah interface pada R1 sudah diaktifkan authentication maka akan muncul notifikasi seperti ini :

*Jan  1 16:35:34.431: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on GigabitEthernet1/0 from FULL to DOWN, Neighbor Down: Dead timer expired

Ini terjadi karena R2 tidak melakukan authentication pada R1, sehingga R1 tidak akan menerima setiap pesan yang dikirim oleh R2 sebelum melakukan authentication, oleh karena itu kita lanjut pada R2 :


R2 Authentication


R2(config)#int g1/0
R2(config-if)#ip ospf authentication-key rahasia
R2(config-if)#ip ospf authentication
R2(config-if)#exit

Setelah R2 kita konfigurasi maka akan terlihat status dari kedua Router sudah berkomunikasi dengan munculnya notifikasi ini :

*Jan  1 16:39:45.083: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet1/0 from LOADING to FULL, Loading Done

Untuk konfirmasi kita lihat status interface OSPF pada Router dengan perintah sh ip ospf interface :


R1 Interface


R1#sh ip ospf interface
GigabitEthernet1/0 is up, line protocol is up
Internet Address 10.10.10.1/30, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 2.2.2.2, Interface address 10.10.10.2
Backup Designated router (ID) 1.1.1.1, Interface address 10.10.10.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:01
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2 (Designated Router)
Suppress hello for 0 neighbor(s)
Simple password authentication enabled


R2 Interface


R2#sh ip ospf interface
GigabitEthernet1/0 is up, line protocol is up
Internet Address 10.10.10.2/30, Area 0
Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 2.2.2.2, Interface address 10.10.10.2
Backup Designated router (ID) 1.1.1.1, Interface address 10.10.10.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 1.1.1.1 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
Simple password authentication enabled

Kesimpulan

Dengan kita menerapkan Authentication pada OSPF, informasi Routing yang didapat lebih terpercaya dan lebih aman, dan mencegah para penyerang-penyerang jaringan OSPF untuk masuk.

Cara konfigurasi OSPF Plain Text Authentication

Setiap Routing Protokol seperti OSPF pasti memiliki fitur Authentication yang bertujuan untuk keamanan, dengan adanya authentication kita dapat mencegah Router-Router asing yang tidak dikenal berusaha berhubungan dengan Router kita dan mengirimkan informasi Routing yang tidak dikenal yang tidak kita inginkan. Kita dapat menerapkan authentication pada Interface Router, sehingga setiap Router tetangga yang terhubung dengan Interface tersebut dan ingin berkomunikasi dengan OSPF harus melakukan authentication sebelum berkomunikasi.

Authentication menggunakan key atau yang biasa kita sebut dengan password, key antara Router satu dengan Router lainnya harus sama, jika tidak sama maka keduanya tidak dapat saling berkomunikasi. ada dua tipe Authentication pada OSPF yaitu :

  • Plain Text Authentication
  • MD5
Kali ini saya akan membahas authentication menggunakan Plain Text. tipe ini adalah authentication paling simpel dan sederhana pada OSPF. Seperti yang sudah saya bilang sebelumnya, untuk menerapkan authentication pada Interface Router, jika pada salah satu interface misalkan G0/0 maka setiap Router yang terhubung dengan interface G0/0 tersebut harus melakukan authentication untuk berkomunikasi menggunakan OSPF, dan kedua Interface Router harus memiliki key atau password yang sama agar dapat terhubung.

Sebelum sampai pada authentication pertama kita berikan alamat IP pada masing-masing Interface Router.


R1 IP Address


R1(config)#int g1/0
R1(config-if)#ip add 10.10.10.1 255.255.255.252
R1(config-if)#no sh
R1(config-if)#exit


R2 IP Address


R2(config)#int g1/0
R2(config-if)#ip add 10.10.10.2 255.255.255.252
R2(config-if)#no sh
R2(config-if)#exit

Setelah IP Address kita lanjut pada OSPF, aktifkan OSPF pada kedua Router.


R1 OSPF


R1(config)#router ospf 1
R1(config-router)#router-id 1.1.1.1
R1(config-router)#network 10.10.10.0 0.0.0.3 area 0
R1(config-router)#exit


R2 OSPF


R2(config)#router ospf 1
R2(config-router)#router-id 2.2.2.2
R2(config-router)#network 10.10.10.0 0.0.0.3 area 0
R2(config-router)#exit

OSPF Authentication

Sekarang pada masing-masing interface Router R1 dan R2 yang saling berhubungan kita gunakan authentication, keduanya kita coba menggunakan key atau password “rahasia”. masuk pada mode konfigurasi interface yang ingin menggunakan authentication :


R1 Authentication


R1(config)#int g1/0
R1(config-if)#ip ospf authentication-key rahasia
R1(config-if)#ip ospf authentication
R1(config-if)#exit

Perintah “ip ospf authentication-key” untuk menetukan key atau password untuk memasuki interface tersebut, dan perintah “ip ospf authentication” untuk mengaktifkan authentication pada interface tersebut. setelah interface pada R1 sudah diaktifkan authentication maka akan muncul notifikasi seperti ini :

*Jan  1 16:35:34.431: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on GigabitEthernet1/0 from FULL to DOWN, Neighbor Down: Dead timer expired

Ini terjadi karena R2 tidak melakukan authentication pada R1, sehingga R1 tidak akan menerima setiap pesan yang dikirim oleh R2 sebelum melakukan authentication, oleh karena itu kita lanjut pada R2 :


R2 Authentication


R2(config)#int g1/0
R2(config-if)#ip ospf authentication-key rahasia
R2(config-if)#ip ospf authentication
R2(config-if)#exit

Setelah R2 kita konfigurasi maka akan terlihat status dari kedua Router sudah berkomunikasi dengan munculnya notifikasi ini :

*Jan  1 16:39:45.083: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on GigabitEthernet1/0 from LOADING to FULL, Loading Done

Untuk konfirmasi kita lihat status interface OSPF pada Router dengan perintah sh ip ospf interface :


R1 Interface


R1#sh ip ospf interface
GigabitEthernet1/0 is up, line protocol is up
Internet Address 10.10.10.1/30, Area 0
Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 2.2.2.2, Interface address 10.10.10.2
Backup Designated router (ID) 1.1.1.1, Interface address 10.10.10.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:01
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 2.2.2.2 (Designated Router)
Suppress hello for 0 neighbor(s)
Simple password authentication enabled


R2 Interface


R2#sh ip ospf interface
GigabitEthernet1/0 is up, line protocol is up
Internet Address 10.10.10.2/30, Area 0
Process ID 1, Router ID 2.2.2.2, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 2.2.2.2, Interface address 10.10.10.2
Backup Designated router (ID) 1.1.1.1, Interface address 10.10.10.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:06
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 1.1.1.1 (Backup Designated Router)
Suppress hello for 0 neighbor(s)
Simple password authentication enabled

Kesimpulan

Dengan kita menerapkan Authentication pada OSPF, informasi Routing yang didapat lebih terpercaya dan lebih aman, dan mencegah para penyerang-penyerang jaringan OSPF untuk masuk.

Konfigurasi OSPF over Frame Relay NBMA Network

Jika kita melakukan konfigurasi OSPF pada jaringan Frame Relay maka jaringan tersebut termasuk pada jenis jaringan NBMA pada OSPF. Apa itu NBMA? NBMA kepanjangan dari Non-Broadcast Multi Access adalah salah satu tipe jaringan atau network pada OSPF, sifat dari jaringan seperti ini adalah tidak terdapat broadcast dan dalam satu link atau network terdapat lebih dari dua Router yang saling terhubung dalam satu segmen network yang sama (multi access), jadi setiap Router OSPF akan melakukan koneksi neighboring lebih dari satu, maka pada jaringan NBMA ini Router akan ada yang bertindak sebagai ketua yang disebut dengan Designated Router,  wakil ketua Backup Designated Router.

Pada jaringan NBMA seperti Frame Relay, karena tidak dapat melakukan broadcast maka fitur Neighbor Discovery tidak akan berfungsi pada jaringan ini, sehingga Router-Router tidak dapat menemukan Router OSPF lainnya secara otomatis, jadi pada jaringan NBMA kita perlu melakukan konfigurasi Static Neighbor atau mendaftarkan secara manual Router-Router Neighbor. pada posting kali ini saya akan menunjukan cara konfigurasi OSPF pada jaringan model NBMA seperti Frame Relay, saya menggunakan aplikasi GNS3 berikut ini adalah topologinya :

Semua perangkat Router dan fr-sw adalah cisco, semua Router berada dalam satu segment network yang sama yaitu 10.10.10.0/24,  dan dihubungkan dengan Frame Relay Switch, fr-sw ini adalah Router Cisco yang dijadikan fr-sw. masing-masing Router memiliki DLCI  yaitu :

  1. R1
    • DLCI 102 untuk berhubungan dengan R2
    • DLCI 103 untuk berhubungan dengan R3
  2. R2
    • DLCI 201 untuk berhubungan dengan R1
    • DLCI 203 untuk berhubungan dengan R3
  3. R3
    • DLCI 301 untuk berhubungan dengan R1
    • DLCI 302 untuk berhubungan dengan R2

 berikut ini adalah konfigurasinya :

Pertama kita ubah fr-sw menjadi sebuah Frame Relay Switch, buat PVC untuk menghubungkan antara satu Router dengan Router lainnya.


Konfigurasi Frame Relay Switch


------ Mengaktifkan Frame Relay Switching ---------
fr-sw(config)#frame-relay switching
------ Membuat PVC pada R1 ------------------------
fr-sw(config)#int s4/0
fr-sw(config-if)#encapsulation frame-relay
fr-sw(config-if)#frame-relay intf-type dce
fr-sw(config-if)#clock rate 128000
fr-sw(config-if)#frame-relay route 102 interface s4/1 201
fr-sw(config-if)#frame-relay route 103 interface s4/2 301
fr-sw(config-if)#no sh
fr-sw(config-if)#exit
------ Membuat PVC pada R2 ------------------------
fr-sw(config)#int s4/1
fr-sw(config-if)#encapsulation frame-relay
fr-sw(config-if)#clock rate 128000
fr-sw(config-if)#frame-relay intf-type dce
fr-sw(config-if)#frame-relay route 203 interface s4/2 302
fr-sw(config-if)#frame-relay route 201 interface serial 4/0 102
fr-sw(config-if)#no sh
fr-sw(config-if)#exit
------ Membuat PVC pada R3
fr-sw(config)#int s4/2
fr-sw(config-if)#encapsulation frame-relay
fr-sw(config-if)#clock rate 128000
fr-sw(config-if)#frame-relay intf-type dce
fr-sw(config-if)#frame-relay route 301 interface s4/0 103
fr-sw(config-if)#frame-relay route 302 interface s4/1 203
fr-sw(config-if)#no sh
fr-sw(config-if)#exit

Konfigurasi diatas untuk membuat koneksi PVC antara satu Router dengan Router lainnya sehingga dapat saling berhubungan, setelah selesai frame relay sekarang kita lakukan konfigurasi interface serial pada setiap RouteR.


IP Address R1


R1(config)#int s4/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay interface-dlci 102
R1(config-if)#frame-relay interface-dlci 103
R1(config-if)#ip add 10.10.10.1 255.255.255.0
R1(config-if)#no sh

Lalu atur mode jaringan OSPF Menjadi non-broadcast

R1(config-if)#ip ospf network non-broadcast 


IP Address R2


R2(config)#int s4/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay interface-dlci 201
R2(config-fr-dlci)#frame-relay interface-dlci 203
R2(config-fr-dlci)#ip add 10.10.10.2 255.255.255.0
R2(config-if)#ip ospf network non-broa
R2(config-if)#no sh
R2(config-if)#exi


IP Address R3


R3(config)#int s4/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#frame-relay interface-dlci 301
R3(config-fr-dlci)#frame-relay interface-dlci 302
R3(config-fr-dlci)#ip add 10.10.10.3 255.255.255.0
R3(config-if)#ip ospf network non-broa
R3(config-if)#no sh
R3(config-if)#exit

Setelah alamat IP selesai sekarang cek konektifitas antar Router dengan melakukan PING dari salah satu Router menuju Router lainnya, contohnya dari R1 menuju R2 dan R3 :


Ping


R1#ping 10.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/35/52 ms
R1#ping 10.10.10.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/28/60 ms
R1#

Setelah antar Router sudah dapat saling berkomunikasi sekarang kita lanjut pada konfigurasi OSPF

Konfigurasi OSPF

Sekarang kita konfigurasi OSPF pada jaringan NBMA Frame Relay, masing-masing Router akan diberikan interface loopback sebagai Router-id dan Network yang akan dibagikan lewat OSPF. Untuk komunikasi antar Router kita gunakan metode Static Neighbor karena pada jaringan NBMA tidak dapat melakukan Neighbor Discovery.

Pertama tama kita buat Interface loopback sebagai Router-id si Router :


Loopback R1


R1(config)#int lo0
R1(config-if)#ip add 1.1.1.1 255.255.255.255
R1(config-if)#exit


Loopback R2


R2(config)#int lo0
R2(config-if)#ip add 2.2.2.2 255.255.255.255
R2(config-if)#exit


Loopback R3


R3(config)#int lo0
R3(config-if)#ip add 3.3.3.3 255.255.255.255
R3(config-if)#exit

Setelah loopback sekarang kita daftarkan alamat IP Router Neighbor, dan network pada setiap Router :

Neighbor R1 adalah 10.10.10.2 dan 10.10.10.3, network yang dimiliki adalah 10.10.10.0/24 dan 1.1.1.1/32 :


OSPF R1


R1(config)#router ospf 1
R1(config-router)#neighbor 10.10.10.2
R1(config-router)#neighbor 10.10.10.3
R1(config-router)#network 10.10.10.0 0.0.0.255 area 0
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
R1(config-router)#exit


OSPF R2


R2(config)#router ospf 1
R2(config-router)#neighbor 10.10.10.1
R2(config-router)#neighbor 10.10.10.3
R2(config-router)#network 10.10.10.0 0.0.0.255 area 0
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
R2(config-router)#exit


OSPF R3


R3(config)#router ospf 1
R3(config-router)#neighbor 10.10.10.1
R3(config-router)#neighbor 10.10.10.2
R3(config-router)#network 10.10.10.0 0.0.0.255 area 0
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0
R3(config-router)#exit

Setelah selesai konfigurasi kita tunggu beberapa saat untuk Router memprosesnya karena pada GNS3 di PC saya waktunya cukup lama, jika proses sudah selesai maka akan muncul notifikasi seperti ini :

*Jan  1 14:06:49.826: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial4/0 from LOADING to FULL, Loading Done
*Jan 1 14:10:21.854: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial4/0 from LOADING to FULL, Loading Done

Setelah notifikasi muncul coba lihat neighbor table salah satu Router untuk melihat siapa yang menjadi ketua (DR) ataupun wakil (BDR), jika bukan DR atau BDR maka akan menjadi DROTHER.


Neighbor table R1


R1#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 1 FULL/BDR 00:01:54 10.10.10.2 Serial4/0
3.3.3.3 1 FULL/DROTHER 00:01:56 10.10.10.3 Serial4/0

R2 menjadi Router BDR, yang bertindak sebagai DR adalah R1 sisanya adalah DROTHER (R3).

Kesimpulan

Untuk melakukan konfigurasi OSPF pada NBMA seperti Frame Relay harus menerapkan Static Neighbor karena fitur Neighbor Discovery atau fitur pencarian Router tetangga secara otomatis tidak dapat berjalan pada jaringan NBMA, karena tidak dapat melakukan broadcast sedangkan untuk pencarian Router tetangga diperlukan broadcast untuk melakukannya.

Konfigurasi OSPF over Frame Relay NBMA Network

Jika kita melakukan konfigurasi OSPF pada jaringan Frame Relay maka jaringan tersebut termasuk pada jenis jaringan NBMA pada OSPF. Apa itu NBMA? NBMA kepanjangan dari Non-Broadcast Multi Access adalah salah satu tipe jaringan atau network pada OSPF, sifat dari jaringan seperti ini adalah tidak terdapat broadcast dan dalam satu link atau network terdapat lebih dari dua Router yang saling terhubung dalam satu segmen network yang sama (multi access), jadi setiap Router OSPF akan melakukan koneksi neighboring lebih dari satu, maka pada jaringan NBMA ini Router akan ada yang bertindak sebagai ketua yang disebut dengan Designated Router,  wakil ketua Backup Designated Router.

Pada jaringan NBMA seperti Frame Relay, karena tidak dapat melakukan broadcast maka fitur Neighbor Discovery tidak akan berfungsi pada jaringan ini, sehingga Router-Router tidak dapat menemukan Router OSPF lainnya secara otomatis, jadi pada jaringan NBMA kita perlu melakukan konfigurasi Static Neighbor atau mendaftarkan secara manual Router-Router Neighbor. pada posting kali ini saya akan menunjukan cara konfigurasi OSPF pada jaringan model NBMA seperti Frame Relay, saya menggunakan aplikasi GNS3 berikut ini adalah topologinya :

Semua perangkat Router dan fr-sw adalah cisco, semua Router berada dalam satu segment network yang sama yaitu 10.10.10.0/24,  dan dihubungkan dengan Frame Relay Switch, fr-sw ini adalah Router Cisco yang dijadikan fr-sw. masing-masing Router memiliki DLCI  yaitu :

  1. R1
    • DLCI 102 untuk berhubungan dengan R2
    • DLCI 103 untuk berhubungan dengan R3
  2. R2
    • DLCI 201 untuk berhubungan dengan R1
    • DLCI 203 untuk berhubungan dengan R3
  3. R3
    • DLCI 301 untuk berhubungan dengan R1
    • DLCI 302 untuk berhubungan dengan R2

 berikut ini adalah konfigurasinya :

Pertama kita ubah fr-sw menjadi sebuah Frame Relay Switch, buat PVC untuk menghubungkan antara satu Router dengan Router lainnya.


Konfigurasi Frame Relay Switch


------ Mengaktifkan Frame Relay Switching ---------
fr-sw(config)#frame-relay switching
------ Membuat PVC pada R1 ------------------------
fr-sw(config)#int s4/0
fr-sw(config-if)#encapsulation frame-relay
fr-sw(config-if)#frame-relay intf-type dce
fr-sw(config-if)#clock rate 128000
fr-sw(config-if)#frame-relay route 102 interface s4/1 201
fr-sw(config-if)#frame-relay route 103 interface s4/2 301
fr-sw(config-if)#no sh
fr-sw(config-if)#exit
------ Membuat PVC pada R2 ------------------------
fr-sw(config)#int s4/1
fr-sw(config-if)#encapsulation frame-relay
fr-sw(config-if)#clock rate 128000
fr-sw(config-if)#frame-relay intf-type dce
fr-sw(config-if)#frame-relay route 203 interface s4/2 302
fr-sw(config-if)#frame-relay route 201 interface serial 4/0 102
fr-sw(config-if)#no sh
fr-sw(config-if)#exit
------ Membuat PVC pada R3
fr-sw(config)#int s4/2
fr-sw(config-if)#encapsulation frame-relay
fr-sw(config-if)#clock rate 128000
fr-sw(config-if)#frame-relay intf-type dce
fr-sw(config-if)#frame-relay route 301 interface s4/0 103
fr-sw(config-if)#frame-relay route 302 interface s4/1 203
fr-sw(config-if)#no sh
fr-sw(config-if)#exit

Konfigurasi diatas untuk membuat koneksi PVC antara satu Router dengan Router lainnya sehingga dapat saling berhubungan, setelah selesai frame relay sekarang kita lakukan konfigurasi interface serial pada setiap RouteR.


IP Address R1


R1(config)#int s4/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay interface-dlci 102
R1(config-if)#frame-relay interface-dlci 103
R1(config-if)#ip add 10.10.10.1 255.255.255.0
R1(config-if)#no sh

Lalu atur mode jaringan OSPF Menjadi non-broadcast

R1(config-if)#ip ospf network non-broadcast 


IP Address R2


R2(config)#int s4/0
R2(config-if)#encapsulation frame-relay
R2(config-if)#frame-relay interface-dlci 201
R2(config-fr-dlci)#frame-relay interface-dlci 203
R2(config-fr-dlci)#ip add 10.10.10.2 255.255.255.0
R2(config-if)#ip ospf network non-broa
R2(config-if)#no sh
R2(config-if)#exi


IP Address R3


R3(config)#int s4/0
R3(config-if)#encapsulation frame-relay
R3(config-if)#frame-relay interface-dlci 301
R3(config-fr-dlci)#frame-relay interface-dlci 302
R3(config-fr-dlci)#ip add 10.10.10.3 255.255.255.0
R3(config-if)#ip ospf network non-broa
R3(config-if)#no sh
R3(config-if)#exit

Setelah alamat IP selesai sekarang cek konektifitas antar Router dengan melakukan PING dari salah satu Router menuju Router lainnya, contohnya dari R1 menuju R2 dan R3 :


Ping


R1#ping 10.10.10.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/35/52 ms
R1#ping 10.10.10.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/28/60 ms
R1#

Setelah antar Router sudah dapat saling berkomunikasi sekarang kita lanjut pada konfigurasi OSPF

Konfigurasi OSPF

Sekarang kita konfigurasi OSPF pada jaringan NBMA Frame Relay, masing-masing Router akan diberikan interface loopback sebagai Router-id dan Network yang akan dibagikan lewat OSPF. Untuk komunikasi antar Router kita gunakan metode Static Neighbor karena pada jaringan NBMA tidak dapat melakukan Neighbor Discovery.

Pertama tama kita buat Interface loopback sebagai Router-id si Router :


Loopback R1


R1(config)#int lo0
R1(config-if)#ip add 1.1.1.1 255.255.255.255
R1(config-if)#exit


Loopback R2


R2(config)#int lo0
R2(config-if)#ip add 2.2.2.2 255.255.255.255
R2(config-if)#exit


Loopback R3


R3(config)#int lo0
R3(config-if)#ip add 3.3.3.3 255.255.255.255
R3(config-if)#exit

Setelah loopback sekarang kita daftarkan alamat IP Router Neighbor, dan network pada setiap Router :

Neighbor R1 adalah 10.10.10.2 dan 10.10.10.3, network yang dimiliki adalah 10.10.10.0/24 dan 1.1.1.1/32 :


OSPF R1


R1(config)#router ospf 1
R1(config-router)#neighbor 10.10.10.2
R1(config-router)#neighbor 10.10.10.3
R1(config-router)#network 10.10.10.0 0.0.0.255 area 0
R1(config-router)#network 1.1.1.1 0.0.0.0 area 0
R1(config-router)#exit


OSPF R2


R2(config)#router ospf 1
R2(config-router)#neighbor 10.10.10.1
R2(config-router)#neighbor 10.10.10.3
R2(config-router)#network 10.10.10.0 0.0.0.255 area 0
R2(config-router)#network 2.2.2.2 0.0.0.0 area 0
R2(config-router)#exit


OSPF R3


R3(config)#router ospf 1
R3(config-router)#neighbor 10.10.10.1
R3(config-router)#neighbor 10.10.10.2
R3(config-router)#network 10.10.10.0 0.0.0.255 area 0
R3(config-router)#network 3.3.3.3 0.0.0.0 area 0
R3(config-router)#exit

Setelah selesai konfigurasi kita tunggu beberapa saat untuk Router memprosesnya karena pada GNS3 di PC saya waktunya cukup lama, jika proses sudah selesai maka akan muncul notifikasi seperti ini :

*Jan  1 14:06:49.826: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial4/0 from LOADING to FULL, Loading Done
*Jan 1 14:10:21.854: %OSPF-5-ADJCHG: Process 1, Nbr 3.3.3.3 on Serial4/0 from LOADING to FULL, Loading Done

Setelah notifikasi muncul coba lihat neighbor table salah satu Router untuk melihat siapa yang menjadi ketua (DR) ataupun wakil (BDR), jika bukan DR atau BDR maka akan menjadi DROTHER.


Neighbor table R1


R1#sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
2.2.2.2 1 FULL/BDR 00:01:54 10.10.10.2 Serial4/0
3.3.3.3 1 FULL/DROTHER 00:01:56 10.10.10.3 Serial4/0

R2 menjadi Router BDR, yang bertindak sebagai DR adalah R1 sisanya adalah DROTHER (R3).

Kesimpulan

Untuk melakukan konfigurasi OSPF pada NBMA seperti Frame Relay harus menerapkan Static Neighbor karena fitur Neighbor Discovery atau fitur pencarian Router tetangga secara otomatis tidak dapat berjalan pada jaringan NBMA, karena tidak dapat melakukan broadcast sedangkan untuk pencarian Router tetangga diperlukan broadcast untuk melakukannya.

LAB 9 iBGP Peering (Physical Interface)

Oke guys, lama ngak update nih, kali ini updatetan post langsung ke BGP, loh kok langsung bgp?? gapapa buat pengetahuna  & share ilmu aja, nah kali imi kita pakai Mikrotik untuk Lab  BGPnya untuk BGPnya cisco nanti ada update pada postingan selanjutnya, langsung aja ke labnya nya

1. Tujuan

  • Mempelajari konfigurasi dari proses BGP peering  dalam AS number yang sama  
2. Topology Lab
3. Metode Lab 
  • Buat topologi seperti diatas, kemudian konfigurasikan BGP instance dan BGP Pering, serta mengadvertive network ke BGP
4. Verifikasi Lab 
  • Pastikan status BGP peering establish 
  • Cek routing table dan ping antar IP Loopback yang diadvertise via iBGP
Konfigurasi Pada R1 
==============R1================
[admin@Mikrotik] > system identity IDN-R1

[admin@IDN-R1] > interface bridge add name=lo0
[admin@IDN-R1] routing bgp instance set default as=100
[admin@IDN-R1] ip address
add address=12.12.12.1/24 interface=ether1
add address=1.1.1.1/32 interface=lo0
[admin@IDN-R1] routing bgp network
add network=1.1.1.1/32
[admin@IDN-R1] routing bgp peer
add name=peer1 remote-address=12.12.12.2 remote-as=100
Konfigurasi R2
==============R2================
[admin@Mikrotik] > system identity IDN-R2
[admin@IDN-R2] > interface bridge add name=lo0
[admin@IDN-R2] routing bgp instance set default as=100
[admin@IDN-R1] ip address
add address=12.12.12.2/24 interface=ether1
add address=2.2.2.2/32 interface=lo0 
[admin@IDN-R1] routing bgp network
add network=2.2.2.2/32
[admin@IDN-R1] routing bgp peer
add name=peer1 remote-address=12.12.12.1 remote-as=100
Untuk memghubungkan 2 buah router agar peering. yang kita butuhkan adalah dengan menambah konfigurasi di routing BGP, pada masing-masing router juga harus melakukan peering 
Untuk mengetahu koneksi peer sudah terhubung (establish) atau belum bisa dengan menggunkan perintah 
[admin@IDN-R1] > routing bgp peer print status 
Flags: X – disabled, E – established 
 0 E name=”peer1″ instance=default remote-address=12.12.12.2 remote-as=100 
     tcp-md5-key=”” nexthop-choice=default multihop=no route-reflect=no 
     hold-time=3m ttl=255 in-filter=”” out-filter=”” address-families=ip 
     default-originate=never remove-private-as=no as-override=no passive=no 
     use-bfd=no remote-id=12.12.12.2 local-address=12.12.12.1 uptime=58m59s 
     prefix-count=1 updates-sent=1 updates-received=1 withdrawn-sent=0 
     withdrawn-received=0 remote-hold-time=3m used-hold-time=3m 
     used-keepalive-time=1m refresh-capability=yes as4-capability=yes 
     state=established 

status diatas menandakan koneksi bgp sudah berhasil dengan status (“state=establish) dengan lama waktu terhubung (hold time) 3 menit. Parameter count adalah jumlah prefix yang diterima dari pasangan  router bgp peernya, 
nah untuk melihat apakah network loopback yang tadi kita advertise ke bgp sudah ada atau belum pada router lawannya maka bisa kita check pada routing tablenya.
[admin@IDN-R1] > ip route print 
Flags: X – disabled, A – active, D – dynamic, 
C – connect, S – static, r – rip, b – bgp, o – ospf, m – mme, 
B – blackhole, U – unreachable, P – prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADC  1.1.1.1/32             1.1.1.1                lo0                          0
 1 ADb  2.2.2.2/32              12.12.12.2                                         200
 2 ADC  12.12.12.0/24        12.12.12.1         ether1                      0
oke untuk update ini sekian dulu aja, tunggu update update selanjutnya
Thank You

LAB 9 iBGP Peering (Physical Interface)

Oke guys, lama ngak update nih, kali ini updatetan post langsung ke BGP, loh kok langsung bgp?? gapapa buat pengetahuna  & share ilmu aja, nah kali imi kita pakai Mikrotik untuk Lab  BGPnya untuk BGPnya cisco nanti ada update pada postingan selanjutnya, langsung aja ke labnya nya

1. Tujuan

  • Mempelajari konfigurasi dari proses BGP peering  dalam AS number yang sama  
2. Topology Lab
3. Metode Lab 
  • Buat topologi seperti diatas, kemudian konfigurasikan BGP instance dan BGP Pering, serta mengadvertive network ke BGP
4. Verifikasi Lab 
  • Pastikan status BGP peering establish 
  • Cek routing table dan ping antar IP Loopback yang diadvertise via iBGP
Konfigurasi Pada R1 
==============R1================
[admin@Mikrotik] > system identity IDN-R1

[admin@IDN-R1] > interface bridge add name=lo0
[admin@IDN-R1] routing bgp instance set default as=100
[admin@IDN-R1] ip address
add address=12.12.12.1/24 interface=ether1
add address=1.1.1.1/32 interface=lo0
[admin@IDN-R1] routing bgp network
add network=1.1.1.1/32
[admin@IDN-R1] routing bgp peer
add name=peer1 remote-address=12.12.12.2 remote-as=100
Konfigurasi R2
==============R2================
[admin@Mikrotik] > system identity IDN-R2
[admin@IDN-R2] > interface bridge add name=lo0
[admin@IDN-R2] routing bgp instance set default as=100
[admin@IDN-R1] ip address
add address=12.12.12.2/24 interface=ether1
add address=2.2.2.2/32 interface=lo0 
[admin@IDN-R1] routing bgp network
add network=2.2.2.2/32
[admin@IDN-R1] routing bgp peer
add name=peer1 remote-address=12.12.12.1 remote-as=100
Untuk memghubungkan 2 buah router agar peering. yang kita butuhkan adalah dengan menambah konfigurasi di routing BGP, pada masing-masing router juga harus melakukan peering 
Untuk mengetahu koneksi peer sudah terhubung (establish) atau belum bisa dengan menggunkan perintah 
[admin@IDN-R1] > routing bgp peer print status 
Flags: X – disabled, E – established 
 0 E name=”peer1″ instance=default remote-address=12.12.12.2 remote-as=100 
     tcp-md5-key=”” nexthop-choice=default multihop=no route-reflect=no 
     hold-time=3m ttl=255 in-filter=”” out-filter=”” address-families=ip 
     default-originate=never remove-private-as=no as-override=no passive=no 
     use-bfd=no remote-id=12.12.12.2 local-address=12.12.12.1 uptime=58m59s 
     prefix-count=1 updates-sent=1 updates-received=1 withdrawn-sent=0 
     withdrawn-received=0 remote-hold-time=3m used-hold-time=3m 
     used-keepalive-time=1m refresh-capability=yes as4-capability=yes 
     state=established 

status diatas menandakan koneksi bgp sudah berhasil dengan status (“state=establish) dengan lama waktu terhubung (hold time) 3 menit. Parameter count adalah jumlah prefix yang diterima dari pasangan  router bgp peernya, 
nah untuk melihat apakah network loopback yang tadi kita advertise ke bgp sudah ada atau belum pada router lawannya maka bisa kita check pada routing tablenya.
[admin@IDN-R1] > ip route print 
Flags: X – disabled, A – active, D – dynamic, 
C – connect, S – static, r – rip, b – bgp, o – ospf, m – mme, 
B – blackhole, U – unreachable, P – prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADC  1.1.1.1/32             1.1.1.1                lo0                          0
 1 ADb  2.2.2.2/32              12.12.12.2                                         200
 2 ADC  12.12.12.0/24        12.12.12.1         ether1                      0
oke untuk update ini sekian dulu aja, tunggu update update selanjutnya
Thank You