Lab 146 – IOS XR IBGP Confederation

Pada lab sebelumnya kita telah belajar tentang IBGP Route Reflcetor pada IOS XR.. selanjutnya pada lab ini kita akan belajar tentang IBGP Confederation..

Berikut topologi yang akan kita gunakan

Pertama kita harus konfigurasi IP Address dan routing protocol IGP pada jaringan diatas.. pada lab ini kita akan menggunakan EIGRP yaaa.. jika ada yg belum bisa konfigurasi EIGRP di IOS XR bisa merujuk ke artikel berikut : Konfigurasi EIGRP di IOS XR..

Setelah konfigurasi EIGRP, hasilnya adalah sebagai berikut

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:47:34.279 UTC

D 2.2.2.2/32 [90/10752] via 12.12.12.2, 00:03:03, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/15872] via 12.12.12.2, 00:01:12, GigabitEthernet0/0/0/0
D 4.4.4.4/32 [90/20992] via 12.12.12.2, 00:00:32, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 12.12.12.2, 00:03:03, GigabitEthernet0/0/0/0
D 34.34.34.0/24 [90/20480] via 12.12.12.2, 00:01:12, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:48:06.896 UTC

D 1.1.1.1/32 [90/10752] via 12.12.12.1, 00:03:17, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/10752] via 23.23.23.3, 00:01:45, GigabitEthernet0/0/0/1
D 4.4.4.4/32 [90/15872] via 23.23.23.3, 00:01:05, GigabitEthernet0/0/0/1
D 34.34.34.0/24 [90/15360] via 23.23.23.3, 00:01:45, GigabitEthernet0/0/0/1
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:48:30.135 UTC

D 1.1.1.1/32 [90/15872] via 23.23.23.2, 00:01:54, GigabitEthernet0/0/0/0
D 2.2.2.2/32 [90/10752] via 23.23.23.2, 00:01:54, GigabitEthernet0/0/0/0
D 4.4.4.4/32 [90/10752] via 34.34.34.4, 00:01:29, GigabitEthernet0/0/0/1
D 12.12.12.0/24 [90/15360] via 23.23.23.2, 00:01:54, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR4(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:48:48.963 UTC

D 1.1.1.1/32 [90/20992] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 2.2.2.2/32 [90/15872] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/10752] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 12.12.12.0/24 [90/20480] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0

Oke.. pastikan hasilnya sudah seperti itu ya.. pastikan juga masing-masing router sudah bisa ping ke loopback0 router lainnya.. berikut contoh ping dari IOS-XR1 ke loopback0 router lainnya

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping ipv4 2.2.2.2
Wed Jun 7 06:51:23.093 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping ipv4 3.3.3.3
Wed Jun 7 06:51:25.653 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/19 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping ipv4 4.4.4.4
Wed Jun 7 06:51:30.342 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

Oke kalu sudah berhasil seperti diatas, selanjutnya kita akan konfigurasi IBGP dengan confederation..

Perhatikan topologi diatas, IOS-XR1 dan IOS-XR2 menggunaakn AS confederation 12 sedangkan IOS-XR3 dan IOS-XR4 menggunakan AS confederation 34..

Berikut konfigurasi pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router bgp 12
RP/0/0/CPU0:IOS-XR1(config-bgp)#bgp confederation identifier 12

RP/0/0/CPU0:IOS-XR1(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#network 11.11.11.11/32
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR1(config-bgp)#neighbor 2.2.2.2
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#remote-as 12
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#commit

Selanjutnya berikut konfigurasi pada IOS-XR2

RP/0/0/CPU0:IOS-XR2(config)#router bgp 12
RP/0/0/CPU0:IOS-XR2(config-bgp)#bgp confederation identifier 12
RP/0/0/CPU0:IOS-XR2(config-bgp)#bgp confederation peers 34

RP/0/0/CPU0:IOS-XR2(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#network 22.22.22.22/32
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR2(config-bgp)#neighbor 1.1.1.1
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#remote-as 12
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR2(config-bgp-nbr-af)#neighbor 3.3.3.3
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#remote-as 34
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR2(config-bgp-nbr-af)#commit

Perhatikan bahwa pada IOS-XR2 kita perlu mengkonfigurisakan ebgp-multihop saat neighbor 3.3.3.3.. ini dikarenakan IOS-XR2 menganggap IOS-XR3 seolah-olah adalah external AS.. sedangkan untuk peering EBGP nilai ttl nya adalah 1.. jadi kita harus memperbesar nilai ttl menggunakan perintah ebgp-multihop ini..

Selanjutnya berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config)#router bgp 34
RP/0/0/CPU0:IOS-XR3(config-bgp)#bgp confederation identifier 1234
RP/0/0/CPU0:IOS-XR3(config-bgp)#bgp confederation peers 12

RP/0/0/CPU0:IOS-XR3(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#network 33.33.33.33/32
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR3(config-bgp)#neighbor 2.2.2.2
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#remote-as 12
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR3(config-bgp-nbr-af)#neighbor 4.4.4.4
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#remote-as 34
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR3(config-bgp-nbr-af)#commit

Perhatikan bahwa kita juga perlu mengkonfigurasikan ebgp-multihop pada IOS-XR3

Yang terahir, berikut konfigurasi pada IOS-XR4

RP/0/0/CPU0:IOS-XR4(config)#router bgp 34
RP/0/0/CPU0:IOS-XR4(config-bgp)#bgp confederation identifier 1234

RP/0/0/CPU0:IOS-XR4(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#network 44.44.44.44/32
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR4(config-bgp)#neighbor 3.3.3.3
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#remote-as 34
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr-af)#commit

Oke.. konfigurasi sudah selesai.. Untuk pengujian,, pastikan IOS-XR1 menerima network dari IOS-XR2, IOS-XR3, dan IOS-XR4

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do sh bgp
Wed Jun 7 07:31:04.430 UTC
BGP router identifier 1.1.1.1, local AS number 12
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.11.11.11/32 0.0.0.0 0 32768 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i33.33.33.33/32 3.3.3.3 0 100 0 (34) i
*>i44.44.44.44/32 4.4.4.4 0 100 0 (34) i

Processed 4 prefixes, 4 paths

Oke sudah berhasil ya.. untuk lebih memastikan, kita coba lihat tabel routing di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do sh route bgp
Wed Jun 7 07:31:43.497 UTC

B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:11:32
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:09:05
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:08:35

Oke sudah lengkap… sekarang kita coba lakukan ping yaa

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do ping 22.22.22.22 sou l1
Wed Jun 7 07:32:10.695 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do ping 33.33.33.33 sou l1
Wed Jun 7 07:32:14.505 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do ping 44.44.44.44 sou l1
Wed Jun 7 07:32:18.435 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 44.44.44.44, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke sudah berhasil yaaa… Sampai saat ini kita sudah selesai dan berhasil melakukan konfigurasi IBGP confederation pada IOS XR.. sampai jumpa di artikel selanjutnya yaa…. In Syaa Allah masih akan membahas seputar IOS XR..

Lab 146 – IOS XR IBGP Confederation

Pada lab sebelumnya kita telah belajar tentang IBGP Route Reflcetor pada IOS XR.. selanjutnya pada lab ini kita akan belajar tentang IBGP Confederation..

Berikut topologi yang akan kita gunakan

Pertama kita harus konfigurasi IP Address dan routing protocol IGP pada jaringan diatas.. pada lab ini kita akan menggunakan EIGRP yaaa.. jika ada yg belum bisa konfigurasi EIGRP di IOS XR bisa merujuk ke artikel berikut : Konfigurasi EIGRP di IOS XR..

Setelah konfigurasi EIGRP, hasilnya adalah sebagai berikut

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:47:34.279 UTC

D 2.2.2.2/32 [90/10752] via 12.12.12.2, 00:03:03, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/15872] via 12.12.12.2, 00:01:12, GigabitEthernet0/0/0/0
D 4.4.4.4/32 [90/20992] via 12.12.12.2, 00:00:32, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 12.12.12.2, 00:03:03, GigabitEthernet0/0/0/0
D 34.34.34.0/24 [90/20480] via 12.12.12.2, 00:01:12, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:48:06.896 UTC

D 1.1.1.1/32 [90/10752] via 12.12.12.1, 00:03:17, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/10752] via 23.23.23.3, 00:01:45, GigabitEthernet0/0/0/1
D 4.4.4.4/32 [90/15872] via 23.23.23.3, 00:01:05, GigabitEthernet0/0/0/1
D 34.34.34.0/24 [90/15360] via 23.23.23.3, 00:01:45, GigabitEthernet0/0/0/1
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:48:30.135 UTC

D 1.1.1.1/32 [90/15872] via 23.23.23.2, 00:01:54, GigabitEthernet0/0/0/0
D 2.2.2.2/32 [90/10752] via 23.23.23.2, 00:01:54, GigabitEthernet0/0/0/0
D 4.4.4.4/32 [90/10752] via 34.34.34.4, 00:01:29, GigabitEthernet0/0/0/1
D 12.12.12.0/24 [90/15360] via 23.23.23.2, 00:01:54, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR4(config-eigrp-af-if)#do sh route eigrp
Wed Jun 7 06:48:48.963 UTC

D 1.1.1.1/32 [90/20992] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 2.2.2.2/32 [90/15872] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/10752] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 12.12.12.0/24 [90/20480] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 34.34.34.3, 00:01:29, GigabitEthernet0/0/0/0

Oke.. pastikan hasilnya sudah seperti itu ya.. pastikan juga masing-masing router sudah bisa ping ke loopback0 router lainnya.. berikut contoh ping dari IOS-XR1 ke loopback0 router lainnya

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping ipv4 2.2.2.2
Wed Jun 7 06:51:23.093 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping ipv4 3.3.3.3
Wed Jun 7 06:51:25.653 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/19 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping ipv4 4.4.4.4
Wed Jun 7 06:51:30.342 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

Oke kalu sudah berhasil seperti diatas, selanjutnya kita akan konfigurasi IBGP dengan confederation..

Perhatikan topologi diatas, IOS-XR1 dan IOS-XR2 menggunaakn AS confederation 12 sedangkan IOS-XR3 dan IOS-XR4 menggunakan AS confederation 34..

Berikut konfigurasi pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router bgp 12
RP/0/0/CPU0:IOS-XR1(config-bgp)#bgp confederation identifier 12

RP/0/0/CPU0:IOS-XR1(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#network 11.11.11.11/32
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR1(config-bgp)#neighbor 2.2.2.2
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#remote-as 12
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#commit

Selanjutnya berikut konfigurasi pada IOS-XR2

RP/0/0/CPU0:IOS-XR2(config)#router bgp 12
RP/0/0/CPU0:IOS-XR2(config-bgp)#bgp confederation identifier 12
RP/0/0/CPU0:IOS-XR2(config-bgp)#bgp confederation peers 34

RP/0/0/CPU0:IOS-XR2(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#network 22.22.22.22/32
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR2(config-bgp)#neighbor 1.1.1.1
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#remote-as 12
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR2(config-bgp-nbr-af)#neighbor 3.3.3.3
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#remote-as 34
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR2(config-bgp-nbr-af)#commit

Perhatikan bahwa pada IOS-XR2 kita perlu mengkonfigurisakan ebgp-multihop saat neighbor 3.3.3.3.. ini dikarenakan IOS-XR2 menganggap IOS-XR3 seolah-olah adalah external AS.. sedangkan untuk peering EBGP nilai ttl nya adalah 1.. jadi kita harus memperbesar nilai ttl menggunakan perintah ebgp-multihop ini..

Selanjutnya berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config)#router bgp 34
RP/0/0/CPU0:IOS-XR3(config-bgp)#bgp confederation identifier 1234
RP/0/0/CPU0:IOS-XR3(config-bgp)#bgp confederation peers 12

RP/0/0/CPU0:IOS-XR3(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#network 33.33.33.33/32
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR3(config-bgp)#neighbor 2.2.2.2
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#remote-as 12
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR3(config-bgp-nbr-af)#neighbor 4.4.4.4
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#remote-as 34
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR3(config-bgp-nbr-af)#commit

Perhatikan bahwa kita juga perlu mengkonfigurasikan ebgp-multihop pada IOS-XR3

Yang terahir, berikut konfigurasi pada IOS-XR4

RP/0/0/CPU0:IOS-XR4(config)#router bgp 34
RP/0/0/CPU0:IOS-XR4(config-bgp)#bgp confederation identifier 1234

RP/0/0/CPU0:IOS-XR4(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#network 44.44.44.44/32
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR4(config-bgp)#neighbor 3.3.3.3
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#remote-as 34
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#address-family ipv4 unicast

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr-af)#commit

Oke.. konfigurasi sudah selesai.. Untuk pengujian,, pastikan IOS-XR1 menerima network dari IOS-XR2, IOS-XR3, dan IOS-XR4

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do sh bgp
Wed Jun 7 07:31:04.430 UTC
BGP router identifier 1.1.1.1, local AS number 12
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.11.11.11/32 0.0.0.0 0 32768 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i33.33.33.33/32 3.3.3.3 0 100 0 (34) i
*>i44.44.44.44/32 4.4.4.4 0 100 0 (34) i

Processed 4 prefixes, 4 paths

Oke sudah berhasil ya.. untuk lebih memastikan, kita coba lihat tabel routing di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do sh route bgp
Wed Jun 7 07:31:43.497 UTC

B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:11:32
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:09:05
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:08:35

Oke sudah lengkap… sekarang kita coba lakukan ping yaa

RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do ping 22.22.22.22 sou l1
Wed Jun 7 07:32:10.695 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do ping 33.33.33.33 sou l1
Wed Jun 7 07:32:14.505 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#do ping 44.44.44.44 sou l1
Wed Jun 7 07:32:18.435 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 44.44.44.44, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke sudah berhasil yaaa… Sampai saat ini kita sudah selesai dan berhasil melakukan konfigurasi IBGP confederation pada IOS XR.. sampai jumpa di artikel selanjutnya yaa…. In Syaa Allah masih akan membahas seputar IOS XR..

Lab 145 – IOS XR IBGP Route Reflector

Sebelumnya kita telah belajar tentang IGP di IOS XR,,. yaitu OSPF dan EIGRP.. selanjutnya pada lab ini kita akan belajar tentang EGP,, yaitu BGP..

Kita akan ngelab IBGP dengan menggunakan Route Reflector.. berikut topologi yang akan kita gunakan

Perhatikan masing-masing router mempunyai dua IP Loopback.. nantinya interface loopback0 pada masing-masing router akan kita advertise ke OSPF.. selanjutnya interface loopback1 pada masing-masing router akan kita advertise ke IBGP..

Oke langsung saja, Diasumsikan kita sudah konfigurasi OSPF ya.. nanti hasilnya harus nya seperti ini..

RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:24:16.743 UTC

O 2.2.2.2/32 [110/2] via 12.12.12.2, 00:02:03, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/3] via 12.12.12.2, 00:00:59, GigabitEthernet0/0/0/0
O 4.4.4.4/32 [110/4] via 12.12.12.2, 00:00:06, GigabitEthernet0/0/0/0
O 23.23.23.0/24 [110/2] via 12.12.12.2, 00:02:03, GigabitEthernet0/0/0/0
O 34.34.34.0/24 [110/3] via 12.12.12.2, 00:00:59, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:24:41.661 UTC

O 1.1.1.1/32 [110/2] via 12.12.12.1, 00:02:27, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/2] via 23.23.23.3, 00:01:28, GigabitEthernet0/0/0/1
O 4.4.4.4/32 [110/3] via 23.23.23.3, 00:00:30, GigabitEthernet0/0/0/1
O 34.34.34.0/24 [110/2] via 23.23.23.3, 00:01:28, GigabitEthernet0/0/0/1
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:24:57.810 UTC

O 1.1.1.1/32 [110/3] via 23.23.23.2, 00:01:44, GigabitEthernet0/0/0/0
O 2.2.2.2/32 [110/2] via 23.23.23.2, 00:01:44, GigabitEthernet0/0/0/0
O 4.4.4.4/32 [110/2] via 34.34.34.4, 00:00:52, GigabitEthernet0/0/0/1
O 12.12.12.0/24 [110/2] via 23.23.23.2, 00:01:44, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR4(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:25:11.609 UTC

O 1.1.1.1/32 [110/4] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 2.2.2.2/32 [110/3] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/2] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 12.12.12.0/24 [110/3] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 23.23.23.0/24 [110/2] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0

Kalau masih ada yang belum bisa konfigurasi OSPF di IOS XR, bisa merujuk ke artikel berikut ya : Konfigurasi OSPF di IOS XR

Oke.. setelah konfigurasi OSPF selesai.. pastikan masing-masing router bisa ping ke loopback0 dari router lain ya.. kita coba ping dari IOS-XR1 ke loopback0 IOS-XR2-4

RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do ping 2.2.2.2
Mon Jun 5 01:26:51.382 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do ping 3.3.3.3
Mon Jun 5 01:26:53.402 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/19 ms
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do ping 4.4.4.4
Mon Jun 5 01:26:55.782 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

Oke sudah jalan semua ya.. sekarang saatnya kita mengkonfigurasi IBGP… pada topologi ini IOS-XR4 akan menjadi Route Reflector ya.. jadi nanti IOS-XR1, 2, dan 3 hanya perlua peering ke IOS-XR4..

Oke langsung saja.. berikut konfigurasi di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router bgp 1234
RP/0/0/CPU0:IOS-XR1(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#network 11.11.11.11/32
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR1(config-bgp)#nei 4.4.4.4
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#remote-as 1234
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#commit

Berikut konfigurasi di IOS-XR2

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#router bgp 1234
RP/0/0/CPU0:IOS-XR2(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#net 22.22.22.22/32
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR2(config-bgp)#nei 4.4.4.4
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#remote-as 1234
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#update-sou lo0
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr-af)#commit

Berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#router bgp 1234
RP/0/0/CPU0:IOS-XR3(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#net 33.33.33.33/32
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR3(config-bgp)#nei 4.4.4.4
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#remote-as 1234
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#update-sou lo0
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr-af)#commit

Berikut konfigurasi di IOS-XR4.. pada IOS-XR4 ini kita akan konfiguruasi peering group ya.. karena IOS-XR4 harus peering ke 3 router.. kalau peering satu-satu kelamaan.. jadi lebih baik pake group aja

RP/0/0/CPU0:IOS-XR4(config)#router bgp 1234
RP/0/0/CPU0:IOS-XR4(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#net 44.44.44.44/32
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR4(config-bgp)#neighbor-group IBGP
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#remote-as 1234
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#update-source lo0
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp-af)#route-reflector-client
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp-af)#exit
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#exit

RP/0/0/CPU0:IOS-XR4(config-bgp)#neigh 1.1.1.1
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#use neighbor-group IBGP

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#nei 2.2.2.2
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#use neighbor-group IBGP

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#nei 3.3.3.3
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#use neighbor-group IBGP
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#commit

Oke untuk pengujian, kita bisa menggunakan perintah berikut

RP/0/0/CPU0:IOS-XR1(config-if)#do sh bgp sum
Mon Jun 5 01:50:04.631 UTC
BGP router identifier 1.1.1.1, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Not Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 6 6 6 6 6 0

Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
4.4.4.4 0 1234 9 5 6 0 0 00:01:21 3

Perhatikan bahwa IOS-XR1 sudah menerima 3 prefix dari IOS-XR4.. kita coba lihat prefix berapa saja yang dimaksud

RP/0/0/CPU0:IOS-XR1(config-if)#do sh bgp
Mon Jun 5 01:51:25.296 UTC
BGP router identifier 1.1.1.1, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.11.11.11/32 0.0.0.0 0 32768 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i33.33.33.33/32 3.3.3.3 0 100 0 i
*>i44.44.44.44/32 4.4.4.4 0 100 0 i

Processed 4 prefixes, 4 paths

Perhatikan bahwa IOS-XR1 sudah menerima prefix yang lengkap.. kita coba lihat yang di Route Reflector ya

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#do sh bgp sum
Mon Jun 5 01:52:49.450 UTC
BGP router identifier 4.4.4.4, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 6 6 6 6 6 0

Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
1.1.1.1 0 1234 8 12 6 0 0 00:04:06 1
2.2.2.2 0 1234 11 14 6 0 0 00:07:01 1
3.3.3.3 0 1234 11 15 6 0 0 00:07:03 1

Route Reflector peering dengan tiga router lainnya., dan menerima 1 prefix dari setiap router.. kita coba lihat prefix berapa saja yg diterima oleh IOS-XR4

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#do sh bgp
Mon Jun 5 01:53:41.046 UTC
BGP router identifier 4.4.4.4, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i11.11.11.11/32 1.1.1.1 0 100 0 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i33.33.33.33/32 3.3.3.3 0 100 0 i
*> 44.44.44.44/32 0.0.0.0 0 32768 i

Processed 4 prefixes, 4 paths

Oke lengkap ya…

Untuk pengujian selanjutnya kita bisa mencoba untuk melihat tabel routing.. berikut tabel routing di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-if)#do sh route bgp
Mon Jun 5 01:54:26.033 UTC

B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:05:37
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:05:37
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:05:37

Berikut tabel routing di IOS-XR2

RP/0/0/CPU0:IOS-XR2#sh route bgp
Mon Jun 5 01:54:59.551 UTC

B 11.11.11.11/32 [200/0] via 1.1.1.1, 00:06:11
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:07:13
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:07:13

Berikut tabel routing BGP di IOS-XR3

RP/0/0/CPU0:IOS-XR3#sh route bgp
Mon Jun 5 01:55:27.709 UTC

B 11.11.11.11/32 [200/0] via 1.1.1.1, 00:06:39
B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:07:41
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:07:41

Berikut tabel routing BGP di IOS-XR4

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#do sh route bgp
Mon Jun 5 01:55:48.918 UTC

B 11.11.11.11/32 [200/0] via 1.1.1.1, 00:07:00
B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:08:02
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:08:02

Oke.. sudah lengkap semua kan ya…

Pengujain terahir, kita coba lakukan ping yaa.. Berikut percobaan ping dari IOS-XR1 ke loopback router lainnya

RP/0/0/CPU0:IOS-XR1(config-if)#do ping 22.22.22.22 sou l1
Mon Jun 5 01:56:32.855 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-if)#do ping 33.33.33.33 sou l1
Mon Jun 5 01:56:37.354 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1(config-if)#do ping 44.44.44.44 sou l1
Mon Jun 5 01:56:41.684 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 44.44.44.44, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke jalan semua ya….

Alhamdulillah Lab IBGP pada IOS XR kita sudah selesai… In Syaa Allah selanjutnya kita masih akan membahas tentang IBGP pada IOS XR.. namun menggunakan Confederation.. Oke sampai ketemu di artikel selanjutnya yaaa

Lab 145 – IOS XR IBGP Route Reflector

Sebelumnya kita telah belajar tentang IGP di IOS XR,,. yaitu OSPF dan EIGRP.. selanjutnya pada lab ini kita akan belajar tentang EGP,, yaitu BGP..

Kita akan ngelab IBGP dengan menggunakan Route Reflector.. berikut topologi yang akan kita gunakan

Perhatikan masing-masing router mempunyai dua IP Loopback.. nantinya interface loopback0 pada masing-masing router akan kita advertise ke OSPF.. selanjutnya interface loopback1 pada masing-masing router akan kita advertise ke IBGP..

Oke langsung saja, Diasumsikan kita sudah konfigurasi OSPF ya.. nanti hasilnya harus nya seperti ini..

RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:24:16.743 UTC

O 2.2.2.2/32 [110/2] via 12.12.12.2, 00:02:03, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/3] via 12.12.12.2, 00:00:59, GigabitEthernet0/0/0/0
O 4.4.4.4/32 [110/4] via 12.12.12.2, 00:00:06, GigabitEthernet0/0/0/0
O 23.23.23.0/24 [110/2] via 12.12.12.2, 00:02:03, GigabitEthernet0/0/0/0
O 34.34.34.0/24 [110/3] via 12.12.12.2, 00:00:59, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:24:41.661 UTC

O 1.1.1.1/32 [110/2] via 12.12.12.1, 00:02:27, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/2] via 23.23.23.3, 00:01:28, GigabitEthernet0/0/0/1
O 4.4.4.4/32 [110/3] via 23.23.23.3, 00:00:30, GigabitEthernet0/0/0/1
O 34.34.34.0/24 [110/2] via 23.23.23.3, 00:01:28, GigabitEthernet0/0/0/1
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:24:57.810 UTC

O 1.1.1.1/32 [110/3] via 23.23.23.2, 00:01:44, GigabitEthernet0/0/0/0
O 2.2.2.2/32 [110/2] via 23.23.23.2, 00:01:44, GigabitEthernet0/0/0/0
O 4.4.4.4/32 [110/2] via 34.34.34.4, 00:00:52, GigabitEthernet0/0/0/1
O 12.12.12.0/24 [110/2] via 23.23.23.2, 00:01:44, GigabitEthernet0/0/0/0
RP/0/0/CPU0:IOS-XR4(config-ospf-ar-if)#do sh route ospf
Mon Jun 5 01:25:11.609 UTC

O 1.1.1.1/32 [110/4] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 2.2.2.2/32 [110/3] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/2] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 12.12.12.0/24 [110/3] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0
O 23.23.23.0/24 [110/2] via 34.34.34.3, 00:01:06, GigabitEthernet0/0/0/0

Kalau masih ada yang belum bisa konfigurasi OSPF di IOS XR, bisa merujuk ke artikel berikut ya : Konfigurasi OSPF di IOS XR

Oke.. setelah konfigurasi OSPF selesai.. pastikan masing-masing router bisa ping ke loopback0 dari router lain ya.. kita coba ping dari IOS-XR1 ke loopback0 IOS-XR2-4

RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do ping 2.2.2.2
Mon Jun 5 01:26:51.382 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do ping 3.3.3.3
Mon Jun 5 01:26:53.402 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/19 ms
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#do ping 4.4.4.4
Mon Jun 5 01:26:55.782 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

Oke sudah jalan semua ya.. sekarang saatnya kita mengkonfigurasi IBGP… pada topologi ini IOS-XR4 akan menjadi Route Reflector ya.. jadi nanti IOS-XR1, 2, dan 3 hanya perlua peering ke IOS-XR4..

Oke langsung saja.. berikut konfigurasi di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router bgp 1234
RP/0/0/CPU0:IOS-XR1(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#network 11.11.11.11/32
RP/0/0/CPU0:IOS-XR1(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR1(config-bgp)#nei 4.4.4.4
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#remote-as 1234
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#update-source lo0
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR1(config-bgp-nbr-af)#commit

Berikut konfigurasi di IOS-XR2

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#router bgp 1234
RP/0/0/CPU0:IOS-XR2(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#net 22.22.22.22/32
RP/0/0/CPU0:IOS-XR2(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR2(config-bgp)#nei 4.4.4.4
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#remote-as 1234
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#update-sou lo0
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR2(config-bgp-nbr-af)#commit

Berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#router bgp 1234
RP/0/0/CPU0:IOS-XR3(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#net 33.33.33.33/32
RP/0/0/CPU0:IOS-XR3(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR3(config-bgp)#nei 4.4.4.4
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#remote-as 1234
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#update-sou lo0
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR3(config-bgp-nbr-af)#commit

Berikut konfigurasi di IOS-XR4.. pada IOS-XR4 ini kita akan konfiguruasi peering group ya.. karena IOS-XR4 harus peering ke 3 router.. kalau peering satu-satu kelamaan.. jadi lebih baik pake group aja

RP/0/0/CPU0:IOS-XR4(config)#router bgp 1234
RP/0/0/CPU0:IOS-XR4(config-bgp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#net 44.44.44.44/32
RP/0/0/CPU0:IOS-XR4(config-bgp-af)#exit

RP/0/0/CPU0:IOS-XR4(config-bgp)#neighbor-group IBGP
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#remote-as 1234
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#update-source lo0
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#address-family ipv4 unicast
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp-af)#route-reflector-client
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp-af)#exit
RP/0/0/CPU0:IOS-XR4(config-bgp-nbrgrp)#exit

RP/0/0/CPU0:IOS-XR4(config-bgp)#neigh 1.1.1.1
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#use neighbor-group IBGP

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#nei 2.2.2.2
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#use neighbor-group IBGP

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#nei 3.3.3.3
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#use neighbor-group IBGP
RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#commit

Oke untuk pengujian, kita bisa menggunakan perintah berikut

RP/0/0/CPU0:IOS-XR1(config-if)#do sh bgp sum
Mon Jun 5 01:50:04.631 UTC
BGP router identifier 1.1.1.1, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Not Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 6 6 6 6 6 0

Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
4.4.4.4 0 1234 9 5 6 0 0 00:01:21 3

Perhatikan bahwa IOS-XR1 sudah menerima 3 prefix dari IOS-XR4.. kita coba lihat prefix berapa saja yang dimaksud

RP/0/0/CPU0:IOS-XR1(config-if)#do sh bgp
Mon Jun 5 01:51:25.296 UTC
BGP router identifier 1.1.1.1, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 11.11.11.11/32 0.0.0.0 0 32768 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i33.33.33.33/32 3.3.3.3 0 100 0 i
*>i44.44.44.44/32 4.4.4.4 0 100 0 i

Processed 4 prefixes, 4 paths

Perhatikan bahwa IOS-XR1 sudah menerima prefix yang lengkap.. kita coba lihat yang di Route Reflector ya

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#do sh bgp sum
Mon Jun 5 01:52:49.450 UTC
BGP router identifier 4.4.4.4, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

BGP is operating in STANDALONE mode.


Process RcvTblVer bRIB/RIB LabelVer ImportVer SendTblVer StandbyVer
Speaker 6 6 6 6 6 0

Neighbor Spk AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down St/PfxRcd
1.1.1.1 0 1234 8 12 6 0 0 00:04:06 1
2.2.2.2 0 1234 11 14 6 0 0 00:07:01 1
3.3.3.3 0 1234 11 15 6 0 0 00:07:03 1

Route Reflector peering dengan tiga router lainnya., dan menerima 1 prefix dari setiap router.. kita coba lihat prefix berapa saja yg diterima oleh IOS-XR4

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#do sh bgp
Mon Jun 5 01:53:41.046 UTC
BGP router identifier 4.4.4.4, local AS number 1234
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000 RD version: 6
BGP main routing table version 6
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i11.11.11.11/32 1.1.1.1 0 100 0 i
*>i22.22.22.22/32 2.2.2.2 0 100 0 i
*>i33.33.33.33/32 3.3.3.3 0 100 0 i
*> 44.44.44.44/32 0.0.0.0 0 32768 i

Processed 4 prefixes, 4 paths

Oke lengkap ya…

Untuk pengujian selanjutnya kita bisa mencoba untuk melihat tabel routing.. berikut tabel routing di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-if)#do sh route bgp
Mon Jun 5 01:54:26.033 UTC

B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:05:37
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:05:37
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:05:37

Berikut tabel routing di IOS-XR2

RP/0/0/CPU0:IOS-XR2#sh route bgp
Mon Jun 5 01:54:59.551 UTC

B 11.11.11.11/32 [200/0] via 1.1.1.1, 00:06:11
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:07:13
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:07:13

Berikut tabel routing BGP di IOS-XR3

RP/0/0/CPU0:IOS-XR3#sh route bgp
Mon Jun 5 01:55:27.709 UTC

B 11.11.11.11/32 [200/0] via 1.1.1.1, 00:06:39
B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:07:41
B 44.44.44.44/32 [200/0] via 4.4.4.4, 00:07:41

Berikut tabel routing BGP di IOS-XR4

RP/0/0/CPU0:IOS-XR4(config-bgp-nbr)#do sh route bgp
Mon Jun 5 01:55:48.918 UTC

B 11.11.11.11/32 [200/0] via 1.1.1.1, 00:07:00
B 22.22.22.22/32 [200/0] via 2.2.2.2, 00:08:02
B 33.33.33.33/32 [200/0] via 3.3.3.3, 00:08:02

Oke.. sudah lengkap semua kan ya…

Pengujain terahir, kita coba lakukan ping yaa.. Berikut percobaan ping dari IOS-XR1 ke loopback router lainnya

RP/0/0/CPU0:IOS-XR1(config-if)#do ping 22.22.22.22 sou l1
Mon Jun 5 01:56:32.855 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-if)#do ping 33.33.33.33 sou l1
Mon Jun 5 01:56:37.354 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1(config-if)#do ping 44.44.44.44 sou l1
Mon Jun 5 01:56:41.684 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 44.44.44.44, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke jalan semua ya….

Alhamdulillah Lab IBGP pada IOS XR kita sudah selesai… In Syaa Allah selanjutnya kita masih akan membahas tentang IBGP pada IOS XR.. namun menggunakan Confederation.. Oke sampai ketemu di artikel selanjutnya yaaa

Lab 144 – IOS XR EIGRP Routing

Oke sesuai janji, kita masih lanjut belajar IOS XR yaa.. setelah sebelumnya kita belajar tentang konfigurasi OSPF di IOS XR, selanjutnya pada lab ini kita akan belajar konfigurasi routing protocol EIGRP pada IOS XR..

Untuk topologinya kita akan menggunakan topologi seperti berikut yaa

Pertama kita konfigurasi addressingnya dulu yaa..

RP/0/0/CPU0:IOS-XR1(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-if)#no sh
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 12.12.12.1/24

RP/0/0/CPU0:IOS-XR1(config-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 1.1.1.1/32

RP/0/0/CPU0:IOS-XR1(config-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 11.11.11.11/32

RP/0/0/CPU0:IOS-XR1(config-if)#commit
Sat Jun 3 15:06:51.991 UTC
RP/0/0/CPU0:IOS-XR2(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 12.12.12.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 2.2.2.2/32

RP/0/0/CPU0:IOS-XR2(config-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 22.22.22.22/32

RP/0/0/CPU0:IOS-XR2(config-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 23.23.23.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#commit
RP/0/0/CPU0:IOS-XR3(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-if)#no sh
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 23.23.23.3/24

RP/0/0/CPU0:IOS-XR3(config-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 3.3.3.3/32

RP/0/0/CPU0:IOS-XR3(config-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 33.33.33.33/32

RP/0/0/CPU0:IOS-XR3(config-if)#commit

Oke.. lanjut sekarang kita konfigurasikan EIGRP pada ketiga router tersebut… Berikut konfigurasi di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router eigrp 1
RP/0/0/CPU0:IOS-XR1(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR1(config-eigrp-af)#interface g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#commit

Berikut konfigurasi di IOS-XR2

RP/0/0/CPU0:IOS-XR2(config)#router eigrp AS1
RP/0/0/CPU0:IOS-XR2(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR2(config-eigrp-af)#autonomous-system 1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#commit

Berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config)#router eigrp 1
RP/0/0/CPU0:IOS-XR3(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR3(config-eigrp-af)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#commit

Untuk pengujian, pertama kita coba lihat apakah masing-masing router sudah menjalankan routing protocol eigrp dengan perintah berikut

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh protocol eigrp
Sat Jun 3 16:43:22.814 UTC

Routing Protocol: EIGRP, instance 1
Default context AS: 1, Router ID: 1.1.1.1
Address Family: IPv4
Default networks not flagged in outgoing updates
Default networks not accepted from incoming updates
Distance: internal 90, external 170
Maximum paths: 4
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0, K6=0
EIGRP metric rib scale 128
EIGRP metric version 64-bit
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
EIGRP NSF: enabled
NSF-aware route hold timer is 480s
NSF signal timer is 20s
NSF converge timer is 300s
Time since last restart is 00:13:09
SIA Active timer is 180s
Interfaces:
Loopback0
Loopback1
GigabitEthernet0/0/0/0

Perhatikan bahwa IOS-XR1 sudah menjalankan routing protocol EIGRP dengan AS 1, router-id 1.1.1.1, metric version 64 bit, dll. kita bisa melihat informasi tentang routing protocol EIGRP yang sedang berjalan dengan perintah diatas..

Selanjutnya, kita juga bisa melihat neighbor untuk melakukan pengujian, kita akan coba lihat neighbor di IOS-XR2

RP/0/0/CPU0:IOS-XR2#show eigrp neighbors
Sat Jun 3 16:46:44.920 UTC

IPv4-EIGRP VR(AS1) Neighbors for AS(1) VRF default

H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 23.23.23.3 Gi0/0/0/1 13 00:00:15 25 200 0 3
0 12.12.12.1 Gi0/0/0/0 11 00:09:35 7 200 0 7

Perhatikan bahwa IOS-XR2 sudah adjacency dengan IOS-XR1 dan IOS-XR3.. Selanjutnya kita juga bisa melihat tabel routing untuk melakukan pengujian.. Berikut tabel routing pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh route eigrp
Sat Jun 3 16:47:45.816 UTC

D 2.2.2.2/32 [90/10752] via 12.12.12.2, 00:10:36, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/15872] via 12.12.12.2, 00:01:16, GigabitEthernet0/0/0/0
D 22.22.22.22/32 [90/10752] via 12.12.12.2, 00:10:36, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 12.12.12.2, 00:01:18, GigabitEthernet0/0/0/0
D 33.33.33.33/32 [90/15872] via 12.12.12.2, 00:01:16, GigabitEthernet0/0/0/0

Perhatikan bahwa IOS-XR1 sudah memiliki tabel routing yang lengkap.. selanjutnya pengujian terahir yang dapat kita lakukan adalah dengan melakukan ping.. berikut percobaan ping dari IOS-XR1 ke loopback XR2 dan XR3

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping 2.2.2.2
Sat Jun 3 16:48:44.142 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping 3.3.3.3
Sat Jun 3 16:48:49.172 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke.. sudah work semua yaaaa…

Alhamdulillah lab ke tiga kita tentang IOS XR sudah selesai.. semoga bermanfaat ya.. In Syaa Allah besok kita masih akan belajar tentang IOS XR… keep spirit yaa!!!

Lab 144 – IOS XR EIGRP Routing

Oke sesuai janji, kita masih lanjut belajar IOS XR yaa.. setelah sebelumnya kita belajar tentang konfigurasi OSPF di IOS XR, selanjutnya pada lab ini kita akan belajar konfigurasi routing protocol EIGRP pada IOS XR..

Untuk topologinya kita akan menggunakan topologi seperti berikut yaa

Pertama kita konfigurasi addressingnya dulu yaa..

RP/0/0/CPU0:IOS-XR1(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-if)#no sh
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 12.12.12.1/24

RP/0/0/CPU0:IOS-XR1(config-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 1.1.1.1/32

RP/0/0/CPU0:IOS-XR1(config-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 11.11.11.11/32

RP/0/0/CPU0:IOS-XR1(config-if)#commit
Sat Jun 3 15:06:51.991 UTC
RP/0/0/CPU0:IOS-XR2(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 12.12.12.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 2.2.2.2/32

RP/0/0/CPU0:IOS-XR2(config-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 22.22.22.22/32

RP/0/0/CPU0:IOS-XR2(config-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 23.23.23.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#commit
RP/0/0/CPU0:IOS-XR3(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-if)#no sh
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 23.23.23.3/24

RP/0/0/CPU0:IOS-XR3(config-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 3.3.3.3/32

RP/0/0/CPU0:IOS-XR3(config-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 33.33.33.33/32

RP/0/0/CPU0:IOS-XR3(config-if)#commit

Oke.. lanjut sekarang kita konfigurasikan EIGRP pada ketiga router tersebut… Berikut konfigurasi di IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router eigrp 1
RP/0/0/CPU0:IOS-XR1(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR1(config-eigrp-af)#interface g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#commit

Berikut konfigurasi di IOS-XR2

RP/0/0/CPU0:IOS-XR2(config)#router eigrp AS1
RP/0/0/CPU0:IOS-XR2(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR2(config-eigrp-af)#autonomous-system 1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-eigrp-af-if)#commit

Berikut konfigurasi di IOS-XR3

RP/0/0/CPU0:IOS-XR3(config)#router eigrp 1
RP/0/0/CPU0:IOS-XR3(config-eigrp)#address-family ipv4
RP/0/0/CPU0:IOS-XR3(config-eigrp-af)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-eigrp-af-if)#commit

Untuk pengujian, pertama kita coba lihat apakah masing-masing router sudah menjalankan routing protocol eigrp dengan perintah berikut

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh protocol eigrp
Sat Jun 3 16:43:22.814 UTC

Routing Protocol: EIGRP, instance 1
Default context AS: 1, Router ID: 1.1.1.1
Address Family: IPv4
Default networks not flagged in outgoing updates
Default networks not accepted from incoming updates
Distance: internal 90, external 170
Maximum paths: 4
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0, K6=0
EIGRP metric rib scale 128
EIGRP metric version 64-bit
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
EIGRP NSF: enabled
NSF-aware route hold timer is 480s
NSF signal timer is 20s
NSF converge timer is 300s
Time since last restart is 00:13:09
SIA Active timer is 180s
Interfaces:
Loopback0
Loopback1
GigabitEthernet0/0/0/0

Perhatikan bahwa IOS-XR1 sudah menjalankan routing protocol EIGRP dengan AS 1, router-id 1.1.1.1, metric version 64 bit, dll. kita bisa melihat informasi tentang routing protocol EIGRP yang sedang berjalan dengan perintah diatas..

Selanjutnya, kita juga bisa melihat neighbor untuk melakukan pengujian, kita akan coba lihat neighbor di IOS-XR2

RP/0/0/CPU0:IOS-XR2#show eigrp neighbors
Sat Jun 3 16:46:44.920 UTC

IPv4-EIGRP VR(AS1) Neighbors for AS(1) VRF default

H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
1 23.23.23.3 Gi0/0/0/1 13 00:00:15 25 200 0 3
0 12.12.12.1 Gi0/0/0/0 11 00:09:35 7 200 0 7

Perhatikan bahwa IOS-XR2 sudah adjacency dengan IOS-XR1 dan IOS-XR3.. Selanjutnya kita juga bisa melihat tabel routing untuk melakukan pengujian.. Berikut tabel routing pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do sh route eigrp
Sat Jun 3 16:47:45.816 UTC

D 2.2.2.2/32 [90/10752] via 12.12.12.2, 00:10:36, GigabitEthernet0/0/0/0
D 3.3.3.3/32 [90/15872] via 12.12.12.2, 00:01:16, GigabitEthernet0/0/0/0
D 22.22.22.22/32 [90/10752] via 12.12.12.2, 00:10:36, GigabitEthernet0/0/0/0
D 23.23.23.0/24 [90/15360] via 12.12.12.2, 00:01:18, GigabitEthernet0/0/0/0
D 33.33.33.33/32 [90/15872] via 12.12.12.2, 00:01:16, GigabitEthernet0/0/0/0

Perhatikan bahwa IOS-XR1 sudah memiliki tabel routing yang lengkap.. selanjutnya pengujian terahir yang dapat kita lakukan adalah dengan melakukan ping.. berikut percobaan ping dari IOS-XR1 ke loopback XR2 dan XR3

RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping 2.2.2.2
Sat Jun 3 16:48:44.142 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
RP/0/0/CPU0:IOS-XR1(config-eigrp-af-if)#do ping 3.3.3.3
Sat Jun 3 16:48:49.172 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke.. sudah work semua yaaaa…

Alhamdulillah lab ke tiga kita tentang IOS XR sudah selesai.. semoga bermanfaat ya.. In Syaa Allah besok kita masih akan belajar tentang IOS XR… keep spirit yaa!!!

Lab 143 – IOS XR OSPF Routing

Pada lab sebelumnya kita sudah belajar tentang konfigurasi static routing di IOS XR.. Selanjutnya pada lab ini kita akan belajar konfigurasi routing OSPF pada IOS XR. Berikut topologi yang akan kita gunakan pada lab ini

Pada topologi diatas kita juga harus konfigurasi virtual link ya.. karena Area 2 tidak terhubung langsung dengan Area 0..

Oke pertama kita konfigurasikan ip address pada ketiga IOS XR sesuai topologi diatas

RP/0/0/CPU0:IOS-XR1(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-if)#no sh
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 12.12.12.1/24

RP/0/0/CPU0:IOS-XR1(config-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 1.1.1.1/32

RP/0/0/CPU0:IOS-XR1(config-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 11.11.11.11/32

RP/0/0/CPU0:IOS-XR1(config-if)#commit
Sat Jun 3 15:06:51.991 UTC
RP/0/0/CPU0:IOS-XR2(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 12.12.12.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 2.2.2.2/32

RP/0/0/CPU0:IOS-XR2(config-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 22.22.22.22/32

RP/0/0/CPU0:IOS-XR2(config-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 23.23.23.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#commit
RP/0/0/CPU0:IOS-XR3(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-if)#no sh
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 23.23.23.3/24

RP/0/0/CPU0:IOS-XR3(config-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 3.3.3.3/32

RP/0/0/CPU0:IOS-XR3(config-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 33.33.33.33/32

RP/0/0/CPU0:IOS-XR3(config-if)#commit

Oke.. konfigurasi ip address sudah selesai ya.. untuk pengujian, kita coba lakukan uji ping ke directly connected network masing2 router.. Berikut pengujian ping dari IOS-XR1 ke IOS-XR2

RP/0/0/CPU0:IOS-XR1(config-if)#do ping ipv4 12.12.12.2
Sat Jun 3 15:10:34.386 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/14/59 ms

Oke dari IOS-XR1 ke IOS-XR2 berhasil.. sekarang kita coba dari IOS-XR2 ke IOS-XR3

RP/0/0/CPU0:IOS-XR2(config-if)#do ping ipv4 23.23.23.3
Sat Jun 3 15:11:08.853 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/10/39 ms

Oke.. sudah berhasil juga ya..

Lanjut kita konfigurasi OSPF pada ketiga router tersebut.. perhatikan konfigurasinya harus sesuai topologi ya.. pada topologi kita diminta untuk mengkonfigurasi OSPF dengan 3 area..

Oke langsung saja, berikut konfigurasi OSPF pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router ospf 1
RP/0/0/CPU0:IOS-XR1(config-ospf)#router-id 1.1.1.1

RP/0/0/CPU0:IOS-XR1(config-ospf)#area 0
RP/0/0/CPU0:IOS-XR1(config-ospf-ar)#interface lo0
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#int l1

RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#area 1
RP/0/0/CPU0:IOS-XR1(config-ospf-ar)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#commit

Perhatikan bahwa kita tidak menggunakan perintah network pada IOS XR, kita menggunakan perintah interface seperti diatas, untuk pengujian kita coba lihat running-config nya ya

RP/0/0/CPU0:IOS-XR1(config-ospf)#do sh run router ospf
Sat Jun 3 15:21:25.241 UTC
router ospf 1
router-id 1.1.1.1
area 0
interface Loopback0
interface Loopback1
!
!
area 1
interface GigabitEthernet0/0/0/0
!
!

Oke.. sekarang lanjut konfigurasi di IOS-XR2 yaa

RP/0/0/CPU0:IOS-XR2(config)#router ospf 2
RP/0/0/CPU0:IOS-XR2(config-ospf)#router-id 2.2.2.2

RP/0/0/CPU0:IOS-XR2(config-ospf)#area 1
RP/0/0/CPU0:IOS-XR2(config-ospf-ar)#int lo0
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#int g0/0/0/0

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#area 2
RP/0/0/CPU0:IOS-XR2(config-ospf-ar)#int lo1
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#int g0/0/0/1

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#commit
Sat Jun 3 15:25:53.883 UTC
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh run router ospf
Sat Jun 3 15:27:19.337 UTC
router ospf 2
router-id 2.2.2.2
area 1
interface Loopback0
interface GigabitEthernet0/0/0/0
!
area 2
interface Loopback1
interface GigabitEthernet0/0/0/1
!
!

Setelah konfigurasi di IOS-XR1 dan IOS-XR2, seharusnya kedua router tersebut sudah adjacency OSPF.. kita coba lihat dulu yaa

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh ospf neig
Sat Jun 3 15:29:20.029 UTC

* Indicates MADJ interface

Neighbors for OSPF 2

Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 1 FULL/DR 00:00:34 12.12.12.1 GigabitEth0/0/0/0
Neighbor is up for 00:03:15

Total neighbor count: 1

Perhatikan bahwa state nya sudah full… Sekarang kita lanjut konfigurasi di IOS-XR3 yaa

RP/0/0/CPU0:IOS-XR3(config)#router ospf 3
RP/0/0/CPU0:IOS-XR3(config-ospf)#router-id 3.3.3.3

RP/0/0/CPU0:IOS-XR3(config-ospf)#area 2
RP/0/0/CPU0:IOS-XR3(config-ospf-ar)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#int l1

RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#commit
Sat Jun 3 15:32:09.727 UTC
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#do sh run router ospf
Sat Jun 3 15:32:18.186 UTC
router ospf 3
router-id 3.3.3.3
area 2
interface Loopback0
interface Loopback1
interface GigabitEthernet0/0/0/0
!
!

Kita coba lihat neighbor tabel di IOS-XR2 ya.. seharusnya IOS-XR2 punya 2 neighbor

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh ospf neigh
Sat Jun 3 15:34:20.278 UTC

* Indicates MADJ interface

Neighbors for OSPF 2

Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 1 FULL/DR 00:00:38 12.12.12.1 GigabitEth0/0/0/0
Neighbor is up for 00:08:15
3.3.3.3 1 FULL/BDR 00:00:35 23.23.23.3 GigabitEth0/0/0/1
Neighbor is up for 00:01:59

Total neighbor count: 2

Oke IOS-XR2 sudah punya 2 neighbor ya.. dan statenya sudah full semua.. terahir kita akan konfigurasikan virtual link antara IOS-XR1 dan IOS-XR2..

RP/0/0/CPU0:IOS-XR1(config)#router ospf 1
RP/0/0/CPU0:IOS-XR1(config-ospf)#area 1
RP/0/0/CPU0:IOS-XR1(config-ospf-ar)#virtual-link 2.2.2.2
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-vl)#commit
RP/0/0/CPU0:IOS-XR2(config)#router ospf 2
RP/0/0/CPU0:IOS-XR2(config-ospf)#area 1
RP/0/0/CPU0:IOS-XR2(config-ospf-ar)#virtual-link 1.1.1.1
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-vl)#commit

Oke, untuk pengujian, pastikan tabel routing di seluruh router sudah lengkap

RP/0/0/CPU0:IOS-XR1#show route ospf
Sat Jun 3 15:56:53.025 UTC

O 2.2.2.2/32 [110/2] via 12.12.12.2, 00:00:40, GigabitEthernet0/0/0/0
O IA 3.3.3.3/32 [110/3] via 12.12.12.2, 00:00:30, GigabitEthernet0/0/0/0
O IA 22.22.22.22/32 [110/2] via 12.12.12.2, 00:00:30, GigabitEthernet0/0/0/0
O IA 23.23.23.0/24 [110/2] via 12.12.12.2, 00:00:30, GigabitEthernet0/0/0/0
O IA 33.33.33.33/32 [110/3] via 12.12.12.2, 00:00:30, GigabitEthernet0/0/0/0

Perhatikan bahwa IOS XR1 sudah punya tabel routing OSPF lengkap, kita coba cek di IOS-XR2 dan IOS-XR3

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh route ospf
Sat Jun 3 15:58:15.940 UTC

O 1.1.1.1/32 [110/2] via 12.12.12.1, 00:01:52, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/2] via 23.23.23.3, 00:02:06, GigabitEthernet0/0/0/1
O 11.11.11.11/32 [110/2] via 12.12.12.1, 00:01:52, GigabitEthernet0/0/0/0
O 33.33.33.33/32 [110/2] via 23.23.23.3, 00:02:06, GigabitEthernet0/0/0/1
RP/0/0/CPU0:IOS-XR3#show route ospf
Sat Jun 3 15:58:35.758 UTC

O IA 1.1.1.1/32 [110/3] via 23.23.23.2, 00:02:12, GigabitEthernet0/0/0/0
O IA 2.2.2.2/32 [110/2] via 23.23.23.2, 00:02:22, GigabitEthernet0/0/0/0
O IA 11.11.11.11/32 [110/3] via 23.23.23.2, 00:02:12, GigabitEthernet0/0/0/0
O IA 12.12.12.0/24 [110/2] via 23.23.23.2, 00:02:22, GigabitEthernet0/0/0/0
O 22.22.22.22/32 [110/2] via 23.23.23.2, 00:02:26, GigabitEthernet0/0/0/0

Oke tabel routing di IOS-XR2 dan IOS-XR3 juga sudah lengkap.. Untuk lebih memastikan kita coba ping ya.. kita akan coba ping dari IOS-XR1 ke loopback XR2 dan XR3

RP/0/0/CPU0:IOS-XR1#ping 2.2.2.2
Sat Jun 3 16:02:21.183 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1#ping 22.22.22.22
Sat Jun 3 16:02:23.943 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1#ping 3.3.3.3
Sat Jun 3 16:02:25.882 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/19 ms
RP/0/0/CPU0:IOS-XR1#ping 33.33.33.33
Sat Jun 3 16:02:28.582 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

Oke ping sudah jalan semua ya…

Alhamdulillah lab kedua kita tentang IOS XR sudah berhasil.. sampai ketemu di artikel selanjutnya yaa.. In Syaa Allah masih akan tetap tentang IOS XR

Lab 143 – IOS XR OSPF Routing

Pada lab sebelumnya kita sudah belajar tentang konfigurasi static routing di IOS XR.. Selanjutnya pada lab ini kita akan belajar konfigurasi routing OSPF pada IOS XR. Berikut topologi yang akan kita gunakan pada lab ini

Pada topologi diatas kita juga harus konfigurasi virtual link ya.. karena Area 2 tidak terhubung langsung dengan Area 0..

Oke pertama kita konfigurasikan ip address pada ketiga IOS XR sesuai topologi diatas

RP/0/0/CPU0:IOS-XR1(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-if)#no sh
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 12.12.12.1/24

RP/0/0/CPU0:IOS-XR1(config-if)#int l0
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 1.1.1.1/32

RP/0/0/CPU0:IOS-XR1(config-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 11.11.11.11/32

RP/0/0/CPU0:IOS-XR1(config-if)#commit
Sat Jun 3 15:06:51.991 UTC
RP/0/0/CPU0:IOS-XR2(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 12.12.12.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#int l0
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 2.2.2.2/32

RP/0/0/CPU0:IOS-XR2(config-if)#int l1
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 22.22.22.22/32

RP/0/0/CPU0:IOS-XR2(config-if)#int g0/0/0/1
RP/0/0/CPU0:IOS-XR2(config-if)#no sh
RP/0/0/CPU0:IOS-XR2(config-if)#ipv4 add 23.23.23.2/24

RP/0/0/CPU0:IOS-XR2(config-if)#commit
RP/0/0/CPU0:IOS-XR3(config)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-if)#no sh
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 23.23.23.3/24

RP/0/0/CPU0:IOS-XR3(config-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 3.3.3.3/32

RP/0/0/CPU0:IOS-XR3(config-if)#int l1
RP/0/0/CPU0:IOS-XR3(config-if)#ipv4 add 33.33.33.33/32

RP/0/0/CPU0:IOS-XR3(config-if)#commit

Oke.. konfigurasi ip address sudah selesai ya.. untuk pengujian, kita coba lakukan uji ping ke directly connected network masing2 router.. Berikut pengujian ping dari IOS-XR1 ke IOS-XR2

RP/0/0/CPU0:IOS-XR1(config-if)#do ping ipv4 12.12.12.2
Sat Jun 3 15:10:34.386 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/14/59 ms

Oke dari IOS-XR1 ke IOS-XR2 berhasil.. sekarang kita coba dari IOS-XR2 ke IOS-XR3

RP/0/0/CPU0:IOS-XR2(config-if)#do ping ipv4 23.23.23.3
Sat Jun 3 15:11:08.853 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/10/39 ms

Oke.. sudah berhasil juga ya..

Lanjut kita konfigurasi OSPF pada ketiga router tersebut.. perhatikan konfigurasinya harus sesuai topologi ya.. pada topologi kita diminta untuk mengkonfigurasi OSPF dengan 3 area..

Oke langsung saja, berikut konfigurasi OSPF pada IOS-XR1

RP/0/0/CPU0:IOS-XR1(config)#router ospf 1
RP/0/0/CPU0:IOS-XR1(config-ospf)#router-id 1.1.1.1

RP/0/0/CPU0:IOS-XR1(config-ospf)#area 0
RP/0/0/CPU0:IOS-XR1(config-ospf-ar)#interface lo0
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#int l1

RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#area 1
RP/0/0/CPU0:IOS-XR1(config-ospf-ar)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-if)#commit

Perhatikan bahwa kita tidak menggunakan perintah network pada IOS XR, kita menggunakan perintah interface seperti diatas, untuk pengujian kita coba lihat running-config nya ya

RP/0/0/CPU0:IOS-XR1(config-ospf)#do sh run router ospf
Sat Jun 3 15:21:25.241 UTC
router ospf 1
router-id 1.1.1.1
area 0
interface Loopback0
interface Loopback1
!
!
area 1
interface GigabitEthernet0/0/0/0
!
!

Oke.. sekarang lanjut konfigurasi di IOS-XR2 yaa

RP/0/0/CPU0:IOS-XR2(config)#router ospf 2
RP/0/0/CPU0:IOS-XR2(config-ospf)#router-id 2.2.2.2

RP/0/0/CPU0:IOS-XR2(config-ospf)#area 1
RP/0/0/CPU0:IOS-XR2(config-ospf-ar)#int lo0
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#int g0/0/0/0

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#area 2
RP/0/0/CPU0:IOS-XR2(config-ospf-ar)#int lo1
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#int g0/0/0/1

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#commit
Sat Jun 3 15:25:53.883 UTC
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh run router ospf
Sat Jun 3 15:27:19.337 UTC
router ospf 2
router-id 2.2.2.2
area 1
interface Loopback0
interface GigabitEthernet0/0/0/0
!
area 2
interface Loopback1
interface GigabitEthernet0/0/0/1
!
!

Setelah konfigurasi di IOS-XR1 dan IOS-XR2, seharusnya kedua router tersebut sudah adjacency OSPF.. kita coba lihat dulu yaa

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh ospf neig
Sat Jun 3 15:29:20.029 UTC

* Indicates MADJ interface

Neighbors for OSPF 2

Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 1 FULL/DR 00:00:34 12.12.12.1 GigabitEth0/0/0/0
Neighbor is up for 00:03:15

Total neighbor count: 1

Perhatikan bahwa state nya sudah full… Sekarang kita lanjut konfigurasi di IOS-XR3 yaa

RP/0/0/CPU0:IOS-XR3(config)#router ospf 3
RP/0/0/CPU0:IOS-XR3(config-ospf)#router-id 3.3.3.3

RP/0/0/CPU0:IOS-XR3(config-ospf)#area 2
RP/0/0/CPU0:IOS-XR3(config-ospf-ar)#int g0/0/0/0
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#int l0
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#int l1

RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#commit
Sat Jun 3 15:32:09.727 UTC
RP/0/0/CPU0:IOS-XR3(config-ospf-ar-if)#do sh run router ospf
Sat Jun 3 15:32:18.186 UTC
router ospf 3
router-id 3.3.3.3
area 2
interface Loopback0
interface Loopback1
interface GigabitEthernet0/0/0/0
!
!

Kita coba lihat neighbor tabel di IOS-XR2 ya.. seharusnya IOS-XR2 punya 2 neighbor

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh ospf neigh
Sat Jun 3 15:34:20.278 UTC

* Indicates MADJ interface

Neighbors for OSPF 2

Neighbor ID Pri State Dead Time Address Interface
1.1.1.1 1 FULL/DR 00:00:38 12.12.12.1 GigabitEth0/0/0/0
Neighbor is up for 00:08:15
3.3.3.3 1 FULL/BDR 00:00:35 23.23.23.3 GigabitEth0/0/0/1
Neighbor is up for 00:01:59

Total neighbor count: 2

Oke IOS-XR2 sudah punya 2 neighbor ya.. dan statenya sudah full semua.. terahir kita akan konfigurasikan virtual link antara IOS-XR1 dan IOS-XR2..

RP/0/0/CPU0:IOS-XR1(config)#router ospf 1
RP/0/0/CPU0:IOS-XR1(config-ospf)#area 1
RP/0/0/CPU0:IOS-XR1(config-ospf-ar)#virtual-link 2.2.2.2
RP/0/0/CPU0:IOS-XR1(config-ospf-ar-vl)#commit
RP/0/0/CPU0:IOS-XR2(config)#router ospf 2
RP/0/0/CPU0:IOS-XR2(config-ospf)#area 1
RP/0/0/CPU0:IOS-XR2(config-ospf-ar)#virtual-link 1.1.1.1
RP/0/0/CPU0:IOS-XR2(config-ospf-ar-vl)#commit

Oke, untuk pengujian, pastikan tabel routing di seluruh router sudah lengkap

RP/0/0/CPU0:IOS-XR1#show route ospf
Sat Jun 3 15:56:53.025 UTC

O 2.2.2.2/32 [110/2] via 12.12.12.2, 00:00:40, GigabitEthernet0/0/0/0
O IA 3.3.3.3/32 [110/3] via 12.12.12.2, 00:00:30, GigabitEthernet0/0/0/0
O IA 22.22.22.22/32 [110/2] via 12.12.12.2, 00:00:30, GigabitEthernet0/0/0/0
O IA 23.23.23.0/24 [110/2] via 12.12.12.2, 00:00:30, GigabitEthernet0/0/0/0
O IA 33.33.33.33/32 [110/3] via 12.12.12.2, 00:00:30, GigabitEthernet0/0/0/0

Perhatikan bahwa IOS XR1 sudah punya tabel routing OSPF lengkap, kita coba cek di IOS-XR2 dan IOS-XR3

RP/0/0/CPU0:IOS-XR2(config-ospf-ar-if)#do sh route ospf
Sat Jun 3 15:58:15.940 UTC

O 1.1.1.1/32 [110/2] via 12.12.12.1, 00:01:52, GigabitEthernet0/0/0/0
O 3.3.3.3/32 [110/2] via 23.23.23.3, 00:02:06, GigabitEthernet0/0/0/1
O 11.11.11.11/32 [110/2] via 12.12.12.1, 00:01:52, GigabitEthernet0/0/0/0
O 33.33.33.33/32 [110/2] via 23.23.23.3, 00:02:06, GigabitEthernet0/0/0/1
RP/0/0/CPU0:IOS-XR3#show route ospf
Sat Jun 3 15:58:35.758 UTC

O IA 1.1.1.1/32 [110/3] via 23.23.23.2, 00:02:12, GigabitEthernet0/0/0/0
O IA 2.2.2.2/32 [110/2] via 23.23.23.2, 00:02:22, GigabitEthernet0/0/0/0
O IA 11.11.11.11/32 [110/3] via 23.23.23.2, 00:02:12, GigabitEthernet0/0/0/0
O IA 12.12.12.0/24 [110/2] via 23.23.23.2, 00:02:22, GigabitEthernet0/0/0/0
O 22.22.22.22/32 [110/2] via 23.23.23.2, 00:02:26, GigabitEthernet0/0/0/0

Oke tabel routing di IOS-XR2 dan IOS-XR3 juga sudah lengkap.. Untuk lebih memastikan kita coba ping ya.. kita akan coba ping dari IOS-XR1 ke loopback XR2 dan XR3

RP/0/0/CPU0:IOS-XR1#ping 2.2.2.2
Sat Jun 3 16:02:21.183 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1#ping 22.22.22.22
Sat Jun 3 16:02:23.943 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR1#ping 3.3.3.3
Sat Jun 3 16:02:25.882 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/6/19 ms
RP/0/0/CPU0:IOS-XR1#ping 33.33.33.33
Sat Jun 3 16:02:28.582 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 33.33.33.33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/5/9 ms

Oke ping sudah jalan semua ya…

Alhamdulillah lab kedua kita tentang IOS XR sudah berhasil.. sampai ketemu di artikel selanjutnya yaa.. In Syaa Allah masih akan tetap tentang IOS XR

Lab 142 – IOS XR Static Routing

Sejauh ini kita sudah belajar tentang Cisco IOS.. sekarang sudah saatnya untuk berkembang nih.. sekarang kita akan belajar tentang Cisco IOS XR..

apa sih bedanya antara Cisco IOS dengan Cisco IOS XR? Secara umum Cisco IOS XR lebih stabil dan memiliki fitur yang lebih advanced.. biasanya sih IOS XR digunakan di service provider.. sejauh ini itu sih yang saya tau tentang IOS XR,.. belum pernah implement juga sih.. hehehe

Oke langsung saja pada lab ini kita akan belajar konfigurasi static routing di IOS XR. berikut topologi yang akan kita gunakan pada lab ini

Nantinya kita akan menggunakan static routing di IOS XR-1 dan default route di IOS XR-2.

Pertama kita konfigurasikan IP Address pada IOS XR-1 dan 2 sesuai topologi diatas. Berikut konfigurasi di IOS-XR1

RP/0/0/CPU0:ios#conf t
Sat Jun 3 14:32:33.568 UTC
RP/0/0/CPU0:ios(config)#hostname IOS-XR1

Konfigurasi diatas belum masuk ke konfig IP sih.. tapi nyadar nda kalau ada yang beda? perhatikan bahwa setelah konfig hostname, tidak langsung berubah.. hal ini karena kita harus menggunakan perintah commit terlebih dahulu

RP/0/0/CPU0:ios(config)#commit
Sat Jun 3 14:34:34.429 UTC
RP/0/0/CPU0:
IOS-XR1(config)#

Perhatikan bahwa saat ini hostname sudah berubah. intinya kita harus mengetikkan perintah commit agar konfigurasi yg kita lakukan bisa dijalankan.

Oke sekarang kita konfigurasikan IP Address nya ya.. tapi sebelumnya kita coba lihat status interfacenya dulu

RP/0/0/CPU0:IOS-XR1(config)#do show ipv4 interface brief
Sat Jun 3 14:36:41.571 UTC

Interface IP-Address Status Protocol
GigabitEthernet0/0/0/0 unassigned Shutdown Down
GigabitEthernet0/0/0/1 unassigned Shutdown Down
GigabitEthernet0/0/0/2 unassigned Shutdown Down

Perhatikan bahwa perintah untuk melihat status interface pun sedikit berbeda dengan Cisco IOS. Selanjutnya berikut perintah untuk konfigurasi ip address di IOS XR

RP/0/0/CPU0:IOS-XR1(config)#int gi0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-if)#no shutdown
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 address 12.12.12.1/24

Sekarang kita coba lihat status interface nya

RP/0/0/CPU0:IOS-XR1(config)#do show ipv4 interface brief
Sat Jun 3 14:36:41.571 UTC

Interface IP-Address Status Protocol
GigabitEthernet0/0/0/0 unassigned Shutdown Down
GigabitEthernet0/0/0/1 unassigned Shutdown Down
GigabitEthernet0/0/0/2 unassigned Shutdown Down

Nah lho.. kog masih belum ada konfignya? padahal kan kita sudah konfig…???

Hayoo.. sudah lupa kah? kan sudah saya bilang harus commit dulu… kita coba commit dulu yaa

RP/0/0/CPU0:IOS-XR1(config-if)#commit
RP/0/0/CPU0:IOS-XR1(config-if)#
do sho ipv4 int br
Sat Jun 3 14:41:06.273 UTC

Interface IP-Address Status Protocol
GigabitEthernet0/0/0/0 12.12.12.1 Up Up
GigabitEthernet0/0/0/1 unassigned Shutdown Down
GigabitEthernet0/0/0/2 unassigned Shutdown Down

Nah.. setelah commit baru deh konfig IP nya jalan.. Lanjut kita konfigurasi interface loopback nya ya

RP/0/0/CPU0:IOS-XR1(config-if)#int lo0
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 1.1.1.1/32

RP/0/0/CPU0:IOS-XR1(config-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 11.11.11.11/32

RP/0/0/CPU0:IOS-XR1(config-if)#commit
Sat Jun 3 14:42:09.338 UTC

Kita coba lihat status interfacenya lagi

RP/0/0/CPU0:IOS-XR1(config-if)#do sh ipv4 int br
Sat Jun 3 14:42:30.357 UTC

Interface IP-Address Status Protocol
Loopback0 1.1.1.1 Up Up
Loopback1 11.11.11.11 Up Up
GigabitEthernet0/0/0/0 12.12.12.1 Up Up
GigabitEthernet0/0/0/1 unassigned Shutdown Down
GigabitEthernet0/0/0/2 unassigned Shutdown Down

Oke sudah sesuai ya.. sekarang lanjut kita konfigurasi di IOS XR-2

RP/0/0/CPU0:ios(config)#host IOS-XR2

RP/0/0/CPU0:ios(config)#
int g0/0/0/0
RP/0/0/CPU0:ios(config-if)#
no sh
RP/0/0/CPU0:ios(config-if)#
ipv4 add 12.12.12.2/24

RP/0/0/CPU0:ios(config-if)#
int l0
RP/0/0/CPU0:ios(config-if)#
ipv4 add 2.2.2.2/32

RP/0/0/CPU0:ios(config-if)#
int l1
RP/0/0/CPU0:ios(config-if)#
ipv4 add 22.22.22.22/32

RP/0/0/CPU0:ios(config-if)#
commit

RP/0/0/CPU0:IOS-XR2(config-if)#
do sh ipv4 int br
Sat Jun 3 14:43:42.482 UTC
Interface IP-Address Status Protocol
Loopback0 2.2.2.2 Up Up
Loopback1 22.22.22.22 Up Up
GigabitEthernet0/0/0/0 12.12.12.2 Up Up
GigabitEthernet0/0/0/1 unassigned Shutdown Down
GigabitEthernet0/0/0/2 unassigned Shutdown Down

Oke.. konfigurasi IP Address sudah selesai, sekarang lanjut kita konfigurasikan routing static nya..

Disini kita akan konfigurasi routing static di IOS XR1 dan static default route di IOS XR2. Berikut konfigurasi static routing di IOS XR1

RP/0/0/CPU0:IOS-XR1(config)#router static address-family ipv4 unicast
2.2.2.2/32 12.12.12.2

RP/0/0/CPU0:IOS-XR1(config)#router static address-family ipv4 unicast
22.22.22.22/32 12.12.12.2

RP/0/0/CPU0:IOS-XR1(config)#commit

Untuk pengujian, kita bisa menggunakan perintah show run ataupun melihat tabel routing seperti berikut

RP/0/0/CPU0:IOS-XR1(config)#do sh run router static
Sat Jun 3 14:47:37.936 UTC
router static
address-family ipv4 unicast
2.2.2.2/32 12.12.12.2
22.22.22.22/32 12.12.12.2
!
!
RP/0/0/CPU0:IOS-XR1(config)#
do sh route
Gateway of last resort is not set

L 1.1.1.1/32 is directly connected, 00:05:46, Loopback0
S 2.2.2.2/32 [1/0] via 12.12.12.2, 00:00:42
L 11.11.11.11/32 is directly connected, 00:05:46, Loopback1
C 12.12.12.0/24 is directly connected, 00:06:57, GigabitEthernet0/0/0/0
L 12.12.12.1/32 is directly connected, 00:06:57, GigabitEthernet0/0/0/0
S 22.22.22.22/32 [1/0] via 12.12.12.2, 00:00:42

Oke.. saya rasa konfigurasi di IOS XR1 sudah selesai.. bisa difahami kan ya? meski perintahnya aga berbeda tapi konsepnya sama aja kog dengan IOS biasa..

Sekarang kita lanjut konfigurasi default route di IOS XR2

RP/0/0/CPU0:IOS-XR2(config)#router static address-family ipv4 unicast
0.0.0.0/0 12.12.12.1

RP/0/0/CPU0:IOS-XR2(config)#
commit
RP/0/0/CPU0:IOS-XR2(config)#
do sh route
Gateway of last resort is 12.12.12.1 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 12.12.12.1, 00:00:17
L 2.2.2.2/32 is directly connected, 00:06:28, Loopback0
C 12.12.12.0/24 is directly connected, 00:06:28, GigabitEthernet0/0/0/0
L 12.12.12.2/32 is directly connected, 00:06:28, GigabitEthernet0/0/0/0
L 22.22.22.22/32 is directly connected, 00:06:28, Loopback1

Oke.. saya rasa konfigurasi sudah selesai.. sekarang kita lakukan pengujian ping yaa..Berikut pengujian ping dari IOS XR1 ke loopback XR2

RP/0/0/CPU0:IOS-XR1(config)#do ping ipv4 2.2.2.2
Sat Jun 3 14:50:49.653 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/16/69 ms
RP/0/0/CPU0:IOS-XR1(config)#
do ping ipv4 22.22.22.22
Sat Jun 3 14:50:55.222 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke berhasil semua ya… sekarang kita coba ping dari IOS XR2 ke loopback XR1

RP/0/0/CPU0:IOS-XR2(config)#do ping ipv4 1.1.1.1
Sat Jun 3 14:51:41.599 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR2(config)#
do ping ipv4 11.11.11.11
Sat Jun 3 14:51:45.579 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Oke jalan semua ya…..

Alhamdulillah lab pertama kita tentang IOS XR sudah jalan.. sampai disini dulu ya.. sampai jumpa di artikel selanjutnya, In Syaa Allah masih akan tentang IOS XR..

Lab 142 – IOS XR Static Routing

Sejauh ini kita sudah belajar tentang Cisco IOS.. sekarang sudah saatnya untuk berkembang nih.. sekarang kita akan belajar tentang Cisco IOS XR..

apa sih bedanya antara Cisco IOS dengan Cisco IOS XR? Secara umum Cisco IOS XR lebih stabil dan memiliki fitur yang lebih advanced.. biasanya sih IOS XR digunakan di service provider.. sejauh ini itu sih yang saya tau tentang IOS XR,.. belum pernah implement juga sih.. hehehe

Oke langsung saja pada lab ini kita akan belajar konfigurasi static routing di IOS XR. berikut topologi yang akan kita gunakan pada lab ini

Nantinya kita akan menggunakan static routing di IOS XR-1 dan default route di IOS XR-2.

Pertama kita konfigurasikan IP Address pada IOS XR-1 dan 2 sesuai topologi diatas. Berikut konfigurasi di IOS-XR1

RP/0/0/CPU0:ios#conf t
Sat Jun 3 14:32:33.568 UTC
RP/0/0/CPU0:ios(config)#hostname IOS-XR1

Konfigurasi diatas belum masuk ke konfig IP sih.. tapi nyadar nda kalau ada yang beda? perhatikan bahwa setelah konfig hostname, tidak langsung berubah.. hal ini karena kita harus menggunakan perintah commit terlebih dahulu

RP/0/0/CPU0:ios(config)#commit
Sat Jun 3 14:34:34.429 UTC
RP/0/0/CPU0:
IOS-XR1(config)#

Perhatikan bahwa saat ini hostname sudah berubah. intinya kita harus mengetikkan perintah commit agar konfigurasi yg kita lakukan bisa dijalankan.

Oke sekarang kita konfigurasikan IP Address nya ya.. tapi sebelumnya kita coba lihat status interfacenya dulu

RP/0/0/CPU0:IOS-XR1(config)#do show ipv4 interface brief
Sat Jun 3 14:36:41.571 UTC

Interface IP-Address Status Protocol
GigabitEthernet0/0/0/0 unassigned Shutdown Down
GigabitEthernet0/0/0/1 unassigned Shutdown Down
GigabitEthernet0/0/0/2 unassigned Shutdown Down

Perhatikan bahwa perintah untuk melihat status interface pun sedikit berbeda dengan Cisco IOS. Selanjutnya berikut perintah untuk konfigurasi ip address di IOS XR

RP/0/0/CPU0:IOS-XR1(config)#int gi0/0/0/0
RP/0/0/CPU0:IOS-XR1(config-if)#no shutdown
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 address 12.12.12.1/24

Sekarang kita coba lihat status interface nya

RP/0/0/CPU0:IOS-XR1(config)#do show ipv4 interface brief
Sat Jun 3 14:36:41.571 UTC

Interface IP-Address Status Protocol
GigabitEthernet0/0/0/0 unassigned Shutdown Down
GigabitEthernet0/0/0/1 unassigned Shutdown Down
GigabitEthernet0/0/0/2 unassigned Shutdown Down

Nah lho.. kog masih belum ada konfignya? padahal kan kita sudah konfig…???

Hayoo.. sudah lupa kah? kan sudah saya bilang harus commit dulu… kita coba commit dulu yaa

RP/0/0/CPU0:IOS-XR1(config-if)#commit
RP/0/0/CPU0:IOS-XR1(config-if)#
do sho ipv4 int br
Sat Jun 3 14:41:06.273 UTC

Interface IP-Address Status Protocol
GigabitEthernet0/0/0/0 12.12.12.1 Up Up
GigabitEthernet0/0/0/1 unassigned Shutdown Down
GigabitEthernet0/0/0/2 unassigned Shutdown Down

Nah.. setelah commit baru deh konfig IP nya jalan.. Lanjut kita konfigurasi interface loopback nya ya

RP/0/0/CPU0:IOS-XR1(config-if)#int lo0
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 1.1.1.1/32

RP/0/0/CPU0:IOS-XR1(config-if)#int l1
RP/0/0/CPU0:IOS-XR1(config-if)#ipv4 add 11.11.11.11/32

RP/0/0/CPU0:IOS-XR1(config-if)#commit
Sat Jun 3 14:42:09.338 UTC

Kita coba lihat status interfacenya lagi

RP/0/0/CPU0:IOS-XR1(config-if)#do sh ipv4 int br
Sat Jun 3 14:42:30.357 UTC

Interface IP-Address Status Protocol
Loopback0 1.1.1.1 Up Up
Loopback1 11.11.11.11 Up Up
GigabitEthernet0/0/0/0 12.12.12.1 Up Up
GigabitEthernet0/0/0/1 unassigned Shutdown Down
GigabitEthernet0/0/0/2 unassigned Shutdown Down

Oke sudah sesuai ya.. sekarang lanjut kita konfigurasi di IOS XR-2

RP/0/0/CPU0:ios(config)#host IOS-XR2

RP/0/0/CPU0:ios(config)#
int g0/0/0/0
RP/0/0/CPU0:ios(config-if)#
no sh
RP/0/0/CPU0:ios(config-if)#
ipv4 add 12.12.12.2/24

RP/0/0/CPU0:ios(config-if)#
int l0
RP/0/0/CPU0:ios(config-if)#
ipv4 add 2.2.2.2/32

RP/0/0/CPU0:ios(config-if)#
int l1
RP/0/0/CPU0:ios(config-if)#
ipv4 add 22.22.22.22/32

RP/0/0/CPU0:ios(config-if)#
commit

RP/0/0/CPU0:IOS-XR2(config-if)#
do sh ipv4 int br
Sat Jun 3 14:43:42.482 UTC
Interface IP-Address Status Protocol
Loopback0 2.2.2.2 Up Up
Loopback1 22.22.22.22 Up Up
GigabitEthernet0/0/0/0 12.12.12.2 Up Up
GigabitEthernet0/0/0/1 unassigned Shutdown Down
GigabitEthernet0/0/0/2 unassigned Shutdown Down

Oke.. konfigurasi IP Address sudah selesai, sekarang lanjut kita konfigurasikan routing static nya..

Disini kita akan konfigurasi routing static di IOS XR1 dan static default route di IOS XR2. Berikut konfigurasi static routing di IOS XR1

RP/0/0/CPU0:IOS-XR1(config)#router static address-family ipv4 unicast
2.2.2.2/32 12.12.12.2

RP/0/0/CPU0:IOS-XR1(config)#router static address-family ipv4 unicast
22.22.22.22/32 12.12.12.2

RP/0/0/CPU0:IOS-XR1(config)#commit

Untuk pengujian, kita bisa menggunakan perintah show run ataupun melihat tabel routing seperti berikut

RP/0/0/CPU0:IOS-XR1(config)#do sh run router static
Sat Jun 3 14:47:37.936 UTC
router static
address-family ipv4 unicast
2.2.2.2/32 12.12.12.2
22.22.22.22/32 12.12.12.2
!
!
RP/0/0/CPU0:IOS-XR1(config)#
do sh route
Gateway of last resort is not set

L 1.1.1.1/32 is directly connected, 00:05:46, Loopback0
S 2.2.2.2/32 [1/0] via 12.12.12.2, 00:00:42
L 11.11.11.11/32 is directly connected, 00:05:46, Loopback1
C 12.12.12.0/24 is directly connected, 00:06:57, GigabitEthernet0/0/0/0
L 12.12.12.1/32 is directly connected, 00:06:57, GigabitEthernet0/0/0/0
S 22.22.22.22/32 [1/0] via 12.12.12.2, 00:00:42

Oke.. saya rasa konfigurasi di IOS XR1 sudah selesai.. bisa difahami kan ya? meski perintahnya aga berbeda tapi konsepnya sama aja kog dengan IOS biasa..

Sekarang kita lanjut konfigurasi default route di IOS XR2

RP/0/0/CPU0:IOS-XR2(config)#router static address-family ipv4 unicast
0.0.0.0/0 12.12.12.1

RP/0/0/CPU0:IOS-XR2(config)#
commit
RP/0/0/CPU0:IOS-XR2(config)#
do sh route
Gateway of last resort is 12.12.12.1 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 12.12.12.1, 00:00:17
L 2.2.2.2/32 is directly connected, 00:06:28, Loopback0
C 12.12.12.0/24 is directly connected, 00:06:28, GigabitEthernet0/0/0/0
L 12.12.12.2/32 is directly connected, 00:06:28, GigabitEthernet0/0/0/0
L 22.22.22.22/32 is directly connected, 00:06:28, Loopback1

Oke.. saya rasa konfigurasi sudah selesai.. sekarang kita lakukan pengujian ping yaa..Berikut pengujian ping dari IOS XR1 ke loopback XR2

RP/0/0/CPU0:IOS-XR1(config)#do ping ipv4 2.2.2.2
Sat Jun 3 14:50:49.653 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/16/69 ms
RP/0/0/CPU0:IOS-XR1(config)#
do ping ipv4 22.22.22.22
Sat Jun 3 14:50:55.222 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 22.22.22.22, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

Oke berhasil semua ya… sekarang kita coba ping dari IOS XR2 ke loopback XR1

RP/0/0/CPU0:IOS-XR2(config)#do ping ipv4 1.1.1.1
Sat Jun 3 14:51:41.599 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
RP/0/0/CPU0:IOS-XR2(config)#
do ping ipv4 11.11.11.11
Sat Jun 3 14:51:45.579 UTC
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Oke jalan semua ya…..

Alhamdulillah lab pertama kita tentang IOS XR sudah jalan.. sampai disini dulu ya.. sampai jumpa di artikel selanjutnya, In Syaa Allah masih akan tentang IOS XR..