Konfigurasi VLAN pada Switch Catalyst Cisco

Switch bekerja pada Layer2, dan secara default seluruh port interface Switch berada dalam satu Broadcast Domain yang sama atau satu Network yang sama. Tetapi pada Switch manageable seperti Cisco Catalyst memiliki sebuah fitur teknologi VLAN (Virtual LAN), yaitu teknologi pada Switch yang dapat membagi-bagi satu Switch menjadi beberapa Brodcast Domain yang berbeda-beda, sehingga dalam satu Switch menjadi seperti terdapat lebih dari satu jaringan LAN. Secara default seluruh port  interface pada Switch Cisco berada di VLAN-ID 1 atau VLAN default.

VLAN menggunakan VLAN-ID untuk mengidentifikasi suatu port-interface berada di VLAN mana dan juga untuk membedakan Brodcast domain yang ada pada Switch. Terdapat beberapa VLAN-ID yang dapat digunakan dan juga tidak, yaitu :

  • VLAN 1 : VLAN default pada Switch Cisco jika belum dikonfigurasi VLAN, tidak dapat dimodifikasi, dan dihapus.
  • VLAN 1 – 1005 : VLAN yang dapat digunakan untuk dibuat, dihapus, atau dimodifikasi.
Ketika frame memasuki suatu port interface dengan VLAN ID tertentu, maka frame tersebut akan ditandai dengan VLAN ID tersebut, dan frame itu hanya akan dikirimkan pada port interface yang memiliki VLAN ID sama dengan VLAN ID pada frame tersebut, dan juga pada jalur Trunk jika masuk dalam daftar. Untuk mengirimkan paket antar VLAN yang berbeda, diperlukan sebuah Router untuk melakukannya.
Untuk melakukan konfigurasi VLAN pada Switch Cisco Catalyst, berikut ini adalah sintaks konfigurasinya :
  • Buat beberapa VLAN yang nantinya akan digunakan.
  • Switch(config)#vlan [vlan-id]
  • Dan jika perlu berikan nama pada tiap VLAN -nya.
  • Switch(config-vlan)#name [nama]
  • Dan kemudian masuk pada sebuah Interface, lalu assign vlan pada Inteface tersebut.
  • Switch(config)#interface [slot/number]
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan [vlan-id]

Dan kemudian sekarang kita akan mencoba melakukan praktek VLAN pada topologi ini.

Pertama kita buat VLAN 10 dan 20 pada Switch, dan berikan nama jika diperlukan.

    Switch(config)#vlan 10
    Switch(config-vlan)#name sepuluh
    Switch(config-vlan)#exi
    Switch(config)#vlan 20
    Switch(config-vlan)#name duapuluh
    Switch(config-vlan)#exi

Kemudian assign VLAN tersebut pada interface yang diinginkan.

    Switch(config)#int ra e0/0-1
    Switch(config-if-range)#sw mo acc
    Switch(config-if-range)#sw acc vl 10
    Switch(config-if-range)#exi
    Switch(config)#int ra e0/2-3
    Switch(config-if-range)#sw mo acc
    Switch(config-if-range)#sw acc vl 20
    Switch(config-if-range)#exi

Untuk memastikan VLAN yang telah kita buat, kita dapat melihat VLAN Database pada Switch dengan perintah show vlan brief.

    Switch#sh vlan brief 

    VLAN Name Status Ports
    ---- -------------------------------- --------- -------------------------------
    1 default active Et1/0, Et1/1, Et1/2, Et1/3
    Et2/0, Et2/1, Et2/2, Et2/3
    Et3/0, Et3/1, Et3/2, Et3/3
    10 sepuluh active Et0/0, Et0/1
    20 duapuluh active Et0/2, Et0/3

    1002 fddi-default act/unsup
    1003 token-ring-default act/unsup
    1004 fddinet-default act/unsup
    1005 trnet-default act/unsup

Kemudian kita berikan IP Address pada masing-masing VPCS. Untuk VLAN 10 (10.10.10.0/24) dan VLAN 20 (20.20.20.0/24).

    VLAN 10

    PC1> ip 10.10.10.2/24
    Checking for duplicate address...
    PC1 : 10.10.10.2 255.255.255.0

    PC2> ip 10.10.10.3/24
    Checking for duplicate address...
    PC1 : 10.10.10.3 255.255.255.0

    VLAN 20

    PC3> ip 20.20.20.3/24
    Checking for duplicate address...
    PC1 : 20.20.20.3 255.255.255.0

    PC4> ip 20.20.20.4/24
    Checking for duplicate address...
    PC1 : 20.20.20.4 255.255.255.0

    Setelah itu coba lakukan PING antar PC dalam satu VLAN yang sama.

    PC1> ping 10.10.10.3

    84 bytes from 10.10.10.3 icmp_seq=1 ttl=64 time=0.437 ms
    84 bytes from 10.10.10.3 icmp_seq=2 ttl=64 time=0.386 ms
    84 bytes from 10.10.10.3 icmp_seq=3 ttl=64 time=0.864 ms
    84 bytes from 10.10.10.3 icmp_seq=4 ttl=64 time=0.525 ms
    84 bytes from 10.10.10.3 icmp_seq=5 ttl=64 time=0.592 ms

    PC4> ping 20.20.20.3

    84 bytes from 20.20.20.3 icmp_seq=1 ttl=64 time=0.560 ms
    84 bytes from 20.20.20.3 icmp_seq=2 ttl=64 time=0.637 ms
    84 bytes from 20.20.20.3 icmp_seq=3 ttl=64 time=0.936 ms
    84 bytes from 20.20.20.3 icmp_seq=4 ttl=64 time=0.527 ms
    84 bytes from 20.20.20.3 icmp_seq=5 ttl=64 time=0.597 ms

    Jika kita lakukan PING antar PC yang berbeda VLAN maka tidak dapat sampai paket PING (ICMP) nya.

    PC1> ping 20.20.20.3

    No gateway found

    Karena jika sudah berbeda VLAN, Switch tidak akan pernah mengirimkannya pada PC tujuan karena sudah berbeda VLAN dan juga Network/Broadcast Domain. Agar antar VLAN dapat berkomunikasi dibutuhkan sebuah Router yang akan melakukan Inter-VLAN Routing (Router on Stick)

Konfigurasi VLAN pada Switch Catalyst Cisco

Switch bekerja pada Layer2, dan secara default seluruh port interface Switch berada dalam satu Broadcast Domain yang sama atau satu Network yang sama. Tetapi pada Switch manageable seperti Cisco Catalyst memiliki sebuah fitur teknologi VLAN (Virtual LAN), yaitu teknologi pada Switch yang dapat membagi-bagi satu Switch menjadi beberapa Brodcast Domain yang berbeda-beda, sehingga dalam satu Switch menjadi seperti terdapat lebih dari satu jaringan LAN. Secara default seluruh port  interface pada Switch Cisco berada di VLAN-ID 1 atau VLAN default.

VLAN menggunakan VLAN-ID untuk mengidentifikasi suatu port-interface berada di VLAN mana dan juga untuk membedakan Brodcast domain yang ada pada Switch. Terdapat beberapa VLAN-ID yang dapat digunakan dan juga tidak, yaitu :

  • VLAN 1 : VLAN default pada Switch Cisco jika belum dikonfigurasi VLAN, tidak dapat dimodifikasi, dan dihapus.
  • VLAN 1 – 1005 : VLAN yang dapat digunakan untuk dibuat, dihapus, atau dimodifikasi.
Ketika frame memasuki suatu port interface dengan VLAN ID tertentu, maka frame tersebut akan ditandai dengan VLAN ID tersebut, dan frame itu hanya akan dikirimkan pada port interface yang memiliki VLAN ID sama dengan VLAN ID pada frame tersebut, dan juga pada jalur Trunk jika masuk dalam daftar. Untuk mengirimkan paket antar VLAN yang berbeda, diperlukan sebuah Router untuk melakukannya.
Untuk melakukan konfigurasi VLAN pada Switch Cisco Catalyst, berikut ini adalah sintaks konfigurasinya :
  • Buat beberapa VLAN yang nantinya akan digunakan.
  • Switch(config)#vlan [vlan-id]
  • Dan jika perlu berikan nama pada tiap VLAN -nya.
  • Switch(config-vlan)#name [nama]
  • Dan kemudian masuk pada sebuah Interface, lalu assign vlan pada Inteface tersebut.
  • Switch(config)#interface [slot/number]
    Switch(config-if)#switchport mode access
    Switch(config-if)#switchport access vlan [vlan-id]

Dan kemudian sekarang kita akan mencoba melakukan praktek VLAN pada topologi ini.

Pertama kita buat VLAN 10 dan 20 pada Switch, dan berikan nama jika diperlukan.

    Switch(config)#vlan 10
    Switch(config-vlan)#name sepuluh
    Switch(config-vlan)#exi
    Switch(config)#vlan 20
    Switch(config-vlan)#name duapuluh
    Switch(config-vlan)#exi

Kemudian assign VLAN tersebut pada interface yang diinginkan.

    Switch(config)#int ra e0/0-1
    Switch(config-if-range)#sw mo acc
    Switch(config-if-range)#sw acc vl 10
    Switch(config-if-range)#exi
    Switch(config)#int ra e0/2-3
    Switch(config-if-range)#sw mo acc
    Switch(config-if-range)#sw acc vl 20
    Switch(config-if-range)#exi

Untuk memastikan VLAN yang telah kita buat, kita dapat melihat VLAN Database pada Switch dengan perintah show vlan brief.

    Switch#sh vlan brief 

    VLAN Name Status Ports
    ---- -------------------------------- --------- -------------------------------
    1 default active Et1/0, Et1/1, Et1/2, Et1/3
    Et2/0, Et2/1, Et2/2, Et2/3
    Et3/0, Et3/1, Et3/2, Et3/3
    10 sepuluh active Et0/0, Et0/1
    20 duapuluh active Et0/2, Et0/3

    1002 fddi-default act/unsup
    1003 token-ring-default act/unsup
    1004 fddinet-default act/unsup
    1005 trnet-default act/unsup

Kemudian kita berikan IP Address pada masing-masing VPCS. Untuk VLAN 10 (10.10.10.0/24) dan VLAN 20 (20.20.20.0/24).

    VLAN 10

    PC1> ip 10.10.10.2/24
    Checking for duplicate address...
    PC1 : 10.10.10.2 255.255.255.0

    PC2> ip 10.10.10.3/24
    Checking for duplicate address...
    PC1 : 10.10.10.3 255.255.255.0

    VLAN 20

    PC3> ip 20.20.20.3/24
    Checking for duplicate address...
    PC1 : 20.20.20.3 255.255.255.0

    PC4> ip 20.20.20.4/24
    Checking for duplicate address...
    PC1 : 20.20.20.4 255.255.255.0

    Setelah itu coba lakukan PING antar PC dalam satu VLAN yang sama.

    PC1> ping 10.10.10.3

    84 bytes from 10.10.10.3 icmp_seq=1 ttl=64 time=0.437 ms
    84 bytes from 10.10.10.3 icmp_seq=2 ttl=64 time=0.386 ms
    84 bytes from 10.10.10.3 icmp_seq=3 ttl=64 time=0.864 ms
    84 bytes from 10.10.10.3 icmp_seq=4 ttl=64 time=0.525 ms
    84 bytes from 10.10.10.3 icmp_seq=5 ttl=64 time=0.592 ms

    PC4> ping 20.20.20.3

    84 bytes from 20.20.20.3 icmp_seq=1 ttl=64 time=0.560 ms
    84 bytes from 20.20.20.3 icmp_seq=2 ttl=64 time=0.637 ms
    84 bytes from 20.20.20.3 icmp_seq=3 ttl=64 time=0.936 ms
    84 bytes from 20.20.20.3 icmp_seq=4 ttl=64 time=0.527 ms
    84 bytes from 20.20.20.3 icmp_seq=5 ttl=64 time=0.597 ms

    Jika kita lakukan PING antar PC yang berbeda VLAN maka tidak dapat sampai paket PING (ICMP) nya.

    PC1> ping 20.20.20.3

    No gateway found

    Karena jika sudah berbeda VLAN, Switch tidak akan pernah mengirimkannya pada PC tujuan karena sudah berbeda VLAN dan juga Network/Broadcast Domain. Agar antar VLAN dapat berkomunikasi dibutuhkan sebuah Router yang akan melakukan Inter-VLAN Routing (Router on Stick)

Konfigurasi BGP peering eBGP pada Cisco

Sebelumnya saya sudah membahas tentang peering iBGP atau hubungan neighbor/adjacencies antar Router BGP dalam satu AS yang sama. Sekarang saya akan membahas tentang peering eBGP yang merupakan kebalikan dari iBGP yaitu hubungan neighbor antar Router BGP antar AS yang berbeda, sesuai namanya eBGP (external BGP). Pada BGP tidak terdapat fitur Neighbor Discovery atau pencarian neighbor Router secara otomatis, itulah sebabnya sebelum dapat membagikan informasi Routing dengan BGP pertama harus melakukan peering antar Router secara manual.

Peering antar Router BGP yang berbeda AS ini ada beberapa aturan, berikut ini adalah beberapa yang saya ketahui :

  • Peering eBGP tidak perlu full mesh, karena Router BGP dapat meneruskan informasi dari satu Router ke Router lainnya yang berada di AS yang berbeda.
  • Untuk melakukan peering, antar Router yang ingin dihubungkan harus terhubung langsung atau Directly connected, karena secara default paket-paket yang dikirimkan dengan eBGP TTL nya hanya 1.
  • Setiap mengirimkan informasi pada Router yang berbeda AS, maka atribut atribut yang ada pada informasi tersebut akan diubah, tidak seperti iBGP yang tidak diubah atribut-atributnya.
Setelah saya membahas sedikit teori tentang eBGP sekarang saya akan menunjukan sintaks dan cara konfigurasinya pada Cisco :
  • Aktifkan BGP pada nomor AS tertentu.
  • Router(config)# router bgp [AS-Number]
  • Kemudian konfigurasi peering pada alamat IP Router tetangga.
  • Router(config-router)# neighbor [x.x.x.x] remote-as [AS-Number]
  • Dan konfigurasi network-network yang akan didistribusikan.
  • Router(config-router)# network [x.x.x.x] mask [m.m.m.m]

Setelah sintaks dan cara konfigurasi sekarang kita akan coba praktekan pada topologi dibawah ini.

Tiga Router diatas menggunakan BGP untuk menghubungkan satu sama lain, ketiganya berada di AS yang berbeda maka peering yang akan kita gunakan adalah eBGP. Kemudian antar Router tersebut akan mengirimkan informasi Routing satu sama lain.

Konfigurasi

Pertama kita lakukan konfigurasi mendasar pada masing-masing Router, yaitu konfigurasi IP Address pada tiap Interface Router.

    Router R1

    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi

    Router R2

    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi

    Router R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi

Setelah konfigurasi IP Address selesai sekarang kita lanjut konfigurasi BGP pada masing-masing Router.

    Router R1

    Pertama konfigurasi eBGP peering terlebih dahulu.

    R1(config)#router bgp 10
    R1(config-router)#neighbor 12.12.12.2 remote-as 20

    Barulah masukan network-network yang ingin didistribusikan.

    R1(config-router)#net 12.12.12.0 mask 255.255.255.0
    R1(config-router)#net 1.1.1.1 mask 255.255.255.255
    R1(config-router)#exi

    Router R2

    R2(config)#router bgp 20
    R2(config-router)#neighbor 12.12.12.1 remote-as 10
    R2(config-router)#neighbor 23.23.23.3 remote-as 30
    R2(config-router)#net 12.12.12.0 mask 255.255.255.0
    R2(config-router)#net 23.23.23.0 mask 255.255.255.0
    R2(config-router)#net 2.2.2.2 mask 255.255.255.255
    R2(config-router)#exi

    Router R3

    R3(config)#router bgp 30
    R3(config-router)#neighbor 23.23.23.2 remote-as 20
    R3(config-router)#net 23.23.23.0 mask 255.255.255.0
    R3(config-router)#net 3.3.3.3 mask 255.255.255.255
    R3(config-router)#exi

Konfirmasi

Setelah selesai konfigurasi, sekarang kita konfirmasi untuk melihat hasil dari konfigurasi yang kita lakukan, coba cek BGP Routing table pada salah satu Router.

R1#sh bgp
BGP table version is 6, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 0.0.0.0 0 32768 i
*> 2.2.2.2/32 12.12.12.2 0 0 20 i
*> 3.3.3.3/32 12.12.12.2 0 20 30 i
* 12.12.12.0/24 12.12.12.2 0 0 20 i
*> 0.0.0.0 0 32768 i
*> 23.23.23.0/24 12.12.12.2 0 0 20 i

Dan sekarang kita lihat pada main Routing table.

R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
B 2.2.2.2 [20/0] via 12.12.12.2, 00:06:27
3.0.0.0/32 is subnetted, 1 subnets
B 3.3.3.3 [20/0] via 12.12.12.2, 00:05:22
12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.1/32 is directly connected, Ethernet0/0
23.0.0.0/24 is subnetted, 1 subnets
B 23.23.23.0 [20/0] via 12.12.12.2, 00:06:27

Kemudian lakukan PING pada interface loopback tiap Router.

R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Konfigurasi BGP peering eBGP pada Cisco

Sebelumnya saya sudah membahas tentang peering iBGP atau hubungan neighbor/adjacencies antar Router BGP dalam satu AS yang sama. Sekarang saya akan membahas tentang peering eBGP yang merupakan kebalikan dari iBGP yaitu hubungan neighbor antar Router BGP antar AS yang berbeda, sesuai namanya eBGP (external BGP). Pada BGP tidak terdapat fitur Neighbor Discovery atau pencarian neighbor Router secara otomatis, itulah sebabnya sebelum dapat membagikan informasi Routing dengan BGP pertama harus melakukan peering antar Router secara manual.

Peering antar Router BGP yang berbeda AS ini ada beberapa aturan, berikut ini adalah beberapa yang saya ketahui :

  • Peering eBGP tidak perlu full mesh, karena Router BGP dapat meneruskan informasi dari satu Router ke Router lainnya yang berada di AS yang berbeda.
  • Untuk melakukan peering, antar Router yang ingin dihubungkan harus terhubung langsung atau Directly connected, karena secara default paket-paket yang dikirimkan dengan eBGP TTL nya hanya 1.
  • Setiap mengirimkan informasi pada Router yang berbeda AS, maka atribut atribut yang ada pada informasi tersebut akan diubah, tidak seperti iBGP yang tidak diubah atribut-atributnya.
Setelah saya membahas sedikit teori tentang eBGP sekarang saya akan menunjukan sintaks dan cara konfigurasinya pada Cisco :
  • Aktifkan BGP pada nomor AS tertentu.
  • Router(config)# router bgp [AS-Number]
  • Kemudian konfigurasi peering pada alamat IP Router tetangga.
  • Router(config-router)# neighbor [x.x.x.x] remote-as [AS-Number]
  • Dan konfigurasi network-network yang akan didistribusikan.
  • Router(config-router)# network [x.x.x.x] mask [m.m.m.m]

Setelah sintaks dan cara konfigurasi sekarang kita akan coba praktekan pada topologi dibawah ini.

Tiga Router diatas menggunakan BGP untuk menghubungkan satu sama lain, ketiganya berada di AS yang berbeda maka peering yang akan kita gunakan adalah eBGP. Kemudian antar Router tersebut akan mengirimkan informasi Routing satu sama lain.

Konfigurasi

Pertama kita lakukan konfigurasi mendasar pada masing-masing Router, yaitu konfigurasi IP Address pada tiap Interface Router.

    Router R1

    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi

    Router R2

    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi

    Router R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi

Setelah konfigurasi IP Address selesai sekarang kita lanjut konfigurasi BGP pada masing-masing Router.

    Router R1

    Pertama konfigurasi eBGP peering terlebih dahulu.

    R1(config)#router bgp 10
    R1(config-router)#neighbor 12.12.12.2 remote-as 20

    Barulah masukan network-network yang ingin didistribusikan.

    R1(config-router)#net 12.12.12.0 mask 255.255.255.0
    R1(config-router)#net 1.1.1.1 mask 255.255.255.255
    R1(config-router)#exi

    Router R2

    R2(config)#router bgp 20
    R2(config-router)#neighbor 12.12.12.1 remote-as 10
    R2(config-router)#neighbor 23.23.23.3 remote-as 30
    R2(config-router)#net 12.12.12.0 mask 255.255.255.0
    R2(config-router)#net 23.23.23.0 mask 255.255.255.0
    R2(config-router)#net 2.2.2.2 mask 255.255.255.255
    R2(config-router)#exi

    Router R3

    R3(config)#router bgp 30
    R3(config-router)#neighbor 23.23.23.2 remote-as 20
    R3(config-router)#net 23.23.23.0 mask 255.255.255.0
    R3(config-router)#net 3.3.3.3 mask 255.255.255.255
    R3(config-router)#exi

Konfirmasi

Setelah selesai konfigurasi, sekarang kita konfirmasi untuk melihat hasil dari konfigurasi yang kita lakukan, coba cek BGP Routing table pada salah satu Router.

R1#sh bgp
BGP table version is 6, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 0.0.0.0 0 32768 i
*> 2.2.2.2/32 12.12.12.2 0 0 20 i
*> 3.3.3.3/32 12.12.12.2 0 20 30 i
* 12.12.12.0/24 12.12.12.2 0 0 20 i
*> 0.0.0.0 0 32768 i
*> 23.23.23.0/24 12.12.12.2 0 0 20 i

Dan sekarang kita lihat pada main Routing table.

R1#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C 1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
B 2.2.2.2 [20/0] via 12.12.12.2, 00:06:27
3.0.0.0/32 is subnetted, 1 subnets
B 3.3.3.3 [20/0] via 12.12.12.2, 00:05:22
12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.1/32 is directly connected, Ethernet0/0
23.0.0.0/24 is subnetted, 1 subnets
B 23.23.23.0 [20/0] via 12.12.12.2, 00:06:27

Kemudian lakukan PING pada interface loopback tiap Router.

R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Konfigurasi iBGP Peering pada Cisco

Pada kali ini saya akan membahas tentang Routing Protocol BGP. Routing protocol BGP (Border Gateway Protocol) ini masuk dalam kategori Exterior Gateway Protocol yang artinya BGP dikhususkan untuk menghubungkan antar Autonomous System yang berbeda atau mengirimkan informasi Routing antar AS yang berbeda. Sebelum BGP dapat membagikan informasi Routing pada Router lainnya, pertama antar Router BGP harus membentuk hubungan tetangga yang disebut dengan Peering. Dalam BGP ada dua jenis peering yaitu iBGP dan eBGP kali ini saya akan membahas lebih dalam tentang iBGP.

Peering iBGP (internal BGP) adalah hubungan tetangga antar Router BGP yang masih dalam satu AS yang sama. iBGP biasanya dilakukan jika suatu AS memiliki dua atau lebih Router BGP yang berfungsi sebagai pintu masuk dan keluar informasi Routing, dan kemudian antar pintu tersebut atau Router BGP dihubungkan dengan peering agar informasi Routing tersebut dapat melewati AS ini untuk menuju AS berikutnya. Dalam iBGP peering terdapat beberapa aturan yaitu :

  • Peering iBGP harus full mesh pada antar Router, ini dikarenakan antar Router yang terhubung dengan iBGP tidak dapat meneruskan informasi Routing dari satu iBGP peer pada iBGP peer lainnya, semuanya harus dikirimkan langsung oleh pengirim informasi, dan diterima secara langsung oleh penerimanya. Bisa dibilang informasi Routing yang dikirim tanpa perantara Router lain.
  • Ketika informasi Routing dikirimkan pada antar iBGP Peer, informasi Routing tersebut harus ada dalam Routing table Routing Protocol IGP seperti OSPF, EIGRP, dll. jika tidak maka informasi Routing tersebut tidak akan sampai pada tujuannya. Ini disebut juga dengan Synchronization.
  • Ketika Router BGP menerima informasi dari eBGP kemudian akan diteruskan pada Router yang terhubung dengan iBGP maka atribut-atribut pada informasi Routing tersebut tidak akan diubah, termasuk next-hop atau gateway-nya akan tetap murni yang didapat dari eBGP peer sebelumnya.
Setelah saya bahas sedikit tentang teori iBGP sekarang kita perlu mengetahui sintaks untuk melakukan iBGP peering dan cara mendistribusikan informasi Routing menggunakan BGP dengan koneksi iBGP. Berikut ini adalah sintaksnya :
  • Aktifkan BGP pada nomor AS tertentu.
  • Router(config)# router bgp [AS-Number]
  • Kemudian konfigurasi peering pada alamat IP Router tetangga.
  • Router(config-router)# neighbor [x.x.x.x] remote-as [AS-Number]
  • Dan konfigurasi network-network yang akan didistribusikan.
  • Router(config-router)# network [x.x.x.x] mask [m.m.m.m]

Setelah mengetahui sintaks dan cara konfigurasinya sekarang kita coba praktekan pada topologi dibawah ini :

Tiga Router tersebut akan saling kita hubungkan dengan iBGP Peering, koneksi iBGP seluruhnya secara langsung, R1 dengan R2 dan R3, R2 dengan R1 dan R3, dan R3 dengan R1 dan R2. Dan kita juga akan mengkonfigurasi EIGRP agar alamat IP interaface Router dapat dijangkau pada seluruh Router lainnya.

Konfigurasi

Pertama kita konfigurasi beberapa hal-hal mendasar seperti IP Address pada tiap Interface Router, dan juga membuat sebuah interface loopback. Dan juga langsung saja konfigurasi EIGRP.

    Router R1

    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi

    Kemudian konfigurasi EIGRP

    R1(config)#router eigrp 1
    R1(config-router)#no auto-summ
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#exi

    Router R2

    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi
    R2(config)#router eigrp 1
    R2(config-router)#no auto-summ
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#exi

    Router R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#router eigrp 1
    R3(config-router)#no auto-sum
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#exi

Setelah beberapa konfigurasi mendasar selesai sekarang kita konfigurasi BGP pada masing-masing Router ini.

    Router R1

    Pertama aktifkan BGP pada nomor AS tertentu, dan nomor AS harus disamakan pada Router berikutnya, kemudian masukan alamat IP Neighbor atau Router yang ingin dihubungkan dengan iBGP. Konfigurasi peering ke R2 dan R3.

    R1(config)#router bgp 1
    R1(config-router)#neighbor 12.12.12.2 remote-as 1
    R1(config-router)#neighbor 23.23.23.3 remote-as 1

    Kemudian masukan network yang ingin didistribusikan, saya akan mendistribusikan network yang ada di interface loopback.

    R1(config-router)#network 1.1.1.1 mask 255.255.255.255
    R1(config-router)#exi

    Router R2

    R2(config)#router bgp 1
    R2(config-router)#neighbor 12.12.12.1 remote-as 1
    R2(config-router)#neighbor 23.23.23.3 remote-as 1
    R2(config-router)#net 2.2.2.2 mask 255.255.255.255
    R2(config-router)#exi

    Router R3

    R3(config)#router bgp 1
    R3(config-router)#neighbor 12.12.12.1 remote-as 1
    R3(config-router)#neighbor 23.23.23.2 remote-as 1
    R3(config-router)#net 3.3.3.3 mask 255.255.255.255
    R3(config-router)#exi

Konfirmasi

Setelah konfigurasi selesai sekarang kita tinggal konfirmasi pada BGP Routing table, dan main Routing table apakah informasi antar Router sudah sampai. Cek BGP Routing table salah satu Router :

R1#sh bgp
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 0.0.0.0 0 32768 i
*>i 2.2.2.2/32 12.12.12.2 0 100 0 i
*>i 3.3.3.3/32 23.23.23.3 0 100 0 i

Kita bisa lihat tulisan yang ditebalkan merupakan informasi yang didapatkan oleh BGP, dan asalnya dari AS yang sama (internal). Kemudian kita cek ping pada interface loopback tersebut.

R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#

Konfigurasi iBGP Peering pada Cisco

Pada kali ini saya akan membahas tentang Routing Protocol BGP. Routing protocol BGP (Border Gateway Protocol) ini masuk dalam kategori Exterior Gateway Protocol yang artinya BGP dikhususkan untuk menghubungkan antar Autonomous System yang berbeda atau mengirimkan informasi Routing antar AS yang berbeda. Sebelum BGP dapat membagikan informasi Routing pada Router lainnya, pertama antar Router BGP harus membentuk hubungan tetangga yang disebut dengan Peering. Dalam BGP ada dua jenis peering yaitu iBGP dan eBGP kali ini saya akan membahas lebih dalam tentang iBGP.

Peering iBGP (internal BGP) adalah hubungan tetangga antar Router BGP yang masih dalam satu AS yang sama. iBGP biasanya dilakukan jika suatu AS memiliki dua atau lebih Router BGP yang berfungsi sebagai pintu masuk dan keluar informasi Routing, dan kemudian antar pintu tersebut atau Router BGP dihubungkan dengan peering agar informasi Routing tersebut dapat melewati AS ini untuk menuju AS berikutnya. Dalam iBGP peering terdapat beberapa aturan yaitu :

  • Peering iBGP harus full mesh pada antar Router, ini dikarenakan antar Router yang terhubung dengan iBGP tidak dapat meneruskan informasi Routing dari satu iBGP peer pada iBGP peer lainnya, semuanya harus dikirimkan langsung oleh pengirim informasi, dan diterima secara langsung oleh penerimanya. Bisa dibilang informasi Routing yang dikirim tanpa perantara Router lain.
  • Ketika informasi Routing dikirimkan pada antar iBGP Peer, informasi Routing tersebut harus ada dalam Routing table Routing Protocol IGP seperti OSPF, EIGRP, dll. jika tidak maka informasi Routing tersebut tidak akan sampai pada tujuannya. Ini disebut juga dengan Synchronization.
  • Ketika Router BGP menerima informasi dari eBGP kemudian akan diteruskan pada Router yang terhubung dengan iBGP maka atribut-atribut pada informasi Routing tersebut tidak akan diubah, termasuk next-hop atau gateway-nya akan tetap murni yang didapat dari eBGP peer sebelumnya.
Setelah saya bahas sedikit tentang teori iBGP sekarang kita perlu mengetahui sintaks untuk melakukan iBGP peering dan cara mendistribusikan informasi Routing menggunakan BGP dengan koneksi iBGP. Berikut ini adalah sintaksnya :
  • Aktifkan BGP pada nomor AS tertentu.
  • Router(config)# router bgp [AS-Number]
  • Kemudian konfigurasi peering pada alamat IP Router tetangga.
  • Router(config-router)# neighbor [x.x.x.x] remote-as [AS-Number]
  • Dan konfigurasi network-network yang akan didistribusikan.
  • Router(config-router)# network [x.x.x.x] mask [m.m.m.m]

Setelah mengetahui sintaks dan cara konfigurasinya sekarang kita coba praktekan pada topologi dibawah ini :

Tiga Router tersebut akan saling kita hubungkan dengan iBGP Peering, koneksi iBGP seluruhnya secara langsung, R1 dengan R2 dan R3, R2 dengan R1 dan R3, dan R3 dengan R1 dan R2. Dan kita juga akan mengkonfigurasi EIGRP agar alamat IP interaface Router dapat dijangkau pada seluruh Router lainnya.

Konfigurasi

Pertama kita konfigurasi beberapa hal-hal mendasar seperti IP Address pada tiap Interface Router, dan juga membuat sebuah interface loopback. Dan juga langsung saja konfigurasi EIGRP.

    Router R1

    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi
    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi

    Kemudian konfigurasi EIGRP

    R1(config)#router eigrp 1
    R1(config-router)#no auto-summ
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#exi

    Router R2

    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi
    R2(config)#router eigrp 1
    R2(config-router)#no auto-summ
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#exi

    Router R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#router eigrp 1
    R3(config-router)#no auto-sum
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#exi

Setelah beberapa konfigurasi mendasar selesai sekarang kita konfigurasi BGP pada masing-masing Router ini.

    Router R1

    Pertama aktifkan BGP pada nomor AS tertentu, dan nomor AS harus disamakan pada Router berikutnya, kemudian masukan alamat IP Neighbor atau Router yang ingin dihubungkan dengan iBGP. Konfigurasi peering ke R2 dan R3.

    R1(config)#router bgp 1
    R1(config-router)#neighbor 12.12.12.2 remote-as 1
    R1(config-router)#neighbor 23.23.23.3 remote-as 1

    Kemudian masukan network yang ingin didistribusikan, saya akan mendistribusikan network yang ada di interface loopback.

    R1(config-router)#network 1.1.1.1 mask 255.255.255.255
    R1(config-router)#exi

    Router R2

    R2(config)#router bgp 1
    R2(config-router)#neighbor 12.12.12.1 remote-as 1
    R2(config-router)#neighbor 23.23.23.3 remote-as 1
    R2(config-router)#net 2.2.2.2 mask 255.255.255.255
    R2(config-router)#exi

    Router R3

    R3(config)#router bgp 1
    R3(config-router)#neighbor 12.12.12.1 remote-as 1
    R3(config-router)#neighbor 23.23.23.2 remote-as 1
    R3(config-router)#net 3.3.3.3 mask 255.255.255.255
    R3(config-router)#exi

Konfirmasi

Setelah konfigurasi selesai sekarang kita tinggal konfirmasi pada BGP Routing table, dan main Routing table apakah informasi antar Router sudah sampai. Cek BGP Routing table salah satu Router :

R1#sh bgp
BGP table version is 5, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.1/32 0.0.0.0 0 32768 i
*>i 2.2.2.2/32 12.12.12.2 0 100 0 i
*>i 3.3.3.3/32 23.23.23.3 0 100 0 i

Kita bisa lihat tulisan yang ditebalkan merupakan informasi yang didapatkan oleh BGP, dan asalnya dari AS yang sama (internal). Kemudian kita cek ping pada interface loopback tersebut.

R1#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R1#

Konfigurasi EIGRP manual Summarization

Pada EIGRP kita dapat melakukan Summarization terhadap Alamat IP network-network yang ingin didistribusikan. Apa itu Summarization? dalam bahasa Indonesia artinya meringkas, jadi EIGRP Summarization ini adalah fitur untuk meringkas beberapa Alamat IP Network-network yang banyak menjadi satu saja yang dapat mewakili semuanya. Tujuan dari Summarization ini adalah untuk memperkecil jumlah entri dalam Routing table dengan cara meringkasnya.

Cara meringkas beberapa IP Network menjadi satu adalah dengan mencari Subnet Mask atau prefix yang dapat menjangkau semua IP Network yang ingin diringkas. Contoh sederhananya adalah sebagai berikut :
  • 10.10.10.1/32
  • 10.10.10.2/32
  • 10.10.10.3/32
  • 10.10.10.4/32
  • 10.10.10.5/32
  • 10.10.10.6/32
  • 10.10.10.7/32
Oktet dari satu hingga ke tiga sama, sedangkan yang ke empat berbeda, maka sudah dipastikan IP Network ringkasannya adalah 10.10.10.x/xx . Setelah itu kita harus menentukan Subnet Mask yang dapat menjangkau dari 1 sampai 7, kita tinggal ingat ingat subnet mask atau prefix yang dapat memiliki host hingga 8 adalah :
255.255.255.248 dengan prefix /29
Maka IP network yang diringkas adalah 10.10.10.0/29 dapat menjangkau dari 1 hingga 7. Contoh lain adalah sebagai berikut :
  • 172.16.1.0/24
  • 172.16.2.0/24
  • 172.16.3.0/24
  • 172.16.4.0/24
Alamat IP Network tersebut dapat diringkas menjadi 172.16.0.0/21
Setelah mengetahui secara singkat cara melakukan summarize pada IP Network sekarang kita lanjut pada sintaks konfigurasi pada Router Cisco untuk melakukan EIGRP Manual Summarization.

  • Masuk pada konfigurasi Interface Router, dimana IP Network yang sudah di ringkas ingin dididstribusikan.
  • Router(config)#interface [slot/number]
  • Barulah masukan IP Network yang telah diringkas tadi
  • Router(config-if)#ip summary-address eigrp 1 x.x.x.x x.x.x.x

Setelah kita mengetahui sintaks konfigurasinya sekarang kita akan coba praktekan pada topologi dibawah ini :

Pada Router R1 dan R3 kita akan membuat beberapa Interface loopback, dan Network pada Interface loopback tersebut akan didistribusikan menggunakan EIGRP tetapi kita ringkas terlebih dahulu.

Konfigurasi

Pertama kita lakukan konfigurasi dasar pada Router seperti IP Address tiap interface, dan juga Interface loopback

    Router R1

    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi

    Dan untuk interface loopback nya.

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo1
    R1(config-if)#ip add 10.10.10.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo2
    R1(config-if)#ip add 10.10.10.2 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo3
    R1(config-if)#ip add 10.10.10.3 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo4
    R1(config-if)#ip add 10.10.10.4 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo5
    R1(config-if)#ip add 10.10.10.5 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo6
    R1(config-if)#ip add 10.10.10.6 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo7
    R1(config-if)#ip add 10.10.10.7 255.255.255.255
    R1(config-if)#exi

    Router R2

    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi

    Router R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#int lo1
    R3(config-if)#ip add 172.16.1.10 255.255.255.0
    R3(config-if)#exi
    R3(config)#int lo2
    R3(config-if)#ip add 172.16.2.20 255.255.255.0
    R3(config-if)#exi
    R3(config)#int lo3
    R3(config-if)#ip add 172.16.3.30 255.255.255.0
    R3(config-if)#exi
    R3(config)#int lo4
    R3(config-if)#ip add 172.16.4.40 255.255.255.0
    R3(config-if)#exi

Setelah IP Addressing selesai sekarang kita lanjut pada konfigurasi EIGRP untuk menghubungkan antar Router dengan EIGRP ini, dan mendistribusikan informasi Routing.

    Router R1

    R1(config)#router eigrp 1
    R1(config-router)#no auto-summ
    R1(config-router)#eigrp router-id 1.1.1.1
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#net 10.10.10.0 0.0.0.7
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#exi

    Router R2

    R2(config)#router eigrp 1
    R2(config-router)#no auto-sum
    R2(config-router)#eigrp router-id 2.2.2.2
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#exi

    Router R3

    R3(config)#router eigrp 1
    R3(config-router)#no auto-summ
    R3(config-router)#eigrp router-id 3.3.3.3
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 172.16.0.0 0.0.7.255
    R3(config-router)#exi

    Yang ditebalkan merupakan IP Network interface loopback yang telah diringkas.

Setelah selesai konfigurasi sekarang kita cek pada Routing table salah satu Router.

R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 23.23.23.3, 00:07:39, Ethernet0/1
10.0.0.0/32 is subnetted, 7 subnets
D 10.10.10.1 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
D 10.10.10.2 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
D 10.10.10.3 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
D 10.10.10.4 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
D 10.10.10.5 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
D 10.10.10.6 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
D 10.10.10.7 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.2/32 is directly connected, Ethernet0/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, Ethernet0/1
L 23.23.23.2/32 is directly connected, Ethernet0/1
172.16.0.0/24 is subnetted, 4 subnets
D 172.16.1.0 [90/409600] via 23.23.23.3, 00:00:03, Ethernet0/1
D 172.16.2.0 [90/409600] via 23.23.23.3, 00:00:03, Ethernet0/1
D 172.16.3.0 [90/409600] via 23.23.23.3, 00:00:03, Ethernet0/1
D 172.16.4.0 [90/409600] via 23.23.23.3, 00:00:03, Ethernet0/1

Kita bisa lihat pada tulisan yang ditebalkan merupakan rute rute yang memakan banyak tempat pada Routing table, ini dikarenakan kita belum melakukan summarization dan kita mematikan auto summary eigrp dengan perintah no auto-summ pada konfigurasi sebelumnya. Untuk itu kita perlu mengkonfigurasi EIGRP summarization pada Router yang mendistribusikan informasi network tersebut :

    Router R1

    Masuk pada konfigurasi Interface dimana informasi network yang ingin diringkas.

    R1(config)#int e0/0

    Kemudian ketikan alamat IP Network yang sudah diringkas.

    R1(config-if)#ip summary-address eigrp 1 10.10.10.0 255.255.255.248

    Router R3

    R3(config)#int e0/0
    R3(config-if)#ip summary-addr eigrp 1 172.16.0.0 255.255.248.0
    R3(config-if)#exi

Konfirmasi

Setelah konfigurasi dan summarization selesai, kita kembali cek Routing table pada salah satu Router.

R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/409600] via 12.12.12.1, 00:22:50, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 23.23.23.3, 00:20:42, Ethernet0/1
10.0.0.0/29 is subnetted, 1 subnets
D 10.10.10.0 [90/409600] via 12.12.12.1, 00:01:28, Ethernet0/0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.2/32 is directly connected, Ethernet0/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, Ethernet0/1
L 23.23.23.2/32 is directly connected, Ethernet0/1
172.16.0.0/21 is subnetted, 1 subnets
D 172.16.0.0 [90/409600] via 23.23.23.3, 00:00:22, Ethernet0/1

Setelah kita konfigurasi summarization atau peringkasan, Routing table dapat kita perkecil ukurannya dan tidak begitu memakan banyak tempat. Sekarang kita coba lakukan PING untuk memastikan kebenarannya :

R2#ping 10.10.10.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R2#ping 172.16.3.30
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.30, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Konfigurasi EIGRP manual Summarization

Pada EIGRP kita dapat melakukan Summarization terhadap Alamat IP network-network yang ingin didistribusikan. Apa itu Summarization? dalam bahasa Indonesia artinya meringkas, jadi EIGRP Summarization ini adalah fitur untuk meringkas beberapa Alamat IP Network-network yang banyak menjadi satu saja yang dapat mewakili semuanya. Tujuan dari Summarization ini adalah untuk memperkecil jumlah entri dalam Routing table dengan cara meringkasnya.

Cara meringkas beberapa IP Network menjadi satu adalah dengan mencari Subnet Mask atau prefix yang dapat menjangkau semua IP Network yang ingin diringkas. Contoh sederhananya adalah sebagai berikut :
  • 10.10.10.1/32
  • 10.10.10.2/32
  • 10.10.10.3/32
  • 10.10.10.4/32
  • 10.10.10.5/32
  • 10.10.10.6/32
  • 10.10.10.7/32
Oktet dari satu hingga ke tiga sama, sedangkan yang ke empat berbeda, maka sudah dipastikan IP Network ringkasannya adalah 10.10.10.x/xx . Setelah itu kita harus menentukan Subnet Mask yang dapat menjangkau dari 1 sampai 7, kita tinggal ingat ingat subnet mask atau prefix yang dapat memiliki host hingga 8 adalah :
255.255.255.248 dengan prefix /29
Maka IP network yang diringkas adalah 10.10.10.0/29 dapat menjangkau dari 1 hingga 7. Contoh lain adalah sebagai berikut :
  • 172.16.1.0/24
  • 172.16.2.0/24
  • 172.16.3.0/24
  • 172.16.4.0/24
Alamat IP Network tersebut dapat diringkas menjadi 172.16.0.0/21
Setelah mengetahui secara singkat cara melakukan summarize pada IP Network sekarang kita lanjut pada sintaks konfigurasi pada Router Cisco untuk melakukan EIGRP Manual Summarization.

  • Masuk pada konfigurasi Interface Router, dimana IP Network yang sudah di ringkas ingin dididstribusikan.
  • Router(config)#interface [slot/number]
  • Barulah masukan IP Network yang telah diringkas tadi
  • Router(config-if)#ip summary-address eigrp 1 x.x.x.x x.x.x.x

Setelah kita mengetahui sintaks konfigurasinya sekarang kita akan coba praktekan pada topologi dibawah ini :

Pada Router R1 dan R3 kita akan membuat beberapa Interface loopback, dan Network pada Interface loopback tersebut akan didistribusikan menggunakan EIGRP tetapi kita ringkas terlebih dahulu.

Konfigurasi

Pertama kita lakukan konfigurasi dasar pada Router seperti IP Address tiap interface, dan juga Interface loopback

    Router R1

    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi

    Dan untuk interface loopback nya.

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo1
    R1(config-if)#ip add 10.10.10.1 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo2
    R1(config-if)#ip add 10.10.10.2 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo3
    R1(config-if)#ip add 10.10.10.3 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo4
    R1(config-if)#ip add 10.10.10.4 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo5
    R1(config-if)#ip add 10.10.10.5 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo6
    R1(config-if)#ip add 10.10.10.6 255.255.255.255
    R1(config-if)#exi
    R1(config)#int lo7
    R1(config-if)#ip add 10.10.10.7 255.255.255.255
    R1(config-if)#exi

    Router R2

    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi

    Router R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#int lo1
    R3(config-if)#ip add 172.16.1.10 255.255.255.0
    R3(config-if)#exi
    R3(config)#int lo2
    R3(config-if)#ip add 172.16.2.20 255.255.255.0
    R3(config-if)#exi
    R3(config)#int lo3
    R3(config-if)#ip add 172.16.3.30 255.255.255.0
    R3(config-if)#exi
    R3(config)#int lo4
    R3(config-if)#ip add 172.16.4.40 255.255.255.0
    R3(config-if)#exi

Setelah IP Addressing selesai sekarang kita lanjut pada konfigurasi EIGRP untuk menghubungkan antar Router dengan EIGRP ini, dan mendistribusikan informasi Routing.

    Router R1

    R1(config)#router eigrp 1
    R1(config-router)#no auto-summ
    R1(config-router)#eigrp router-id 1.1.1.1
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#net 10.10.10.0 0.0.0.7
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#exi

    Router R2

    R2(config)#router eigrp 1
    R2(config-router)#no auto-sum
    R2(config-router)#eigrp router-id 2.2.2.2
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#exi

    Router R3

    R3(config)#router eigrp 1
    R3(config-router)#no auto-summ
    R3(config-router)#eigrp router-id 3.3.3.3
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 172.16.0.0 0.0.7.255
    R3(config-router)#exi

    Yang ditebalkan merupakan IP Network interface loopback yang telah diringkas.

Setelah selesai konfigurasi sekarang kita cek pada Routing table salah satu Router.

R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 23.23.23.3, 00:07:39, Ethernet0/1
10.0.0.0/32 is subnetted, 7 subnets
D 10.10.10.1 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
D 10.10.10.2 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
D 10.10.10.3 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
D 10.10.10.4 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
D 10.10.10.5 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
D 10.10.10.6 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0
D 10.10.10.7 [90/409600] via 12.12.12.1, 00:09:47, Ethernet0/0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.2/32 is directly connected, Ethernet0/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, Ethernet0/1
L 23.23.23.2/32 is directly connected, Ethernet0/1
172.16.0.0/24 is subnetted, 4 subnets
D 172.16.1.0 [90/409600] via 23.23.23.3, 00:00:03, Ethernet0/1
D 172.16.2.0 [90/409600] via 23.23.23.3, 00:00:03, Ethernet0/1
D 172.16.3.0 [90/409600] via 23.23.23.3, 00:00:03, Ethernet0/1
D 172.16.4.0 [90/409600] via 23.23.23.3, 00:00:03, Ethernet0/1

Kita bisa lihat pada tulisan yang ditebalkan merupakan rute rute yang memakan banyak tempat pada Routing table, ini dikarenakan kita belum melakukan summarization dan kita mematikan auto summary eigrp dengan perintah no auto-summ pada konfigurasi sebelumnya. Untuk itu kita perlu mengkonfigurasi EIGRP summarization pada Router yang mendistribusikan informasi network tersebut :

    Router R1

    Masuk pada konfigurasi Interface dimana informasi network yang ingin diringkas.

    R1(config)#int e0/0

    Kemudian ketikan alamat IP Network yang sudah diringkas.

    R1(config-if)#ip summary-address eigrp 1 10.10.10.0 255.255.255.248

    Router R3

    R3(config)#int e0/0
    R3(config-if)#ip summary-addr eigrp 1 172.16.0.0 255.255.248.0
    R3(config-if)#exi

Konfirmasi

Setelah konfigurasi dan summarization selesai, kita kembali cek Routing table pada salah satu Router.

R2#sh ip ro
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
D 1.1.1.1 [90/409600] via 12.12.12.1, 00:22:50, Ethernet0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
D 3.3.3.3 [90/409600] via 23.23.23.3, 00:20:42, Ethernet0/1
10.0.0.0/29 is subnetted, 1 subnets
D 10.10.10.0 [90/409600] via 12.12.12.1, 00:01:28, Ethernet0/0

12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 12.12.12.0/24 is directly connected, Ethernet0/0
L 12.12.12.2/32 is directly connected, Ethernet0/0
23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 23.23.23.0/24 is directly connected, Ethernet0/1
L 23.23.23.2/32 is directly connected, Ethernet0/1
172.16.0.0/21 is subnetted, 1 subnets
D 172.16.0.0 [90/409600] via 23.23.23.3, 00:00:22, Ethernet0/1

Setelah kita konfigurasi summarization atau peringkasan, Routing table dapat kita perkecil ukurannya dan tidak begitu memakan banyak tempat. Sekarang kita coba lakukan PING untuk memastikan kebenarannya :

R2#ping 10.10.10.5
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.10.10.5, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R2#ping 172.16.3.30
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.30, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Konfigurasi EIGRP dengan Authentication MD5

Pada EIGRP terdapat fitur Authentication, fitur ini berfungsi untuk keamanan jaringan yang menggunakan Routing Protocol EIGRP. Seperti yang kita tahu sebelumnya antar Router sebelum mendistribusikan informasi Routing-nya, Router tersebut harus membentuk hubungan adjacencies pada Router lainnya yang saling terhubung langsung, hubungan tersebut bisa dilakukan dengan Router siapa saja, hal ini bisa mempengerahui keamanan karena informasi Routing bisa diterima oleh Router penyusup atau yang tidak diinginkan masuk, atau ada Router penyerang yang mengirimkan informasi Routing yang tidak diinginkan pada Router yang kita konfigurasi.

Dengan authentication, hubungan adjacencies antar Router EIGRP akan memiliki sebuah password untuk menjaga keamanan dan kepercayaan, sebelum Router mengirimkan atau menerima harus melakukan authentication dengan sebuah password. Password pada kedua Router harus sama agar valid. Agar password yang dikirimkan tidak dapat di capture oleh orang lain, maka password yang dikirimkan dalam bentuk MD5.
Untuk melakukan konfigurasi EIGRP Authentication pada Cisco, pertama kita harus membuat key chain atau bisa diibaratkan dengan gantungan kunci yang berisi banyak kunci, setelah membuat key chain kemudian pada key chain tersebut kita isi dengan beberapa password yang merupakan kunci yang ada pada gantungan kunci key chain tersebut. Setelah kunci dan gantungannya dibuat, barulah kita terapkan pada Interface Router yang terhubung dengan Router EIGRP tetangga sebelahnya.

Sintaks untuk konfigurasi Authentication adalah :

  • Buat sebuah key chain dengan nama tertentu.
  • Router(config)#key chain [nama]
  • Lalu isi dengan beberapa key atau password, tiap key diidentifikasi oleh angka dari 1 sampai 2147483647.
  • Router(config-keychain)#key [number]
    Router(config-keychain-key)#key-string [password]
  • Terapkan pada sebuah interface yang ingin dberikan authentication.
  • Router(config)#int [slot/number]
    Router(config-if)#ip authentication key-chain eigrp [as-num] [key-chain-name]
    Router(config-if)#ip authentication mode eigrp [as-num] md5

Setelah kita mengetahui sintaks konfigurasinya, sekarang kita dapat mempraktekan pada topologi dibawah ini.

Konfigurasi

Pertama kita konfigurasi IP Address pada tiap Interface Router, beserta konfigurasi EIGRP Dasar pada setiap Router.

    R1

    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi

    Dan untuk interface loopback Router ini.

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi

    Kemudian konfigurasi EIGRP dasar pada Router ini.

    R1(config)#router eigrp 1
    R1(config-router)#no auto-sum
    R1(config-router)#eigrp router-id 1.1.1.1
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#exi

    R2

    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi
    R2(config)#router eigrp 1
    R2(config-router)#no auto-summ
    R2(config-router)#eigrp router-id 2.2.2.2
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#ex

    R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#router eigrp 1
    R3(config-router)#no auto-sum
    R3(config-router)#eigrp router-id 3.3.3.3
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#exi

Setelah selesai konfigurasi IP Address dan EIGRP, Sekarang kita lanjut pada konfigurasi Key chain dan Authentication.

    R1

    Pertama kita buat key chain atau gantungan kunci, kemudian kita isi dengan sebuah kunci atau password.

    R1(config)#key chain gantungan-kunci
    R1(config-keychain)#key 1
    R1(config-keychain-key)#key-string password

    Lalu terapkan pada Interface R1 yang terhubung dengan Router EIGRP sebelah.

    R1(config)#int e0/0
    R1(config-if)#ip authentication key-chain eigrp 1 gantungan-kunci
    R1(config-if)#ip authentication mode eigrp 1 md5

    R2

    R2(config)#key chain gantungan-kunci
    R2(config-keychain)#key 1
    R2(config-keychain-key)#key-string password
    R2(config-keychain-key)#exi
    R2(config-keychain)#exi
    R2(config)#int e0/0
    R2(config-if)#ip authentication key-chain eigrp 1 gantungan-kunci
    R2(config-if)#ip authentication mode eigrp 1 md5
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip authentication key-chain eigrp 1 gantungan-kunci
    R2(config-if)#ip authentication mode eigrp 1 md5
    R2(config-if)#exi

    R3

    R3(config)#key chain gantungan-kunci
    R3(config-keychain)#key 1
    R3(config-keychain-key)#key-string password
    R3(config-keychain-key)#exi
    R3(config-keychain)#exi
    R3(config)#int e0/0
    R3(config-if)#ip authentication key-chain eigrp 1 gantungan-kunci
    R3(config-if)#ip authentication mode eigrp 1 md5
    R3(config-if)#exi

Konfirmasi

Untuk melakukan konfirmasi kita dapat melihat EIGRP packet dengan melakukan debugging pada setiap EIGRP packet yang masuk.

R2#debug eigrp packet
*Mar 22 01:49:31.016: EIGRP: received packet with MD5 authentication, key id = 1
*Mar 22 01:49:31.016: EIGRP: Received HELLO on Et0/1 - paklen 60 nbr 23.23.23.3
*Mar 22 01:49:31.016: AS 1, Flags 0x0:(NULL), Seq 0/0 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0

Konfigurasi EIGRP dengan Authentication MD5

Pada EIGRP terdapat fitur Authentication, fitur ini berfungsi untuk keamanan jaringan yang menggunakan Routing Protocol EIGRP. Seperti yang kita tahu sebelumnya antar Router sebelum mendistribusikan informasi Routing-nya, Router tersebut harus membentuk hubungan adjacencies pada Router lainnya yang saling terhubung langsung, hubungan tersebut bisa dilakukan dengan Router siapa saja, hal ini bisa mempengerahui keamanan karena informasi Routing bisa diterima oleh Router penyusup atau yang tidak diinginkan masuk, atau ada Router penyerang yang mengirimkan informasi Routing yang tidak diinginkan pada Router yang kita konfigurasi.

Dengan authentication, hubungan adjacencies antar Router EIGRP akan memiliki sebuah password untuk menjaga keamanan dan kepercayaan, sebelum Router mengirimkan atau menerima harus melakukan authentication dengan sebuah password. Password pada kedua Router harus sama agar valid. Agar password yang dikirimkan tidak dapat di capture oleh orang lain, maka password yang dikirimkan dalam bentuk MD5.
Untuk melakukan konfigurasi EIGRP Authentication pada Cisco, pertama kita harus membuat key chain atau bisa diibaratkan dengan gantungan kunci yang berisi banyak kunci, setelah membuat key chain kemudian pada key chain tersebut kita isi dengan beberapa password yang merupakan kunci yang ada pada gantungan kunci key chain tersebut. Setelah kunci dan gantungannya dibuat, barulah kita terapkan pada Interface Router yang terhubung dengan Router EIGRP tetangga sebelahnya.

Sintaks untuk konfigurasi Authentication adalah :

  • Buat sebuah key chain dengan nama tertentu.
  • Router(config)#key chain [nama]
  • Lalu isi dengan beberapa key atau password, tiap key diidentifikasi oleh angka dari 1 sampai 2147483647.
  • Router(config-keychain)#key [number]
    Router(config-keychain-key)#key-string [password]
  • Terapkan pada sebuah interface yang ingin dberikan authentication.
  • Router(config)#int [slot/number]
    Router(config-if)#ip authentication key-chain eigrp [as-num] [key-chain-name]
    Router(config-if)#ip authentication mode eigrp [as-num] md5

Setelah kita mengetahui sintaks konfigurasinya, sekarang kita dapat mempraktekan pada topologi dibawah ini.

Konfigurasi

Pertama kita konfigurasi IP Address pada tiap Interface Router, beserta konfigurasi EIGRP Dasar pada setiap Router.

    R1

    R1(config)#int e0/0
    R1(config-if)#ip add 12.12.12.1 255.255.255.0
    R1(config-if)#no sh
    R1(config-if)#exi

    Dan untuk interface loopback Router ini.

    R1(config)#int lo0
    R1(config-if)#ip add 1.1.1.1 255.255.255.255
    R1(config-if)#exi

    Kemudian konfigurasi EIGRP dasar pada Router ini.

    R1(config)#router eigrp 1
    R1(config-router)#no auto-sum
    R1(config-router)#eigrp router-id 1.1.1.1
    R1(config-router)#net 1.1.1.1 0.0.0.0
    R1(config-router)#net 12.12.12.0 0.0.0.255
    R1(config-router)#exi

    R2

    R2(config)#int e0/0
    R2(config-if)#ip add 12.12.12.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip add 23.23.23.2 255.255.255.0
    R2(config-if)#no sh
    R2(config-if)#exi
    R2(config)#int lo0
    R2(config-if)#ip add 2.2.2.2 255.255.255.255
    R2(config-if)#exi
    R2(config)#router eigrp 1
    R2(config-router)#no auto-summ
    R2(config-router)#eigrp router-id 2.2.2.2
    R2(config-router)#net 2.2.2.2 0.0.0.0
    R2(config-router)#net 23.23.23.0 0.0.0.255
    R2(config-router)#net 12.12.12.0 0.0.0.255
    R2(config-router)#ex

    R3

    R3(config)#int e0/0
    R3(config-if)#ip add 23.23.23.3 255.255.255.0
    R3(config-if)#no sh
    R3(config-if)#exi
    R3(config)#int lo0
    R3(config-if)#ip add 3.3.3.3 255.255.255.255
    R3(config-if)#exi
    R3(config)#router eigrp 1
    R3(config-router)#no auto-sum
    R3(config-router)#eigrp router-id 3.3.3.3
    R3(config-router)#net 3.3.3.3 0.0.0.0
    R3(config-router)#net 23.23.23.0 0.0.0.255
    R3(config-router)#exi

Setelah selesai konfigurasi IP Address dan EIGRP, Sekarang kita lanjut pada konfigurasi Key chain dan Authentication.

    R1

    Pertama kita buat key chain atau gantungan kunci, kemudian kita isi dengan sebuah kunci atau password.

    R1(config)#key chain gantungan-kunci
    R1(config-keychain)#key 1
    R1(config-keychain-key)#key-string password

    Lalu terapkan pada Interface R1 yang terhubung dengan Router EIGRP sebelah.

    R1(config)#int e0/0
    R1(config-if)#ip authentication key-chain eigrp 1 gantungan-kunci
    R1(config-if)#ip authentication mode eigrp 1 md5

    R2

    R2(config)#key chain gantungan-kunci
    R2(config-keychain)#key 1
    R2(config-keychain-key)#key-string password
    R2(config-keychain-key)#exi
    R2(config-keychain)#exi
    R2(config)#int e0/0
    R2(config-if)#ip authentication key-chain eigrp 1 gantungan-kunci
    R2(config-if)#ip authentication mode eigrp 1 md5
    R2(config-if)#exi
    R2(config)#int e0/1
    R2(config-if)#ip authentication key-chain eigrp 1 gantungan-kunci
    R2(config-if)#ip authentication mode eigrp 1 md5
    R2(config-if)#exi

    R3

    R3(config)#key chain gantungan-kunci
    R3(config-keychain)#key 1
    R3(config-keychain-key)#key-string password
    R3(config-keychain-key)#exi
    R3(config-keychain)#exi
    R3(config)#int e0/0
    R3(config-if)#ip authentication key-chain eigrp 1 gantungan-kunci
    R3(config-if)#ip authentication mode eigrp 1 md5
    R3(config-if)#exi

Konfirmasi

Untuk melakukan konfirmasi kita dapat melihat EIGRP packet dengan melakukan debugging pada setiap EIGRP packet yang masuk.

R2#debug eigrp packet
*Mar 22 01:49:31.016: EIGRP: received packet with MD5 authentication, key id = 1
*Mar 22 01:49:31.016: EIGRP: Received HELLO on Et0/1 - paklen 60 nbr 23.23.23.3
*Mar 22 01:49:31.016: AS 1, Flags 0x0:(NULL), Seq 0/0 interfaceQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0