Lab 130 – Multi Area OSPF Juniper

Wihh semangat nih belajarnya… kemarin kita sudah belajar Basic OSPF di Juniper.. hari ini kita lanjut belajar OSPF yang lebih advanced ya.. kita akan konfig Multi Area OSPF.. Oke langsung aja ya.. kita akan pake topologi berikut

Wishh.. lumayan komplek nih topologi nya.. hehe.. nantinya kita akan membuat masing-masing satu interface loopback pada seluruh router.. Perhatikan bahwa kita nanti juga perlu membuat virtual link ya antara R3 dan R4..

Oke langsung aja ya.. pertama kita harus konfig addressing nya yaa.. berikut konfigurasi addressing pada R1

[edit]
root# run show configuration logical-systems R1
interfaces {
em0 {
unit 13 {
vlan-id 13;
family inet {
address 13.13.13.1/24;
}
}
}
lo0 {
unit 1 {
family inet {
address 1.1.1.1/32;
}
}
}
}

Berikut konfigurasi R2

[edit]
root# run show configuration logical-systems R2
interfaces {
em0 {
unit 23 {
vlan-id 23;
family inet {
address 23.23.23.2/24;
}
}
unit 24 {
vlan-id 24;
family inet {
address 24.24.24.2/24;
}
}
}
lo0 {
unit 2 {
family inet {
address 2.2.2.2/32;
}
}
}
}

Berikut konfigurasi di R3

[edit]
root# run show configuration logical-systems R3
interfaces {
em1 {
unit 13 {
vlan-id 13;
family inet {
address 13.13.13.3/24;
}
}
unit 23 {
vlan-id 23;
family inet {
address 23.23.23.3/24;
}
}
unit 34 {
vlan-id 34;
family inet {
address 34.34.34.3/24;
}
}
}
lo0 {
unit 3 {
family inet {
address 3.3.3.3/32;
}
}
}
}

Berikut konfigurasi di R4

[edit]
root# run show configuration logical-systems R4
interfaces {
em0 {
unit 34 {
vlan-id 34;
family inet {
address 34.34.34.4/24;
}
}
unit 45 {
vlan-id 45;
family inet {
address 45.45.45.4/24;
}
}
}
em1 {
unit 24 {
vlan-id 24;
family inet {
address 24.24.24.4/24;
}
}
}
lo0 {
unit 4 {
family inet {
address 4.4.4.4/32;
}
}
}
}

Berikut konfigurasi di R5

[edit]
root# run show configuration logical-systems R5
interfaces {
em1 {
unit 45 {
vlan-id 45;
family inet {
address 45.45.45.5/24;
}
}
}
lo0 {
unit 5 {
family inet {
address 5.5.5.5/32;
}
}
}
}

Okeee.. konfigurasi addressing sudah selesai.. lanjut kita konfigurasi OSPF nya yaaa.. berikut konfigurasi OSPF di R1

[edit]
root# run show configuration logical-systems R1 protocols
ospf {
area 0.0.0.0 {
interface em0.13;
interface lo0.1 {
passive;
}
}
}

Berikut konfigurasi OSPF di R2

[edit]
root# run show configuration logical-systems R2 protocols
ospf {
area 0.0.0.1 {
interface em0.23;
interface em0.24;
interface lo0.2 {
passive;
}
}
}

Berikut konfigurasi OSPF di R3

[edit]
root# run show configuration logical-systems R3 protocols
ospf {
area 0.0.0.0 {
interface em1.13;
}
area 0.0.0.1 {
interface em1.23;
interface em1.34;
interface lo0.3 {
passive;
}
}
}

Berikut konfigurasi OSPF di R4

[edit]
root# run show configuration logical-systems R4 protocols
ospf {
area 0.0.0.1 {
interface em0.34;
interface em1.24;
interface lo0.4 {
passive;
}
}
area 0.0.0.2 {
interface em0.45;
}
}

Berikut konfigurasi OSPF di R5

[edit]
root# run show configuration logical-systems R5 protocols
ospf {
area 0.0.0.2 {
interface em1.45;
interface lo0.5 {
passive;
}
}
}

Okeee.. konfigurasi OSPF sudah selesai.. untuk pengujian.. kita coba lihat tabel routing di R1 yaa

[edit]
root#
run show route logical-system R1

inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32 *[Direct/0] 00:14:28
> via lo0.1
2.2.2.2/32 *[
OSPF/10] 00:07:07, metric 2
> to 13.13.13.3 via em0.13
3.3.3.3/32 *[
OSPF/10] 00:07:17, metric 1
> to 13.13.13.3 via em0.13
4.4.4.4/32 *[
OSPF/10] 00:07:17, metric 2
> to 13.13.13.3 via em0.13
13.13.13.0/24 *[Direct/0] 00:08:15
> via em0.13
13.13.13.1/32 *[Local/0] 00:08:15
Local via em0.13
23.23.23.0/24 *[
OSPF/10] 00:07:17, metric 2
> to 13.13.13.3 via em0.13
24.24.24.0/24 *[
OSPF/10] 00:07:17, metric 3
> to 13.13.13.3 via em0.13
34.34.34.0/24 *[
OSPF/10] 00:07:17, metric 2
> to 13.13.13.3 via em0.13
224.0.0.5/32 *[OSPF/10] 00:08:15, metric 1
MultiRecv

Oke.. R1 sudah memiliki bebara route melalui OSPF.. namun ada yang kurang nih.. R1 belum punya route untuk ke R5.. kenapa deimikian?? karena R5 berada di Area yang tidak terhubung langsung dengan area backbone.. jadu harus kita konfigurasikan virtual link yaa..

Oke sekarang kita konfigurasikan virtual link antara R3 dan R4.. berikut konfigurasi virtual link di R3

[edit]
root#
edit logical-systems R3

[edit logical-systems R3]
root#
set routing-options router-id 3.3.3.3

[edit logical-systems R3]
root#
edit protocols ospf area 0.0.0.0

[edit logical-systems R3 protocols ospf area 0.0.0.0]
root#
set virtual-link neighbor-id 4.4.4.4 transit-area 0.0.0.1

[edit logical-systems R3 protocols ospf area 0.0.0.0]
root#
up

[edit logical-systems R3 protocols ospf]
root#
show
area 0.0.0.0 {
virtual-link neighbor-id 4.4.4.4 transit-area 0.0.0.1;
interface em1.13;
}
area 0.0.0.1 {
interface em1.23;
interface em1.34;
interface lo0.3 {
passive;
}
}

Berikut konfigurasi virtual link di R4

[edit]
root#
edit logical-systems R4

[edit logical-systems R4]
root#
set routing-options router-id 4.4.4.4

[edit logical-systems R4]
root#
edit protocols ospf area 0.0.0.0

[edit logical-systems R4 protocols ospf area 0.0.0.0]
root#
set virtual-link neighbor-id 3.3.3.3 transit-area 0.0.0.1

[edit logical-systems R4 protocols ospf area 0.0.0.0]
root#
up

[edit logical-systems R4 protocols ospf]
root#
show
area 0.0.0.1 {
interface em0.34;
interface em1.24;
interface lo0.4 {
passive;
}
}
area 0.0.0.2 {
interface em0.45;
}
area 0.0.0.0 {
virtual-link neighbor-id 3.3.3.3 transit-area 0.0.0.1;
}

Okeee.. sudah selesai nih… kita coba cek yaa

[edit]
root#
run show ospf neighbor logical-system R3
Address Interface State ID Pri Dead
13.13.13.1 em1.13 Full 1.1.1.1 128 33
34.34.34.4 vl-4.4.4.4 Full 4.4.4.4 0 35
23.23.23.2 em1.23 Full 2.2.2.2 128 32
34.34.34.4 em1.34 Full 4.4.4.4 128 32

Perhatikan bahwa R3 sudah bertetangga dengan R4 melalui virtual link.. sekarang kita coba cek tabel routing di R1 yaa

[edit]
root#
run show route logical-system R1

inet.0: 12 destinations, 12 routes (12 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32 *[Direct/0] 00:22:21
> via lo0.1
2.2.2.2/32 *[OSPF/10] 00:01:42, metric 2
> to 13.13.13.3 via em0.13
3.3.3.3/32 *[OSPF/10] 00:01:42, metric 1
> to 13.13.13.3 via em0.13
4.4.4.4/32 *[OSPF/10] 00:01:42, metric 2
> to 13.13.13.3 via em0.13
5.5.5.5/32 *[OSPF/10] 00:01:42, metric 3
> to 13.13.13.3 via em0.13
13.13.13.0/24 *[Direct/0] 00:02:23
> via em0.13
13.13.13.1/32 *[Local/0] 00:02:23
Local via em0.13
23.23.23.0/24 *[OSPF/10] 00:01:42, metric 2
> to 13.13.13.3 via em0.13
24.24.24.0/24 *[OSPF/10] 00:01:42, metric 3
> to 13.13.13.3 via em0.13
34.34.34.0/24 *[OSPF/10] 00:01:42, metric 2
> to 13.13.13.3 via em0.13
45.45.45.0/24 *[OSPF/10] 00:01:42, metric 3
> to 13.13.13.3 via em0.13
224.0.0.5/32 *[OSPF/10] 00:16:08, metric 1
MultiRecv

Okeee.. sekarang tabel routing di R1 sudah lengkap yaaaa… sekarang kita coba lakukan ping dari R1 ke interface loopback seluruh router

[edit]
root#
run ping 2.2.2.2 logical-system R1 count 1
PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=63 time=0.860 ms

--- 2.2.2.2 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.860/0.860/0.860/0.000 ms

[edit]
root# run ping 3.3.3.3 logical-system R1 count 1
PING 3.3.3.3 (3.3.3.3): 56 data bytes
64 bytes from 3.3.3.3: icmp_seq=0 ttl=64 time=0.797 ms

--- 3.3.3.3 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.797/0.797/0.797/0.000 ms

[edit]
root# run ping 4.4.4.4 logical-system R1 count 1
PING 4.4.4.4 (4.4.4.4): 56 data bytes
64 bytes from 4.4.4.4: icmp_seq=0 ttl=63 time=1.420 ms

--- 4.4.4.4 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.420/1.420/1.420/0.000 ms

[edit]
root# run ping 5.5.5.5 logical-system R1 count 1
PING 5.5.5.5 (5.5.5.5): 56 data bytes
64 bytes from 5.5.5.5: icmp_seq=0 ttl=62 time=1.696 ms

--- 5.5.5.5 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.696/1.696/1.696/0.000 ms

Okeee.. ping nya sukses semua yaa… oke sampai disini dulu ya.. sampai jumpa di artikel artikel selanjutnya.. semoga bermanfaat…

Lab 130 – Multi Area OSPF Juniper

Wihh semangat nih belajarnya… kemarin kita sudah belajar Basic OSPF di Juniper.. hari ini kita lanjut belajar OSPF yang lebih advanced ya.. kita akan konfig Multi Area OSPF.. Oke langsung aja ya.. kita akan pake topologi berikut

Wishh.. lumayan komplek nih topologi nya.. hehe.. nantinya kita akan membuat masing-masing satu interface loopback pada seluruh router.. Perhatikan bahwa kita nanti juga perlu membuat virtual link ya antara R3 dan R4..

Oke langsung aja ya.. pertama kita harus konfig addressing nya yaa.. berikut konfigurasi addressing pada R1

[edit]
root# run show configuration logical-systems R1
interfaces {
em0 {
unit 13 {
vlan-id 13;
family inet {
address 13.13.13.1/24;
}
}
}
lo0 {
unit 1 {
family inet {
address 1.1.1.1/32;
}
}
}
}

Berikut konfigurasi R2

[edit]
root# run show configuration logical-systems R2
interfaces {
em0 {
unit 23 {
vlan-id 23;
family inet {
address 23.23.23.2/24;
}
}
unit 24 {
vlan-id 24;
family inet {
address 24.24.24.2/24;
}
}
}
lo0 {
unit 2 {
family inet {
address 2.2.2.2/32;
}
}
}
}

Berikut konfigurasi di R3

[edit]
root# run show configuration logical-systems R3
interfaces {
em1 {
unit 13 {
vlan-id 13;
family inet {
address 13.13.13.3/24;
}
}
unit 23 {
vlan-id 23;
family inet {
address 23.23.23.3/24;
}
}
unit 34 {
vlan-id 34;
family inet {
address 34.34.34.3/24;
}
}
}
lo0 {
unit 3 {
family inet {
address 3.3.3.3/32;
}
}
}
}

Berikut konfigurasi di R4

[edit]
root# run show configuration logical-systems R4
interfaces {
em0 {
unit 34 {
vlan-id 34;
family inet {
address 34.34.34.4/24;
}
}
unit 45 {
vlan-id 45;
family inet {
address 45.45.45.4/24;
}
}
}
em1 {
unit 24 {
vlan-id 24;
family inet {
address 24.24.24.4/24;
}
}
}
lo0 {
unit 4 {
family inet {
address 4.4.4.4/32;
}
}
}
}

Berikut konfigurasi di R5

[edit]
root# run show configuration logical-systems R5
interfaces {
em1 {
unit 45 {
vlan-id 45;
family inet {
address 45.45.45.5/24;
}
}
}
lo0 {
unit 5 {
family inet {
address 5.5.5.5/32;
}
}
}
}

Okeee.. konfigurasi addressing sudah selesai.. lanjut kita konfigurasi OSPF nya yaaa.. berikut konfigurasi OSPF di R1

[edit]
root# run show configuration logical-systems R1 protocols
ospf {
area 0.0.0.0 {
interface em0.13;
interface lo0.1 {
passive;
}
}
}

Berikut konfigurasi OSPF di R2

[edit]
root# run show configuration logical-systems R2 protocols
ospf {
area 0.0.0.1 {
interface em0.23;
interface em0.24;
interface lo0.2 {
passive;
}
}
}

Berikut konfigurasi OSPF di R3

[edit]
root# run show configuration logical-systems R3 protocols
ospf {
area 0.0.0.0 {
interface em1.13;
}
area 0.0.0.1 {
interface em1.23;
interface em1.34;
interface lo0.3 {
passive;
}
}
}

Berikut konfigurasi OSPF di R4

[edit]
root# run show configuration logical-systems R4 protocols
ospf {
area 0.0.0.1 {
interface em0.34;
interface em1.24;
interface lo0.4 {
passive;
}
}
area 0.0.0.2 {
interface em0.45;
}
}

Berikut konfigurasi OSPF di R5

[edit]
root# run show configuration logical-systems R5 protocols
ospf {
area 0.0.0.2 {
interface em1.45;
interface lo0.5 {
passive;
}
}
}

Okeee.. konfigurasi OSPF sudah selesai.. untuk pengujian.. kita coba lihat tabel routing di R1 yaa

[edit]
root#
run show route logical-system R1

inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32 *[Direct/0] 00:14:28
> via lo0.1
2.2.2.2/32 *[
OSPF/10] 00:07:07, metric 2
> to 13.13.13.3 via em0.13
3.3.3.3/32 *[
OSPF/10] 00:07:17, metric 1
> to 13.13.13.3 via em0.13
4.4.4.4/32 *[
OSPF/10] 00:07:17, metric 2
> to 13.13.13.3 via em0.13
13.13.13.0/24 *[Direct/0] 00:08:15
> via em0.13
13.13.13.1/32 *[Local/0] 00:08:15
Local via em0.13
23.23.23.0/24 *[
OSPF/10] 00:07:17, metric 2
> to 13.13.13.3 via em0.13
24.24.24.0/24 *[
OSPF/10] 00:07:17, metric 3
> to 13.13.13.3 via em0.13
34.34.34.0/24 *[
OSPF/10] 00:07:17, metric 2
> to 13.13.13.3 via em0.13
224.0.0.5/32 *[OSPF/10] 00:08:15, metric 1
MultiRecv

Oke.. R1 sudah memiliki bebara route melalui OSPF.. namun ada yang kurang nih.. R1 belum punya route untuk ke R5.. kenapa deimikian?? karena R5 berada di Area yang tidak terhubung langsung dengan area backbone.. jadu harus kita konfigurasikan virtual link yaa..

Oke sekarang kita konfigurasikan virtual link antara R3 dan R4.. berikut konfigurasi virtual link di R3

[edit]
root#
edit logical-systems R3

[edit logical-systems R3]
root#
set routing-options router-id 3.3.3.3

[edit logical-systems R3]
root#
edit protocols ospf area 0.0.0.0

[edit logical-systems R3 protocols ospf area 0.0.0.0]
root#
set virtual-link neighbor-id 4.4.4.4 transit-area 0.0.0.1

[edit logical-systems R3 protocols ospf area 0.0.0.0]
root#
up

[edit logical-systems R3 protocols ospf]
root#
show
area 0.0.0.0 {
virtual-link neighbor-id 4.4.4.4 transit-area 0.0.0.1;
interface em1.13;
}
area 0.0.0.1 {
interface em1.23;
interface em1.34;
interface lo0.3 {
passive;
}
}

Berikut konfigurasi virtual link di R4

[edit]
root#
edit logical-systems R4

[edit logical-systems R4]
root#
set routing-options router-id 4.4.4.4

[edit logical-systems R4]
root#
edit protocols ospf area 0.0.0.0

[edit logical-systems R4 protocols ospf area 0.0.0.0]
root#
set virtual-link neighbor-id 3.3.3.3 transit-area 0.0.0.1

[edit logical-systems R4 protocols ospf area 0.0.0.0]
root#
up

[edit logical-systems R4 protocols ospf]
root#
show
area 0.0.0.1 {
interface em0.34;
interface em1.24;
interface lo0.4 {
passive;
}
}
area 0.0.0.2 {
interface em0.45;
}
area 0.0.0.0 {
virtual-link neighbor-id 3.3.3.3 transit-area 0.0.0.1;
}

Okeee.. sudah selesai nih… kita coba cek yaa

[edit]
root#
run show ospf neighbor logical-system R3
Address Interface State ID Pri Dead
13.13.13.1 em1.13 Full 1.1.1.1 128 33
34.34.34.4 vl-4.4.4.4 Full 4.4.4.4 0 35
23.23.23.2 em1.23 Full 2.2.2.2 128 32
34.34.34.4 em1.34 Full 4.4.4.4 128 32

Perhatikan bahwa R3 sudah bertetangga dengan R4 melalui virtual link.. sekarang kita coba cek tabel routing di R1 yaa

[edit]
root#
run show route logical-system R1

inet.0: 12 destinations, 12 routes (12 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32 *[Direct/0] 00:22:21
> via lo0.1
2.2.2.2/32 *[OSPF/10] 00:01:42, metric 2
> to 13.13.13.3 via em0.13
3.3.3.3/32 *[OSPF/10] 00:01:42, metric 1
> to 13.13.13.3 via em0.13
4.4.4.4/32 *[OSPF/10] 00:01:42, metric 2
> to 13.13.13.3 via em0.13
5.5.5.5/32 *[OSPF/10] 00:01:42, metric 3
> to 13.13.13.3 via em0.13
13.13.13.0/24 *[Direct/0] 00:02:23
> via em0.13
13.13.13.1/32 *[Local/0] 00:02:23
Local via em0.13
23.23.23.0/24 *[OSPF/10] 00:01:42, metric 2
> to 13.13.13.3 via em0.13
24.24.24.0/24 *[OSPF/10] 00:01:42, metric 3
> to 13.13.13.3 via em0.13
34.34.34.0/24 *[OSPF/10] 00:01:42, metric 2
> to 13.13.13.3 via em0.13
45.45.45.0/24 *[OSPF/10] 00:01:42, metric 3
> to 13.13.13.3 via em0.13
224.0.0.5/32 *[OSPF/10] 00:16:08, metric 1
MultiRecv

Okeee.. sekarang tabel routing di R1 sudah lengkap yaaaa… sekarang kita coba lakukan ping dari R1 ke interface loopback seluruh router

[edit]
root#
run ping 2.2.2.2 logical-system R1 count 1
PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=63 time=0.860 ms

--- 2.2.2.2 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.860/0.860/0.860/0.000 ms

[edit]
root# run ping 3.3.3.3 logical-system R1 count 1
PING 3.3.3.3 (3.3.3.3): 56 data bytes
64 bytes from 3.3.3.3: icmp_seq=0 ttl=64 time=0.797 ms

--- 3.3.3.3 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.797/0.797/0.797/0.000 ms

[edit]
root# run ping 4.4.4.4 logical-system R1 count 1
PING 4.4.4.4 (4.4.4.4): 56 data bytes
64 bytes from 4.4.4.4: icmp_seq=0 ttl=63 time=1.420 ms

--- 4.4.4.4 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.420/1.420/1.420/0.000 ms

[edit]
root# run ping 5.5.5.5 logical-system R1 count 1
PING 5.5.5.5 (5.5.5.5): 56 data bytes
64 bytes from 5.5.5.5: icmp_seq=0 ttl=62 time=1.696 ms

--- 5.5.5.5 ping statistics ---
1 packets transmitted, 1 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.696/1.696/1.696/0.000 ms

Okeee.. ping nya sukses semua yaa… oke sampai disini dulu ya.. sampai jumpa di artikel artikel selanjutnya.. semoga bermanfaat…

Lab 129 – Basic OSPF in Juniper

Lanjut seri Juniper nya yaaa.. sekarang gilirannya OSPF nih buat kita hajar di Juniper.. langsung aja kali ya.. kita akan pake topologi ini yaa

O yaaa.. disini kita akan pake logical system ya.. masih ada yang belum tau apa itu logical system di juniper?? monggo dibaca artikel sebelumnya dulu ya tentang Logical System di Juniper

Oke.. saya akan langsung tunjuikkin konfigurasinya yaa… berikut konfigurasi untuk logical system R1

[edit]
root# run show configuration logical-systems R1
interfaces {
em0 {
unit 12 {
vlan-id 12;
family inet {
address 12.12.12.1/24;
}
}
}
lo0 {
unit 1 {
family inet {
address 1.1.1.1/32;
}
}
}
}

Berikut konfigurasi logical system R2

[edit]
root# run show configuration logical-systems R2
interfaces {
em1 {
unit 12 {
vlan-id 12;
family inet {
address 12.12.12.2/24;
}
}
unit 23 {
vlan-id 23;
family inet {
address 23.23.23.2/24;
}
}
unit 24 {
vlan-id 24;
family inet {
address 24.24.24.2/24;
}
}
}
lo0 {
unit 2 {
family inet {
address 2.2.2.2/32;
}
}
}
}

Berikut konfigurasi logical system R3

[edit]
root# run show configuration logical-systems R3
interfaces {
em0 {
unit 23 {
vlan-id 23;
family inet {
address 23.23.23.3/24;
}
}
unit 34 {
vlan-id 34;
family inet {
address 34.34.34.3/24;
}
}
}
lo0 {
unit 3 {
family inet {
address 3.3.3.3/32;
}
}
}
}

Berikut konfigurasi logical system R4

[edit]
root# run show configuration logical-systems R4
interfaces {
em0 {
unit 24 {
vlan-id 24;
family inet {
address 24.24.24.4/24;
}
}
}
em1 {
unit 34 {
vlan-id 34;
family inet {
address 34.34.34.4/24;
}
}
}
lo0 {
unit 4 {
family inet {
address 4.4.4.4/32;
}
}
}
}

Okeee.. konfigurasi addressing pada seluruh logical system sudah selesai.. o yaaa.. jangan lupa di commit lho ya. hehe

Okeoke langsung aja kita konfig OSPF nya ya.. berikut konfigurasi OSPF di logical system R1

[edit]
root# edit logical-systems R1 protocols ospf area 0.0.0.0

[edit logical-systems R1 protocols ospf area 0.0.0.0]
root# set interface em0.12

[edit logical-systems R1 protocols ospf area 0.0.0.0]
root# set interface lo0.1 passive

Bingung ya baca nya?? kayaknya lebih jelas kalau saya tampilkan show nya deh..

[edit]
root# run show configuration logical-systems R1 protocols
ospf {
area 0.0.0.0 {
interface em0.12;
interface lo0.1 {
passive;
}
}
}

Oke di R1 sudah selesai.. lanjut kita konfig di R2.. saya tampilkan show nya aja yaaa.. untuk perintahnya sama seperti yang di R1 kog..

[edit]
root# run show configuration logical-systems R2 protocols
ospf {
area 0.0.0.0 {
interface em1.12;
interface em1.24;
interface em1.23;
interface lo0.2 {
passive;
}
}
}

Lanjut berikut konfigurasi di R3

[edit]
root# run show configuration logical-systems R3 protocols
ospf {
area 0.0.0.0 {
interface em0.23;
interface em0.34;
interface lo0.3 {
passive;
}
}
}

Terahir kita konfig OSPF di R4 yaa

[edit]
root# run show configuration logical-systems R4 protocols
ospf {
area 0.0.0.0 {
interface em0.24;
interface em1.34;
interface lo0.4 {
passive;
}
}
}

Nah lhooo udah semua.. cepet banget yaa.. hehehe

Untuk pengujian.. kita bisa melihat neighbor tabel dengan perintah berikut

[edit]
root#
run show ospf neighbor logical-system R2
Address Interface State ID Pri Dead
12.12.12.1 em1.12
Full 1.1.1.1 128 38
23.23.23.3 em1.23
Full 3.3.3.3 128 35
24.24.24.4 em1.24
Full 4.4.4.4 128 37

Oke.. di R2 sudah full semua.. R2 sudah adjacency dengan ketiga router.. kita coba lihat neighbor tabel di R4 juga yaa

[edit]
root#
run show ospf neighbor logical-system R4
Address Interface State ID Pri Dead
24.24.24.2 em0.24
Full 2.2.2.2 128 39
34.34.34.3 em1.34
Full 3.3.3.3 128 36

Alhamdulillah R4 juga sudah adjacency dengan R2 dan R3..

Kita juga bisa melihat tabel routing untuk melakukan pengujian.. kita coba cek tabel routing di R1 yaa

[edit]
root#
run show route logical-system R1

inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32 *[Direct/0] 00:12:04
> via lo0.1
2.2.2.2/32 *[
OSPF/10] 00:02:00, metric 1
> to 12.12.12.2 via em0.12
3.3.3.3/32 *[
OSPF/10] 00:02:00, metric 2
> to 12.12.12.2 via em0.12
4.4.4.4/32 *[
OSPF/10] 00:01:58, metric 2
> to 12.12.12.2 via em0.12
12.12.12.0/24 *[Direct/0] 00:02:50
> via em0.12
12.12.12.1/32 *[Local/0] 00:02:50
Local via em0.12
23.23.23.0/24 *[
OSPF/10] 00:02:00, metric 2
> to 12.12.12.2 via em0.12
24.24.24.0/24 *[
OSPF/10] 00:02:00, metric 2
> to 12.12.12.2 via em0.12
34.34.34.0/24 *[
OSPF/10] 00:02:00, metric 3
> to 12.12.12.2 via em0.12
224.0.0.5/32 *[
OSPF/10] 00:07:49, metric 1
MultiRecv

Oke.. R1 sudah memiliki route ke seluruh network ya… wahhh.. sukses nih OSPF nya.. hehehe

Kita coba ping deh biar lebih pasti.. hehe

[edit]
root# run ping 2.2.2.2 logical-system R1 count 2
PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=64 time=1.377 ms
64 bytes from 2.2.2.2: icmp_seq=1 ttl=64 time=0.469 ms

--- 2.2.2.2 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.469/0.923/1.377/0.454 ms

[edit]
root# run ping 3.3.3.3 logical-system R1 count 2
PING 3.3.3.3 (3.3.3.3): 56 data bytes
64 bytes from 3.3.3.3: icmp_seq=0 ttl=63 time=2.200 ms
64 bytes from 3.3.3.3: icmp_seq=1 ttl=63 time=1.118 ms

--- 3.3.3.3 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.118/1.659/2.200/0.541 ms

[edit]
root# run ping 4.4.4.4 logical-system R1 count 2
PING 4.4.4.4 (4.4.4.4): 56 data bytes
64 bytes from 4.4.4.4: icmp_seq=0 ttl=63 time=1.294 ms
64 bytes from 4.4.4.4: icmp_seq=1 ttl=63 time=0.467 ms

--- 4.4.4.4 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.467/0.881/1.294/0.413 ms

Alhamdulillah… R1 bisa ping ke IP loopback seluruh router lain ya… oyaaaa kita coba traceroute yaa dari R1 ke ip loopback R4

[edit]
root#
run traceroute 4.4.4.4 logical-system R1
traceroute to 4.4.4.4 (4.4.4.4), 30 hops max, 40 byte packets
1 12.12.12.2 (12.12.12.2) 0.934 ms 0.796 ms 0.657 ms
2 4.4.4.4 (4.4.4.4) 1.013 ms 0.704 ms 0.636 ms

Oke … R1 memilih jalur via R2 untuk menjangkau IP loopback R4.. Okeee.. karena konfigurasi OSPF nya sudah jalan.. sampai disini dulu yaa.. sampai jumpa di artikel artikel selanjutnya..

Lab 129 – Basic OSPF in Juniper

Lanjut seri Juniper nya yaaa.. sekarang gilirannya OSPF nih buat kita hajar di Juniper.. langsung aja kali ya.. kita akan pake topologi ini yaa

O yaaa.. disini kita akan pake logical system ya.. masih ada yang belum tau apa itu logical system di juniper?? monggo dibaca artikel sebelumnya dulu ya tentang Logical System di Juniper

Oke.. saya akan langsung tunjuikkin konfigurasinya yaa… berikut konfigurasi untuk logical system R1

[edit]
root# run show configuration logical-systems R1
interfaces {
em0 {
unit 12 {
vlan-id 12;
family inet {
address 12.12.12.1/24;
}
}
}
lo0 {
unit 1 {
family inet {
address 1.1.1.1/32;
}
}
}
}

Berikut konfigurasi logical system R2

[edit]
root# run show configuration logical-systems R2
interfaces {
em1 {
unit 12 {
vlan-id 12;
family inet {
address 12.12.12.2/24;
}
}
unit 23 {
vlan-id 23;
family inet {
address 23.23.23.2/24;
}
}
unit 24 {
vlan-id 24;
family inet {
address 24.24.24.2/24;
}
}
}
lo0 {
unit 2 {
family inet {
address 2.2.2.2/32;
}
}
}
}

Berikut konfigurasi logical system R3

[edit]
root# run show configuration logical-systems R3
interfaces {
em0 {
unit 23 {
vlan-id 23;
family inet {
address 23.23.23.3/24;
}
}
unit 34 {
vlan-id 34;
family inet {
address 34.34.34.3/24;
}
}
}
lo0 {
unit 3 {
family inet {
address 3.3.3.3/32;
}
}
}
}

Berikut konfigurasi logical system R4

[edit]
root# run show configuration logical-systems R4
interfaces {
em0 {
unit 24 {
vlan-id 24;
family inet {
address 24.24.24.4/24;
}
}
}
em1 {
unit 34 {
vlan-id 34;
family inet {
address 34.34.34.4/24;
}
}
}
lo0 {
unit 4 {
family inet {
address 4.4.4.4/32;
}
}
}
}

Okeee.. konfigurasi addressing pada seluruh logical system sudah selesai.. o yaaa.. jangan lupa di commit lho ya. hehe

Okeoke langsung aja kita konfig OSPF nya ya.. berikut konfigurasi OSPF di logical system R1

[edit]
root# edit logical-systems R1 protocols ospf area 0.0.0.0

[edit logical-systems R1 protocols ospf area 0.0.0.0]
root# set interface em0.12

[edit logical-systems R1 protocols ospf area 0.0.0.0]
root# set interface lo0.1 passive

Bingung ya baca nya?? kayaknya lebih jelas kalau saya tampilkan show nya deh..

[edit]
root# run show configuration logical-systems R1 protocols
ospf {
area 0.0.0.0 {
interface em0.12;
interface lo0.1 {
passive;
}
}
}

Oke di R1 sudah selesai.. lanjut kita konfig di R2.. saya tampilkan show nya aja yaaa.. untuk perintahnya sama seperti yang di R1 kog..

[edit]
root# run show configuration logical-systems R2 protocols
ospf {
area 0.0.0.0 {
interface em1.12;
interface em1.24;
interface em1.23;
interface lo0.2 {
passive;
}
}
}

Lanjut berikut konfigurasi di R3

[edit]
root# run show configuration logical-systems R3 protocols
ospf {
area 0.0.0.0 {
interface em0.23;
interface em0.34;
interface lo0.3 {
passive;
}
}
}

Terahir kita konfig OSPF di R4 yaa

[edit]
root# run show configuration logical-systems R4 protocols
ospf {
area 0.0.0.0 {
interface em0.24;
interface em1.34;
interface lo0.4 {
passive;
}
}
}

Nah lhooo udah semua.. cepet banget yaa.. hehehe

Untuk pengujian.. kita bisa melihat neighbor tabel dengan perintah berikut

[edit]
root#
run show ospf neighbor logical-system R2
Address Interface State ID Pri Dead
12.12.12.1 em1.12
Full 1.1.1.1 128 38
23.23.23.3 em1.23
Full 3.3.3.3 128 35
24.24.24.4 em1.24
Full 4.4.4.4 128 37

Oke.. di R2 sudah full semua.. R2 sudah adjacency dengan ketiga router.. kita coba lihat neighbor tabel di R4 juga yaa

[edit]
root#
run show ospf neighbor logical-system R4
Address Interface State ID Pri Dead
24.24.24.2 em0.24
Full 2.2.2.2 128 39
34.34.34.3 em1.34
Full 3.3.3.3 128 36

Alhamdulillah R4 juga sudah adjacency dengan R2 dan R3..

Kita juga bisa melihat tabel routing untuk melakukan pengujian.. kita coba cek tabel routing di R1 yaa

[edit]
root#
run show route logical-system R1

inet.0: 10 destinations, 10 routes (10 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

1.1.1.1/32 *[Direct/0] 00:12:04
> via lo0.1
2.2.2.2/32 *[
OSPF/10] 00:02:00, metric 1
> to 12.12.12.2 via em0.12
3.3.3.3/32 *[
OSPF/10] 00:02:00, metric 2
> to 12.12.12.2 via em0.12
4.4.4.4/32 *[
OSPF/10] 00:01:58, metric 2
> to 12.12.12.2 via em0.12
12.12.12.0/24 *[Direct/0] 00:02:50
> via em0.12
12.12.12.1/32 *[Local/0] 00:02:50
Local via em0.12
23.23.23.0/24 *[
OSPF/10] 00:02:00, metric 2
> to 12.12.12.2 via em0.12
24.24.24.0/24 *[
OSPF/10] 00:02:00, metric 2
> to 12.12.12.2 via em0.12
34.34.34.0/24 *[
OSPF/10] 00:02:00, metric 3
> to 12.12.12.2 via em0.12
224.0.0.5/32 *[
OSPF/10] 00:07:49, metric 1
MultiRecv

Oke.. R1 sudah memiliki route ke seluruh network ya… wahhh.. sukses nih OSPF nya.. hehehe

Kita coba ping deh biar lebih pasti.. hehe

[edit]
root# run ping 2.2.2.2 logical-system R1 count 2
PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=64 time=1.377 ms
64 bytes from 2.2.2.2: icmp_seq=1 ttl=64 time=0.469 ms

--- 2.2.2.2 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.469/0.923/1.377/0.454 ms

[edit]
root# run ping 3.3.3.3 logical-system R1 count 2
PING 3.3.3.3 (3.3.3.3): 56 data bytes
64 bytes from 3.3.3.3: icmp_seq=0 ttl=63 time=2.200 ms
64 bytes from 3.3.3.3: icmp_seq=1 ttl=63 time=1.118 ms

--- 3.3.3.3 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 1.118/1.659/2.200/0.541 ms

[edit]
root# run ping 4.4.4.4 logical-system R1 count 2
PING 4.4.4.4 (4.4.4.4): 56 data bytes
64 bytes from 4.4.4.4: icmp_seq=0 ttl=63 time=1.294 ms
64 bytes from 4.4.4.4: icmp_seq=1 ttl=63 time=0.467 ms

--- 4.4.4.4 ping statistics ---
2 packets transmitted, 2 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.467/0.881/1.294/0.413 ms

Alhamdulillah… R1 bisa ping ke IP loopback seluruh router lain ya… oyaaaa kita coba traceroute yaa dari R1 ke ip loopback R4

[edit]
root#
run traceroute 4.4.4.4 logical-system R1
traceroute to 4.4.4.4 (4.4.4.4), 30 hops max, 40 byte packets
1 12.12.12.2 (12.12.12.2) 0.934 ms 0.796 ms 0.657 ms
2 4.4.4.4 (4.4.4.4) 1.013 ms 0.704 ms 0.636 ms

Oke … R1 memilih jalur via R2 untuk menjangkau IP loopback R4.. Okeee.. karena konfigurasi OSPF nya sudah jalan.. sampai disini dulu yaa.. sampai jumpa di artikel artikel selanjutnya..

Lab 128 – Static Routing Juniper

Welcome to juniper second lab!!!.. hehehe ini adalah lab kedua juniper nih.. semoga bisa istiqomah belajarnya.. Aamiin..

Pada lab ini kita akan sama2 belajar static routing di juniper yaaa.. kita akan pake topologi ini yaa

O yaaa.. disini kita akan pake logical system ya… kemarin di lab juniper pertama kita udah beljar kan tentang logical system juniper...

Pertama kita konfig logical system nya dulu yaaa

[edit]
root# set interfaces em0 vlan-tagging

[edit]
root# set interfaces em1 vlan-tagging

Berikut konfigurasi logical system untuk R1

[edit]
root# edit logical-systems R1

[edit logical-systems R1]
root# set interfaces em0.12 vlan-id 12 family inet address 12.12.12.1/24


[edit logical-systems R1]
root# set interfaces lo0.1 family inet address 1.1.1.1/32

Berikut konfigurasi logical system untuk R2

[edit logical-systems R1]
root# top

[edit]
root# edit logical-systems R2

[edit logical-systems R2]
root# set interfaces em1.12 vlan-id 12 family inet address 12.12.12.2/24

[edit logical-systems R2]
root# set interfaces em1.23 vlan-id 23 family inet address 23.23.23.2/24

[edit logical-systems R2]
root# set interfaces lo0.2 family inet address 2.2.2.2/32

Berikut konfigurasi logical system address untuk R3

[edit logical-systems R2]
root# top

[edit]
root# edit logical-systems R3

[edit logical-systems R3]
root# set interfaces em0.23 vlan-id 23 family inet address 23.23.23.3/24

[edit logical-systems R3]
root# set interfaces lo0.3 family inet address 3.3.3.3/32

O yaaaa.. jangan lupa commit ya

[edit]
root# commit
commit complete

Okeee.. konfigurasi addressing sudah selesai pada seluruh logical system.. kita coba cek yaa

root# run show interfaces terse
Interface Admin Link Proto Local Remote
cbp0 up up
demux0 up up
dsc up up
em0 up up
em0.12 up up inet 12.12.12.1/24
em0.23 up up inet 23.23.23.3/24
em1 up up
em1.12 up up inet 12.12.12.2/24
em1.23 up up inet 23.23.23.2/24
gre up up
ipip up up
irb up up
lo0 up up
lo0.1 up up inet 1.1.1.1 --> 0/0
lo0.2 up up inet 2.2.2.2 --> 0/0
lo0.3 up up inet 3.3.3.3 --> 0/0

Okee.. sudah sesuai..

Sekarang lanjut kita konfigurasi static routing pada seluruh logical system ya… berikut konfigurasi static routing di R1

[edit]
root# set logical-systems R1 routing-options static route 2.2.2.2/32 next-hop
12.12.12.2


[edit]
root# set logical-systems R1 routing-options static route 3.3.3.3/32 next-hop
12.12.12.2



[edit]
root# set logical-systems R1 routing-options static route 23.23.23.0/24 next-hop
12.12.12.2

Berikut konfigurasi static routing di R2

[edit]
root# set logical-systems R2 routing-options static route 1.1.1.1/32 next-hop
12.12.12.1


[edit]
root# set logical-systems R2 routing-options static route 3.3.3.3/32 next-hop
23.23.23.2

Berikut konfigurasi static routing di R3

[edit]
root# set logical-systems R3 routing-options static route 1.1.1.1/32 next-hop
23.23.23.2


[edit]
root# set logical-systems R3 routing-options static route 2.2.2.2/32 next-hop
23.23.23.2


[edit]
root# set logical-systems R3 routing-options static route 12.12.12.0/24 next-hop
23.23.23.2

Oke.. sudah selesai.. kalo mau chek bisa pake perintah ini nih

[edit]
root#
show logical-systems R1 routing-options
static {
route 2.2.2.2/32 next-hop 12.12.12.2;
route 3.3.3.3/32 next-hop 12.12.12.2;
}

[edit]
root#
show logical-systems R2 routing-options
static {
route 1.1.1.1/32 next-hop 12.12.12.1;
route 3.3.3.3/32 next-hop 23.23.23.3;
}

[edit]
root#
show logical-systems R3 routing-options
static {
route 1.1.1.1/32 next-hop 23.23.23.2;
route 2.2.2.2/32 next-hop 23.23.23.2;
}

Okeee.. sudah benar kan..

O yaaa.. jangan lupa di commit ya

[edit]
root# commit
commit complete

Sekarang kita coba lakukan ping dari R1 ke loopback R2 dan R3

[edit]
root# run ping 2.2.2.2 logical-system R1 count 3
PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=64 time=1.569 ms
64 bytes from 2.2.2.2: icmp_seq=1 ttl=64 time=0.567 ms
64 bytes from 2.2.2.2: icmp_seq=2 ttl=64 time=0.671 ms

--- 2.2.2.2 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.567/0.936/1.569/0.450 ms

[edit]
root# run ping 3.3.3.3 logical-system R1 count 3
PING 3.3.3.3 (3.3.3.3): 56 data bytes
64 bytes from 3.3.3.3: icmp_seq=0 ttl=63 time=1.630 ms
64 bytes from 3.3.3.3: icmp_seq=1 ttl=63 time=0.897 ms
64 bytes from 3.3.3.3: icmp_seq=2 ttl=63 time=0.974 ms

--- 3.3.3.3 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.897/1.167/1.630/0.329 ms

Mau coba traceroute??

[edit]
root# run traceroute 2.2.2.2 logical-system R1
traceroute to 2.2.2.2 (2.2.2.2), 30 hops max, 40 byte packets
1 2.2.2.2 (2.2.2.2) 0.536 ms 0.427 ms 0.267 ms

[edit]
root# run traceroute 3.3.3.3 logical-system R1
traceroute to 3.3.3.3 (3.3.3.3), 30 hops max, 40 byte packets
1 12.12.12.2 (12.12.12.2) 0.653 ms 0.461 ms 0.486 ms
2 3.3.3.3 (3.3.3.3) 0.989 ms 0.779 ms 1.319 ms

Okeeee… berhasil yaa kita setting static routingnya di juniper..

Sampai disini dulu yaaa.. sampai jumpa di artikel artikel selanjutnya… semoga bermanfaat

Lab 128 – Static Routing Juniper

Welcome to juniper second lab!!!.. hehehe ini adalah lab kedua juniper nih.. semoga bisa istiqomah belajarnya.. Aamiin..

Pada lab ini kita akan sama2 belajar static routing di juniper yaaa.. kita akan pake topologi ini yaa

O yaaa.. disini kita akan pake logical system ya… kemarin di lab juniper pertama kita udah beljar kan tentang logical system juniper...

Pertama kita konfig logical system nya dulu yaaa

[edit]
root# set interfaces em0 vlan-tagging

[edit]
root# set interfaces em1 vlan-tagging

Berikut konfigurasi logical system untuk R1

[edit]
root# edit logical-systems R1

[edit logical-systems R1]
root# set interfaces em0.12 vlan-id 12 family inet address 12.12.12.1/24


[edit logical-systems R1]
root# set interfaces lo0.1 family inet address 1.1.1.1/32

Berikut konfigurasi logical system untuk R2

[edit logical-systems R1]
root# top

[edit]
root# edit logical-systems R2

[edit logical-systems R2]
root# set interfaces em1.12 vlan-id 12 family inet address 12.12.12.2/24

[edit logical-systems R2]
root# set interfaces em1.23 vlan-id 23 family inet address 23.23.23.2/24

[edit logical-systems R2]
root# set interfaces lo0.2 family inet address 2.2.2.2/32

Berikut konfigurasi logical system address untuk R3

[edit logical-systems R2]
root# top

[edit]
root# edit logical-systems R3

[edit logical-systems R3]
root# set interfaces em0.23 vlan-id 23 family inet address 23.23.23.3/24

[edit logical-systems R3]
root# set interfaces lo0.3 family inet address 3.3.3.3/32

O yaaaa.. jangan lupa commit ya

[edit]
root# commit
commit complete

Okeee.. konfigurasi addressing sudah selesai pada seluruh logical system.. kita coba cek yaa

root# run show interfaces terse
Interface Admin Link Proto Local Remote
cbp0 up up
demux0 up up
dsc up up
em0 up up
em0.12 up up inet 12.12.12.1/24
em0.23 up up inet 23.23.23.3/24
em1 up up
em1.12 up up inet 12.12.12.2/24
em1.23 up up inet 23.23.23.2/24
gre up up
ipip up up
irb up up
lo0 up up
lo0.1 up up inet 1.1.1.1 --> 0/0
lo0.2 up up inet 2.2.2.2 --> 0/0
lo0.3 up up inet 3.3.3.3 --> 0/0

Okee.. sudah sesuai..

Sekarang lanjut kita konfigurasi static routing pada seluruh logical system ya… berikut konfigurasi static routing di R1

[edit]
root# set logical-systems R1 routing-options static route 2.2.2.2/32 next-hop
12.12.12.2


[edit]
root# set logical-systems R1 routing-options static route 3.3.3.3/32 next-hop
12.12.12.2



[edit]
root# set logical-systems R1 routing-options static route 23.23.23.0/24 next-hop
12.12.12.2

Berikut konfigurasi static routing di R2

[edit]
root# set logical-systems R2 routing-options static route 1.1.1.1/32 next-hop
12.12.12.1


[edit]
root# set logical-systems R2 routing-options static route 3.3.3.3/32 next-hop
23.23.23.2

Berikut konfigurasi static routing di R3

[edit]
root# set logical-systems R3 routing-options static route 1.1.1.1/32 next-hop
23.23.23.2


[edit]
root# set logical-systems R3 routing-options static route 2.2.2.2/32 next-hop
23.23.23.2


[edit]
root# set logical-systems R3 routing-options static route 12.12.12.0/24 next-hop
23.23.23.2

Oke.. sudah selesai.. kalo mau chek bisa pake perintah ini nih

[edit]
root#
show logical-systems R1 routing-options
static {
route 2.2.2.2/32 next-hop 12.12.12.2;
route 3.3.3.3/32 next-hop 12.12.12.2;
}

[edit]
root#
show logical-systems R2 routing-options
static {
route 1.1.1.1/32 next-hop 12.12.12.1;
route 3.3.3.3/32 next-hop 23.23.23.3;
}

[edit]
root#
show logical-systems R3 routing-options
static {
route 1.1.1.1/32 next-hop 23.23.23.2;
route 2.2.2.2/32 next-hop 23.23.23.2;
}

Okeee.. sudah benar kan..

O yaaa.. jangan lupa di commit ya

[edit]
root# commit
commit complete

Sekarang kita coba lakukan ping dari R1 ke loopback R2 dan R3

[edit]
root# run ping 2.2.2.2 logical-system R1 count 3
PING 2.2.2.2 (2.2.2.2): 56 data bytes
64 bytes from 2.2.2.2: icmp_seq=0 ttl=64 time=1.569 ms
64 bytes from 2.2.2.2: icmp_seq=1 ttl=64 time=0.567 ms
64 bytes from 2.2.2.2: icmp_seq=2 ttl=64 time=0.671 ms

--- 2.2.2.2 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.567/0.936/1.569/0.450 ms

[edit]
root# run ping 3.3.3.3 logical-system R1 count 3
PING 3.3.3.3 (3.3.3.3): 56 data bytes
64 bytes from 3.3.3.3: icmp_seq=0 ttl=63 time=1.630 ms
64 bytes from 3.3.3.3: icmp_seq=1 ttl=63 time=0.897 ms
64 bytes from 3.3.3.3: icmp_seq=2 ttl=63 time=0.974 ms

--- 3.3.3.3 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.897/1.167/1.630/0.329 ms

Mau coba traceroute??

[edit]
root# run traceroute 2.2.2.2 logical-system R1
traceroute to 2.2.2.2 (2.2.2.2), 30 hops max, 40 byte packets
1 2.2.2.2 (2.2.2.2) 0.536 ms 0.427 ms 0.267 ms

[edit]
root# run traceroute 3.3.3.3 logical-system R1
traceroute to 3.3.3.3 (3.3.3.3), 30 hops max, 40 byte packets
1 12.12.12.2 (12.12.12.2) 0.653 ms 0.461 ms 0.486 ms
2 3.3.3.3 (3.3.3.3) 0.989 ms 0.779 ms 1.319 ms

Okeeee… berhasil yaa kita setting static routingnya di juniper..

Sampai disini dulu yaaa.. sampai jumpa di artikel artikel selanjutnya… semoga bermanfaat

Lab 127 – Logical System in Juniper

Ceritanya ahir2 ini lagi galau.. pengen belajar sesuatu yang baru.. hehe.. Ahirnya ketemu nih sama juniper.. kenalan dikit sama juniper, eh kayaknya kog pengen lebih deket.. hehehe…

Ya begitulah.. ceritanya pengen belajar sesuatu hal yang baru,, dan saya rasa Juniper merupakan product yang unik.. konfigurasinya jauh beda dengan mikrotik ataupun cisco.. jadi yaaaaa… saya merasa tertarik dan tertantang untuk mempelajari yang satu ini.. hehe

Artikel pertama tentang Juniper ini saya akan membahas tentang logical system.. Logical system juniper ini asyik banget.. kita bisa menjalankan berapapun router dalam sebuah router… milik virtualisasi lah..

Kayak gini nih ilustrasinya logical system juniper

Yang kiri itu system biasa.. kalau kita mau praktik pake 6 router. berarti kita harus punya 6 router juga.. nah yang kanan tuh pake logical system.. untuk praktik 6 router,, kita cukup menggunakan 1 router saja..

bingung yaa??? hahaha oke dah daripada tambah bingung langsung kita ngelab aja..

Perhatikan gambar diatas,, dengan satu rotuer saja.. saya bisa praktik mengkonfigurasi 3 router.. yaitu R1 R2 dan R3.. asumsinya disini router asli saya (Juniper) hanya memiliki dua interface, yaitu em0 dan em1.

Nah kedua interface itu bisa digunakan oleh seluruh logical rotuer (R1, R2, ataupun R3)…. yang penting adalah sebuah interface nda boleh digunakan dalam vlan yang sama… sebagai contoh link antara R1 dan R2 kan make vlan 12.. nah di kedua router tersebut ga bisa kalo hanya pake satu interface yang sama.. harus pake dua interface yang beda.. pada topologi diatas kita make em0 pada R1 dan em1 pada R2.. tapi sebuah interface bisa dipake rotuer lain.. asal dengan vlan id yang beda yaaa…

Oke sekarang kita konfig yaaa..

root@% cli

root> configure

[edit]
root#

Untuk login pertama kali ke juniper, gunakan user root,, nanti akan diarahkan ke prompt root@% seperti diatas..promt ini menunjukkan bahwa kita berada di free bsd mode.. selanjutnya ketikkan cli untuk masuk ke juniper mode.. kemudian ketikkan configure untuk masuk ke config mode.. disini kita bisa melakukan konfigurasi pada juniper..

Selanjutnya lakukan konfigurasi berikut

root# set system root-authentication plain-text-password
New password:
Retype new password:

Konfigurasi diatas digunakan untuk set password user root.. kalau kita tidak melakukan langkah diatas.. nanti kita ga bisa commit

Oke.. sekarang kita konfigurasikan vlan tagging pada interface em0 dan em1

root# set interfaces em0 vlan-tagging

[edit]
root# set interfaces em1 vlan-tagging

[edit]
root#

Oke lanjut.. kita lakukan konfigurasi logical system R1.. sesuaikan dengan topologi yaaa untuk interface dan ip address nya.. o yaa.. untuk ip address kita akan menggunakan standard IDN yaa

root# edit logical-systems R1

[edit logical-systems R1]
root#
set interfaces em0.12 vlan-id 12 family inet address 12.12.12.1/24

[edit logical-systems R1]
root#
set interfaces em0.13 vlan-id 13 family inet address 13.13.13.1/24

[edit logical-systems R1]
root#
commit
commit complete

Setelah mengetikkan perintah pertama diatas.. kita berganti direktori lah enak nya kalo nyebut.. hehe.. di direktori logical-system R1 kita konfigurasikan interface em0.12 dan em0.13..

Untuk melihat konfigurasi yang telah kita lakukan.. kita bisa menggunakan perintah berikut

[edit logical-systems R1]
root#
show
interfaces {
em0 {
unit 12 {
vlan-id 12;
family inet {
address 12.12.12.1/24;
}
}
unit 13 {
vlan-id 13;
family inet {
address 13.13.13.1/24;
}
}
}
}

Perintah diatas digunakan untuk melihat konfigurasi pada logical-system R1 aja.. coba lihat tuh sekarang posisi kita ada di logical-system R1..

Oke.. sudah sesuai dengan yang kita konfigurasikan yaaa… kalau pengen lihat hasilnya,, kita bisa pake perintah berikut

root# run show interfaces terse
Interface Admin Link Proto Local Remote
cbp0 up up
demux0 up up
dsc up up
em0 up up
em0.12 up up inet 12.12.12.1/24
em0.13 up up inet 13.13.13.1/24
......
...........

Oke.. ip address 12.12.12.1/24 dan 13.13.13.1/24 sudah aktif.. perhatikan bahwa interface nya juga sesuai dengan yang kita konfigurasikan..

Oke konfigurasi logical system R1 sudah selesai.. lanjut kita konfigurasi logical system R2 yaa

[edit logical-systems R1]
root#
top

[edit]
root# edit logical-systems R2

[edit logical-systems R2]
root# set interfaces em1.12 vlan-id 12 family inet address 12.12.12.2/24

[edit logical-systems R2]
root# set interfaces em1.23 vlan-id 23 family inet address 23.23.23.2/24

[edit logical-systems R2]
root# commit
commit complete

Perintah top itu digunakan untuk kembali ke hirarki tertinggi.. yaitu di edit

Oke.. sebelum lanjut konfigurasi logical system R3.. kita coba ping dulu ya dari R1 ke R2..

root# run ping 12.12.12.2 logical-system R1 count 3
PING 12.12.12.2 (12.12.12.2): 56 data bytes
64 bytes from 12.12.12.2: icmp_seq=0 ttl=64 time=1.194 ms
64 bytes from 12.12.12.2: icmp_seq=1 ttl=64 time=0.492 ms
64 bytes from 12.12.12.2: icmp_seq=2 ttl=64 time=0.736 ms

--- 12.12.12.2 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.492/0.807/1.194/0.291 ms

[edit logical-systems R2]
root#

Oke.. sudah berhasil yaa.. mantabbb lahhh

Sekarang kita lakukan konfigurasi logical system R3

[edit logical-systems R2]
root# top

[edit]
root# edit logical-systems R3

[edit logical-systems R3]
root# set interfaces em1.13 vlan-id 13 family inet address 13.13.13.3/24

[edit logical-systems R3]
root# set interfaces em0.23 vlan-id 23 family inet address 23.23.23.3/24

[edit logical-systems R3]
root# commit
commit complete

Sepertinya konfignya sudah selesai nih.. coba kita ping dari R3 ke R1 dan R2

root# run ping 13.13.13.1 logical-system R3 count 3
PING 13.13.13.1 (13.13.13.1): 56 data bytes
64 bytes from 13.13.13.1: icmp_seq=0 ttl=64 time=0.690 ms
64 bytes from 13.13.13.1: icmp_seq=1 ttl=64 time=0.465 ms
64 bytes from 13.13.13.1: icmp_seq=2 ttl=64 time=0.549 ms

--- 13.13.13.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.465/0.568/0.690/0.093 ms

[edit logical-systems R3]
root# run ping 23.23.23.2 logical-system R3 count 3
PING 23.23.23.2 (23.23.23.2): 56 data bytes
64 bytes from 23.23.23.2: icmp_seq=0 ttl=64 time=5.917 ms
64 bytes from 23.23.23.2: icmp_seq=1 ttl=64 time=0.744 ms
64 bytes from 23.23.23.2: icmp_seq=2 ttl=64 time=0.570 ms

--- 23.23.23.2 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.570/2.410/5.917/2.481 ms

Okeeee.. sudah jalan semua yaaaa.. gimana gimana?? asyik kan?? dengan satu router aja kita bisa praktik seolah-olah punya 3 router.. hehehe bisa kaya nih kita bisa gandain router.. hehe

Oke sampai disini dulu yaaa.. semoga bermanfaat

Lab 127 – Logical System in Juniper

Ceritanya ahir2 ini lagi galau.. pengen belajar sesuatu yang baru.. hehe.. Ahirnya ketemu nih sama juniper.. kenalan dikit sama juniper, eh kayaknya kog pengen lebih deket.. hehehe…

Ya begitulah.. ceritanya pengen belajar sesuatu hal yang baru,, dan saya rasa Juniper merupakan product yang unik.. konfigurasinya jauh beda dengan mikrotik ataupun cisco.. jadi yaaaaa… saya merasa tertarik dan tertantang untuk mempelajari yang satu ini.. hehe

Artikel pertama tentang Juniper ini saya akan membahas tentang logical system.. Logical system juniper ini asyik banget.. kita bisa menjalankan berapapun router dalam sebuah router… milik virtualisasi lah..

Kayak gini nih ilustrasinya logical system juniper

Yang kiri itu system biasa.. kalau kita mau praktik pake 6 router. berarti kita harus punya 6 router juga.. nah yang kanan tuh pake logical system.. untuk praktik 6 router,, kita cukup menggunakan 1 router saja..

bingung yaa??? hahaha oke dah daripada tambah bingung langsung kita ngelab aja..

Perhatikan gambar diatas,, dengan satu rotuer saja.. saya bisa praktik mengkonfigurasi 3 router.. yaitu R1 R2 dan R3.. asumsinya disini router asli saya (Juniper) hanya memiliki dua interface, yaitu em0 dan em1.

Nah kedua interface itu bisa digunakan oleh seluruh logical rotuer (R1, R2, ataupun R3)…. yang penting adalah sebuah interface nda boleh digunakan dalam vlan yang sama… sebagai contoh link antara R1 dan R2 kan make vlan 12.. nah di kedua router tersebut ga bisa kalo hanya pake satu interface yang sama.. harus pake dua interface yang beda.. pada topologi diatas kita make em0 pada R1 dan em1 pada R2.. tapi sebuah interface bisa dipake rotuer lain.. asal dengan vlan id yang beda yaaa…

Oke sekarang kita konfig yaaa..

root@% cli

root> configure

[edit]
root#

Untuk login pertama kali ke juniper, gunakan user root,, nanti akan diarahkan ke prompt root@% seperti diatas..promt ini menunjukkan bahwa kita berada di free bsd mode.. selanjutnya ketikkan cli untuk masuk ke juniper mode.. kemudian ketikkan configure untuk masuk ke config mode.. disini kita bisa melakukan konfigurasi pada juniper..

Selanjutnya lakukan konfigurasi berikut

root# set system root-authentication plain-text-password
New password:
Retype new password:

Konfigurasi diatas digunakan untuk set password user root.. kalau kita tidak melakukan langkah diatas.. nanti kita ga bisa commit

Oke.. sekarang kita konfigurasikan vlan tagging pada interface em0 dan em1

root# set interfaces em0 vlan-tagging

[edit]
root# set interfaces em1 vlan-tagging

[edit]
root#

Oke lanjut.. kita lakukan konfigurasi logical system R1.. sesuaikan dengan topologi yaaa untuk interface dan ip address nya.. o yaa.. untuk ip address kita akan menggunakan standard IDN yaa

root# edit logical-systems R1

[edit logical-systems R1]
root#
set interfaces em0.12 vlan-id 12 family inet address 12.12.12.1/24

[edit logical-systems R1]
root#
set interfaces em0.13 vlan-id 13 family inet address 13.13.13.1/24

[edit logical-systems R1]
root#
commit
commit complete

Setelah mengetikkan perintah pertama diatas.. kita berganti direktori lah enak nya kalo nyebut.. hehe.. di direktori logical-system R1 kita konfigurasikan interface em0.12 dan em0.13..

Untuk melihat konfigurasi yang telah kita lakukan.. kita bisa menggunakan perintah berikut

[edit logical-systems R1]
root#
show
interfaces {
em0 {
unit 12 {
vlan-id 12;
family inet {
address 12.12.12.1/24;
}
}
unit 13 {
vlan-id 13;
family inet {
address 13.13.13.1/24;
}
}
}
}

Perintah diatas digunakan untuk melihat konfigurasi pada logical-system R1 aja.. coba lihat tuh sekarang posisi kita ada di logical-system R1..

Oke.. sudah sesuai dengan yang kita konfigurasikan yaaa… kalau pengen lihat hasilnya,, kita bisa pake perintah berikut

root# run show interfaces terse
Interface Admin Link Proto Local Remote
cbp0 up up
demux0 up up
dsc up up
em0 up up
em0.12 up up inet 12.12.12.1/24
em0.13 up up inet 13.13.13.1/24
......
...........

Oke.. ip address 12.12.12.1/24 dan 13.13.13.1/24 sudah aktif.. perhatikan bahwa interface nya juga sesuai dengan yang kita konfigurasikan..

Oke konfigurasi logical system R1 sudah selesai.. lanjut kita konfigurasi logical system R2 yaa

[edit logical-systems R1]
root#
top

[edit]
root# edit logical-systems R2

[edit logical-systems R2]
root# set interfaces em1.12 vlan-id 12 family inet address 12.12.12.2/24

[edit logical-systems R2]
root# set interfaces em1.23 vlan-id 23 family inet address 23.23.23.2/24

[edit logical-systems R2]
root# commit
commit complete

Perintah top itu digunakan untuk kembali ke hirarki tertinggi.. yaitu di edit

Oke.. sebelum lanjut konfigurasi logical system R3.. kita coba ping dulu ya dari R1 ke R2..

root# run ping 12.12.12.2 logical-system R1 count 3
PING 12.12.12.2 (12.12.12.2): 56 data bytes
64 bytes from 12.12.12.2: icmp_seq=0 ttl=64 time=1.194 ms
64 bytes from 12.12.12.2: icmp_seq=1 ttl=64 time=0.492 ms
64 bytes from 12.12.12.2: icmp_seq=2 ttl=64 time=0.736 ms

--- 12.12.12.2 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.492/0.807/1.194/0.291 ms

[edit logical-systems R2]
root#

Oke.. sudah berhasil yaa.. mantabbb lahhh

Sekarang kita lakukan konfigurasi logical system R3

[edit logical-systems R2]
root# top

[edit]
root# edit logical-systems R3

[edit logical-systems R3]
root# set interfaces em1.13 vlan-id 13 family inet address 13.13.13.3/24

[edit logical-systems R3]
root# set interfaces em0.23 vlan-id 23 family inet address 23.23.23.3/24

[edit logical-systems R3]
root# commit
commit complete

Sepertinya konfignya sudah selesai nih.. coba kita ping dari R3 ke R1 dan R2

root# run ping 13.13.13.1 logical-system R3 count 3
PING 13.13.13.1 (13.13.13.1): 56 data bytes
64 bytes from 13.13.13.1: icmp_seq=0 ttl=64 time=0.690 ms
64 bytes from 13.13.13.1: icmp_seq=1 ttl=64 time=0.465 ms
64 bytes from 13.13.13.1: icmp_seq=2 ttl=64 time=0.549 ms

--- 13.13.13.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.465/0.568/0.690/0.093 ms

[edit logical-systems R3]
root# run ping 23.23.23.2 logical-system R3 count 3
PING 23.23.23.2 (23.23.23.2): 56 data bytes
64 bytes from 23.23.23.2: icmp_seq=0 ttl=64 time=5.917 ms
64 bytes from 23.23.23.2: icmp_seq=1 ttl=64 time=0.744 ms
64 bytes from 23.23.23.2: icmp_seq=2 ttl=64 time=0.570 ms

--- 23.23.23.2 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max/stddev = 0.570/2.410/5.917/2.481 ms

Okeeee.. sudah jalan semua yaaaa.. gimana gimana?? asyik kan?? dengan satu router aja kita bisa praktik seolah-olah punya 3 router.. hehehe bisa kaya nih kita bisa gandain router.. hehe

Oke sampai disini dulu yaaa.. semoga bermanfaat