Pembahasan Soal Superlab Cisco IDN Competition 2017 : Section 1 Part 2

Joss, kita lanjutin lagi ke Section 1 part 2. Untuk Pembahasan sebelumnya bisa di clik disini Pembahasan Soal Superlab Cisco IDN Competition 2017 : Section 1 Part 1

1.3 Spanning Tree

1. Pada tahap ini kita diminta untuk mengkonfigurasikan beberapa device dengan ketentuan
sebagai berikut :

  • Konfigurasikan mode yang langsung membypass listening dan learning, konfigurasikan mode ini hanya pada port yang mengarah ke client (PC).

Jadi kita diminta untuk mengkonfigurasi spanning tree portfast pada port switch yang mengarah ke client (PC)

Switch yang perlu dikonfigurasi pada jaringan

  • Internet    : SW0 port fa0/3 (Disini masih kurang yakin perlu dikonfigurasi atau gk. Cuman diliat dari soalnya minta semua PC, jadi mungkin disini juga diminta)
  • Makassar : SW11 port fa0/3
  • Semarng  : SW-SMG port fa0/3-4
  • Solo          : SW7-SW10 port fa0/2-3 dan SW6 port fa0/9

Untuk perintah nya :

  • Masuk ke interface : interface fa0/nomor-interface.
    Jika ada 2 interface yang dikonfigurasi contoh pada SW-SMG, Gunakan range. Ex: interface range fa0/3-4

    • spanning-tree portfast : mengaktifkan fitur spanning tree portfast

Cukup 2 perintah tersebut

1.4 Implement WAN Technologies

1. Konfigurasikan WAN pada link ISP6 dan R19 di Jayapura dengan ketentuan sebagai berikut :

  •  Link WAN harus support negotiation dan authentication
  • Gunakan WAN Protocol yang memiliki fitur kompresi, authentikasi, dan error detection
  • Untuk authentikasinya gunakan mode yang support enkripsi
  • Jangan merubah hostname di kedua device gunakan password idnmantab

WAN Technologies, yang perlu kita konfigurasi itu adalah encapsulation pada interface serial di antar router. Disini yang diminta adalah ISP6 dan R19. Yang support negotiation dan authentication itu encapsulation menggunakan PPP. Authentication pada PPP ada 2, PAP sama CHAP. Tpi disini diminta yang mensupport enkripsi berarti kita menggunakan CHAP.

Selection_022
Link Serial ISP6-R19

ISP6

  • interface se0/0/1
    • no shutdown
      (karena pada router semua interface defaultnya dalam keadaan shutdown)
    • encapsulation ppp
    • ppp authentication chap
    • exit (perlu exit karena command selanjutnya digunakan pada global-config)
  • username R19 password idnmantab
    (Untuk authentikasi menggunakan chap kita membuat user dengan hostname lawan (R19) lalu password yang sama dikedua router)
  • Untuk penghecheckan bisa menggunakan perintah “show interface se0/0/1” lalu lihat pada bagian encapsulation apakah sudah PPP
  • Namun jika router pasangannya (R19) belum dikonfigurasi maka status interface akan down

R19

  • interface se0/0/0
    • no shutdown
    • encapsulation ppp
    • ppp authentication
    • exit
  • username ISP6 password idnmantab
  • Jika kedua router sudah di konfigurasi maka status interfacenya akan kembali up

2. Konfigurasikan WAN pada link ISP4 dan R13 di Semarang dengan ketentuan sebagai berikut:

  • Link WAN harus support negotiation dan authentication
  • Gunakan WAN Protocol yang memiliki fitur kompresi, authentikasi dan error detection
  • Gunakan authentikasi yang support enkripsi
  • Jangan merubah hostname di kedua device gunakan password idn

Disini juga sama saja seperti sebelumnya. Cuman beda di password saja

Selection_023.png
Link antar ISP4 – R13

ISP4

  • interface se0/1/1
    • no shutdown
    • encapsulation ppp
    • ppp authentication dot1q
    • exit
  • username R13 password idn

R13

  • interface se0/1/0
    • no shutdown
    • encapsulation ppp
    • ppp authentication dot1q
    • exit
  • username ISP4 password idn

3. Konfigurasikan WAN pada link ISP1 dan R2 di Jakarta dengan ketentuan sebagai berikut:

  • Gunakan Link WAN yang mempunyai encapsulation default untuk interface serial
  •  Jangan merubah hostname di kedua device

Disini kita diminta untuk mengkonfigurasi link antar ISP1 dan R2 di Jakarta menggunakan encapsulation default yaitu HDLC. Gk ada authentication disini, jadi hanya perlu menyalakan interface dan di ubah ke HDLC. 

Selection_024.png
Link ISP1 – R2

Jika kita check link antar ISP1 dan R2, Linknya menggunakan encapsulation PPP. Contoh check di R2

Selection_025.png
Check encapsulation interface serial 0/1/0 pada Router R2

R2

  • interface se0/1/0
    • no shutdown
    • encapsulation hdlc

ISP1

  • interface se0/0/0
    • no shutdown
    • encapsulation hdlc

Jika mau di check gunakan perintah “show interface inteface-number”

1.5 Implement VPN

Untuk yang VPN saya skip dulu. 😀 saya masih bingung yang diminta jadi VPN Server atau tunneling. Soalnya saya udah coba keduanya gk ada naik nilainya 😀
Mungkin nanti klo sudah dapat pencerahan dari yang buat, saya share lagi buat VPN

OK ? siap, Udah selesai yang section 1 semoga mudah dipahami dan dimengerti.

Post berikutnya lanjut ke Section 2 (Layer 3). Jadi pastikan pantau blognya yaa …

Pembahasan Soal Superlab Cisco IDN Competition 2017 : Section 1 Part 1

Kali ini akan membahas soal superlab cisco yang di adakan oleh ID-Networkers. Udah 2 kali coba dan nilainya cuman dapat 75% saja. OK gk masalah, bukan masalah nilai yang kita butuhkan yang penting kita dapat belajar hal baru lagi dengan mencoba soal ini. Aku masih belajar juga mungkin di pembahasan ini ada yang salah atau kurang benar mohon dikoreksi dan juga kedepannya ada beberapa service yang saya tidak masukkan karena saya juga masih bingung.

Sebelum mengerjakan juga diharapkan udah paham ya cara konfigurasi di cisco bagaimana. Beberapa service udah ada saya jelasin di blog, tinggal di cari saja. Misal VTP atau VLAN dll.

Untuk soal dan file .pka nya bisa di ambil di sini Soal dan Pka

Topologi Jaringan

A. Physical Topologi

Selection_009.png
Physical Topologi

B. Logical Topologi

Selection_010
Logical Topologi

Jangan terlalu pusing melihat topologinya yang besar. Kita kerjainnya satu-satu biar mudah. Fokus ke soal saja, kerjain per service yang diminta.

Section 1 : Switching

1.1 Switch Administration (VTP)

1. Konfigurasikan device di bagian Jakarta dengan ketentuan sebagai berikut :

  • VTP domain harus di set idncompetition2017
  • Jangan gunakan VTP versi default
  •  SW2 harus di set agar menerima informasi VTP dari SW1
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    IDNcompetition2017mantab

Kita pahamin dulu soalnya ok. Kita diminta untuk mengkonfigurasi VTP pada SW1 dan SW2 di Jakarta dengan ketentuan :

  • VTP Domain : idncompetition2017
  • VTP Version 2, karena VTP versi defaultnya adalah versi 1
  • SW1 modenya Server dan SW2 modenya Client
  • VTP password : IDNcompetition2017mantab

Konfigurasinya :

SW1

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode server
  4. vtp password IDNcompetition2017mantab

SW2

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode client
  4. vtp password IDNcompetition2017mantab

Untuk pengecheckan vtp nya bisa menggunakan perintah

  1. show vtp status
  2. show vtp password

2. Konfigurasikan device di bagian Samarinda dengan ketentuan sebagai berikut :

  • VTP domain harus di set idncompetition2017
  • Jangan gunakan VTP versi default
  • Pastikan MLS4 menerima update informasi VTP dari MLS3
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    IDNcompetition2017mantab

Hampir sama saja dengan yang dijakarta. Kita mengerjakannya di Samarinda dan disini MLS4 sebagai Client dan MLS3 sebagai Server

MLS3

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode server
  4. vtp password IDNcompetition2017mantab

MLS4

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode client
  4. vtp password IDNcompetition2017mantab

3. Konfigurasikan device di bagian Makasar dengan ketentuan sebagai berikut :

  • VTP domain harus di set IDNcompetition2017!
  • Jangan gunakan VTP versi default
  • Pastikan MLS5 dan MLS6 tidak menyebarkan informasi VTP ke switch lain
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    idnmantab

Kita mengerjakannya di Makasar. Hampir sama seperti sebelumnya. Bedanya disini kedua switch menggunakan mode VTP Transparent.

MLS5 & MLS6

  1. vtp domain IDNcompetition2017!
  2. vtp version 2
  3. vtp mode transparent
  4. vtp password idnmantab

4. Konfigurasikan device di bagian Semarang dengan ketentuan       sebagai berikut :

  • VTP domain harus di set idnid
  • Pastikan semua switch di area semarang mendapat update informasi VTP dari MLS8
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    idncompetition2017

Disini mungkin menggunakan vtp version 1 karena tidak diminta untuk mengubahnya. Semua switch di Semarang modenya adalah client kecuali MLS8 yang menggunakan mode server

MLS8

  1. vtp domain idnid
  2. vtp mode server
  3. vtp password idncompetition2017

MLS1, MLS2 & MLS7

  1. vtp domain idnid
  2. vtp mode client
  3. vtp password idncompetition2017

4. Konfigurasikan device di bagian Solo dengan ketentuan sebagai berikut :

  • VTP domain harus di set IDNcompetition2017!
  • Jangan gunakan VTP versi default
  •  Konfigurasikan agar SW3 mau menyebarkan update informasi VTP ke Swith lain yang ada di Solo
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    IDN@2017_competition

Disini SW3 sebagai server dan switch yang lainnya sebagai client

SW3

  1. vtp domain IDNcompetition2017!
  2. vtp version 2
  3. vtp mode server
  4. vtp password IDN@2017_competition

SW4-10

  1. vtp domain IDNcompetition2017!
  2. vtp version 2
  3. vtp mode client
  4. vtp password IDN@2017_competition

1.2 Layer 2 Ports

1. Pada tahap ini kita diminta untuk mengkonfigurasikan beberapa device dengan ketentuan sebagai berikut :

  • Konfigurasikan VLAN pada device sesuai dengan logical topologi.
  • Pastikan database VLAN antar switch sama.
  • Konfigurasikan link antara SW1-SW2 dan MLS3-MLS4 pastikan semua link up menggunakan tipe open standard.
  • Semua port switch pada topologi yang support up to 1000mb/s pastikan statusnya di assign ke vlan88 dan statusnya administratively down

Ini kita kerjakan di Jakarta dan Samarinda. Kita disuruh membuat VLAN dan assign interface ke VLAN menyesuaikan sesuai dengan logical topologi.

Jakarta


Untuk link antar switch menggunakan tipe dot1q lalu di trunk. Trus port interface gig itu dimasukkan ke vlan88 dan di shutdown biar statusnya jadi administratively down. Kita konfigurasi SW1 dulu untuk membuat VLAN karena SW1 sebagai VTP server. Dan juga memasukkan masing-masing interface sesuai logical topologi.

SW1

  1. Buat vlan sesuai logical yaitu VLAN 14,15,23,24,35,46,57,67,88 totalnya ada 9 VLAN
    • perintah “vlan vlan-number
    • Check dengan perintah “show vlan brief”
  2. Interface 21-23 kita ubah menjadi trunk
    • interface range fa0/21-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • Check dengan perintah “show interface fa0/21 switchport” atau “show run”
  3. Assign Vlan sesuai Logical topologi
    • interface fa0/6
      • switchport mode access
      • switchport access vlan 67
    • interface fa0/7
      • switchport mode access
      • switchport access vlan 67
    • interface fa0/4
      • switchport mode access
      • switchport access vlan 14
    • interface fa0/5
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
      • Dikonfigurasi Trunk karena pada fa0/5 terhubung ke R5-fa0/0 yang menggunakan interVLAN
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 24
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 35
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 14
    • Check dengan perintah “show vlan brief”
  4. Masukkan vlan 88 pada interface gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown
    • Check dengan perintah “show vlan brief” dan “show ip interface brief”

SW2

  1. Gk usah buat VLAN, karena sudah terbuat hasil dari VTP. bisa di check menggunakan “show vlan brief”
  2. Interface fa0/21-23 ubah menjadi trunk
    • interface range fa0/21-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign Vlan sesuai Logical topologi
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 23
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 23
    • interface fa0/4
      • switchport trunk encapsulation dot1q
      • switchport mode trunk (penjelasan sama seperti sebelumnya)
    • interface fa0/5
      • switchport mode access
      • switchport access vlan 15
    • interface fa0/6
      • switchport mode access
      • switchport access vlan 46
    • interface fa0/7
      • switchport mode access
      • switchport access vlan 57
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 15
  4. Masukkan vlan 88 pada interface gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown

Samarinda


Hampir sama dengan di Jakarta. Bedanya hanya di VLAN dan interfacenya. Kita buat VLANnya di MLS3 karena sebagai VTP Server

MLS3

  1. Membuat VLAN 89,108,118,109,119,110,88 total ada 7 vlan.
    • vlan vlan-number
  2. Ubah interface fa0/20-23 menjadi trunk
    • interface range fa0/20-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 89
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 109
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 108
    • interface fa0/4
      • switchport trunk encapsulation dot1q
      • switchport mode trunk (Diubah ke trunk karena fa0/0 pada R11 menggunakan interVLAN)
  4. Assign VLAN 88 ke gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown

MLS4

  1. Membuat VLAN 89,108,118,109,119,110,88 total ada 7 vlan.
    • vlan vlan-number
  2. Ubah interface fa0/20-23 menjadi trunk
    • interface range fa0/20-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/2
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/3
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  4. Assign VLAN 88 ke gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown

2. Konfigurasikan network device yang ada di Makassar dengan ketentuan sebagai berikut :

  • Pastikan database VLAN antar switch sama.
  • Konfigurasikan VLAN dan assign switchport sesuai dengan topologi logical.
  • Gunakan model dot1q trunk untuk menghubungkan SW5 dan SW6. (maksudnya MLS5 dan MLS6)
  • Trunk jangan di set auto negotiation ataupun etherchannel.

Sama seperti sebelumnya. Kita buat VLANnya dulu. Karena kedua VLAN menggunakan VTP transparent jadi keduanya membuat VLAN. Assign interface ke VLAN sesuai dengan logical topologi. Interface antar MLS5-MLS6 diganti ke trunk dengan dot1q.


MLS5

  1. Buat VLAN 156 dan 157 “vlan vlan-number”
  2. Interface fa0/11-13 ubah menjadi trunk
    • interface range fa0/11-13
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 156
    • Karena R16 terhubung ke VLAN 156 menggunakan interface e0/1/0 maka di MLS5 cuman 1 interface saja

MLS6

  1. Buat VLAN 156 dan 157 “vlan vlan-number”
  2. Interface fa0/11-13 ubah menjadi trunk
    • interface range fa0/11-13
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 157
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 157
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 156

3. Konfigurasikan network device yang ada di Semarang dengan ketentuan sebagai berikut :

  • Pastikan database VLAN antar switch sama.
  • Konfigurasikan VLAN dan assign switchport sesuai dengan topologi logical. Pastikan VLAN yang telah di assign banar dan sesuai topologi.
  • Trunk jangan di set auto negotiation ataupun etherchannel.

Sama seperti sebelumnya. Kita buat VLANnya hanya di MLS8 karena VTP modenya server dan switch lain VTP modenya client. Lalu assign sesuai topologi. Dan antar switchnya gunakan mode trunk.


MLS8

  1. Buat VLAN 212, 213, 214, 223, 224, 234 dengan perintah “vlan vlan-number”
  2. Interface fa0/21-22 modenya jadi trunk
    • interface range fa0/21-22
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 213
    • interface fa0/2
      • switchport trunk encapsulation dot1q
      • swithcport mode trunk

MLS7

  1. VLAN sudah terbuat, bisa di check dengan “show vlan brief”
  2. Interface fa0/22-23 kita ubah modenya jadi trunk
    • interface range fa0/22-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/2
      • switchport trunk encapsulation dot1q
      • switchport mode turnk

MLS1

  1. VLAN sudah terbuat, bisa di check dengan “show vlan brief”
  2. Interface fa0/20 dan fa0/23 diubah menjadi trunk (dan bukan sampai)
    • interface range fa0/20, fa0/23 (menggunakan “,” artinya dan”
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 234
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 214

MLS2

  1. VLAN sudah terbuat, bisa di check dengan “show vlan brief”
  2. Interface fa0/20-21 kita ubah modenya jadi trunk
    • interface range fa0/20-21
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/2
      • switchport mode access
      • switchpor access vlan 223

4. Konfigurasikan network device yang ada di Solo dengan ketentuan sebagai berikut :

  • Pastikan database VLAN antar switch sama
  • Konfigurasikan VLAN dan assign switchport sesuai dengan topologi logical
  • Pastikan semua link di setiap switch di gunakan untuk mengirimkan dan menerima data.
  • Untuk mengatasi permasalahan point C pada SW3 dan SW4 gunakan mode tanpa
    negotiations dan sisanya gunakan mode cisco propritary.
  • Gunakan Network 172.34.34.0/30 untuk menghubungkan SW3 dan SW4, IP terkecil
    gunakan untuk SW3 dan IP terbesar gunakan untuk SW4.

Untuk poin 1 dan 2 sama seperti sebelumnya. Kita buat VLANnya di SW3 karena menjadi VTP Server.  Untuk point ke-3  mintanya semua linknya aktif, jadi kita konfigurasi etherchannel disitu. Untuk poin ke-4 semua switch di Solo menggunakan mode pagp kecuali SW3 dan SW4 yang menggunakan mode on. Trus nanti antar switch kita ubah ke trunk kecuali SW3 dan SW4 yang linknya kita kasih IP Address.


SW3

  1. Membuat VLAN 7,8,9 dan 10 menggunakan perintah “vlan vlan-number”
  2. Konfigurasi Etherchannel, group number ada pada physical topologi.
    • interface range fa0/2-3 (Link SW3-SW5)
      • channel-group 35 mode desirable (disini aku gk tau modenya pake auto atau desirable soalnya di soal gk ada penjelasannya)
      • nanti akan terbuat port-channel 35, jadi interface fa0/2-3 digabung menjadi port-channel 35. disitu baru kita ubah ke mode trunk
      • channel-protocol pagp (optional)
    • interface port-channel 35
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/4-5 (Link SW3-SW6)
      • channel-group 36 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 36
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/10-12 (Link SW3-SW4)
      • no switchport (perlu kita definisikan dlu secara manual agar link antar SW3 dan SW4 sama sama menggunakan no switchport)
      • channel-group 34 mode on
    • interface port-channel 34
      • no switchport
      • ip address 172.34.34.1 255.255.255.252

SW4

  1. VLAN sudah terbuat
  2. Konfigurasi Etherchannel, group number sesuai dengan topologi
    • interface range fa0/2-3 (Link SW4-SW6)
      • channel-group 46 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 46
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/4-5 (Link SW4-SW5)
      • channel-group 45 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 45
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/10-12 (Link SW3-SW4)
      • no switchport
      • channel-group 34 mode on
    • interface port-channel 34
      • no switchport
      • ip address 172.34.34.1 255.255.255.252

SW5

  1. VLAN sudah terbuat
  2. Konfigurasi Trunk yang mengaraha ke Switch Client
    • interface range fa0/7-8
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Konfigurasi Etherchannel, group number sesuai dengan topologi
    • interface range fa0/1-2 (Link SW3-SW5)
      • channel-group 35 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 35
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/5-6(Link SW4-SW5)
      • channel-group 45 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 45
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/3-4(Link SW5-SW6)
      • channel-group 11 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 11
      • switchport trunk encapsulation dot1q
      • switchport mode trunk

SW6

  1. VLAN sudah terbuat
  2. Konfigurasi Trunk yang mengaraha ke Switch Client
    • interface range fa0/7-8
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN 10 pada interface fa0/9
    • interface fa0/9
      • switchport mode access
      • switchport access vlan 10
  4. Konfigurasi Etherchannel, group number sesuai dengan topologi
    • interface range fa0/1-2 (Link SW4-SW6)
      • channel-group 46 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 46
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/5-6(Link SW3-SW6)
      • channel-group 36 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 36
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/3-4(Link SW5-SW6)
      • channel-group 11 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 11
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  5. Untuk penghechekan etherchannelnya bisa menggunakan perintah “show etherchannel summary” apakah tandanya sudah “P” dan “SU”

SW7-SW10

  1. Pada interface fa0/1 menjadi mode trunk
    • Switchport mode trunk
  2. Assign VLAN sesuai topologi pada interface fa0/2-3

Untuk 1.3 dan Selanjutnya akan di bahas di Part 2. Selamat mencoba dan mudahan dimengerti

Cisco LAB.103 – Port Security Auto Recovery

Bismillahirrohmanirrohim

Sebenarnya sebelum lab ini ada lab-lab yang lain yang saya lewatin karena memang sudah ada pada lab CCNA yaitu

  1. Cisco Lab. 16 Etherchannel (Link Aggregation)
  2. Port Security in Cisco

Kali ini kita membahas bagaimana kita memperbaiki interface yang terkena violation atau dalam posisi err-disable dengan menggunakan recovery. Langsung ke topologi sederhana

recover

Port-Security Auto Recovery

Jika kita menggunakan port-security dan interface terkena violation. Maka interface tersebut dalam posisi err-disable dan perlu dinyalakan dengan perintah shutdown lalu no shutdown.

Check mac-address pada interface e0/0 pada R1. Lalu konfigurasi IP addressnya

R1

R1#show interfaces e0/0
Ethernet0/0 is administratively down, line protocol is down
Hardware is AmdP2, address is aabb.cc00.0200 (bia aabb.cc00.0200)
R1(config)#int e0/0
R1(config-if)#no sh
R1(config-if)#ip add 11.11.11.2 255.255.255.0

Lalu kita konfigurasi port-security pada Interface e0/0 di switch MLS1

MLS1

MLS1(config)#vlan 11
MLS1(config-vlan)#ex

MLS1(config)#int vlan 11
MLS1(config-if)#ip add 11.11.11.1 255.255.255.0
MLS1(config-if)#no sh

MLS1(config)#int e0/0
MLS1(config-if)#swi mode acc
MLS1(config-if)#swi acc vlan 11
MLS1(config-if)#swi port-security
MLS1(config-if)#swi port-security max 1
MLS1(config-if)#swi port-security mac-add aabb.cc00.0200 
atau
MLS1(config-if)#swi port-security mac-add sticky

MLS1(config)#errdisable recovery cause psecure-violation

Memasukkan mac-address bisa manual atau otomatis.
Lalu ubah mac-address pada interface e0/0 R1 agar violationnya berjalan

R1

R1(config)#int e0/0
R1(config-if)#mac-address 1234.aaaa.bbbb

Lalu lakukan ping agar memancing violationnya. Lalu liat pada MLS1 ada notif seperti berikut.

MLS1(config)#
*Jan  3 00:48:11.325: %PM-4-ERR_RECOVER: Attempting to recover from psecure-violation err-disable state on Et0/0
MLS1(config)#
*Jan  3 00:48:13.325: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
*Jan  3 00:48:14.326: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to up

Jika perlu kita juga bisa menentukan berapa menit interface tersebut akan ter-recovery dengan aging time

MLS1

MLS1(config)#int e0/0
MLS1(config-if)#switchport port-security aging time 2

Bisa check konfigurasinya dengan

MLS1

MLS1#show errdisable recovery
ErrDisable Reason            Timer Status
-----------------            --------------
arp-inspection               Disabled
bpduguard                    Disabled
channel-misconfig (STP)      Disabled
dhcp-rate-limit              Disabled
dtp-flap                     Disabled
gbic-invalid                 Disabled
inline-power                 Disabled
l2ptguard                    Disabled
link-flap                    Disabled
mac-limit                    Disabled
link-monitor-failure         Disabled
loopback                     Disabled
oam-remote-failure           Disabled
pagp-flap                    Disabled
port-mode-failure            Disabled
pppoe-ia-rate-limit          Disabled
psecure-violation            Enabled
security-violation           Disabled
sfp-config-mismatch          Disabled
storm-control                Disabled
udld                         Disabled

Cisco LAB 102. RPVST

Bismillahirrohmanirrohim

Sistemnya hampir sama dengan PVST tapi lebih cepat. Masing-masing VLAN maka akan ada perhitungan STPnya. PVST merupakan konfigurasi default jika mau diubah ke RPVST hrus do konfigurasi lagi. Topologinya sama seperti lab sebelumnya.

mstp

Topologi RPVST

Buat VLAN, Trunk dan Konfigurasi RPVST pada kedua Switch.

MLS1

MLS1(config)#vlan 10
MLS1(config-vlan)#vlan 20
MLS1(config-vlan)#vlan 30
MLS1(config-vlan)#vlan 40
MLS1(config-vlan)#vlan 50
MLS1(config-vlan)#vlan 60
MLS1(config-vlan)#ex

MLS1(config)#int ra e0/0-1
MLS1(config-if-range)#swi tru encap dot
MLS1(config-if-range)#swi mode t
MLS1(config-if-range)#ex

MLS1(config)#spanning-tree mode rapid-pvst
MLS1(config)#spanning-tree vlan 10,20,30 root primary
MLS1(config)#spanning-tree vlan 40,50,60 root secondary

MLS2

MLS2(config)#vlan 10
MLS2(config-vlan)#vlan 20
MLS2(config-vlan)#vlan 30
MLS2(config-vlan)#vlan 40
MLS2(config-vlan)#vlan 50
MLS2(config-vlan)#vlan 60
MLS2(config-vlan)#exit

MLS2(config)#int ra e0/0-1
MLS2(config-if-range)#swi tru encap dot
MLS2(config-if-range)#swi mode tr
MLS2(config-if-range)#exi

MLS2(config)#spanning-tree mode rapid-pvst
MLS2(config)#spanning-tree vlan 10,20,30 root secondary
MLS2(config)#spanning-tree vlan 40,50,60 root primary

Sekarang check modenya dengan perintah

MLS1

MLS1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     aabb.cc00.0400
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24586  (priority 24576 sys-id-ext 10)
             Address     aabb.cc00.0400
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Desg FWD 100       128.1    Shr
Et0/1               Desg FWD 100       128.2    Shr

MLS2

VLAN0040
  Spanning tree enabled protocol rstp
  Root ID    Priority    24616
             Address     aabb.cc00.0300
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24616  (priority 24576 sys-id-ext 40)
             Address     aabb.cc00.0300
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  300 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Desg FWD 100       128.1    Shr
Et0/1               Desg FWD 100       128.2    Shr

Cisco LAB.101 – MSTP (Multiple Spanning Tree)

Bismillahirrohmanirrohim

Lanjut lagi ke MSTP atau Multiple Spanning Tree. Switch defaultnya menggunakan protocol PVST yang artinya pada satu VLAN akan menghitung STP nya masing masing tiap VLANnya. Bayangkan jika ada 20 VLAN saja, maka Switch-switch akan menghitung STP atau interface mana yang akan di block tiap VLANnya. Dengan MSTP kita bisa membuat VLAN-VLAN menjadi satu kelompok (Instance), jadi switch hanya perlu menghitung STP pada instance nya saja tidak pada tiap VLAN. Langsung saja ke topologinya

mstp.png

Topologi MSTP

Ada beberapa hal yang harus sama konfigurasinya antar Switch

  1. Nama MST nya
  2. Revision number MST
  3. VLAN yang berada dalam Instance

Langsung saja ke konfigurasi pada MLS 1

MLS1

MLS1(config)#spanning-tree mode mst
MLS1(config)#spanning-tree mst configuration

MLS1(config-mst)#name IDN
MLS1(config-mst)#revision 1
MLS1(config-mst)#instance 1 vlan 10, 20, 30
MLS1(config-mst)#instance 2 vlan 40, 50, 60
MLS1(config-mst)#ex

MLS1(config)#vlan 10
MLS1(config-vlan)#vlan 20
MLS1(config-vlan)#vlan 30
MLS1(config-vlan)#vlan 40
MLS1(config-vlan)#vlan 50
MLS1(config-vlan)#vlan 60
MLS1(config-vlan)#ex

MLS1(config)#spanning-tree mst 1 root primary
MLS1(config)#spanning-tree mst 2 root secondary

MLS1(config)#int ra e0/0-1
MLS1(config-if-range)#swi tru encap dot
MLS1(config-if-range)#swi mode tr

Lalu konfigurasi pada MLS2

MLS2

MLS2(config)#spanning-tree mode mst
MLS2(config)#spanning-tree mst configuration

MLS2(config-mst)#name IDN
MLS2(config-mst)#revision 1
MLS2(config-mst)#instance 1 vlan 10,20,30
MLS2(config-mst)#instance 2 vlan 40,50,60
MLS2(config-mst)#exit

MLS2(config)#vlan 10
MLS2(config-vlan)#vlan 20
MLS2(config-vlan)#vlan 30
MLS2(config-vlan)#vlan 40
MLS2(config-vlan)#vlan 50
MLS2(config-vlan)#vlan 60
MLS2(config-vlan)#exit

MLS2(config)#spanning mst 1 root secondary
MLS2(config)#spanning mst 2 root primary

MLS2(config)#int ra e0/0-1
MLS2(config-if-range)#swi tru encap dot1
MLS2(config-if-range)#swi mode tr

Check Konfigurasi MST pada switchnya

MLS1

MLS1#show spanning-tree mst configuration
Name      [IDN]
Revision  1     Instances configured 3

Instance  Vlans mapped
--------  ---------------------------------------------------------------------
0         1-9,11-19,21-29,31-39,41-49,51-59,61-4094
1         10,20,30
2         40,50,60
-------------------------------------------------------------------------------

Pastikan MLS1 mnejadi root untuk MST1

MLS1

MLS1#show spanning-tree mst 1

##### MST1    vlans mapped:   10,20,30
Bridge        address aabb.cc00.0400  priority      24577 (24576 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Et0/0            Desg FWD 2000000   128.1    Shr
Et0/1            Desg FWD 2000000   128.2    Shr

MLS2

MLS2#show spanning-tree mst 2

##### MST2    vlans mapped:   40,50,60
Bridge        address aabb.cc00.0300  priority      24578 (24576 sysid 2)
Root          this switch for MST2

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Et0/0            Desg FWD 2000000   128.1    Shr
Et0/1            Desg FWD 2000000   128.2    Shr

Cisco LAB.99 – SPAN (Port Mirroring)

Bismillahirrohmanirrohim

SPAN adalah metode dalam switching yang akan membuat traffik  yang dikirim dan diterima pada interface akan dicopykan sama persis ke interface atau port yang diinginkan. Kita bisa melihat traffiknya dengan menggunakan Wireshark.  Langsung ke topologi saja.

span

SPAN – Port Mirroring

Konfigurasi SPAN pada MLS1 yang nanti akan mengirimkan traffik dari VLAN11 (R1) ke PC Wireshark. Nanti pengetesannya adalah kita bisa monitoring dari PC Wireshark yang seharusnya trafiknya sama dengan R1 ke MLS1.

Konfigurasi IP Address terlebih dahulu pada R1 dan MLS1 agar nanti kita bisa melihat traffik pingnya.

R1

R1(config)#int e0/0
R1(config-if)#ip add 11.11.11.1 255.255.255.0
R1(config-if)#no shut

Pada MLS1 kita konfigurasi IP dan SPAN nya juga.

MLS1

MLS1(config)#int e0/0
MLS1(config-if)#swi mode acc
MLS1(config-if)#swi acc vlan 11
% Access VLAN does not exist. Creating vlan 11

MLS1(config-if)#int vlan 11
MLS1(config-if)#no sh
MLS1(config-if)#ip add 11.11.11.2 255.255.255.0
MLS1(config-if)#ex

MLS1(config)#monitor session 1 source vlan 11
MLS1(config)#monitor session 1 destination interface e0/1

Sourcenya dapat berupa VLAN, atau Interface atau Port-channel. Destination adalah traffiknya akan dikirim pada interface mana. Check konfigurasi dengan perintah berikut.

MLS1#show monitor session 1

Di GNS3 tidak mensupport sayangnya.
Pengetesannya dapat dilakukan dengan membuka wireshark trus coba lakukan ping antar R1 ke MLS1

R1

R1#ping 11.11.11.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 11.11.11.2, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/5 ms

Cisco LAB.98 – QinQ – L2 Protocol Forwading

Bismillahirrohmanirrohim

Pada lab sebelumnya kita membahas QinQ tunneling untuk melewatkan VLAN antar Customer. QinQ juga bisa digunakan untuk melewatkan CDP, STP dan VTP antar switch. Namun pada GNS3 tidak bisa haha😀, sayang, alatnya gk mendukung. Tapi untuk konfigurasi akan kita labkan. Topologinya sama seperti sebelumnya

qnq

QinQ – L2 Protocol Forwading

MTU juga harus dipastikan sudah diubah minimal 1504. Kita melanjutkan konfigurasi pada lab sebelumnya Cisco LAB.97 – QinQ – Transparent (802.1Q) Tunneling . Untuk konfigurasi L2 Protocol Forwading di konfigurasi pada Switch Provider, yaitu MLS2 dan MLS3, pada interface yang mengarah ke Customer.

MLS2 dan MLS3

MLS2(config)#int e0/0
MLS2(config-if)#l2protocol-tunnel cdp
MLS2(config-if)#l2protocol-tunnel stp
MLS2(config-if)#l2protocol-tunnel vtp

Untuk melihatnya kita bisa check CDP neighbor pada Customernya.

MLS1

MLS1#show cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
MLS2             Eth 0/0           165             R S I  Linux Uni Eth 0/0
MLS4             Eth 0/0           165             R S I  Linux Uni Eth 0/0

Seharusnya muncul MLS4. Dan bisa juga mencheck VTP dan STPnya.

Cisco LAB.97 – QinQ – Transparent (802.1Q) Tunneling

Bismillahirrohmanirrohim

Masih dalam bab switching. Kali ini adalah (Q-in-Q) atau 802.1Q tunneling, fungsinya adalah melewatkan VLAN yang berada pada Switch Customer. QinQ ini di konfigurasi pada Switch Provider. Langsung ke topologi seperti di bawah ini :

qnq

Topologi Q-in-Q Tunneling

Ada beberapa keterangan sebelum kita konfigurasi seperti berikut :

  1. MLS1 dan MLS4 kita anggap adalah Switch Customer
  2. MLS2 dan MLS3 kita anggap adalah Switch Provider
  3. Pada Customer, bisa kita buat single VLAN atau Multiple VLAN (Trunk)
  4. Pada Provider, hanya ada satu VLAN yang akan kita gunakan untuk tunneling
  5. Pada QinQ akan ada penambahan tag lagi maka dari itu kita perlu menambah nilai MTU, minimal adalah 1504
  6. Perubahan MTU pada switch, maka kita perlu mereload devicenya. Jika pada Router tidak perlu di reload

Pada Lab ini kita akan membuat dua VLAN pada Customer VLAN 11 dan VLAN12.  Konfigurasi terlebih dahulu pada switch Customer. Buat VLAN dan Trunkingnya

MLS1

MLS1(config)#vlan 11
MLS1(config-vlan)#vlan 12
MLS1(config-vlan)#exit

MLS1(config)#interface vlan 11
MLS1(config-if)#no shutdown
MLS1(config-if)#ip add 11.11.11.1 255.255.255.0

MLS1(config-if)#int vlan 12
MLS1(config-if)#no shutdown
MLS1(config-if)#ip add 12.12.12.1 255.255.255.0
MLS1(config-if)#ex

MLS1(config)#int e0/0
MLS1(config-if)#swi tru encap dot1q
MLS1(config-if)#swi mode tr

MLS4

MLS4(config)#vlan 11
MLS4(config-vlan)#vlan 12

MLS4(config-vlan)#int vlan 11
MLS4(config-if)#no shut
MLS4(config-if)#ip add 11.11.11.4 255.255.255.0

MLS4(config-if)#int vlan 12
MLS4(config-if)#no sh
MLS4(config-if)#ip add 12.12.12.4 255.255.255.0

MLS4(config-if)#int e0/0
MLS4(config-if)#swit trun encap dot
MLS4(config-if)#swi mode tr

Lalu lanjut konfigurasi pada Switch Provider yaitu MLS2 dan MLS3. Disini yang kita atur adalah interface yang mengarah syke Customer kita akan masukkan dalam VLAN 100 kemudian konfigurasi QinQ tunnel. Lalu antar Switch Provider konfigurasi Trunk. Jadi disini kita tidak membuat VLAN 11 dan VLAN 12. Ubah MTU pada kedua switch

MLS2 dan MLS3

MLS3(config)#system mtu 1504

MLS3#write
Warning: Attempting to overwrite an NVRAM configuration previously written
by a different version of the system image.
Overwrite the previous NVRAM configuration?[confirm]
Building configuration...
Compressed configuration from 1512 bytes to 870 bytes[OK]
MLS3#reload

Lalu konfigurasi QinQ tunnelnya

MLS2 dan MLS3

MLS3(config)#int e0/0
MLS3(config-if)#swi mode dot1q-tunnel
MLS3(config-if)#swi acc vlan 100
% Access VLAN does not exist. Creating vlan 100
MLS3(config-if)#ex

MLS3(config)#int e0/1
MLS3(config-if)#swi trun encap dot
MLS3(config-if)#swi mode tr

Sekarang coba test ping antar MLS1 dan MLS4.

Test Ping

MLS1#ping 12.12.12.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 12.12.12.4, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Cisco LAB.96 – STP Features: Root Guard

Bismillahirrohmanirrohim

Lanjut lagi pada STP Feature, yaitu Root Guard. Fungsinya adalah tidak akan membiarkan switch lain menjadi Root, yang akan mendisable interfacenya. Oke langsung ke topologi saja.

root-guard

STP Features: Root Guard

Konfigurasi Trunk terlebih dahulu pada kedua Switch

MLS1

MLS1(config)#int e0/0
MLS1(config-if)#swi tru encap dot1
MLS1(config-if)#swi mode tr

MLS2

MLS2(config)#int e0/0
MLS2(config-if)#swi tr encap dot1
MLS2(config-if)#swi mode tr

Lalu pastikan bahwa MLS1 yang menjadi Root Bridge dengan memasukkan perintah berikut

MLS1

MLS1(config)#spanning-tree vlan 1 root primary

MLS1#show spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    24577
             Address     aabb.cc00.0100
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24577  (priority 24576 sys-id-ext 1)
             Address     aabb.cc00.0100
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  15  sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Desg LRN 100       128.1    Shr

Pastikan ada tulisan “This bridge is the root” Lalu sekarang kita konfigurasi Root Guard.

MLS1

MLS1(config)#int e0/0
MLS1(config-if)#spanning-tree guard root

Lalu kita ubah agar MLS2 yang menjadi Root Bridge

MLS2

MLS2(config)#spanning-tree vlan 1 priority 4096

MLS2#show spanning-tree

VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    4097
             Address     aabb.cc00.0200
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    4097   (priority 4096 sys-id-ext 1)
             Address     aabb.cc00.0200
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  15  sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Desg FWD 100       128.1    Shr

Seperti yang terlihat bahwa MLS2 sekarang yang menjadi root bridge. Kita check interface pada MLS1.

MLS1

MLS1#show spanning-tree inte e0/0 detail
 Port 1 (Ethernet0/0) of VLAN0001 is broken  (Root Inconsistent)
   Port path cost 100, Port priority 128, Port Identifier 128.1.
   Designated root has priority 24577, address aabb.cc00.0100
   Designated bridge has priority 24577, address aabb.cc00.0100
   Designated port id is 128.1, designated path cost 0
   Timers: message age 1, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is shared by default
   Root guard is enabled on the port
   BPDU: sent 35, received 27

MLS1#show spanning-tree inconsistentports

Name                 Interface                Inconsistency
-------------------- ------------------------ ------------------
VLAN0001             Ethernet0/0              Root Inconsistent

Number of inconsistent ports (segments) in the system : 1

Interfacenya menjadi Inconsistent untuk VLAN1 dan pastinya tidak bisa dipakai.

Cisco LAB.94 – STP Features: BPDU Guard

Bismillahirrohmanirrohim

Lanjut lagi pada STP Features. Kali ini adalah BPDU Guard. BPDU merupakan packet yang dikirim oleh switch. Bridge Protocol Data Unit (BPDU). Fungsinya adalah ketika interface pada switch menerima BPDU packet maka interfacenya akan terblok error-disable. Oke, Langsung ke topologi saja.

bpdu

Topologi BPDU Guard

Router di atas bisa diganti dengan switch. Jika menggunakan router maka harus dikonfigurasi Bridging terlebih dahulu agar mengirimkan BPDU, jika menggunakan switch otomatis akan mengirim BPDU.

Untuk melihat BPDU packet yang dikirim bisa menggunakan perintah berikut

MMLS1#show spanning-tree interface e0/0 detail
 Port 1 (Ethernet0/0) of VLAN0001 is designated forwarding
   Port path cost 100, Port priority 128, Port Identifier 128.1.
   Designated root has priority 32769, address aabb.cc00.0400
   Designated bridge has priority 32769, address aabb.cc00.0400
   Designated port id is 128.1, designated path cost 0
   Timers: message age 0, forward delay 0, hold 0
   Number of transitions to forwarding state: 1
   Link type is shared by default
   Bpdu guard is enabled
   BPDU: sent 160, received 0

Konfigurasi BPDU Guard pada MLS1

MLS1

MLS1(config)#int e0/0
MLS1(config-if)#spanning-tree bpduguard enable

Aktifkan debug untuk melihat BPDU Guardnya.

MLS1#debug spanning-tree events
Spanning Tree event debugging is on

Lalu konfigurasi pada R1 agar mengirimkan BPDUs

R1(config)#int e0/0
R1(config-if)#no shutdown
R1(config-if)#bridge-group 1
R1(config-if)#exit

R1(config)#bridge 1 protocol ieee
R1(config)#bridge 1 priority 4096

ieee artinya standard 802.1q. Jika kita menggunakan switch hanya perlu shutdown dan no shutdown interface.

MLS1#
*Jan  1 11:04:49.360: %SPANTREE-2-BLOCK_BPDUGUARD: Received BPDU on port Et0/0 with BPDU Guard enabled. Disabling port.
*Jan  1 11:04:49.360: %PM-4-ERR_DISABLE: bpduguard error detected on Et0/0, putting Et0/0 in err-disable state
MLS1#
*Jan  1 11:04:49.360: STP[1]: Generating TC trap for port Ethernet0/0
*Jan  1 11:04:50.366: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down
MLS1#
*Jan  1 11:04:51.360: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to down

Pastikan bahwa interface e0/0 dalam posisi err-disable.

MLS1#show interfaces e0/0
Ethernet0/0 is down, line protocol is down (err-disabled)
  Hardware is AmdP2, address is aabb.cc00.0400 (bia aabb.cc00.0400)
  MTU 1500 bytes, BW 10000 Kbit/sec, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
....