Konfigurasi OSPF Multi Area MikroTik

Sebelumnya saya sudah pernah membahas konfigurasi OSPF single area sebelumnya, kali ini saya akan membahas kelanjutan dari materi tersebut yang lebih tinggi lagi. Seperti yang kita ketahui OSPF dapat dibagi menjadi beberapa area, dan setiap area isinya adalah Network-network atau jaringan pada setiap Router.

Tujuan pembagian area ini adalah  untuk mengurangi beban setiap Router dalam menangani database OSPF jika topologi jaringan memiliki banyak segmen network yang berbeda, nantinya setiap Router akan mengurusi database network atau jaringan pada area-nya masing-masing. Router di OSPF bisa berkemungkinan berada di antara dua atau lebih area OSPF yang berbeda, Router ini disebut dengan ABR (Area Border Router). 

Beberapa poin penting dari OSPF Area :

  • Setiap area diidentifikasi dengan angka desimal (Cisco), untuk MikroTik formatnya seperti IP Address (x.x.x.x) dimana x adalah angka desimal.
  • Harus ada area backbone (0.0.0.0) sebagai pusat terhubungnya seluruh area.
  • Router ABR, akan mengirim database OSPF antar area dalam bentuk LSA Type 3.
Topologi yang akan kita praktekkan :
Router ABR pada topologi diatas adalah R2, Router R2 (ABR) ini akan mengirimkan informasi dari area 0 ke area 1 begitu pula sebaliknya tetapi dalam bentuk Summary Network LSA (Type-3), atau bisa dibilang hanya sebagian kecil informasi penting saja yang dikirimkan.
Berbeda jika Router mengirimkan informasi ke area yang sama pasti lebih lengkap informasinya (LSA Type 1) dibandingkan antar area yang berbeda .
Untuk mengkonfigurasinya, setiap Router pastikan sudah memiliki IP Address seperti topologi diatas atau sesuai keinginan sendiri.

Konfigurasi OSPF

Dari Router yang berada di Area backbone terlebih dahulu, masukan network atau jaringan yang akan disebarkan melalui OSPF.

R1

[admin@R1] > /routing ospf network
add area=backbone network=192.168.1.1/32
add area=backbone network=192.168.12.0/24

Lanjut pada Router ABR, karena di Router ini terdapat area tambahan baru selain dari backbone (Default) maka kita perlu membuatnya terlebih dahulu.

R2

Buat area 1 atau di mikrotik formatnya (0.0.0.1)

[admin@R2] > routing ospf area add area-id=0.0.0.1 name=area-1

Kemudian masukan network yang terdapat didalam area 1 , yaitu network yang terhubung dengan R3 (192.168.23.0/24)

[admin@R2] > routing ospf network add network=192.168.23.0/24 area=area-1

Masukan juga network yang ada di area backbone :

[admin@R2] > /routing ospf network
add area=backbone network=192.168.2.2/32
add area=backbone network=192.168.12.0/24

R3

Karena Router ini akan memiliki area selain area default backbone, kita perlu membuat area tambahan tersebut sama seperti yang dilakukan pada R2.

[admin@R3] > routing ospf area add area-id=0.0.0.1 name=area-1

Masukan semua network pada Router ini didalam area yang dibuat tadi.

[admin@R3] > routing ospf network add network=192.168.3.3/32 area=area-1 
[admin@R3] > routing ospf network add network=192.168.23.0/24 area=area-1

Setelah selesai kita konfirmasi konfigurasi apakah sudah benar atau belum. Yang pertama harus dicek adalah Routing table pada Router, apakah sudah terisi secara otomatis dan lengkap :

[admin@R3] > ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 ADo 192.168.1.1/32 192.168.23.2 110
1 ADo 192.168.2.2/32 192.168.23.2 110
2 ADC 192.168.3.3/32 192.168.3.3 lo0 0
3 ADo 192.168.12.0/24 192.168.23.2 110
4 ADC 192.168.23.0/24 192.168.23.3 ether1 0

Kemudian untuk membandingkan informasi yang berasal dari dalam area dan luar area adalah sebagai berikut, pertama kita buka Router R1. Lihat daftar LSA OSPF di R1 dengan perintah routing ospf lsa print detail

[admin@R1] > routing ospf lsa print detail 
instance=default area=backbone type=router id=192.168.12.1 originator=192.168.12.1 sequence-number=0x80000003 age=1309 checksum=0x1E6 options="E" body=
flags=
link-type=Stub id=192.168.1.1 data=255.255.255.255 metric=10
link-type=Transit id=192.168.12.2 data=192.168.12.1 metric=10

instance=default area=backbone type=router id=192.168.23.2 originator=192.168.23.2 sequence-number=0x80000006 age=946 checksum=0x5474 options="E"
body=
flags=BORDER
link-type=Stub id=192.168.2.2 data=255.255.255.255 metric=10
link-type=Transit id=192.168.12.2 data=192.168.12.2 metric=10

instance=default area=backbone type=router id=192.168.23.3 originator=192.168.23.3 sequence-number=0x80000003 age=1310 checksum=0x862A options="E" body=
flags=
link-type=Stub id=192.168.3.3 data=255.255.255.255 metric=10
link-type=Transit id=192.168.23.3 data=192.168.23.3 metric=10

instance=default area=backbone type=network id=192.168.12.2 originator=192.168.23.2 sequence-number=0x80000001 age=1310 checksum=0xC6A0 options="E"
body=
netmask=255.255.255.0
routerId=192.168.23.2
routerId=192.168.12.1

instance=default area=backbone type=network id=192.168.23.3 originator=192.168.23.3 sequence-number=0x80000001 age=1310 checksum=0xE468 options="E"
body=
netmask=255.255.255.0
routerId=192.168.23.3
routerId=192.168.23.2


instance=default area=backbone type=summary-network id=192.168.3.3 originator=192.168.23.2 sequence-number=0x80000001 age=484 checksum=0x89CD options="E"
body=
netmask=255.255.255.255
metric=20

instance=default area=backbone type=summary-network id=192.168.23.0 originator=192.168.23.2 sequence-number=0x80000001 age=945 checksum=0x66E9 options="E"
body=
netmask=255.255.255.0
metric=10

Yang saya cetak tebal itu adalah informasi yang berasal dari dalam area internal, informasinya jauh lebih lengkap mulai dari dari Router yang ada didalam area tersebut dan juga segmen network/jaringan yang ada di area tersebut, kita bisa bandingkan dengan informasi yang berasal dari luar area saya cetak miring, lebih ringkas dan yang penting-penting saya yang didapat, sedangkan informasi mendetailnya tidak akan dikirimkan.

Sekian terima kasih itu saja yang dapat saya sampaikan, mohon maaf jika terdapat kesalahan.

Konfigurasi OSPF Multi Area MikroTik

Sebelumnya saya sudah pernah membahas konfigurasi OSPF single area sebelumnya, kali ini saya akan membahas kelanjutan dari materi tersebut yang lebih tinggi lagi. Seperti yang kita ketahui OSPF dapat dibagi menjadi beberapa area, dan setiap area isinya adalah Network-network atau jaringan pada setiap Router.

Tujuan pembagian area ini adalah  untuk mengurangi beban setiap Router dalam menangani database OSPF jika topologi jaringan memiliki banyak segmen network yang berbeda, nantinya setiap Router akan mengurusi database network atau jaringan pada area-nya masing-masing. Router di OSPF bisa berkemungkinan berada di antara dua atau lebih area OSPF yang berbeda, Router ini disebut dengan ABR (Area Border Router). 

Beberapa poin penting dari OSPF Area :

  • Setiap area diidentifikasi dengan angka desimal (Cisco), untuk MikroTik formatnya seperti IP Address (x.x.x.x) dimana x adalah angka desimal.
  • Harus ada area backbone (0.0.0.0) sebagai pusat terhubungnya seluruh area.
  • Router ABR, akan mengirim database OSPF antar area dalam bentuk LSA Type 3.
Topologi yang akan kita praktekkan :
Router ABR pada topologi diatas adalah R2, Router R2 (ABR) ini akan mengirimkan informasi dari area 0 ke area 1 begitu pula sebaliknya tetapi dalam bentuk Summary Network LSA (Type-3), atau bisa dibilang hanya sebagian kecil informasi penting saja yang dikirimkan.
Berbeda jika Router mengirimkan informasi ke area yang sama pasti lebih lengkap informasinya (LSA Type 1) dibandingkan antar area yang berbeda .
Untuk mengkonfigurasinya, setiap Router pastikan sudah memiliki IP Address seperti topologi diatas atau sesuai keinginan sendiri.

Konfigurasi OSPF

Dari Router yang berada di Area backbone terlebih dahulu, masukan network atau jaringan yang akan disebarkan melalui OSPF.

R1

[admin@R1] > /routing ospf network
add area=backbone network=192.168.1.1/32
add area=backbone network=192.168.12.0/24

Lanjut pada Router ABR, karena di Router ini terdapat area tambahan baru selain dari backbone (Default) maka kita perlu membuatnya terlebih dahulu.

R2

Buat area 1 atau di mikrotik formatnya (0.0.0.1)

[admin@R2] > routing ospf area add area-id=0.0.0.1 name=area-1

Kemudian masukan network yang terdapat didalam area 1 , yaitu network yang terhubung dengan R3 (192.168.23.0/24)

[admin@R2] > routing ospf network add network=192.168.23.0/24 area=area-1

Masukan juga network yang ada di area backbone :

[admin@R2] > /routing ospf network
add area=backbone network=192.168.2.2/32
add area=backbone network=192.168.12.0/24

R3

Karena Router ini akan memiliki area selain area default backbone, kita perlu membuat area tambahan tersebut sama seperti yang dilakukan pada R2.

[admin@R3] > routing ospf area add area-id=0.0.0.1 name=area-1

Masukan semua network pada Router ini didalam area yang dibuat tadi.

[admin@R3] > routing ospf network add network=192.168.3.3/32 area=area-1 
[admin@R3] > routing ospf network add network=192.168.23.0/24 area=area-1

Setelah selesai kita konfirmasi konfigurasi apakah sudah benar atau belum. Yang pertama harus dicek adalah Routing table pada Router, apakah sudah terisi secara otomatis dan lengkap :

[admin@R3] > ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 ADo 192.168.1.1/32 192.168.23.2 110
1 ADo 192.168.2.2/32 192.168.23.2 110
2 ADC 192.168.3.3/32 192.168.3.3 lo0 0
3 ADo 192.168.12.0/24 192.168.23.2 110
4 ADC 192.168.23.0/24 192.168.23.3 ether1 0

Kemudian untuk membandingkan informasi yang berasal dari dalam area dan luar area adalah sebagai berikut, pertama kita buka Router R1. Lihat daftar LSA OSPF di R1 dengan perintah routing ospf lsa print detail

[admin@R1] > routing ospf lsa print detail 
instance=default area=backbone type=router id=192.168.12.1 originator=192.168.12.1 sequence-number=0x80000003 age=1309 checksum=0x1E6 options="E" body=
flags=
link-type=Stub id=192.168.1.1 data=255.255.255.255 metric=10
link-type=Transit id=192.168.12.2 data=192.168.12.1 metric=10

instance=default area=backbone type=router id=192.168.23.2 originator=192.168.23.2 sequence-number=0x80000006 age=946 checksum=0x5474 options="E"
body=
flags=BORDER
link-type=Stub id=192.168.2.2 data=255.255.255.255 metric=10
link-type=Transit id=192.168.12.2 data=192.168.12.2 metric=10

instance=default area=backbone type=router id=192.168.23.3 originator=192.168.23.3 sequence-number=0x80000003 age=1310 checksum=0x862A options="E" body=
flags=
link-type=Stub id=192.168.3.3 data=255.255.255.255 metric=10
link-type=Transit id=192.168.23.3 data=192.168.23.3 metric=10

instance=default area=backbone type=network id=192.168.12.2 originator=192.168.23.2 sequence-number=0x80000001 age=1310 checksum=0xC6A0 options="E"
body=
netmask=255.255.255.0
routerId=192.168.23.2
routerId=192.168.12.1

instance=default area=backbone type=network id=192.168.23.3 originator=192.168.23.3 sequence-number=0x80000001 age=1310 checksum=0xE468 options="E"
body=
netmask=255.255.255.0
routerId=192.168.23.3
routerId=192.168.23.2


instance=default area=backbone type=summary-network id=192.168.3.3 originator=192.168.23.2 sequence-number=0x80000001 age=484 checksum=0x89CD options="E"
body=
netmask=255.255.255.255
metric=20

instance=default area=backbone type=summary-network id=192.168.23.0 originator=192.168.23.2 sequence-number=0x80000001 age=945 checksum=0x66E9 options="E"
body=
netmask=255.255.255.0
metric=10

Yang saya cetak tebal itu adalah informasi yang berasal dari dalam area internal, informasinya jauh lebih lengkap mulai dari dari Router yang ada didalam area tersebut dan juga segmen network/jaringan yang ada di area tersebut, kita bisa bandingkan dengan informasi yang berasal dari luar area saya cetak miring, lebih ringkas dan yang penting-penting saya yang didapat, sedangkan informasi mendetailnya tidak akan dikirimkan.

Sekian terima kasih itu saja yang dapat saya sampaikan, mohon maaf jika terdapat kesalahan.

OSPF Single Area pada MikroTik

OSPF kepanjangan dari Open Shortest Path First, adalah salah satu protokol Dynamic Routing yang berfungsi mendistribusikan informasi Routing berupa jalur jalur dan jaringan dari satu Router ke Router lainnya, selain itu OSPF juga menyusun informasi pada tabel Routing pada Router, dan menentukan jalan terbaik untuk menuju suatu jaringan menggunakan algoritma Djikstra.

Beberapa poin penting pada OSPF :

  • Routing protokol Interior yang hanya dapat menanggung satu AS atau ISP saja.
  • Menggunakan IP Multicast 224.0.0.5 dalam pengiriman paketnya.
  • Dapat dibagi menjadi beberapa area.
  • Sebelum saling bertukar informasi, Router terlebih dahulu membentuk hubungan Adjacencies.
  • Tahapan terhubungnya antar Router OSPF :
    • Down 
    • Init
    • Attempt
    • 2Way
    • ExStart
    • ExChange
    • Loading
    • Full
  • Setiap Router memiliki Router-id berdasarkan IP loopback atau manual config.
  • dll
Dengan menggunakan OSPF kita lebih mudah dalam mengkonfigurasi jaringan yang membutuhkan banyak proses Routing atau terdapat banyak jaringan yang berbeda, kita tinggal memasukan IP Network atau jaringan yang ada di masing-masing Router ke konfigurasi OSPF, kemudian OSPF akan langsung mendistribusikannya ke Router lain.
Kali ini saya tidak membahas secara detail OSPF, tapi akan membahas cara konfigurasinya di Router MikroTik. Berikut ini topologinya :
Seluruh Router masih kita masukan dalam satu area yang sama atau Single Area, masing-masing Router akan mengirimkan Network atau jaringan masing-masing yang dipunya, kemudian mereka juga akan saling menerima informasi dari tetangganya lalu informasi tersebut akan dimasukan didalam Routing table masing-masing Router.

IP Address

Kita mulai dari yang dasar terlebih dahulu, yaitu konfigurasi IP Address dan loopback interface pada masing-masing Router sesuai topologi diatas.

Router R1

[admin@R1] > interface bridge add name=lo0
[admin@R1] > ip address add address=192.168.1.1/32 interface=lo0
[admin@R1] > ip address add address=192.168.12.1/24 interface=ether1

Router R2

[admin@R2] > interface bridge add name=lo0
[admin@R2] > ip address add address=192.168.2.2/32 interface=lo0
[admin@R2] > ip address add address=192.168.12.2/24 interface=ether1
[admin@R2] > ip address add address=192.168.23.2/24 interface=ether2

Router R3

[admin@R3] > interface bridge add name=lo0
[admin@R3] > ip address add address=192.168.3.3/32 interface=lo0
[admin@R3] > ip address add address=192.168.23.3/24 interface=ether1

OSPF

Setelah itu barulah konfigurasi OSPF dapat dilakukan, caranya seperti yang sudah saya katakan yaitu masukan IP Network masing-masing Router di konfigurasi OSPF.

Router R1

Di Router ini memiliki network 192.168.12.0/24 dan 192.168.1.1/32

[admin@R1] > routing ospf network add network=192.168.1.1/32 area=backbone 
[admin@R1] > routing ospf network add network=192.168.12.0/24 area=backbone

Router R2

[admin@R2] > routing ospf network add network=192.168.2.2/32 area=backbone 
[admin@R2] > routing ospf network add network=192.168.12.0/24 area=backbone
[admin@R2] > routing ospf network add network=192.168.23.0/24 area=backbone

Router R3

[admin@R3] > routing ospf network add  network=192.168.3.3/32 area=backbone 
[admin@R3] > routing ospf network add network=192.168.23.0/24 area=backbone

Setelah selesai sekarang coba kita lihat Routing table salah satu Router untuk melihat hasilnya sudah berhasil atau belum.

[admin@R3] > ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 ADo 192.168.1.1/32 192.168.23.2 110
1 ADo 192.168.2.2/32 192.168.23.2 110
2 ADC 192.168.3.3/32 192.168.3.3 lo0 0
3 ADo 192.168.12.0/24 192.168.23.2 110
4 ADC 192.168.23.0/24 192.168.23.3 ether1 0

Dan sudah dapat kita lihat, antar Router sudah dapat saling bertukar informasi dan tandanya konfigurasi sudah selesai.

OSPF Single Area pada MikroTik

OSPF kepanjangan dari Open Shortest Path First, adalah salah satu protokol Dynamic Routing yang berfungsi mendistribusikan informasi Routing berupa jalur jalur dan jaringan dari satu Router ke Router lainnya, selain itu OSPF juga menyusun informasi pada tabel Routing pada Router, dan menentukan jalan terbaik untuk menuju suatu jaringan menggunakan algoritma Djikstra.

Beberapa poin penting pada OSPF :

  • Routing protokol Interior yang hanya dapat menanggung satu AS atau ISP saja.
  • Menggunakan IP Multicast 224.0.0.5 dalam pengiriman paketnya.
  • Dapat dibagi menjadi beberapa area.
  • Sebelum saling bertukar informasi, Router terlebih dahulu membentuk hubungan Adjacencies.
  • Tahapan terhubungnya antar Router OSPF :
    • Down 
    • Init
    • Attempt
    • 2Way
    • ExStart
    • ExChange
    • Loading
    • Full
  • Setiap Router memiliki Router-id berdasarkan IP loopback atau manual config.
  • dll
Dengan menggunakan OSPF kita lebih mudah dalam mengkonfigurasi jaringan yang membutuhkan banyak proses Routing atau terdapat banyak jaringan yang berbeda, kita tinggal memasukan IP Network atau jaringan yang ada di masing-masing Router ke konfigurasi OSPF, kemudian OSPF akan langsung mendistribusikannya ke Router lain.
Kali ini saya tidak membahas secara detail OSPF, tapi akan membahas cara konfigurasinya di Router MikroTik. Berikut ini topologinya :
Seluruh Router masih kita masukan dalam satu area yang sama atau Single Area, masing-masing Router akan mengirimkan Network atau jaringan masing-masing yang dipunya, kemudian mereka juga akan saling menerima informasi dari tetangganya lalu informasi tersebut akan dimasukan didalam Routing table masing-masing Router.

IP Address

Kita mulai dari yang dasar terlebih dahulu, yaitu konfigurasi IP Address dan loopback interface pada masing-masing Router sesuai topologi diatas.

Router R1

[admin@R1] > interface bridge add name=lo0
[admin@R1] > ip address add address=192.168.1.1/32 interface=lo0
[admin@R1] > ip address add address=192.168.12.1/24 interface=ether1

Router R2

[admin@R2] > interface bridge add name=lo0
[admin@R2] > ip address add address=192.168.2.2/32 interface=lo0
[admin@R2] > ip address add address=192.168.12.2/24 interface=ether1
[admin@R2] > ip address add address=192.168.23.2/24 interface=ether2

Router R3

[admin@R3] > interface bridge add name=lo0
[admin@R3] > ip address add address=192.168.3.3/32 interface=lo0
[admin@R3] > ip address add address=192.168.23.3/24 interface=ether1

OSPF

Setelah itu barulah konfigurasi OSPF dapat dilakukan, caranya seperti yang sudah saya katakan yaitu masukan IP Network masing-masing Router di konfigurasi OSPF.

Router R1

Di Router ini memiliki network 192.168.12.0/24 dan 192.168.1.1/32

[admin@R1] > routing ospf network add network=192.168.1.1/32 area=backbone 
[admin@R1] > routing ospf network add network=192.168.12.0/24 area=backbone

Router R2

[admin@R2] > routing ospf network add network=192.168.2.2/32 area=backbone 
[admin@R2] > routing ospf network add network=192.168.12.0/24 area=backbone
[admin@R2] > routing ospf network add network=192.168.23.0/24 area=backbone

Router R3

[admin@R3] > routing ospf network add  network=192.168.3.3/32 area=backbone 
[admin@R3] > routing ospf network add network=192.168.23.0/24 area=backbone

Setelah selesai sekarang coba kita lihat Routing table salah satu Router untuk melihat hasilnya sudah berhasil atau belum.

[admin@R3] > ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit
# DST-ADDRESS PREF-SRC GATEWAY DISTANCE
0 ADo 192.168.1.1/32 192.168.23.2 110
1 ADo 192.168.2.2/32 192.168.23.2 110
2 ADC 192.168.3.3/32 192.168.3.3 lo0 0
3 ADo 192.168.12.0/24 192.168.23.2 110
4 ADC 192.168.23.0/24 192.168.23.3 ether1 0

Dan sudah dapat kita lihat, antar Router sudah dapat saling bertukar informasi dan tandanya konfigurasi sudah selesai.

Memblokir situs web menggunakan Firewall MikroTik

Postingan saya ini adalah kelanjutan dari materi Firewall filter di MikroTik. Didalam firewall mikrotik kita dapat menggunakan fitur deteksi content, dengan fitur ini kita dapat mendeteksi isi berupa tulisan yang ada didalam paket data seperti URL sebuah situs, lalu kita dapat melakukan pengizinan atau pemblokiran pada URL tersebut.

Fitur ini hanya dapat memblokir URL situs web yang masih menggunakan HTTP port 80 tanpa SSL, maka situs yang sudah menggunakan HTTPS seperti facebook, google, dll tidak dapat diblokir menggunakan fitur ini karena tiap tulisan didalam paket HTTPS dienkripsi sehingga Router MikroTik tidak dapat membacanya.

Topologi :

Skema :

  • IP Network Client adalah 192.168.9.0/24, Client akan mendapatkan IP DHCP dari Router yang sudah saya konfigurasi DHCP Server.
  • Router MikroTik akan mendapatkan IP Address DHCP dari Internet, maka saya lakukan konfigurasi DHCP Client pada interface yang mengarah ke Internet.
  • Router akan memblokir paket berisikan tulisan “www.mikrotik.co.id” dan “detik.com” yang akan melewati Router. Chain = Forward.
Pertama remote Router MikroTik dari Client menggunakan winbox, telnet, ssh. Kemudian lakukan konfigurasi dasar seperti IP Address, DHCP Server, DHCP Client, NAT, jika Router sudah dikonfigurasi sebelumnya langsung saja ke bagian Firewall.

Firewall

  • Buka menu IP > Firewall > filter > Add.
  • Buat rule untuk memblokir paket yang berisi tulisan “www.mikrotik.co.id” pada bagian content.
    • Pada tab general, set chain ke “Forward” karena paket yang disaring adalah paket yang melewati Router.
    • Pindah ke tab Advanced, isi kolom “content” dengan URL yang akan diblokir.
    • PIndah ke tab Action, set action drop untuk membuang paket.
  • Lalu buat rule lainnya untuk memblokir situs lain, caranya sama seperti diatas hanya ubah saja contentnya menjadi URL situs yang ingin diblokir seperti detik.com, dll.
  • Hasilnya akan seperti ini :

Testing

Coba buka situs yang telah diblokir tadi.

Pastikan perhitungannya berjalan pada Firewall filternya.

Memblokir situs web menggunakan Firewall MikroTik

Postingan saya ini adalah kelanjutan dari materi Firewall filter di MikroTik. Didalam firewall mikrotik kita dapat menggunakan fitur deteksi content, dengan fitur ini kita dapat mendeteksi isi berupa tulisan yang ada didalam paket data seperti URL sebuah situs, lalu kita dapat melakukan pengizinan atau pemblokiran pada URL tersebut.

Fitur ini hanya dapat memblokir URL situs web yang masih menggunakan HTTP port 80 tanpa SSL, maka situs yang sudah menggunakan HTTPS seperti facebook, google, dll tidak dapat diblokir menggunakan fitur ini karena tiap tulisan didalam paket HTTPS dienkripsi sehingga Router MikroTik tidak dapat membacanya.

Topologi :

Skema :

  • IP Network Client adalah 192.168.9.0/24, Client akan mendapatkan IP DHCP dari Router yang sudah saya konfigurasi DHCP Server.
  • Router MikroTik akan mendapatkan IP Address DHCP dari Internet, maka saya lakukan konfigurasi DHCP Client pada interface yang mengarah ke Internet.
  • Router akan memblokir paket berisikan tulisan “www.mikrotik.co.id” dan “detik.com” yang akan melewati Router. Chain = Forward.
Pertama remote Router MikroTik dari Client menggunakan winbox, telnet, ssh. Kemudian lakukan konfigurasi dasar seperti IP Address, DHCP Server, DHCP Client, NAT, jika Router sudah dikonfigurasi sebelumnya langsung saja ke bagian Firewall.

Firewall

  • Buka menu IP > Firewall > filter > Add.
  • Buat rule untuk memblokir paket yang berisi tulisan “www.mikrotik.co.id” pada bagian content.
    • Pada tab general, set chain ke “Forward” karena paket yang disaring adalah paket yang melewati Router.
    • Pindah ke tab Advanced, isi kolom “content” dengan URL yang akan diblokir.
    • PIndah ke tab Action, set action drop untuk membuang paket.
  • Lalu buat rule lainnya untuk memblokir situs lain, caranya sama seperti diatas hanya ubah saja contentnya menjadi URL situs yang ingin diblokir seperti detik.com, dll.
  • Hasilnya akan seperti ini :

Testing

Coba buka situs yang telah diblokir tadi.

Pastikan perhitungannya berjalan pada Firewall filternya.

Membatasi akses service yang ada di Internet pada MikroTik

Router MikroTik dapat kita fungsikan sebagai Router dan juga firewall, karena pada Router MikroTik terdapat fitur penyaringan jaringan yang disebut dengan Firewall filter. Dengan fitur ini kita dapat membuat aturan aturan sendiri pada Router MikroTik untuk membatasi sejumlah akses pada jaringan atau layanan tertentu, dan juga memperbolehkan akses jaringan atau layanan.

Contoh konfigurasi Firewall kali ini adalah saya akan mencoba membatasi akses service atau layanan yang boleh diakses oleh si Client di Internet, dan jika si Client berusahan mengakses service selain yang dibolehkan maka Router akan menolaknya. Berikut ini adalah topologinya :

Skema :

  • Chain yang digunakan adalah Forward, karena yang disaring adalah lalu lintas dari Client menuju ke Internet yang melewati Router.
  • Akses layanan web HTTP dan juga HTTPS akan diterima oleh Router.
  • Akses DNS akan diterima oleh Router.
  • Selain yang diizinkan akan ditolak oleh Router.
Lanjut pada tahap konfigurasi, saya lakukan pada salah satu Client Windows 7 :
  • Pertama Remote Router mikrotik lewat WinBox jika ingin menggunakan GUI.
  • Lalu lakukan konfigurasi addressing IP Address pada Interface Router, jika sudah ada IP Address lewati saja langkah ini.
    • Ether1 : DHCP
    • Ether2 : 192.168.9.1/24
    • Karena Ether1 yang mengarah ke internet mendapat IP DHCP, Saya akan melakukan konfigurasi DHCP Client, caranya IP > DHCP-Client > New.

      Kemudian pada port Ether2 saya mengkonfigurasi static IP atau IP Address secara manual. IP > Address > Add.

      Verifikasi IP Address.

  • Setelah IP Address, konfigurasi NAT Masquerade.

Firewall filter

  • Pertama kita buat rule yang menerima tujuan port 80,443 yang keluar melalui interface ether1. rule ini untuk menerima trafik client menuju ke Internet. Untuk membuatnya klik IP > Firewall > Filter > Add.
  • Kemudian buat rule yang kebalikan dari rule sebelumnya, yaitu menerima protokol TCP yang asal portnya 80 dan 443 keluar melalui ether2 Client. Rule ini untuk menerima trafik dari Server yang menuju ke Client.
  • Buat rule yang menerima protokol UDP dengan tujuan port 53, keluar melalui interface ether1. caranya sama seperti diatas hanya ubah saja parameternya.
  • Buat rule kebalikan, yaitu menerima protokol UDP dengan sumber port 53, keluar melalui ether2.
  • Terakhir buat rule yang menolak semua koneksi selain yang diperbolehkan diatas.
  • Verifikasi hasilnya seperti ini.

Testing Client

Pertama kita coba akses Layanan web dan juga DNS dengan membuka browser dan mengakses sebuah situs.

Coba testing layanan yang tidak diperbolehkan seperti ICMP Ping, FTP, dll.

Membatasi akses service yang ada di Internet pada MikroTik

Router MikroTik dapat kita fungsikan sebagai Router dan juga firewall, karena pada Router MikroTik terdapat fitur penyaringan jaringan yang disebut dengan Firewall filter. Dengan fitur ini kita dapat membuat aturan aturan sendiri pada Router MikroTik untuk membatasi sejumlah akses pada jaringan atau layanan tertentu, dan juga memperbolehkan akses jaringan atau layanan.

Contoh konfigurasi Firewall kali ini adalah saya akan mencoba membatasi akses service atau layanan yang boleh diakses oleh si Client di Internet, dan jika si Client berusahan mengakses service selain yang dibolehkan maka Router akan menolaknya. Berikut ini adalah topologinya :

Skema :

  • Chain yang digunakan adalah Forward, karena yang disaring adalah lalu lintas dari Client menuju ke Internet yang melewati Router.
  • Akses layanan web HTTP dan juga HTTPS akan diterima oleh Router.
  • Akses DNS akan diterima oleh Router.
  • Selain yang diizinkan akan ditolak oleh Router.
Lanjut pada tahap konfigurasi, saya lakukan pada salah satu Client Windows 7 :
  • Pertama Remote Router mikrotik lewat WinBox jika ingin menggunakan GUI.
  • Lalu lakukan konfigurasi addressing IP Address pada Interface Router, jika sudah ada IP Address lewati saja langkah ini.
    • Ether1 : DHCP
    • Ether2 : 192.168.9.1/24
    • Karena Ether1 yang mengarah ke internet mendapat IP DHCP, Saya akan melakukan konfigurasi DHCP Client, caranya IP > DHCP-Client > New.

      Kemudian pada port Ether2 saya mengkonfigurasi static IP atau IP Address secara manual. IP > Address > Add.

      Verifikasi IP Address.

  • Setelah IP Address, konfigurasi NAT Masquerade.

Firewall filter

  • Pertama kita buat rule yang menerima tujuan port 80,443 yang keluar melalui interface ether1. rule ini untuk menerima trafik client menuju ke Internet. Untuk membuatnya klik IP > Firewall > Filter > Add.
  • Kemudian buat rule yang kebalikan dari rule sebelumnya, yaitu menerima protokol TCP yang asal portnya 80 dan 443 keluar melalui ether2 Client. Rule ini untuk menerima trafik dari Server yang menuju ke Client.
  • Buat rule yang menerima protokol UDP dengan tujuan port 53, keluar melalui interface ether1. caranya sama seperti diatas hanya ubah saja parameternya.
  • Buat rule kebalikan, yaitu menerima protokol UDP dengan sumber port 53, keluar melalui ether2.
  • Terakhir buat rule yang menolak semua koneksi selain yang diperbolehkan diatas.
  • Verifikasi hasilnya seperti ini.

Testing Client

Pertama kita coba akses Layanan web dan juga DNS dengan membuka browser dan mengakses sebuah situs.

Coba testing layanan yang tidak diperbolehkan seperti ICMP Ping, FTP, dll.

Menghubungkan dua Wireless MikroTik Point-to-Point

Salah satu perangkat MikroTik yang terkenal adalah perangkat nirkabelnya atau yang biasa disebut wireless, dengan perangkat ini memungkinkan kita untuk membuat sebuah jalur link tanpa kabel. Kali ini saya akan membahas tutorial cara konfigurasi Wireless MikroTik secara point-to-point.

Untuk membentuk sebuah koneksi point-to-point salah satu Wireless MikroTik harus berada di mode bridge dan satunya lagi mode station, mode bridge ini bertindak sebagai pemancar yang hanya dapat dihubungkan 1 client saja , sedangkan station sebagai penerima, antara bridge dan station harus memiliki ssid yang sama dan juga channel yang sama untuk saling terhubung.

berikut ini adalah topologinya :

Penjelasan detail
Wireless1
  • SSID : Terangkanlah!!!
  • Mode : Bridge
  • Band : 2.4GHz b/g/n
  • wlan1 IP : 10.10.10.1
Wireless2
  • SSID : Terangkanlah!!!
  • Mode : Station
  • Band : 2.4GHz b/g/n
  • wlan1 IP : 10.10.10.2
Setelah itu kita lanjut pada konfigurasinya :

Sisi Bridge

Pertama. Remote perangkat wireless tersebut menggunakan winbox setelah itu buka menu Wireless > Tab Interfaces, Kemudian klik salah satu device wireless, lalu pindah ke tab Wireless.


  • Ganti mode menjadi bridge.
  • Saya sarankan untuk menentukan Frequency secara manual agar tidak terjadi interferensi.
  • Beri SSID atau nama Wireless sesuka anda.
  • Wireless Protocol tetapkan menjadi 802.11.
  • Setelah itu klik OK untuk menerapkan konfigurasi.
Kedua. Kita berikan IP Address pada interface wlan1, caranya klik menu IP > Address.
  • Masukan IP Address yang ingin diberikan.
  • Setelah itu atur interface yang ingin diberikan IP Address.
  • Klik OK.

Sisi Station

Pertama. Remote perangkat wireless tersebut menggunakan winbox setelah itu buka menu Wireless > Tab Interfaces, Kemudian klik salah satu device wireless, lalu pindah ke tab Wireless.

  • Ganti mode menjadi station.
  • Saya sarankan untuk menentukan Frequency secara manual agar tidak terjadi interferensi.
  • Beri SSID atau nama Wireless sesuai dengan yang ada pada wireless1 sebelumnya.
  • Wireless Protocol tetapkan menjadi 802.11.
  • Setelah itu klik OK untuk menerapkan konfigurasi.
Tunggu hingga muncul huruf R disamping tulisan wlan1 yang artinya koneksi berhasil terbentuk.

Ketiga. Kita berikan IP Address pada interface wlan1.

Keempat. Ini merupakan langkah opsional, hanya untuk melakukan pengujian bandwitdh yang didapatkan, jika dirasa tidak perlu maka lewati saja. Buka menu Tools > BTest Server untuk mengaktifkan server yang akan digunakan sebagai pengujian bandwitdh.

Pengetesan

Kita lakukan pengetesan bandwidth pada sisi Bridge, klik menu Tools > Bandwitdh test.

  • Masukan IP Address si Station.
  • Kemudian klik OK untuk memulai pengujiannya.
Dari hasil diatas kita dapat melihat hasil pengujian bandwitdh seberapa besar bandwitdh yang dapat dicapai oleh koneksi kedua wireless tersebut.
Kita lanjut pada pengujian berikutnya, buka menu Wireless > Registration.
Klik client yang terdapat dalam daftar tersebut, pindah pada tab signal dan kita bisa melihat CCQ dan Throughput yang didapat oleh client tersebut. CCQ adalah persentase efektif bandwitdh yang dapat digunakan oleh client tersebut, sedangkan throughput adalah  hasil kecepatan transfer yang didapatkan oleh client tersebut.

Menghubungkan dua Wireless MikroTik Point-to-Point

Salah satu perangkat MikroTik yang terkenal adalah perangkat nirkabelnya atau yang biasa disebut wireless, dengan perangkat ini memungkinkan kita untuk membuat sebuah jalur link tanpa kabel. Kali ini saya akan membahas tutorial cara konfigurasi Wireless MikroTik secara point-to-point.

Untuk membentuk sebuah koneksi point-to-point salah satu Wireless MikroTik harus berada di mode bridge dan satunya lagi mode station, mode bridge ini bertindak sebagai pemancar yang hanya dapat dihubungkan 1 client saja , sedangkan station sebagai penerima, antara bridge dan station harus memiliki ssid yang sama dan juga channel yang sama untuk saling terhubung.

berikut ini adalah topologinya :

Penjelasan detail
Wireless1
  • SSID : Terangkanlah!!!
  • Mode : Bridge
  • Band : 2.4GHz b/g/n
  • wlan1 IP : 10.10.10.1
Wireless2
  • SSID : Terangkanlah!!!
  • Mode : Station
  • Band : 2.4GHz b/g/n
  • wlan1 IP : 10.10.10.2
Setelah itu kita lanjut pada konfigurasinya :

Sisi Bridge

Pertama. Remote perangkat wireless tersebut menggunakan winbox setelah itu buka menu Wireless > Tab Interfaces, Kemudian klik salah satu device wireless, lalu pindah ke tab Wireless.


  • Ganti mode menjadi bridge.
  • Saya sarankan untuk menentukan Frequency secara manual agar tidak terjadi interferensi.
  • Beri SSID atau nama Wireless sesuka anda.
  • Wireless Protocol tetapkan menjadi 802.11.
  • Setelah itu klik OK untuk menerapkan konfigurasi.
Kedua. Kita berikan IP Address pada interface wlan1, caranya klik menu IP > Address.
  • Masukan IP Address yang ingin diberikan.
  • Setelah itu atur interface yang ingin diberikan IP Address.
  • Klik OK.

Sisi Station

Pertama. Remote perangkat wireless tersebut menggunakan winbox setelah itu buka menu Wireless > Tab Interfaces, Kemudian klik salah satu device wireless, lalu pindah ke tab Wireless.

  • Ganti mode menjadi station.
  • Saya sarankan untuk menentukan Frequency secara manual agar tidak terjadi interferensi.
  • Beri SSID atau nama Wireless sesuai dengan yang ada pada wireless1 sebelumnya.
  • Wireless Protocol tetapkan menjadi 802.11.
  • Setelah itu klik OK untuk menerapkan konfigurasi.
Tunggu hingga muncul huruf R disamping tulisan wlan1 yang artinya koneksi berhasil terbentuk.

Ketiga. Kita berikan IP Address pada interface wlan1.

Keempat. Ini merupakan langkah opsional, hanya untuk melakukan pengujian bandwitdh yang didapatkan, jika dirasa tidak perlu maka lewati saja. Buka menu Tools > BTest Server untuk mengaktifkan server yang akan digunakan sebagai pengujian bandwitdh.

Pengetesan

Kita lakukan pengetesan bandwidth pada sisi Bridge, klik menu Tools > Bandwitdh test.

  • Masukan IP Address si Station.
  • Kemudian klik OK untuk memulai pengujiannya.
Dari hasil diatas kita dapat melihat hasil pengujian bandwitdh seberapa besar bandwitdh yang dapat dicapai oleh koneksi kedua wireless tersebut.
Kita lanjut pada pengujian berikutnya, buka menu Wireless > Registration.
Klik client yang terdapat dalam daftar tersebut, pindah pada tab signal dan kita bisa melihat CCQ dan Throughput yang didapat oleh client tersebut. CCQ adalah persentase efektif bandwitdh yang dapat digunakan oleh client tersebut, sedangkan throughput adalah  hasil kecepatan transfer yang didapatkan oleh client tersebut.