MPLS Traffic Engineering

Assalamualaikum, 
Pada kali ini, saya akan share mengenai MPLS Traffic Engineering. Lalu apa itu MPLS Traffic Engineering? Overview dulu yuk materinya. 
Di dalam dunia jaringan tentunya ada banyak device yang saling menghubungkan satu sama lain. Dalam hal ini, tentunya routing akan dipergunakan untuk menghubungkan sebuah network dengan network yang lainnya.
Untuk routing sendiri, entah itu static routing ataupun dynamic routing, tentunya tujuannya tetaplah sama, yaitu bertujuan untuk menghubungkan sebuah network dengan network lainnya. 
Dalam menggunakan static routing, oke kita dapat menentukan jalur yang akan kita kehendaki, tujuannya kemana, dan gateway yang akan digunakan melewati mana. Dalam hal ini, mungkin bisa kita bilang cukup teratur dikarenakan kita dapat menentukan packe tersebut melewati jalur yang padat trafficnya atau tidak. 
Namun, ada sebuah masalah dimana jaringan yang menggunakan dynamic routing untuk menghubungkan beberapa network yang ada, tentunya tergantung routing itu sendiri, apakah menggunakan jalur terdekat ataupun bandwith yang lebih besar. 
Namun tentunya apabila di dalam sebuah jaringan sama sama memilih jalur yang sama sebagai jalur yang akan digunakan, maka akan menyebabkan padatnya traffic yang ada pada jalur tersebut. 
Seperti contoh yang terlihat diatas, jalur yang digunakan oleh kedua router untuk menuju router yang berbeda, tetap sama. Dan tentunya hal ini akan menyebabkan padatnya jalur yang digunakan itu. Padahal masih ada jalur lain yang tidak digunakan. 
Apabila seperti ini, kita dapat menerapkan sebuah protocol dimana protocol ini akan menggunakan jalur yang admin kehendaki. Jadi tidak menggunakan routing yang menentukan jalur berdasarkan jalur dengan hop tersedikit ataupun jalur dengan bandwith terbesar. Protocol tersebut dinamakan dengan MPLS TE.
MPLS TE sendiri merupakan sebuah protocol yang berjalan pada MPLS Backbone, yang akan memanfaatkan jaringan MPLS sebagai perantaranya. MPLS TE memiliki tunnel yang dapat dimanfaatkan untuk menentukan mana jalur yang akan digunakan untuk dilewati sebuah packet. Lalu apa hubungannya dengan routing? 
Seperti yang sudah dibahas tadi, apabila terlalu memanfaatkan routing pada suatu jaringan, maka akan menyebabkan padatnya lalu lintas yang ada pada jaringan tersebut. Dikarenakan protocol routing itu tetaplah sama, apabila dalam hal menentukan jalur. Jadi tidak ada namanya “jalur ini telah digunakan” tapi yang ada adalah “jalur ini merupakan jalur terbaik”. 
Seperti yang terlihat pada gambar diatas, TE akan memungkinkan router yang bekerja sebagai PE untuk membuat sebuah tunnel yang dibentuk berdasarkan address yang akan dilewati. Jadi kita dapat membuat tunnel, dengan mendefinisikan address yang akan di lewati. 
Selain mendefinisikannya satu per satu ip address yang akan dibuat hubungan tunnel, dalam MPLS TE juga kita dapat menentukan tunnel yang dibuat secara dinamis. Jadi kita hanya perlu untuk mengaktifkan TE yang ada pada router yang kita miliki. 
Untuk membuat hubungan secara static juga ada beberapa cara untuk mendefinisikan jalur yang akan digunakan, diantaranya sebagai berikut. 
  • Strict 
Strict merupakan sebuah cara yang digunakan untuk mendefinisikan jalur directly connected yang dapat digunakan. Dalam hal ini juga kita juga harus mendefinisikan secara spesifik melewati address mana jalur ini dibuat. 
  • Loose
Loose merupakan sebuah cara yang digunakan untuk mendefinisikan jalur yang tidak directly connected, atau dalam artian kita hanya perlu mendefinisikan router penengah yang akan dilewati. Dalam hal ini juga brarti loose tidak perlu mendefinisikan sebuah jalur yang akan dibuat secara lebih spesifik. 
Opsi diatas tadi merupakan sebuah cara yang dapat digunakan untuk mendefinisikan jalur yang akan digunakan secara manual. 

[admin@MikroTik] > /mpls traffic-eng tunnel-path
add hops=[address|strict]
Hops ::= Hop[,Hops]
   Hop ::= Address:Strict
      Address ::= A.B.C.D (IP address)
      Strict ::= strict | loose

Seperti yang terlihat pada konfigurasi diatas, itu merupakan cara untuk membuat jalur static. Dan untuk hop yang akan di definisikan tidak seperti mengkonfigurasikan gateway pada static routing, akan tetapi menggunakan strict yang ada. 
Selain itu, seperti yang sudah saya bilang bahwa jalur juga dapat ditentukan secara dynamic. Apabila kita membuat tunnel secara dynamic, maka diperlukan diaktifkannya CSPF pada router tersebut. 
CSPF sendiri merupakan fitur yang ada pada MPLS TE yang akan memungkinkan kedua site untuk membentuk jalur dengan jalur terpendek. Jadi TE akan memilih secara otomatis jalur terpendek mana yang akan ia gunakan. 

[admin@MikroTik] > /mpls traffic-eng tunnel-path
add name=dynamic use-cspf=yes

Seperti yang terlihat pada konfigurasi diatas, kita perlu untuk mendefinisikan cspf agar aktif pada jalur dynamic. 
Pada MPLS TE sendiri, dapat dikatakan sebagai protocol yang support high avaibility. Hal ini dikarenakan dalam membuat tunneling, kita dapat menentukan 2 jalur dimana salah satunya akan digunakan sebagai backup, dan juga sebagai jalur utama. Kita dapat mendefinisikannya sebagai berikut. 

[admin@MikroTik] > /interface traffic-eng
add primary-path=static secondary-paths=dynamic

Seperti yang terlihat pada konfigurasi diatas, kita melakukan konfigurasi jalur mana yang dijadikan jalur utama, dan jalur mana yang akan dijadikan sebagai jalur cadangan.
Pada dasarnya, jalur utama yang dipilih, merupakan jalur static yang sudah kita buat tadi. Dan untuk jalur cadangan, kita menggunakan jalur dynamic yang sudah dibuat. 

MPLS Traffic Engineering

Assalamualaikum, 
Pada kali ini, saya akan share mengenai MPLS Traffic Engineering. Lalu apa itu MPLS Traffic Engineering? Overview dulu yuk materinya. 
Di dalam dunia jaringan tentunya ada banyak device yang saling menghubungkan satu sama lain. Dalam hal ini, tentunya routing akan dipergunakan untuk menghubungkan sebuah network dengan network yang lainnya.
Untuk routing sendiri, entah itu static routing ataupun dynamic routing, tentunya tujuannya tetaplah sama, yaitu bertujuan untuk menghubungkan sebuah network dengan network lainnya. 
Dalam menggunakan static routing, oke kita dapat menentukan jalur yang akan kita kehendaki, tujuannya kemana, dan gateway yang akan digunakan melewati mana. Dalam hal ini, mungkin bisa kita bilang cukup teratur dikarenakan kita dapat menentukan packe tersebut melewati jalur yang padat trafficnya atau tidak. 
Namun, ada sebuah masalah dimana jaringan yang menggunakan dynamic routing untuk menghubungkan beberapa network yang ada, tentunya tergantung routing itu sendiri, apakah menggunakan jalur terdekat ataupun bandwith yang lebih besar. 
Namun tentunya apabila di dalam sebuah jaringan sama sama memilih jalur yang sama sebagai jalur yang akan digunakan, maka akan menyebabkan padatnya traffic yang ada pada jalur tersebut. 
Seperti contoh yang terlihat diatas, jalur yang digunakan oleh kedua router untuk menuju router yang berbeda, tetap sama. Dan tentunya hal ini akan menyebabkan padatnya jalur yang digunakan itu. Padahal masih ada jalur lain yang tidak digunakan. 
Apabila seperti ini, kita dapat menerapkan sebuah protocol dimana protocol ini akan menggunakan jalur yang admin kehendaki. Jadi tidak menggunakan routing yang menentukan jalur berdasarkan jalur dengan hop tersedikit ataupun jalur dengan bandwith terbesar. Protocol tersebut dinamakan dengan MPLS TE.
MPLS TE sendiri merupakan sebuah protocol yang berjalan pada MPLS Backbone, yang akan memanfaatkan jaringan MPLS sebagai perantaranya. MPLS TE memiliki tunnel yang dapat dimanfaatkan untuk menentukan mana jalur yang akan digunakan untuk dilewati sebuah packet. Lalu apa hubungannya dengan routing? 
Seperti yang sudah dibahas tadi, apabila terlalu memanfaatkan routing pada suatu jaringan, maka akan menyebabkan padatnya lalu lintas yang ada pada jaringan tersebut. Dikarenakan protocol routing itu tetaplah sama, apabila dalam hal menentukan jalur. Jadi tidak ada namanya “jalur ini telah digunakan” tapi yang ada adalah “jalur ini merupakan jalur terbaik”. 
Seperti yang terlihat pada gambar diatas, TE akan memungkinkan router yang bekerja sebagai PE untuk membuat sebuah tunnel yang dibentuk berdasarkan address yang akan dilewati. Jadi kita dapat membuat tunnel, dengan mendefinisikan address yang akan di lewati. 
Selain mendefinisikannya satu per satu ip address yang akan dibuat hubungan tunnel, dalam MPLS TE juga kita dapat menentukan tunnel yang dibuat secara dinamis. Jadi kita hanya perlu untuk mengaktifkan TE yang ada pada router yang kita miliki. 
Untuk membuat hubungan secara static juga ada beberapa cara untuk mendefinisikan jalur yang akan digunakan, diantaranya sebagai berikut. 
  • Strict 
Strict merupakan sebuah cara yang digunakan untuk mendefinisikan jalur directly connected yang dapat digunakan. Dalam hal ini juga kita juga harus mendefinisikan secara spesifik melewati address mana jalur ini dibuat. 
  • Loose
Loose merupakan sebuah cara yang digunakan untuk mendefinisikan jalur yang tidak directly connected, atau dalam artian kita hanya perlu mendefinisikan router penengah yang akan dilewati. Dalam hal ini juga brarti loose tidak perlu mendefinisikan sebuah jalur yang akan dibuat secara lebih spesifik. 
Opsi diatas tadi merupakan sebuah cara yang dapat digunakan untuk mendefinisikan jalur yang akan digunakan secara manual. 

[admin@MikroTik] > /mpls traffic-eng tunnel-path
add hops=[address|strict]
Hops ::= Hop[,Hops]
   Hop ::= Address:Strict
      Address ::= A.B.C.D (IP address)
      Strict ::= strict | loose

Seperti yang terlihat pada konfigurasi diatas, itu merupakan cara untuk membuat jalur static. Dan untuk hop yang akan di definisikan tidak seperti mengkonfigurasikan gateway pada static routing, akan tetapi menggunakan strict yang ada. 
Selain itu, seperti yang sudah saya bilang bahwa jalur juga dapat ditentukan secara dynamic. Apabila kita membuat tunnel secara dynamic, maka diperlukan diaktifkannya CSPF pada router tersebut. 
CSPF sendiri merupakan fitur yang ada pada MPLS TE yang akan memungkinkan kedua site untuk membentuk jalur dengan jalur terpendek. Jadi TE akan memilih secara otomatis jalur terpendek mana yang akan ia gunakan. 

[admin@MikroTik] > /mpls traffic-eng tunnel-path
add name=dynamic use-cspf=yes

Seperti yang terlihat pada konfigurasi diatas, kita perlu untuk mendefinisikan cspf agar aktif pada jalur dynamic. 
Pada MPLS TE sendiri, dapat dikatakan sebagai protocol yang support high avaibility. Hal ini dikarenakan dalam membuat tunneling, kita dapat menentukan 2 jalur dimana salah satunya akan digunakan sebagai backup, dan juga sebagai jalur utama. Kita dapat mendefinisikannya sebagai berikut. 

[admin@MikroTik] > /interface traffic-eng
add primary-path=static secondary-paths=dynamic

Seperti yang terlihat pada konfigurasi diatas, kita melakukan konfigurasi jalur mana yang dijadikan jalur utama, dan jalur mana yang akan dijadikan sebagai jalur cadangan.
Pada dasarnya, jalur utama yang dipilih, merupakan jalur static yang sudah kita buat tadi. Dan untuk jalur cadangan, kita menggunakan jalur dynamic yang sudah dibuat. 

Route Distinguiser (RD) dan Route Target (RT)

Assalamualaikum,
 
Sebelumnya, kita telah membahas mengenai BGP Based VPLS. Akan tetapi ada konfigurasi yang tidak kita ketahui seperti route distinguisher, import-route-target, dan juga export route target. Lalu apakah mereka semua? Dan apa kegunaannya? Berikut penjelasannya.

1. Route distinguisher

Route distinguiser di dalam sebuah jaringan L2VPN dan juga L3VPN, dapat diartikan sebagai tunnel id yang ada di dalam jaringan tersebut. Route distinguisher akan dipadukan dengan IPv4 Prefix dengan rumus seperti berikut.

RD+IPv4 prefix=vpnv4 prefix

Dengan rumus tersebut, maka akan menghasilkan adanya vpnv4. VPNV4 ini akan membuat sebuah ip address menjadi uniqe. Dalam artian, ipv4 akan diganti dengan format yang berbeda. Formatnya adalah sebagai berikut.
  • IP:num
  • ASn:num
Seperti yang terlihat diatas, kita dapat menggunakan IP dan dan num. Selain itu juga kita dapat menggunakan AS dan num. Num sendiri berartikan number yang bersifat bebas. Dalam artian kita dapat menentukannya sesuka kita.

2. Route Targe
t

Route target dibuat untuk mengadakan interkoneksi dengan site lainnya, atau dalam kali ini disebut dengan Extranet VPN.

Dalam penggunaan Extranet sndiri, akan memungkinkan beberapa site, untuk saling terhubung ke dalam tunneling. Sehingga akan terjadi interkoneksi antar site tersebut.

 
 
Di dalam route target juga dibedakan menjadi beberapa macam, yaitu sebagai berikut.
  • export route target
Pada export route target, sebuah PE akan menentukan vpnv4 yang akan di gunakan oleh router tersebut. Atau dalam artian, export route target diibaratkan sebagai router id pada jaringan tersebut dikarenakan ini juga akan berfungsi sebagai identitas site tersebut. 
  • Import route target
Pada import route target, sebuah PE berhak untuk menentukan site mana saja yang akan diperbolehkan masuk ke dalam sitenya. Jadi tidak sembarang site diperbolehkan masuk ke site yang kita miliki.

Route Distinguiser (RD) dan Route Target (RT)

Assalamualaikum,
 
Sebelumnya, kita telah membahas mengenai BGP Based VPLS. Akan tetapi ada konfigurasi yang tidak kita ketahui seperti route distinguisher, import-route-target, dan juga export route target. Lalu apakah mereka semua? Dan apa kegunaannya? Berikut penjelasannya.

1. Route distinguisher

Route distinguiser di dalam sebuah jaringan L2VPN dan juga L3VPN, dapat diartikan sebagai tunnel id yang ada di dalam jaringan tersebut. Route distinguisher akan dipadukan dengan IPv4 Prefix dengan rumus seperti berikut.

RD+IPv4 prefix=vpnv4 prefix

Dengan rumus tersebut, maka akan menghasilkan adanya vpnv4. VPNV4 ini akan membuat sebuah ip address menjadi uniqe. Dalam artian, ipv4 akan diganti dengan format yang berbeda. Formatnya adalah sebagai berikut.
  • IP:num
  • ASn:num
Seperti yang terlihat diatas, kita dapat menggunakan IP dan dan num. Selain itu juga kita dapat menggunakan AS dan num. Num sendiri berartikan number yang bersifat bebas. Dalam artian kita dapat menentukannya sesuka kita.

2. Route Targe
t

Route target dibuat untuk mengadakan interkoneksi dengan site lainnya, atau dalam kali ini disebut dengan Extranet VPN.

Dalam penggunaan Extranet sndiri, akan memungkinkan beberapa site, untuk saling terhubung ke dalam tunneling. Sehingga akan terjadi interkoneksi antar site tersebut.

 
 
Di dalam route target juga dibedakan menjadi beberapa macam, yaitu sebagai berikut.
  • export route target
Pada export route target, sebuah PE akan menentukan vpnv4 yang akan di gunakan oleh router tersebut. Atau dalam artian, export route target diibaratkan sebagai router id pada jaringan tersebut dikarenakan ini juga akan berfungsi sebagai identitas site tersebut. 
  • Import route target
Pada import route target, sebuah PE berhak untuk menentukan site mana saja yang akan diperbolehkan masuk ke dalam sitenya. Jadi tidak sembarang site diperbolehkan masuk ke site yang kita miliki.

BGP Based VPLS

Assalamualaikum, 
Pada kali ini, Kita akan mengetahui apa itu bgp based vpls. Perlu diketahui sebelumnya, VPLS juga dapat dikonfigurasikan menggunakan perantara BGP. BGP akan membuat adjacency atar sisi menjadi lebih mudah. Lalu bagaimana VPLS itu dapat berjalan pada BGP? 
BGP memiliki fungsi untuk membuat hubungan VPLS tanpa harus melakukan konfigurasi VPLS pada kedua sisi. Inilah mengapa BGP VPLS disebut memiliki fungsi autodiscovery dimana tidak perlu untuk melakukan konfigurasi pada kedua sisi.

Lalu bagaimana VPLS tersebut dapat terjalin? BGP VPLS yang sudah dibuat, akan menggunakan update message yang dimiliki BGP itu sendiri, untuk mendistribusikan VPLS tersebut. Dan inilah mengapa BGP VPLS disebut memiliki fungsi signalling dimana BGP akan menggunakan update message untuk mendistribusikan VPLS tersebut.

Penggunaan BGP sebagai perantara hubungan VPLS, bisa dibilang cukup menguntungkan. Hal ini dikarenakan BGP tidak memerlukan perantara MPLS untuk membuat hubungan VPLS tersebut. Jadi hanya menggunakan BGP saja, juga sudah bisa membuat hubungan VPLS.

Untuk konfigurasi pertama kali, tentunya konfigurasikan BGP Instance untuk menentukan AS yang akan digunakan oleh routing BGP.

Jika sudah, konfigurasikan peering antar kedua router. Akan tetapi jangan lupa untuk mendefinisikan Address family yang akan digunakan oleh BGP itu sendiri.

[admin@Mikrotik] > /routing bgp peer
add remote address=[Neighbor address] remote-as=[Neighbor AS] update-source=lo address-families=l2vpn

Seperti yang diketahui sebelumnya, bahwa BGP dapat menjalankan multi protocol. Oleh karena itu, kita harus mendefinisikan L2VPN pada address family yang akan digunakan oleh BGP peer dikarenakan VPLS merupakan protocol yang berjalan pada layer 2. Lalu untuk update sourcenya, kita menggunakan loopback.

Apakah konfigurasi sampai sini saja? Tidak, dikarenakan kita harus melakukan konfigurasi VPLS pada kedua sisi. Loh tadi katanya ga usah konfigurasikan? VPLS tidak usah di konfigurasikan, dalam artian konfigurasi secara manual untuk mendefinisikan address mana yang akan membuat hubungan tunneling. Dikarenakan BGP VPLS merupakan salah satu cara untuk membuat hubungan VPLS secara dynamic.

Pertama untuk membuat tunneling, tentunya buat telebih dahulu interface bridge pada router yang brisikan interdface yang menuju ke jaringan local. Jika sudah, konfigurasikan seperti berikut.

[admin@Mikrotik] > /interface vpls bgp-vpls
add bridge=<bridge> bridge-horizon=1 site-id=1
route-distinguisher=1:1 import-route-targer=1:1 export-route-
target=1:1

Berdasarkan konfigurasi diatas, kita perlu mendefinisikan interface bridge yang sudah kita buat tadi. Nantinya, interface bridge tersebut secara otomatis akan berisikan tunneling VPLS apabila adjacency antar site sudah terjalin.Lalu apa itu Route distinguisher, dan Route target? Anda dapat melihat pada artikel berikut.

BGP Based VPLS

Assalamualaikum, 
Pada kali ini, Kita akan mengetahui apa itu bgp based vpls. Perlu diketahui sebelumnya, VPLS juga dapat dikonfigurasikan menggunakan perantara BGP. BGP akan membuat adjacency atar sisi menjadi lebih mudah. Lalu bagaimana VPLS itu dapat berjalan pada BGP? 
BGP memiliki fungsi untuk membuat hubungan VPLS tanpa harus melakukan konfigurasi VPLS pada kedua sisi. Inilah mengapa BGP VPLS disebut memiliki fungsi autodiscovery dimana tidak perlu untuk melakukan konfigurasi pada kedua sisi.

Lalu bagaimana VPLS tersebut dapat terjalin? BGP VPLS yang sudah dibuat, akan menggunakan update message yang dimiliki BGP itu sendiri, untuk mendistribusikan VPLS tersebut. Dan inilah mengapa BGP VPLS disebut memiliki fungsi signalling dimana BGP akan menggunakan update message untuk mendistribusikan VPLS tersebut.

Penggunaan BGP sebagai perantara hubungan VPLS, bisa dibilang cukup menguntungkan. Hal ini dikarenakan BGP tidak memerlukan perantara MPLS untuk membuat hubungan VPLS tersebut. Jadi hanya menggunakan BGP saja, juga sudah bisa membuat hubungan VPLS.

Untuk konfigurasi pertama kali, tentunya konfigurasikan BGP Instance untuk menentukan AS yang akan digunakan oleh routing BGP.

Jika sudah, konfigurasikan peering antar kedua router. Akan tetapi jangan lupa untuk mendefinisikan Address family yang akan digunakan oleh BGP itu sendiri.

[admin@Mikrotik] > /routing bgp peer
add remote address=[Neighbor address] remote-as=[Neighbor AS] update-source=lo address-families=l2vpn

Seperti yang diketahui sebelumnya, bahwa BGP dapat menjalankan multi protocol. Oleh karena itu, kita harus mendefinisikan L2VPN pada address family yang akan digunakan oleh BGP peer dikarenakan VPLS merupakan protocol yang berjalan pada layer 2. Lalu untuk update sourcenya, kita menggunakan loopback.

Apakah konfigurasi sampai sini saja? Tidak, dikarenakan kita harus melakukan konfigurasi VPLS pada kedua sisi. Loh tadi katanya ga usah konfigurasikan? VPLS tidak usah di konfigurasikan, dalam artian konfigurasi secara manual untuk mendefinisikan address mana yang akan membuat hubungan tunneling. Dikarenakan BGP VPLS merupakan salah satu cara untuk membuat hubungan VPLS secara dynamic.

Pertama untuk membuat tunneling, tentunya buat telebih dahulu interface bridge pada router yang brisikan interdface yang menuju ke jaringan local. Jika sudah, konfigurasikan seperti berikut.

[admin@Mikrotik] > /interface vpls bgp-vpls
add bridge=<bridge> bridge-horizon=1 site-id=1
route-distinguisher=1:1 import-route-targer=1:1 export-route-
target=1:1

Berdasarkan konfigurasi diatas, kita perlu mendefinisikan interface bridge yang sudah kita buat tadi. Nantinya, interface bridge tersebut secara otomatis akan berisikan tunneling VPLS apabila adjacency antar site sudah terjalin.Lalu apa itu Route distinguisher, dan Route target? Anda dapat melihat pada artikel berikut.

Split Horizon Mikrotik

Assalamualaikum,

Pada kali ini, saya share materi mengenai split horizon yang ada pada mikrotik. Perlu diketahui sebelumnya, bahwa split horizon sendiri merupakan suatu cara yang diterapkan pada jaringan yang menggunakan lebih dari 1 VPLS untuk mencegah terjadinya looping pada jaringan tersebut.
Seperti sebuah contoh, ada sebuah jaringan yang menggunakan VPLS seperti berikut.

Lalu seperti yang terlihat pada jaringan tersebut, 3 buah router terhubung menggunakan pseudowire yang sudah dibuat dikarenakan menggunakan VPLS sebagai tunneling kepada router lainnya. Dan pada jaringan tersebut, tunneling yang bekerja pada setiap router tersebut dalam kondisi full mesh atau dalam artian ketiga router tersebut saling terhubung satu sama lainnya.
Lalu bagaimana cara kerja split horizon? split horizon akan bekerja pada interface bridge yang memiliki horizon. Apabila ada bridge yang memiliki nilai split horizon sama, maka packet yang berjalan di dalam jaringan tersebut, tidak akan dikirimkan. Dikarenakan memiliki nilai split horizon yang sama.
Lalu apa hubungannya untuk mencegah looping? Coba lihat jalur jalannya sebuah advertise yang dikirimkan oleh router client. Packet tersebut akan di advertise oleh router yang berada dalam MPLS Backbone. Lalu pada jaringan MPLS Backbone, ada router yang tidak melakukan advertise ke sebuah link. Hal ini dikarenakan keduanya memiliki nilai split horizon yang sama, jadi packet tersebut tidak akan dikirimkan ke bridge yang memiliki split horizon yang sama.
Untuk konfigurasi sendiri, tentunya pastikan terlebih dahulu bahwa VPLS sudah tercipta antar router. jika sudah, maka dapat dilakukan dengan konfigurasi seperti berikut.
[admin@Mikrotik] > /interface bridge port
add bridge=tunnel interface=vpls1 horizon=1
Berdasarkan konfigurasi diatas, kita memberikan value split horizon kepada interface tunnel yang sudah ada. Lalu dengan seperti ini, maka apabila ada VPLS yang juga menggunakan horizon dengan value 1, maka router tersebut tidak akan mengadvertise ke router yang sama tadi. 

Split Horizon Mikrotik

Assalamualaikum,

Pada kali ini, saya share materi mengenai split horizon yang ada pada mikrotik. Perlu diketahui sebelumnya, bahwa split horizon sendiri merupakan suatu cara yang diterapkan pada jaringan yang menggunakan lebih dari 1 VPLS untuk mencegah terjadinya looping pada jaringan tersebut.
Seperti sebuah contoh, ada sebuah jaringan yang menggunakan VPLS seperti berikut.

Lalu seperti yang terlihat pada jaringan tersebut, 3 buah router terhubung menggunakan pseudowire yang sudah dibuat dikarenakan menggunakan VPLS sebagai tunneling kepada router lainnya. Dan pada jaringan tersebut, tunneling yang bekerja pada setiap router tersebut dalam kondisi full mesh atau dalam artian ketiga router tersebut saling terhubung satu sama lainnya.
Lalu bagaimana cara kerja split horizon? split horizon akan bekerja pada interface bridge yang memiliki horizon. Apabila ada bridge yang memiliki nilai split horizon sama, maka packet yang berjalan di dalam jaringan tersebut, tidak akan dikirimkan. Dikarenakan memiliki nilai split horizon yang sama.
Lalu apa hubungannya untuk mencegah looping? Coba lihat jalur jalannya sebuah advertise yang dikirimkan oleh router client. Packet tersebut akan di advertise oleh router yang berada dalam MPLS Backbone. Lalu pada jaringan MPLS Backbone, ada router yang tidak melakukan advertise ke sebuah link. Hal ini dikarenakan keduanya memiliki nilai split horizon yang sama, jadi packet tersebut tidak akan dikirimkan ke bridge yang memiliki split horizon yang sama.
Untuk konfigurasi sendiri, tentunya pastikan terlebih dahulu bahwa VPLS sudah tercipta antar router. jika sudah, maka dapat dilakukan dengan konfigurasi seperti berikut.
[admin@Mikrotik] > /interface bridge port
add bridge=tunnel interface=vpls1 horizon=1
Berdasarkan konfigurasi diatas, kita memberikan value split horizon kepada interface tunnel yang sudah ada. Lalu dengan seperti ini, maka apabila ada VPLS yang juga menggunakan horizon dengan value 1, maka router tersebut tidak akan mengadvertise ke router yang sama tadi. 

iBGP Peer (Physical Interface)

Assalamualaikum,

Pada kali ini saya akan sharing mengenai cara membuat peering iBGP antar router. Seperti yang sudah kita ketahui sebelumnya, bahwa peering iBGP merupakan peering antar router yang masih berada dalam 1 AS.

 

Oke langsung saja, konfigurasi ip address untuk interface yang akan digunakan tentunya. Untuk ip address sendiri kita menggunakan ip address standart IDN. Kita akan melakukan konfigurasi instace yang ada pada router terlebih dahulu.

[admin@Rx] > /routing bgp instance
set default as=1 router-id=x.x.x.x

Berdasarkan konfigurasi diatas, kita melakukan konfigurasi untuk mendefinisikan, sebenarnya router tersebut ada di AS berapa sih. Mendefinisikan AS merupakan hal yang penting sebelum melakukan peering antar router. Router sendiri, sebenarnya mempunyai AS default yang ada pada BGP, yaitu AS 65530. Namun seperti yang sudah diketahui sebelumnya, bahwa AS tersebut merupakan AS Private. Oleh karena itu kita mendefinisikan AS kembali.

Setelah itu untuk konfigurasi router id, ita menentukan pada sebuah router identitasnya yang ada pada jaringan tersebut. Jadi router tersebut memiliki identitas pada jaringan tersebut. Jika sudah tamahkan peering antar router.

[admin@R1] > /routing bgp peer
add name=peer1 remote-address=12.12.12.2 remote-as=1

[admin@R2] > /routing bgp peer
add name=peer1 remote-address=12.12.12.1 remote-as=1

Seperti yang kita ketahui sebelumnya bahwa BGP tidak dapat menambahkan peernya secara otomatis, oleh karena itu kita mendefinisikan peering yang ada pada setiap router.
Untuk remote address sendiri, itu akan mendefinsikan address router lawan yang terhubung dengannya. Dikarenakan R1 memiliki address 12.12.12.1, maka pada R2, kita harus mendefinisikan address tersebut dalam remote address.
Selanjutnya ada juga remote as. Remote as sendiri, digunakan untuk mendefinsikan AS yang ada pada peer. Dikarenakan sebelumnya kita sudah menentukan AS yang digunakan untuk kedua router tersebut, maka pada remote as, masukkan AS yang sudah di konfigurasikan tad. Seperti contoh R1 mendefinisikan R2 berada pada AS1. Begitupun sebaiknya, R2 mendefinisikan R1 berada pada AS1.
Jika sudah, selanjutnya lakukan verifikasi terhadap peer table yang ada pada router. 

Berdasarkan hasil verifikasi pada salah satu router, maka akan memperlihatkan peering yang kita buat tadi, akan memiliki flag E atau dalam artian Established/Terhubung.

Seperti yang sudah kita pelajari sebelumnya mengenai BGP State, bahwa hubungan antar BGP Speaker akan terjalin apabila sudah mencapai status established. Apabila sudah seperti itu, maka hubungan antar router tersebut sudah berhasil.

VPLS Mikrotik

Assalamualaikum,

Pada kali ini, saya akan melanjutkan materi tunneling selanjutnya, yaitu VPLS. VPLS sendiri merupakan tunneling layer2 yang menggunakan MPLS sebagai perantara pembuatan tunneling. Dengan menggunakan VPLS sebagai tunneling, akan memungkinkan kita menghubungkan jaringan local yang berada dalam network tersebut agar seolah olah terhubung secara langsung. 

 


Konsep kerja VPLS, sama dengan EoIP, namun dalam penggunakan VPLS, kecepatan dalam tunneling tersebut lebih cepat 60% dibandingkan dengan EoIP. Oke langsung saja ke TKP..


Topology






Konfigurasi
Untuk konfigurasi sendiri, konfigurasi address untuk setiap interface terlebih dahulu. Untuk interface ether3 pada R1 dan juga R4, tidak usah ditambahkan ip address, dikarenakan nantinya kita akan menghubungkan R5 dan R6 menggunakan layer2. Untuk R5 dan R6 juga tidak usah ditambahkan routing, hanya perlu menambahkan ip address saja. Jika sudah, sekarang kita akan melakukan konfigurasi routing RIP.

[admin@R1] > /routing rip network
add network=13.13.13.0/24
add network=12.12.12.0/24
add network=1.1.1.1/32

[admin@R2] > /routing rip network
add network=12.12.12.0/24
add network=24.24.24.0/24
add network=2.2.2.2/32

[admin@R3] > /routing rip network
add network=13.13.13.0/24
add network=34.34.34.0/24
add network=3.3.3.3/32

[admin@R4] > /routing rip network
add network=34.34.34.0/24
add network=24.24.24.0/24
add network=4.4.4.4/32

Mengapa kita menambahkan routing RIP untuk jaringan tersebut? Hal ini dikarenakan nantinya kita akan menggunakan MPLS dimana, untuk VPLS sendiri menggunakan MPLS agar dapat berjalan. Jika sudah, lakukan konfigurasi MPLS LDP.

[admin@Rx] > /mpls ldp
set enabled=yes lsr-id=x.x.x.x transport-address=x.x.x.x
[admin@Rx] > /mpls ldp interface
add interface=ether1
add interface=ether2

Untuk konfigurasi MPLS, kita aktifkan service MPLS LDP terlebih dahulu, selanjutnya tambahkan lsr-id dan juga transport address yang merupakan address loopback yang dimiliki oleh sebuah router. Setelah itu definisikan interface yang akan digunakan untuk MPLS tersebut. Selanjutnya, konfigurasi VPLS.

[admin@R1] > /interface vpls
add disabled=no name=vpls1 remote-peer=4.4.4.4 vpls-id=100:100 

[admin@R4] > /interface vpls
add disabled=no name=vpls1 remote-peer=1.1.1.1 vpls-id=100:100

Berdasarkan konfigurasi diatas, yang perlu dikonfigurasi dalam pembuatan vpls hanyalah remote address dan juga vpls id. Remote address sendiri merupakan address router yan nantinya akan membuat tunneling vpls juga dengan kita. Sedangkan vpls id sendiri, merupakan unique number yang ada dalam vpls untuk mendefinisikan wilayah yang ditempatinya. Jadi apabila sebuah router dengan router lainnya sama sama ingin membuat tunneling, maka keduanya harus mendefinisikan vpls id yang sama. Jika sudah, lakukan verifikasi.


Berdasarkan verifikasi diatas, terlihat bahwa ada neighbor vpls yang ditambahkan dalam table mpls ldp neighbor. Apabila sudah seperti itu, maka dipastikan hubungan VPLS sudah terbentuk. Namun jika hanya sampai sini, client masih belum dapat berkomunikasi. Mengapa? Dikarenakan VPLS sendiri merupakan tunneling yang bekerja pada layer2, sehingga dibutuhkan interface bridge. Oleh karena itu, buat interface bridge dan definisikan VPLS yang sudah dibuat dengan interface yang menuju ke jaringan local.

[admin@R1] > /interface bridge
add name=vpls
[admin@R1] > /interface bridge port
add bridge=vpls interface=vpls1
add bridge=vpls interface=ether3

[admin@R4] > /interface bridge
add name=vpls
[admin@R4] > /interface bridge port
add bridge=vpls interface=vpls1
add bridge=vpls interface=ether3

Jika sudah, lakukan verifikasi pada client yang sudah ditambahkan ip address.

[admin@R5] > ping 56.56.56.6
SEQ HOST            SIZE TTL TIME STATUS
0      56.56.56.6     56     64    42ms
1      56.56.56.6     56     64    3ms
sent=2 received=2 packet-loss=0% min-rtt=3ms avg-rtt=22ms max-rtt=42ms

[admin@R6] > ping 56.56.56.5
SEQ HOST            SIZE TTL TIME STATUS
0 56.56.56.5          56     64    7ms
1 56.56.56.5          56     64    8ms
sent=2 received=2 packet-loss=0% min-rtt=7ms avg-rtt=7ms max-rtt=8ms

Maka jika sudah seperti itu, maka tunneling sudah sukses.