Routing mark 2 ISP Berbeda

Assalamualaikum,
Pada kali ini, saya akan menunjukkan sebuah cara yang digunakan untuk memanipuasi jalur untuk keluar. Dalam hal ini, nantinya kita akan mengalihkan sebuah traffic untuk network sekian, dan juga sebuah traffic untuk network lainnya. Hal ini biasanya digunakan untuk meoptimalkan beban traffic yang ada pada jaringan tersebut. Sehingga tentunya, traffic akan terasa cukup lega dan terlihat adil.
Oke langsung saja, berikut topologi yang akan kita gunakan.
Topologi
Konfigurasi
Oke berdasarkan topologi diatas, terlihat bahwa sebuah jaringan memiliki 2 ISP yang sama sama digunakan untuk terhubung ke internet tentunya, dan juga ada 2 network yang ada pada sisi client. Sehingga nantinya sebuah network akan melewati jalur ISP A dan network lainnya akan melewati jalur ISP B.
Kita akan membuat agar network dari VLAN 10 melewati ISP A, dan VLAN 20 melewati ISP B.
Router1

[admin@R1]> ip firewall mangle add chain=prerouting src-address=172.4.110.0/24 action=mark-routing new-routing-mark=TrafficVLAN10
[admin@R1] > ip firewall mangle add chain=prerouting src-address=172.4.120.0/24 action=mark-routing new-routing-mark=TrafficVLAN20

Berdasarkan konfigurasi tersebut, menandakan bahwa setiap packet yang berasal ari VLAN10, maka tandai routing tersebut dengan nama TrafficVLAN10. Sedangkan untuk traffic yang berasal dari VLAN20, maka tandai routing tersebut dengan TrafficVLAN20.
Jika sudah seperti itu, kita harus mendefinisikan nantinya traffic yang dibuat tadi akan melewati jalur yang mana. Oleh karena itu, kita harus membuat route untuk masing masing traffic.
Router1

[admin@R1]> ip route add gateway=172.4.2.1/30 routing-mark=TrafficVLAN10
[admin@R1]> ip route add gateway=172.4.2.5/30 routing-mark=TrafficVLAN20

Jika sudah seperti itu, maka lakukan pengecekan dengan menggunakan traceroute. Maka hasilnya itu, apabila VLAN10 melakukan traceroute, maka yang akan dilewati adalah jalur ISP A, dan sedangkan apabila VLAN20 melakukan traceroute, maka yang akan dilewati adalah jalur ISP B.

Routing mark 2 ISP Berbeda

Assalamualaikum,
Pada kali ini, saya akan menunjukkan sebuah cara yang digunakan untuk memanipuasi jalur untuk keluar. Dalam hal ini, nantinya kita akan mengalihkan sebuah traffic untuk network sekian, dan juga sebuah traffic untuk network lainnya. Hal ini biasanya digunakan untuk meoptimalkan beban traffic yang ada pada jaringan tersebut. Sehingga tentunya, traffic akan terasa cukup lega dan terlihat adil.
Oke langsung saja, berikut topologi yang akan kita gunakan.
Topologi
Konfigurasi
Oke berdasarkan topologi diatas, terlihat bahwa sebuah jaringan memiliki 2 ISP yang sama sama digunakan untuk terhubung ke internet tentunya, dan juga ada 2 network yang ada pada sisi client. Sehingga nantinya sebuah network akan melewati jalur ISP A dan network lainnya akan melewati jalur ISP B.
Kita akan membuat agar network dari VLAN 10 melewati ISP A, dan VLAN 20 melewati ISP B.
Router1

[admin@R1]> ip firewall mangle add chain=prerouting src-address=172.4.110.0/24 action=mark-routing new-routing-mark=TrafficVLAN10
[admin@R1] > ip firewall mangle add chain=prerouting src-address=172.4.120.0/24 action=mark-routing new-routing-mark=TrafficVLAN20

Berdasarkan konfigurasi tersebut, menandakan bahwa setiap packet yang berasal ari VLAN10, maka tandai routing tersebut dengan nama TrafficVLAN10. Sedangkan untuk traffic yang berasal dari VLAN20, maka tandai routing tersebut dengan TrafficVLAN20.
Jika sudah seperti itu, kita harus mendefinisikan nantinya traffic yang dibuat tadi akan melewati jalur yang mana. Oleh karena itu, kita harus membuat route untuk masing masing traffic.
Router1

[admin@R1]> ip route add gateway=172.4.2.1/30 routing-mark=TrafficVLAN10
[admin@R1]> ip route add gateway=172.4.2.5/30 routing-mark=TrafficVLAN20

Jika sudah seperti itu, maka lakukan pengecekan dengan menggunakan traceroute. Maka hasilnya itu, apabila VLAN10 melakukan traceroute, maka yang akan dilewati adalah jalur ISP A, dan sedangkan apabila VLAN20 melakukan traceroute, maka yang akan dilewati adalah jalur ISP B.

EoIP Mikrotik

Assalamualaikum,

Pada kali ini saya akan share kembali mengenai materi mikrotik, dan masih sama seperti sebelumnya, kali ini kita masih akan membahas soal tunneling. Tunneling yang akan kita gunakan pada kali ini, adalah tunnel EoIP. EoIP sendiri, merupakan tunneling yang berkerja pada layer2 yang menghubungkan sebuah jaringan dengan jaringan lainnya.


Untuk keamanan sendiri, EoIP memiliki keamanan yang sangat rendah, dikarenakan EoIP tidak melakukan enkripsi terhadap packet yang dikirimkan melalui EoIP. Namun untuk keuntungannya, EoIP dapat menghubungkan network yang sama walaupun dalam wilayah yang berbeda. Oke langsung saja ke TKP..


Topology

Konfigurasi

Untuk konfigurasi , tentunya lakukan konfigurasi terlebih dahulu ip address untuk interface yang akan digunakan. Untuk ip address sendiri, buat agar jaringan local R1 dan R2 berada dalam 1 network yang sama dikarenakan kita akan membuat tunnel EoIP yang bekerja berdasarkan Layer 2. Selanjutnya, konfigurasikan EoIP pada router.

[admin@R1] > /interface eoip
add local-address=12.12.12.1 name=eoip1 remote-address=12.12.12.2 tunnel-id=10
[admin@R2] > /interface eoip
add local-address=12.12.12.2 name=eoip1 remote-address=12.12.12.1 tunnel-id=10

Berdasarkan konfigurasi diatas, kita hanya perlu untuk mendefinisikan local address dan remote address router yang ingin membuat tunneling. Lalu untuk tunnel id, ia akan memberikan identitas untuk tunneling yang dibuat tersebut bahwa tunneling yang digunakan tersebut hanya untuk yang menggunakan tunnel id 10. Selanjutnya, konfigurasikan bridge.

[admin@R1] > /interface bridge
add name=eoip
[admin@R1] > /interface bridge port
add bridge=eoip interface=ether1
add bridge=eoip interface=eoip1

[admin@R2] > /interface bridge
add name=eoip
[admin@R2] > /interface bridge port
add bridge=eoip interface=ether1
add bridge=eoip interface=eoip1

Berdasarkan konfigurasi diatas, kita membuat agar interface eoip yang sudah dbuat tadi, “ter-bridge” dengan interface yang menuju jaringan local yang kita miliki. Hal ini dikarenakan EoIP bekerja pada layer 2. Jadi agar router client dapat berhubungan dengan router lainnya, kita hanya perlu melakukan konfigurasi bridge dengan interface eoip yang ada pada router. Jika sudah, lakukan verifikasi.