Pembahasan Soal Superlab Cisco IDN Competition 2017 : Section 1 Part 2

Joss, kita lanjutin lagi ke Section 1 part 2. Untuk Pembahasan sebelumnya bisa di clik disini Pembahasan Soal Superlab Cisco IDN Competition 2017 : Section 1 Part 1

1.3 Spanning Tree

1. Pada tahap ini kita diminta untuk mengkonfigurasikan beberapa device dengan ketentuan
sebagai berikut :

  • Konfigurasikan mode yang langsung membypass listening dan learning, konfigurasikan mode ini hanya pada port yang mengarah ke client (PC).

Jadi kita diminta untuk mengkonfigurasi spanning tree portfast pada port switch yang mengarah ke client (PC)

Switch yang perlu dikonfigurasi pada jaringan

  • Internet    : SW0 port fa0/3 (Disini masih kurang yakin perlu dikonfigurasi atau gk. Cuman diliat dari soalnya minta semua PC, jadi mungkin disini juga diminta)
  • Makassar : SW11 port fa0/3
  • Semarng  : SW-SMG port fa0/3-4
  • Solo          : SW7-SW10 port fa0/2-3 dan SW6 port fa0/9

Untuk perintah nya :

  • Masuk ke interface : interface fa0/nomor-interface.
    Jika ada 2 interface yang dikonfigurasi contoh pada SW-SMG, Gunakan range. Ex: interface range fa0/3-4

    • spanning-tree portfast : mengaktifkan fitur spanning tree portfast

Cukup 2 perintah tersebut

1.4 Implement WAN Technologies

1. Konfigurasikan WAN pada link ISP6 dan R19 di Jayapura dengan ketentuan sebagai berikut :

  •  Link WAN harus support negotiation dan authentication
  • Gunakan WAN Protocol yang memiliki fitur kompresi, authentikasi, dan error detection
  • Untuk authentikasinya gunakan mode yang support enkripsi
  • Jangan merubah hostname di kedua device gunakan password idnmantab

WAN Technologies, yang perlu kita konfigurasi itu adalah encapsulation pada interface serial di antar router. Disini yang diminta adalah ISP6 dan R19. Yang support negotiation dan authentication itu encapsulation menggunakan PPP. Authentication pada PPP ada 2, PAP sama CHAP. Tpi disini diminta yang mensupport enkripsi berarti kita menggunakan CHAP.

Selection_022
Link Serial ISP6-R19

ISP6

  • interface se0/0/1
    • no shutdown
      (karena pada router semua interface defaultnya dalam keadaan shutdown)
    • encapsulation ppp
    • ppp authentication chap
    • exit (perlu exit karena command selanjutnya digunakan pada global-config)
  • username R19 password idnmantab
    (Untuk authentikasi menggunakan chap kita membuat user dengan hostname lawan (R19) lalu password yang sama dikedua router)
  • Untuk penghecheckan bisa menggunakan perintah “show interface se0/0/1” lalu lihat pada bagian encapsulation apakah sudah PPP
  • Namun jika router pasangannya (R19) belum dikonfigurasi maka status interface akan down

R19

  • interface se0/0/0
    • no shutdown
    • encapsulation ppp
    • ppp authentication
    • exit
  • username ISP6 password idnmantab
  • Jika kedua router sudah di konfigurasi maka status interfacenya akan kembali up

2. Konfigurasikan WAN pada link ISP4 dan R13 di Semarang dengan ketentuan sebagai berikut:

  • Link WAN harus support negotiation dan authentication
  • Gunakan WAN Protocol yang memiliki fitur kompresi, authentikasi dan error detection
  • Gunakan authentikasi yang support enkripsi
  • Jangan merubah hostname di kedua device gunakan password idn

Disini juga sama saja seperti sebelumnya. Cuman beda di password saja

Selection_023.png
Link antar ISP4 – R13

ISP4

  • interface se0/1/1
    • no shutdown
    • encapsulation ppp
    • ppp authentication dot1q
    • exit
  • username R13 password idn

R13

  • interface se0/1/0
    • no shutdown
    • encapsulation ppp
    • ppp authentication dot1q
    • exit
  • username ISP4 password idn

3. Konfigurasikan WAN pada link ISP1 dan R2 di Jakarta dengan ketentuan sebagai berikut:

  • Gunakan Link WAN yang mempunyai encapsulation default untuk interface serial
  •  Jangan merubah hostname di kedua device

Disini kita diminta untuk mengkonfigurasi link antar ISP1 dan R2 di Jakarta menggunakan encapsulation default yaitu HDLC. Gk ada authentication disini, jadi hanya perlu menyalakan interface dan di ubah ke HDLC. 

Selection_024.png
Link ISP1 – R2

Jika kita check link antar ISP1 dan R2, Linknya menggunakan encapsulation PPP. Contoh check di R2

Selection_025.png
Check encapsulation interface serial 0/1/0 pada Router R2

R2

  • interface se0/1/0
    • no shutdown
    • encapsulation hdlc

ISP1

  • interface se0/0/0
    • no shutdown
    • encapsulation hdlc

Jika mau di check gunakan perintah “show interface inteface-number”

1.5 Implement VPN

Untuk yang VPN saya skip dulu. 😀 saya masih bingung yang diminta jadi VPN Server atau tunneling. Soalnya saya udah coba keduanya gk ada naik nilainya 😀
Mungkin nanti klo sudah dapat pencerahan dari yang buat, saya share lagi buat VPN

OK ? siap, Udah selesai yang section 1 semoga mudah dipahami dan dimengerti.

Post berikutnya lanjut ke Section 2 (Layer 3). Jadi pastikan pantau blognya yaa …

Pembahasan Soal Superlab Cisco IDN Competition 2017 : Section 1 Part 1

Kali ini akan membahas soal superlab cisco yang di adakan oleh ID-Networkers. Udah 2 kali coba dan nilainya cuman dapat 75% saja. OK gk masalah, bukan masalah nilai yang kita butuhkan yang penting kita dapat belajar hal baru lagi dengan mencoba soal ini. Aku masih belajar juga mungkin di pembahasan ini ada yang salah atau kurang benar mohon dikoreksi dan juga kedepannya ada beberapa service yang saya tidak masukkan karena saya juga masih bingung.

Sebelum mengerjakan juga diharapkan udah paham ya cara konfigurasi di cisco bagaimana. Beberapa service udah ada saya jelasin di blog, tinggal di cari saja. Misal VTP atau VLAN dll.

Untuk soal dan file .pka nya bisa di ambil di sini Soal dan Pka

Topologi Jaringan

A. Physical Topologi

Selection_009.png
Physical Topologi

B. Logical Topologi

Selection_010
Logical Topologi

Jangan terlalu pusing melihat topologinya yang besar. Kita kerjainnya satu-satu biar mudah. Fokus ke soal saja, kerjain per service yang diminta.

Section 1 : Switching

1.1 Switch Administration (VTP)

1. Konfigurasikan device di bagian Jakarta dengan ketentuan sebagai berikut :

  • VTP domain harus di set idncompetition2017
  • Jangan gunakan VTP versi default
  •  SW2 harus di set agar menerima informasi VTP dari SW1
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    IDNcompetition2017mantab

Kita pahamin dulu soalnya ok. Kita diminta untuk mengkonfigurasi VTP pada SW1 dan SW2 di Jakarta dengan ketentuan :

  • VTP Domain : idncompetition2017
  • VTP Version 2, karena VTP versi defaultnya adalah versi 1
  • SW1 modenya Server dan SW2 modenya Client
  • VTP password : IDNcompetition2017mantab

Konfigurasinya :

SW1

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode server
  4. vtp password IDNcompetition2017mantab

SW2

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode client
  4. vtp password IDNcompetition2017mantab

Untuk pengecheckan vtp nya bisa menggunakan perintah

  1. show vtp status
  2. show vtp password

2. Konfigurasikan device di bagian Samarinda dengan ketentuan sebagai berikut :

  • VTP domain harus di set idncompetition2017
  • Jangan gunakan VTP versi default
  • Pastikan MLS4 menerima update informasi VTP dari MLS3
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    IDNcompetition2017mantab

Hampir sama saja dengan yang dijakarta. Kita mengerjakannya di Samarinda dan disini MLS4 sebagai Client dan MLS3 sebagai Server

MLS3

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode server
  4. vtp password IDNcompetition2017mantab

MLS4

  1. vtp domain idncompetition2017
  2. vtp version 2
  3. vtp mode client
  4. vtp password IDNcompetition2017mantab

3. Konfigurasikan device di bagian Makasar dengan ketentuan sebagai berikut :

  • VTP domain harus di set IDNcompetition2017!
  • Jangan gunakan VTP versi default
  • Pastikan MLS5 dan MLS6 tidak menyebarkan informasi VTP ke switch lain
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    idnmantab

Kita mengerjakannya di Makasar. Hampir sama seperti sebelumnya. Bedanya disini kedua switch menggunakan mode VTP Transparent.

MLS5 & MLS6

  1. vtp domain IDNcompetition2017!
  2. vtp version 2
  3. vtp mode transparent
  4. vtp password idnmantab

4. Konfigurasikan device di bagian Semarang dengan ketentuan       sebagai berikut :

  • VTP domain harus di set idnid
  • Pastikan semua switch di area semarang mendapat update informasi VTP dari MLS8
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    idncompetition2017

Disini mungkin menggunakan vtp version 1 karena tidak diminta untuk mengubahnya. Semua switch di Semarang modenya adalah client kecuali MLS8 yang menggunakan mode server

MLS8

  1. vtp domain idnid
  2. vtp mode server
  3. vtp password idncompetition2017

MLS1, MLS2 & MLS7

  1. vtp domain idnid
  2. vtp mode client
  3. vtp password idncompetition2017

4. Konfigurasikan device di bagian Solo dengan ketentuan sebagai berikut :

  • VTP domain harus di set IDNcompetition2017!
  • Jangan gunakan VTP versi default
  •  Konfigurasikan agar SW3 mau menyebarkan update informasi VTP ke Swith lain yang ada di Solo
  • Amankan semua update informasi VTP menggunakan MD5 digest of ASCII string
    IDN@2017_competition

Disini SW3 sebagai server dan switch yang lainnya sebagai client

SW3

  1. vtp domain IDNcompetition2017!
  2. vtp version 2
  3. vtp mode server
  4. vtp password IDN@2017_competition

SW4-10

  1. vtp domain IDNcompetition2017!
  2. vtp version 2
  3. vtp mode client
  4. vtp password IDN@2017_competition

1.2 Layer 2 Ports

1. Pada tahap ini kita diminta untuk mengkonfigurasikan beberapa device dengan ketentuan sebagai berikut :

  • Konfigurasikan VLAN pada device sesuai dengan logical topologi.
  • Pastikan database VLAN antar switch sama.
  • Konfigurasikan link antara SW1-SW2 dan MLS3-MLS4 pastikan semua link up menggunakan tipe open standard.
  • Semua port switch pada topologi yang support up to 1000mb/s pastikan statusnya di assign ke vlan88 dan statusnya administratively down

Ini kita kerjakan di Jakarta dan Samarinda. Kita disuruh membuat VLAN dan assign interface ke VLAN menyesuaikan sesuai dengan logical topologi.

Jakarta


Untuk link antar switch menggunakan tipe dot1q lalu di trunk. Trus port interface gig itu dimasukkan ke vlan88 dan di shutdown biar statusnya jadi administratively down. Kita konfigurasi SW1 dulu untuk membuat VLAN karena SW1 sebagai VTP server. Dan juga memasukkan masing-masing interface sesuai logical topologi.

SW1

  1. Buat vlan sesuai logical yaitu VLAN 14,15,23,24,35,46,57,67,88 totalnya ada 9 VLAN
    • perintah “vlan vlan-number
    • Check dengan perintah “show vlan brief”
  2. Interface 21-23 kita ubah menjadi trunk
    • interface range fa0/21-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • Check dengan perintah “show interface fa0/21 switchport” atau “show run”
  3. Assign Vlan sesuai Logical topologi
    • interface fa0/6
      • switchport mode access
      • switchport access vlan 67
    • interface fa0/7
      • switchport mode access
      • switchport access vlan 67
    • interface fa0/4
      • switchport mode access
      • switchport access vlan 14
    • interface fa0/5
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
      • Dikonfigurasi Trunk karena pada fa0/5 terhubung ke R5-fa0/0 yang menggunakan interVLAN
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 24
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 35
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 14
    • Check dengan perintah “show vlan brief”
  4. Masukkan vlan 88 pada interface gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown
    • Check dengan perintah “show vlan brief” dan “show ip interface brief”

SW2

  1. Gk usah buat VLAN, karena sudah terbuat hasil dari VTP. bisa di check menggunakan “show vlan brief”
  2. Interface fa0/21-23 ubah menjadi trunk
    • interface range fa0/21-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign Vlan sesuai Logical topologi
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 23
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 23
    • interface fa0/4
      • switchport trunk encapsulation dot1q
      • switchport mode trunk (penjelasan sama seperti sebelumnya)
    • interface fa0/5
      • switchport mode access
      • switchport access vlan 15
    • interface fa0/6
      • switchport mode access
      • switchport access vlan 46
    • interface fa0/7
      • switchport mode access
      • switchport access vlan 57
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 15
  4. Masukkan vlan 88 pada interface gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown

Samarinda


Hampir sama dengan di Jakarta. Bedanya hanya di VLAN dan interfacenya. Kita buat VLANnya di MLS3 karena sebagai VTP Server

MLS3

  1. Membuat VLAN 89,108,118,109,119,110,88 total ada 7 vlan.
    • vlan vlan-number
  2. Ubah interface fa0/20-23 menjadi trunk
    • interface range fa0/20-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 89
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 109
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 108
    • interface fa0/4
      • switchport trunk encapsulation dot1q
      • switchport mode trunk (Diubah ke trunk karena fa0/0 pada R11 menggunakan interVLAN)
  4. Assign VLAN 88 ke gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown

MLS4

  1. Membuat VLAN 89,108,118,109,119,110,88 total ada 7 vlan.
    • vlan vlan-number
  2. Ubah interface fa0/20-23 menjadi trunk
    • interface range fa0/20-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/2
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/3
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  4. Assign VLAN 88 ke gig0/1-2 dan di shutdown
    • interface range gig0/1-2
      • switchport mode access
      • switchport access vlan 88
      • shutdown

2. Konfigurasikan network device yang ada di Makassar dengan ketentuan sebagai berikut :

  • Pastikan database VLAN antar switch sama.
  • Konfigurasikan VLAN dan assign switchport sesuai dengan topologi logical.
  • Gunakan model dot1q trunk untuk menghubungkan SW5 dan SW6. (maksudnya MLS5 dan MLS6)
  • Trunk jangan di set auto negotiation ataupun etherchannel.

Sama seperti sebelumnya. Kita buat VLANnya dulu. Karena kedua VLAN menggunakan VTP transparent jadi keduanya membuat VLAN. Assign interface ke VLAN sesuai dengan logical topologi. Interface antar MLS5-MLS6 diganti ke trunk dengan dot1q.


MLS5

  1. Buat VLAN 156 dan 157 “vlan vlan-number”
  2. Interface fa0/11-13 ubah menjadi trunk
    • interface range fa0/11-13
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 156
    • Karena R16 terhubung ke VLAN 156 menggunakan interface e0/1/0 maka di MLS5 cuman 1 interface saja

MLS6

  1. Buat VLAN 156 dan 157 “vlan vlan-number”
  2. Interface fa0/11-13 ubah menjadi trunk
    • interface range fa0/11-13
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 157
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 157
    • interface fa0/3
      • switchport mode access
      • switchport access vlan 156

3. Konfigurasikan network device yang ada di Semarang dengan ketentuan sebagai berikut :

  • Pastikan database VLAN antar switch sama.
  • Konfigurasikan VLAN dan assign switchport sesuai dengan topologi logical. Pastikan VLAN yang telah di assign banar dan sesuai topologi.
  • Trunk jangan di set auto negotiation ataupun etherchannel.

Sama seperti sebelumnya. Kita buat VLANnya hanya di MLS8 karena VTP modenya server dan switch lain VTP modenya client. Lalu assign sesuai topologi. Dan antar switchnya gunakan mode trunk.


MLS8

  1. Buat VLAN 212, 213, 214, 223, 224, 234 dengan perintah “vlan vlan-number”
  2. Interface fa0/21-22 modenya jadi trunk
    • interface range fa0/21-22
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 213
    • interface fa0/2
      • switchport trunk encapsulation dot1q
      • swithcport mode trunk

MLS7

  1. VLAN sudah terbuat, bisa di check dengan “show vlan brief”
  2. Interface fa0/22-23 kita ubah modenya jadi trunk
    • interface range fa0/22-23
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/2
      • switchport trunk encapsulation dot1q
      • switchport mode turnk

MLS1

  1. VLAN sudah terbuat, bisa di check dengan “show vlan brief”
  2. Interface fa0/20 dan fa0/23 diubah menjadi trunk (dan bukan sampai)
    • interface range fa0/20, fa0/23 (menggunakan “,” artinya dan”
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport mode access
      • switchport access vlan 234
    • interface fa0/2
      • switchport mode access
      • switchport access vlan 214

MLS2

  1. VLAN sudah terbuat, bisa di check dengan “show vlan brief”
  2. Interface fa0/20-21 kita ubah modenya jadi trunk
    • interface range fa0/20-21
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN ke interface sesuai logical topologi
    • interface fa0/1
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface fa0/2
      • switchport mode access
      • switchpor access vlan 223

4. Konfigurasikan network device yang ada di Solo dengan ketentuan sebagai berikut :

  • Pastikan database VLAN antar switch sama
  • Konfigurasikan VLAN dan assign switchport sesuai dengan topologi logical
  • Pastikan semua link di setiap switch di gunakan untuk mengirimkan dan menerima data.
  • Untuk mengatasi permasalahan point C pada SW3 dan SW4 gunakan mode tanpa
    negotiations dan sisanya gunakan mode cisco propritary.
  • Gunakan Network 172.34.34.0/30 untuk menghubungkan SW3 dan SW4, IP terkecil
    gunakan untuk SW3 dan IP terbesar gunakan untuk SW4.

Untuk poin 1 dan 2 sama seperti sebelumnya. Kita buat VLANnya di SW3 karena menjadi VTP Server.  Untuk point ke-3  mintanya semua linknya aktif, jadi kita konfigurasi etherchannel disitu. Untuk poin ke-4 semua switch di Solo menggunakan mode pagp kecuali SW3 dan SW4 yang menggunakan mode on. Trus nanti antar switch kita ubah ke trunk kecuali SW3 dan SW4 yang linknya kita kasih IP Address.


SW3

  1. Membuat VLAN 7,8,9 dan 10 menggunakan perintah “vlan vlan-number”
  2. Konfigurasi Etherchannel, group number ada pada physical topologi.
    • interface range fa0/2-3 (Link SW3-SW5)
      • channel-group 35 mode desirable (disini aku gk tau modenya pake auto atau desirable soalnya di soal gk ada penjelasannya)
      • nanti akan terbuat port-channel 35, jadi interface fa0/2-3 digabung menjadi port-channel 35. disitu baru kita ubah ke mode trunk
      • channel-protocol pagp (optional)
    • interface port-channel 35
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/4-5 (Link SW3-SW6)
      • channel-group 36 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 36
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/10-12 (Link SW3-SW4)
      • no switchport (perlu kita definisikan dlu secara manual agar link antar SW3 dan SW4 sama sama menggunakan no switchport)
      • channel-group 34 mode on
    • interface port-channel 34
      • no switchport
      • ip address 172.34.34.1 255.255.255.252

SW4

  1. VLAN sudah terbuat
  2. Konfigurasi Etherchannel, group number sesuai dengan topologi
    • interface range fa0/2-3 (Link SW4-SW6)
      • channel-group 46 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 46
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/4-5 (Link SW4-SW5)
      • channel-group 45 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 45
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/10-12 (Link SW3-SW4)
      • no switchport
      • channel-group 34 mode on
    • interface port-channel 34
      • no switchport
      • ip address 172.34.34.1 255.255.255.252

SW5

  1. VLAN sudah terbuat
  2. Konfigurasi Trunk yang mengaraha ke Switch Client
    • interface range fa0/7-8
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Konfigurasi Etherchannel, group number sesuai dengan topologi
    • interface range fa0/1-2 (Link SW3-SW5)
      • channel-group 35 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 35
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/5-6(Link SW4-SW5)
      • channel-group 45 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 45
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/3-4(Link SW5-SW6)
      • channel-group 11 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 11
      • switchport trunk encapsulation dot1q
      • switchport mode trunk

SW6

  1. VLAN sudah terbuat
  2. Konfigurasi Trunk yang mengaraha ke Switch Client
    • interface range fa0/7-8
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  3. Assign VLAN 10 pada interface fa0/9
    • interface fa0/9
      • switchport mode access
      • switchport access vlan 10
  4. Konfigurasi Etherchannel, group number sesuai dengan topologi
    • interface range fa0/1-2 (Link SW4-SW6)
      • channel-group 46 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 46
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/5-6(Link SW3-SW6)
      • channel-group 36 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 36
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
    • interface range fa0/3-4(Link SW5-SW6)
      • channel-group 11 mode desirable
      • channel-protocol pagp (optional)
    • interface port-channel 11
      • switchport trunk encapsulation dot1q
      • switchport mode trunk
  5. Untuk penghechekan etherchannelnya bisa menggunakan perintah “show etherchannel summary” apakah tandanya sudah “P” dan “SU”

SW7-SW10

  1. Pada interface fa0/1 menjadi mode trunk
    • Switchport mode trunk
  2. Assign VLAN sesuai topologi pada interface fa0/2-3

Untuk 1.3 dan Selanjutnya akan di bahas di Part 2. Selamat mencoba dan mudahan dimengerti

Cisco LAB.90 – BGP Attribute

Bismillahirrohmanirrohim

Routing protocol BGP sangat berbeda dengan routing protocol lain. OSPF menggunakan cost sebagai metricnya. EIGRP menggunakan K5, defaultnya adalah bandwitdh dan delay sebagai metricnya. Sedangkan BGP menggunakan Attribute sebagai metricnya dan attributenya ada 11 pada Cisco. Salah satunya adalah Origin

bgpattribute

BGP Attribute

Ada satu lagi yaitu Weight yang merupakan Cisco Proprietary.

BGP Attribute :

  1. Weight
  2. Well-Known
  3. Optional

Well-Known

Attribute yang pasti di support oleh semua router.  Pasti dikenal oleh Router neighbornya

Well-Known Mandatory

Merupakan attribute yang pasti ada dalam router BGP. Router manapun tanpa kita konfigurasi sudah defaultnya memang dikirim pada BGP update.

  1. Next-hop
  2. AS-PATH
  3. Origin

Well-Known Discretionary

Merupakan attribute yang ada bila kita konfigurasi.

  1. Local-Preference
  2. Aggregation

Optional

Attribute BGP yang tidak semua router mensupportnya.

Optional Transitive

Jika router mendapatkan BGP update dengan attribute ini maka support ataupun tidak support akan tetap di lewatkan atau dikirim kembali ke router AS lainnya.

  1. Aggregator
  2. Community

Optional Non-Transitive

Jika router mendapatkan BGP update dengan attribute ini, jika router yang menerima tidak mensupport maka tidak akan dilewatkan ke router lainnya.

  1. MED
  2. Originator
  3. Cluster-ID

Pemilihan Jalur

Terus bagaimana penentuan jalurnya, ada urutannya seperti berikut. Dari yang paling utama ke bawah.

  1. Weight(tertinggi) = berdasarkan administrative preference.
  2. Local Preference (tertinggi) = Berkomunikasi antara peer dalam satu AS.
  3. Self/Locally Originated(True/False) = Lebih memilih origin local.
  4. AS Path (terendah) = Memilih AS hops yang terendah.
  5. Origin (IGP>EGP>?) = Lebih memilih IGP yang dipelajari router lewat EGP.
  6. MED (Terendah) = digunakan jalur external untuk masuk kedalam AS.
  7. External(eBGP) = Lebih dipilih routing yang didapat dari eBGP daripada iBGP.
  8. IGP Cost(Terendah) = Lebih memilih IGP metric.
  9. eBGP Peering(Oldest) = Lebih menghasilkan routing yang stabil.
  10. Router ID(Lowest) = dipilih sebagai penentu terakhir dalam penentuan path.

Cisco LAB.89 – BGP – BGP Route Reflector

Bismillahirrohmanirrohim

Oke lanjut lab selanjutnya. Sebelumnya kita sudah mencoba eBGP peering dan iBGP peering. Pada eBGP semua router tidak wajib saling peering, namun pada iBGP semua wajib peering.  Berarti peeringnya harus full-mesh dan ini sangat memakan waktu yang lama untuk dikonfigurasi. Untuk mengatasi hal tersebut kita perlu konfigurasi Route Reflector. Peeringnya hanya perlu ke pusat saja yang menjadi RR Server.

Langsung saja ke topology

BGP RR.png

Topologi BGP Route Reflector

Seperti biasa konfigurasi IP Address terlebih dahulu pada semua router dan juga ada penambahan loopback pada senua router.

R1

R1(config)#int e0/0
R1(config-if)#ip add 12.12.12.1 255.255.255.0
R1(config-if)#no sh

R1(config-if)#int e0/1
R1(config-if)#ip add 13.13.13.1 255.255.255.0
R1(config-if)#no sh

R1(config-if)#int lo0
R1(config-if)#ip add 1.1.1.1 255.255.255.255

R2

R2(config)#int e0/0
R2(config-if)#ip add 12.12.12.2 255.255.255.0
R2(config-if)#no sh

R2(config-if)#int e0/1
R2(config-if)#ip add 24.24.24.2 255.255.255.0
R2(config-if)#no sh

R2(config-if)#int lo0
R2(config-if)#ip add 2.2.2.2 255.255.255.255

R3

R3(config)#int e0/0
R3(config-if)#ip add 13.13.13.3 255.255.255.0
R3(config-if)#no sh

R3(config-if)#int e0/1
R3(config-if)#ip add 34.34.34.3 255.255.255.0
R3(config-if)#no sh

R3(config-if)#int lo0
R3(config-if)#ip add 3.3.3.3 255.255.255.255

R4

R4(config)#int e0/0
R4(config-if)#ip add 24.24.24.4 255.255.255.0
R4(config-if)#no sh

R4(config-if)#int e0/1
R4(config-if)#ip add 34.34.34.4 255.255.255.0
R4(config-if)#no sh

R4(config-if)#int lo0
R4(config-if)#ip add 4.4.4.4 255.255.255.0

Sekarang kita peering ke router sebelahnya terlebih dahulu. Untuk peering kita dapat menggunakan physical atau menggunakan loopbacknya. Kali ini kita akan menggunakan peering menggunakan loopbacknya saja. Konfigurasi EIGRP agar loopback bisa dihubungi. EIGRP menggunakan network 0.0.0.0 saja agar mudah, dan mencakup semua network.

R1

R1(config)#router eigrp 1234
R1(config-router)#no auto
R1(config-router)#network 0.0.0.0

R2

R2(config)#router eigrp 1234
R2(config-router)#no auto
R2(config-router)#network 0.0.0.0

R3

R3(config)#router eigrp 1234
R3(config-router)#no auto
R3(config-router)#network 0.0.0.0

R4

R4(config)#router eigrp 1234
R4(config-router)#no auto
R4(config-router)#network 0.0.0.0

Semua router sudah adjacency. Sekarang konfigurasi peering dan pada R4 akan membuat loopback baru yang akan di advertise pada BGP.

R1

R1(config)#router bgp 1234
R1(config-router)#neighbor 2.2.2.2 remote-as 1234
R1(config-router)#neighbor 2.2.2.2 update-source lo0

R1(config-router)#neighbor 3.3.3.3 remote-as 1234
R1(config-router)#neighbor 3.3.3.3 update-source lo0

R2

R2(config)#router bgp 1234
R2(config-router)#neighbor 1.1.1.1 remote-as 1234
R2(config-router)#neighbor 1.1.1.1 update-source lo0

R2(config-router)#neighbor 4.4.4.4 remote-as 1234
R2(config-router)#neighbor 4.4.4.4 update lo0

R3

R3(config)#router bgp 1234
R3(config-router)#neighbor 1.1.1.1 remote-as 1234
R3(config-router)#neighbor 1.1.1.1 update lo0

R3(config-router)#neighbor 4.4.4.4 remote-as 1234
R3(config-router)#neighbor 4.4.4.4 update lo0

R4

R4(config)#router bgp 1234
R4(config-router)#neighbor 2.2.2.2 remote-as 1234
R4(config-router)#neighbor 2.2.2.2 update lo0

R4(config-router)#neighbor 3.3.3.3 remote-as 1234
R4(config-router)#neighbor 3.3.3.3 update lo0
R4(config-router)#network 40.40.40.0 mask 255.255.255.0
R4(config-router)#ex

R4(config)#int lo40
R4(config-if)#ip add 40.40.40.254 255.255.255.0

Jika kita check pada R2 dan R3 terlihat network 40.40.40.0 yang sudah dibagikan R4

R2#show ip bgp
BGP table version is 4, local router ID is 2.2.2.2                 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,                                                                       
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 r>i 40.40.40.0/24    4.4.4.4                  0    100      0 i
R3#show ip bgp BGP table version is 2, local router ID is 3.3.3.3            Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,                                                                              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,                x best-external, a additional-path, c RIB-compressed,  Origin codes: i - IGP, e - EGP, ? - incomplete RPKI validation codes: V valid, I invalid, N Not found       Network          Next Hop            Metric LocPrf Weight Path  r>i 40.40.40.0/24    4.4.4.4                  0    100      0 i
R1#show ip bgp
R1#

Namun pada R1 tidak ada. Ini dikarenakan sistemnya tidak seperti Routing protocol pada IGP, seperti EIGRP atau OSPF. Pada iBGP semua router harus peering, berarti R1 harus peering juga ke R4 dan sebaliknya. Untuk mengatasi ini kita tidak perlu peering full-mesh hanya peering ke router yang menjadi RR Server. Pada topologi ini adalah R2 dan R3. Sedangkan R1 dan R4 menjadi RR Client. Konfigurasinya pada R2 dan R3.

R2

R2(config)#router bgp 1234
R2(config-router)#neighbor 1.1.1.1 route-reflector-client 
R2(config-router)#neighbor 4.4.4.4 route-reflector-client

R4

R3(config)#router bgp 1234                        
R3(config-router)#neighbor 1.1.1.1 route-reflector-client
R3(config-router)#neighbor 4.4.4.4 route-reflector-client

Lihat lagi route yang di terima pada R1

R1#show ip bgp
BGP table version is 5, local router ID is 1.1.1.1                 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed,             
Origin codes: i - IGP, e - EGP, ? - incomplete                                  
RPKI validation codes: V valid, I invalid, N Not found                               
                                                                                           
     Network          Next Hop            Metric LocPrf Weight Path                        
 r i 40.40.40.0/24    4.4.4.4                  0    100      0 i                           
 r>i                  4.4.4.4                  0    100      0 i 

Cisco LAB.87 – BGP – Next Hop Self

Bismillahirrohmanirrohim

 Melanjutkan lab sebelumnya, kali ini kita akan mengkonfigurasi Next-Hop Self. Langsung ke topologi saja.

ibgp-peering

Topologi BGP Next-Hop Self

Sebelum kita masuk pembahasan Next-hop Self. Hapus terlebih dahulu Peering eBGP loopback dan Routing staticnya, karena kita hanya menggunakan Peering physical.

R2

R2(config)#router bgp 12
R2(config-router)#no neighbor 3.3.3.3 
R2(config-router)#exit
R2(config)#no ip route 3.3.3.3 255.255.255.255 23.23.23.3

R3

R3(config)#router bgp 3
R3(config-router)#no neighbor 2.2.2.2
R3(config-router)#exit
R3(config)#no ip route 2.2.2.2 255.255.255.255 23.23.23.2

Sekarang check peeringnya memastikan tidak ada peering ke 3.3.3.3

R2#show ip bgp summary 
BGP router identifier 2.2.2.2, local AS number 12
BGP table version is 2, main routing table version 2
1 network entries using 144 bytes of memory
1 path entries using 80 bytes of memory
1/1 BGP path/bestpath attribute entries using 152 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 400 total bytes of memory
BGP activity 1/0 prefixes, 1/0 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4           12      47      47        2    0    0 00:41:01        0
12.12.12.1      4           12      65      65        2    0    0 00:56:46        0
23.23.23.3      4            3      33      32        2    0    0 00:26:12        0

Sekarang seharusnya R2 tidak dapat ping ke 3.3.3.3

R2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Kita coba advertise dulu network 3.3.3.3 yang berada di R3. Untuk advertisenya netmasknya harus sesuai dengan network yang kita buat yaitu /32

R3(config)#router bgp 3
R3(config-router)#network 3.3.3.3 mask 255.255.255.255

Sekarang seharusnya R2 sudah mendapatkan network 3.3.3.3. Check pada R2

R2#show ip bgp
BGP table version is 4, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  3.3.3.3/32       23.23.23.3               0             0 3 i
R2#show ip route 
Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/409600] via 12.12.12.1, 00:57:00, Ethernet0/0
      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
      3.0.0.0/32 is subnetted, 1 subnets
B        3.3.3.3 [20/0] via 23.23.23.3, 00:00:39
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.12.12.0/24 is directly connected, Ethernet0/0
L        12.12.12.2/32 is directly connected, Ethernet0/0
      23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        23.23.23.0/24 is directly connected, Ethernet0/1
L        23.23.23.2/32 is directly connected, Ethernet0/1

Namun jika kita lihat routing tabel pada R1 maka network 3.3.3.3 tidak ada

R1#show ip route 
Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback0
      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/409600] via 12.12.12.2, 00:57:35, Ethernet0/0
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.12.12.0/24 is directly connected, Ethernet0/0
L        12.12.12.1/32 is directly connected, Ethernet0/0

Coba kita check routing tabel pada BGP nya

R1#show ip bgp
BGP table version is 1, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 3.3.3.3/32       23.23.23.3               0    100      0 3 i
 * i                  23.23.23.3               0    100      0 3 i

Seperti yang terlihat bahwa next-hop network 3.3.3.3/32 adalah 23.23.23.3 (R3) yang seharusnya adalah R2. Tidak seperti routing protocol biasanya, next-hop nya adalah IP router yang membagikannya (R3). Sedangkan R3 tidak bisa dihubungi oleh R1. Maka dari itu kita perlu konfigurasi Next-Hop Self agar yang menjadi next-hopnya adalah R2. Konfigurasinya pada R2 seperti berikut

R2(config)#router bgp 12
R2(config-router)#neighbor 1.1.1.1 next-hop-self 

Sekarang coba check dengan show ip bgp pada R1

R1#show ip bg
BGP table version is 2, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 3.3.3.3/32       23.23.23.3               0    100      0 3 i
 *>i                  2.2.2.2                  0    100      0 3 i

Sekarang pada network 3.3.3.3 sudah ada tanda > yang artinya best. Next-hop sudah terganti menjadi R2. Sekarang coba liat routing tabelnya.

R1#show ip route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
C        1.1.1.1 is directly connected, Loopback0
      2.0.0.0/32 is subnetted, 1 subnets
D        2.2.2.2 [90/409600] via 12.12.12.2, 01:11:47, Ethernet0/0
      3.0.0.0/32 is subnetted, 1 subnets
B        3.3.3.3 [200/0] via 2.2.2.2, 00:01:00
      12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        12.12.12.0/24 is directly connected, Ethernet0/0
L        12.12.12.1/32 is directly connected, Ethernet0/0

Cisco LAB.85 – BGP – eBGP Peering Physical Interface

Bismillahirrohmanirrohim

Melanjutkan konfigurasi pada lab sebelumnya. Sekarang kita akan mengkonfigurasi eBGP (External BGP) yang berarti peering yang berbeda AS. Topologi masih menggunakan lab sebelumnya.

ibgp-peering

Topologi eBGP peering

Sebelum kita melakukan peering antar R2 dan R3. Pastikan dulu R2 dan R3 bisa terhubung.

R2#ping 23.23.23.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 23.23.23.3, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms
 00:21:45        0

Sekarang konfigurasi eBGP peering pada R2 dan R3

R2

R2(config)#router bgp 12
R2(config-router)#neighbor 23.23.23.3 remote-as 3

R3

R3(config)#router bgp 3
R3(config-router)#neighbor 23.23.23.2 remote-as 12

Remote-as nya adalah AS-number lawannya. Tunggu hingga ada notif seperti berikut

R3(config-router)#
*Dec 21 07:01:19.128: %BGP-5-ADJCHANGE: neighbor 23.23.23.2 Up 

Sekarang sudah adjacency. Check peering nya pada R2 dan R3.

R2

R2#show ip bgp summary 
BGP router identifier 2.2.2.2, local AS number 12
BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
1.1.1.1         4           12      11      11        1    0    0 00:08:32        0
12.12.12.1      4           12      14      13        1    0    0 00:10:05        0
23.23.23.3      4            3       5       5        1    0    0 00:01:31        0

R3

R3#show ip bgp sum
BGP router identifier 3.3.3.3, local AS number 3
BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
23.23.23.2      4           12       6       6        1    0    0 00:02:21        0

Cisco LAB.84 – BGP – iBGP Peering Loopback

Bismillahirrohmanirrohim

Oke, melanjutkan lab sebelumnya. Sebelumnya kita melakukan peering pada IP Physicalnya. Namun jika kita menggunakan iBGP yang artinya kedua router menggunakan AS yang sama, berarti Perusahaan yang sama, sebaiknya kita peeringnya menggunakan IP Loopback karena IP loopback tidak pernah mati. Ok langsung ke topologi saja

ibgp-peering

Topologi iBGP peering Loopback

Jika kita melakukan peering menggunakan loopback maka IP loopback tersebut harus bisa dihubungi terlebih dahulu karena jika tidak maka tidak bisa peering. Konfigurasi EIGRP dengan AS 12 pada R1 dan R2 agar loopbacknya bisa terhubung.

R1

R1(config)#router eigrp 12                                             R1(config-router)#no auto
R1(config-router)#network 12.12.12.0
R1(config-router)#network 1.1.1.1

R2

R2(config)#router eigrp 12                                             
R2(config-router)#no auto                                             
R2(config-router)#network 2.2.2.2                                     
R2(config-router)#network 12.12.12.0

Test ping dari R1 ke loopback R2

R1(config-router)#do ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Sekarang kita konfigurasi iBGP peering loopbacknya.

R1

R1(config)#router bgp 12
R1(config-router)#neighbor 2.2.2.2 remote-as 12
R1(config-router)#neighbor 2.2.2.2 update-source lo0

R2

R2(config)#router ei
R2(config)#router bgp 12
R2(config-router)#neighbor 1.1.1.1 remote-as 12
R2(config-router)#neighbor 1.1.1.1 update-source lo0
*Dec 21 04:18:56.516: %BGP-5-ADJCHANGE: neighbor 1.1.1.1 Up 

Jika kita peering menggunakan loopback maka kita perlu mendefinisikan source nya menggunakan loopback, karena defaultnya source nya adalah interface physical.
Check peeringnya menggunakan perintah di bawah ini

R1#show ip bgp summary 
BGP router identifier 1.1.1.1, local AS number 12
BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2.2.2.2         4           12       4       4        1    0    0 00:01:52        0
12.12.12.2      4           12      26      27        1    0    0 00:21:45        0

Terlihat ada dua peering.

Cisco LAB.81 – Tunneling dari IPv6 Melewati IPv4 (IPv6 Tunnel 6to4)

Tunneling 6to4 adalah metode yang digunakan pada jaringan private yang menggunakan IPv6 address namun di internet menggunakan IPv4. Langsung ke topologi saja biar lebih mengerti.

tunneling-6to4

Topologi Tunneling 6to4

Gimana caranya agar loopback 1 kita yaitu IPv6 melewati IPv4 dan terhubung kembali ke IPv6 itu yang dimaksud dengan Tunneling 6to4.

Konfigurasi IP Address dan EIGRP.

R1

R1(config)#int e0/0
R1(config-if)#ip add 12.12.12.1 255.255.255.0
R1(config-if)#no sh

R1(config-if)#int lo1
R1(config-if)#ipv6 add 1::1/128
R1(config-if)#ex

R1(config)#ipv6 unicast-routing 

R1(config)#router eigrp 123
R1(config-router)#no auto
R1(config-router)#network 12.12.12.0

R2

R2(config)#int e0/0
R2(config-if)#ip add 12.12.12.2 255.255.255.0
R2(config-if)#no sh
R2(config-if)#int e0/1
R2(config-if)#ip add 23.23.23.2 255.255.255.0
R2(config-if)#no sh

R2(config)#router eigrp 123
R2(config-router)#no auto
R2(config-router)#network 12.12.12.0
R2(config-router)#network 23.23.23.0

R3

R3(config)#int e0/0
R3(config-if)#ip add 23.23.23.3 255.255.255.0
R3(config-if)#no sh
R3(config-if)#int lo3
R3(config-if)#ipv6 add 3::3/128
R3(config-if)#ex

R3(config)#ipv6 unicast-routing 

R3(config)#router eigrp 123
R3(config-router)#no auto
R3(config-router)#network 23.23.23.0

Kita ubah IP Address IPv4 ke IPv6 pada interface Ethernet0/0
R1

R1(config)#ipv6 general-prefix PREFIX 6to4 ethernet 0/0

R3

R1(config)#ipv6 general-prefix PREFIX 6to4 ethernet 0/0

ipv6 general-prefix digunakan untuk mengubah IPv4 ke IPv6 dengan tambahan 2002 didepan dan menggunakan /48. Untuk melihat hasilnya menggunakan perintah berikut.
R1

R1#show ipv6 general-prefix 
IPv6 Prefix PREFIX, acquired via 6to4
  2002:C0C:C01::/48 Valid lifetime infinite, preferred lifetime infinite

R3

R3#show ipv6 general-prefix 
IPv6 Prefix PREFIX, acquired via 6to4
  2002:1717:1703::/48 Valid lifetime infinite, preferred lifetime infinite

Buat tunnel dengan menggunakan IPv6 yang kita buat sebelumnya. Untuk bisa melewatkan IPv6 kita menggunakan mode ipv6ip 6to4
R1

R1(config)#interface Tunnel13
R1(config-if)#ipv6 address 2002:C0C:C01::1/48
R1(config-if)#tunnel source 12.12.12.1
R1(config-if)#tunnel mode ipv6ip 6to4

R3

R3(config)#interface Tunnel31
R3(config-if)#ipv6 address 2002:1717:1703::3/48
R3(config-if)#tunnel source 23.23.23.3
R3(config-if)#tunnel mode ipv6ip 6to4

Sekarang kita static route agar IPv6 Tunnel R1 dan R3 terhubung
R1

R1(config)#ipv6 route 2002::/16 tunnel13

R3

R3(config)#ipv6 route 2002::/16 tunnel31

Test Ping antar tunnel.

R1#ping   2002:1717:1703::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2002:1717:1703::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

Kita test ping antar loopback.

R1#ping 3::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3::3, timeout is 2 seconds:

% No valid route for destination
Success rate is 0 percent (0/1)
R1

Karena belum ada routing ke IP Loopback. Sekarang kita tambahkan routing static.

R1(config)#ipv6 route 3::3/128 2002:1717:1703::3

R3

R1(config)#ipv6 route 1::1/128 2002:C0C:C01::1

Sekarang lakukan ping antar Loopback.

R1#ping 3::3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

Cisco LAB.80 – Tunneling pada IPv6 (GRE IP)

Tujuan :

  1. Mengetahui konfigurasi tunneling pada IPv6 dengan mode GRE IP

Pada lab sebelumnya kita mengkonfigurasi tunneling dengan metode IPv6/IP sekarang kita akan konfigurasi dengan metode GRE IP. Untuk topologinya menggunakan topologi pada lab sebelumnya.

screenshot6

Melanjutkan konfigurasi pada lab sebelumnya. Hapus terlebih dahulu konfigurasi routing dan tunnelnya.

R1

R1(config)#no int tunnel 13
R1(config)#no ipv6 route 3::3/128 13::3

R3

R3(config)#no int tunnel 31            
R3(config)#no ipv6 route 1::1/128 13::1

Lalu check pada routing tabelnya

R1

R1#show ipv6 route

LC  1::1/128 [0/0]
     via ::, Loopback1
L   FF00::/8 [0/0]
     via ::, Null0

R3

R3#show ipv6 route

LC  3::3/128 [0/0]
     via ::, Loopback3
L   FF00::/8 [0/0]
     via ::, Null0

Konfigurasi sudah hilang. Di ping pun akan RTO.

R1#ping 3::3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3::3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Sekarang kita konfigurasi tunnel dengan mode GRE IP, yang merupakan konfigurasi defaultnya.

R1

R1(config)#int tunnel 13
R1(config-if)#ipv6 address 13::1/64
R1(config-if)#tunnel source 12.12.12.1
R1(config-if)#tunnel destination 23.23.23.3 
R1(config-if)#tunnel mode gre ip

R3

R3(config)#int tunnel 31
R3(config-if)#ipv6 address 13::3/64
R3(config-if)#tunnel source 23.23.23.3 
R3(config-if)#tunnel destination 12.12.12.1 
R3(config-if)#tunnel mode gre ip

Tanpa mendefinisikan mode gre/ip juga tunnel akan menggunakan mode gre/ip. Check tunnelingnya

R1

R1#show int tunn 13
Tunnel13 is up, line protocol is up 
  Hardware is Tunnel
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 12.12.12.1, destination 23.23.23.3
  Tunnel protocol/transport GRE/IP
R1#show ipv6 int tunnel 13
Tunnel13 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::C201:1AFF:FED8:0 
  No Virtual link-local address(es):
  Global unicast address(es):
    13::1, subnet is 13::/64 
  Joined group address(es):
    FF02::1
    FF02::1:FF00:1
    FF02::1:FFD8:0
  MTU is 1476 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds

R3

R3#show int tunnel 31
Tunnel31 is up, line protocol is up 
  Hardware is Tunnel
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 23.23.23.3, destination 12.12.12.1
  Tunnel protocol/transport GRE/IP
R3#show ipv6 int tunnel 31
Tunnel31 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::C203:12FF:FEA8:0 
  No Virtual link-local address(es):
  Global unicast address(es):
    13::3, subnet is 13::/64 
  Joined group address(es):
    FF02::1
    FF02::1:FF00:3
    FF02::1:FFA8:0
  MTU is 1476 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds

Baru tambahkan static route ke network loopbacknya.

R1(config)#ipv6 route 3::3/128 13::3
R3(config)#ipv6 route 1::1/128 13::1

Sekarang check pada routing tabelnya.

R1#show ipv6 route

LC  1::1/128 [0/0]
     via ::, Loopback1
S   3::3/128 [1/0]
     via 13::3
C   13::/64 [0/0]
     via ::, Tunnel13
L   13::1/128 [0/0]
     via ::, Tunnel13
L   FF00::/8 [0/0]
     via ::, Null0
R3#show ipv6 route

S   1::1/128 [1/0]
     via 13::1
LC  3::3/128 [0/0]
     via ::, Loopback3
C   13::/64 [0/0]
     via ::, Tunnel31
L   13::3/128 [0/0]
     via ::, Tunnel31
L   FF00::/8 [0/0]
     via ::, Null0

Sekarang sudah ada routing nya. Sekarang coba test ping ke network loopback

R1#ping 3::3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/40/52 ms

Cisco LAB.79 Tunneling pada IPv6 (IPv6G/IP)

Tujuan :

  1. Mengetahui konfigurasi tunneling dengan mode IPv6G/IP pada IPv6

Pada tunneling di IPv6 memiliki banyak mode, salah satunya IPv6G. Untuk topologi yang akan digunakan seperti berikut

screenshot6

Topologi Tunneling IPv6G/IP

Konfigurasi IP Address pada interface semua router lalu konfigurasi EIGRP AS 1 namun tidak memasukkan loopbacknya.

R1

R1(config)#int se1/0
R1(config-if)#no shutdown
R1(config-if)#ip add 12.12.12.1 255.255.255.0

R1(config-if)#int lo1
R1(config-if)#ipv6 address 1::1/128
R1(config-if)#exit

R1(config)#router eigrp 1
R1(config-router)#no auto-summary
R1(config-router)#network 12.12.12.0 0.0.0.255

R2

R2(config)#int se1/0
R2(config-if)#no sh
R2(config-if)#ip add 12.12.12.2 255.255.255.0

R2(config-if)#int fa0/0
R2(config-if)#no sh
R2(config-if)#ip add 23.23.23.2 255.255.255.0
R2(config-if)#ex    

R2(config)#router eigrp 1
R2(config-router)#no auto-summary
R2(config-router)#network 12.12.12.0 0.0.0.255 
R2(config-router)#network 23.23.23.0 0.0.0.255

R3

R3(config)#int fa0/0
R3(config-if)#no sh
R3(config-if)#ip add 23.23.23.3 255.255.255.0

R3(config-if)#int lo3
R3(config-if)#ipv6 address 3::3/128
R3(config-if)#exit

R3(config)#router eigrp 1
R3(config-router)#no auto-summary
R3(config-router)#network 23.23.23.0 0.0.0.255

Lalu konfigurasi tunnel IPv6G/IP, pada R1 dan R3.

R1

R1(config)#int tunnel 13
R1(config-if)#ipv6 address 13::1/64
R1(config-if)#tunnel source 12.12.12.1   
R1(config-if)#tunnel destination 23.23.23.3
R1(config-if)#tunnel mode ipv6ip

R3

R3(config)#int tunnel 31
R3(config-if)#ipv6 address 13::3/64
R3(config-if)#tunnel source 23.23.23.3    
R3(config-if)#tunnel destination 12.12.12.1 
R3(config-if)#tunnel mode ipv6ip

Perintah di atas akan memasukkan IPv6 pada interface tunnel, lalu menggunakan mode IPv6/IP. Setelah itu check IPv6 pada tunnel dan interface tunnel.

R1

R1#show ipv6 int br
FastEthernet0/0            [administratively down/down]
Serial0/0                  [administratively down/down]
FastEthernet0/1            [administratively down/down]
Serial0/1                  [administratively down/down]
Serial0/2                  [administratively down/down]
Serial1/0                  [up/up]
Serial1/1                  [administratively down/down]
Serial1/2                  [administratively down/down]
Serial1/3                  [administratively down/down]
Loopback1                  [up/up]
    FE80::C201:1AFF:FED8:0
    1::1
Tunnel13                   [up/up]
    FE80::C0C:C01
    13::1
R1#show int tunnel 13
Tunnel13 is up, line protocol is up 
  Hardware is Tunnel
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 12.12.12.1, destination 23.23.23.3
  Tunnel protocol/transport IPv6/IP
R1#show ipv6 interface tunnel 13
Tunnel13 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::C0C:C01 
  No Virtual link-local address(es):
  Global unicast address(es):
    13::1, subnet is 13::/64 
  Joined group address(es):
    FF02::1
    FF02::1:FF00:1
    FF02::1:FF0C:C01
  MTU is 1480 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds

Terlihat di atas IP Addressnya sudah menggunakan IPv6 dan tunnelnya menggunakan protocol IPv6/IP. Selanjutnya pada R3

R3

R3#show ipv6 int br
FastEthernet0/0            [up/up]
Serial0/0                  [administratively down/down]
FastEthernet0/1            [administratively down/down]
Serial0/1                  [administratively down/down]
Serial0/2                  [administratively down/down]
Serial1/0                  [administratively down/down]
Serial1/1                  [administratively down/down]
Serial1/2                  [administratively down/down]
Serial1/3                  [administratively down/down]
Loopback3                  [up/up]
    FE80::C203:12FF:FEA8:0
    3::3
Tunnel31                   [up/up]
    FE80::1717:1703
    13::3
R3#show int tunnel 31
Tunnel31 is up, line protocol is up 
  Hardware is Tunnel
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive not set
  Tunnel source 23.23.23.3, destination 12.12.12.1
  Tunnel protocol/transport IPv6/IP
R3#show ipv6 int tunnel 31
Tunnel31 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::1717:1703 
  No Virtual link-local address(es):
  Global unicast address(es):
    13::3, subnet is 13::/64 
  Joined group address(es):
    FF02::1
    FF02::1:FF00:3
    FF02::1:FF17:1703
  MTU is 1480 bytes
  ICMP error messages limited to one every 100 milliseconds
  ICMP redirects are enabled
  ICMP unreachables are sent
  ND DAD is enabled, number of DAD attempts: 1
  ND reachable time is 30000 milliseconds

Karena sudah mengkonfigurasi tunnel maka coba test ping ke tunnel.

R1#ping 13::3 

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 13::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/29/52 ms

Sudah sukses namun untuk ping ke loopback hasilnya RTO.

R1#ping 3::3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3::3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

Karena kita tidak mengkonfigurasi routing pada network tersebut. Kita akan konfigurasi routing static IPv6 namun gatewaynya ada pada tunnel

R1(config)#ipv6 route 3::3/128 13::3
R3(config)#ipv6 route 1::1/128 13::1

Lihat routing tabel ipv6.

R1

R1#show ipv6 route

LC  1::1/128 [0/0]
     via ::, Loopback1
S   3::3/128 [1/0]
     via 13::3
C   13::/64 [0/0]
     via ::, Tunnel13
L   13::1/128 [0/0]
     via ::, Tunnel13
L   FF00::/8 [0/0]
     via ::, Null0

Sudah ada routing staticnya yang gatewaynya adalah address tunnel. Sekarang coba test ping.

R1#ping 3::3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/36/52 ms